Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Configuration et dépannage de la commutation multicouche IP sur les commutateurs Catalyst 6500/6000 avec une carte MSFC

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 septembre 2015) | Commentaires


Contenu


Introduction

Ce document montre comment vérifier et interpréter les commandes de commutation multicouche (MLS) de Catalyst 6500/6000. Le document passe brièvement en revue MLS et des exemples de son utilisation. À partir de ces exemples, ce document montre comment vérifier l'exécution de MLS et fournit quelques conseils de dépannage pour la configuration de MLS.

Ce document s'applique seulement à la gamme Catalyst 6500/6000 commutent équipé du matériel suivant :

  • Logiciel courant de SYSTÈME D'EXPLOITATION de Catalyst de l'engine 1A de superviseur (CatOS)

  • Carte de fonctionnalité de stratégie (PFC)

  • Carte de commutation multicouche (MSFC)

Remarque: Ce document est non valide en utilisant n'importe quelle autre configuration matérielle telle que le module de Supervisor Engine 2 ou de commutateur multicouche (MSM). Il est également non valide en exécutant le logiciel de Cisco IOSÝ sur l'engine 1A de superviseur et MSFC.

Pour des informations similaires sur le routage d'unicast de dépannage sur une gamme Catalyst 6500/6000 commutez avec le Supervisor Engine 2 et le logiciel de CatOS d'exécution, se rapportent dépannent le Routage IP d'Unicast impliquant le CEF sur des Commutateurs de gamme Catalyst 6500/6000 d'un logiciel système de CatOS de Supervisor Engine 2 et d'exécution.

Pour une description plus complète de terminologie et d'exécution MLS, voyez la section « de l'information relative ».

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Catalyst 6500/6000 avec un MSFC

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Aperçu de MLS sur le MSFC

Le MSFC est la deuxième génération que l'engine de routage pour la gamme Catalyst 6500/6000 commutent qui peut conduire 15 millions de paquets par seconde. Le MSFC fonctionne seulement avec les engines de superviseur qui ont le PFC. Le MSFC exécute un MLS interne avec le PFC, qui agit semblable au NetFlow Feature Card (NFFC) sur le Catalyst 5000. Ce MLS interne n'est pas visible et est purement limité au commutateur : vous n'avez rien à configurer pour le faire fonctionner et il prend en charge des raccourcis matériels pour l'IP, l'IPX, et le Protocole IP Multicast. La configuration du MSFC est semblable à la configuration d'un RSM ou d'un RSFC utilisant des interfaces VLAN. Vous pouvez l'accéder à utilisant la session 15 (pour MSFC sur l'engine de superviseur en emplacement 1) ou session 16 (pour MSFC sur l'engine de superviseur dans emplacement 2).

Le principe est semblable à Protocol de changement multicouche (MLSP) relatif au Catalyst 5000. Le premier paquet est conduit par le MSFC, et le PFC crée un raccourci qui est utilisé par tous les paquets suivants du même écoulement. À la différence de MLSP sur le Catalyst 5000, qui exige la communication IP entre le MLS-SE et le MLS-RP, MLS sur le Catalyst 6500/6000 fonctionne à côté de transmission entre le MSFC et le PFC au-dessus d'un canal série (SCP).

Le PFC ne peut pas être le MLS-SE pour un environnement du Catalyst 5000 MLS ; cependant, le MSFC peut être MLS-RP pour l'autre Catalyst 5000s dans le réseau. Dans ce cas, vous devriez configurer le MSFC utilisant la même commande de mls rp ip que vous pour n'importe quel routeur Cisco IOS utilisé comme MLS RP.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6000-series-switches/10566-mls.gif

Exemple 1 : Routage MSFC entre deux VLAN

Le MLS sur le Catalyst 6500/6000 pour l'IP d'unicast est prêt à l'emploi. Vous n'avez pas besoin de le configurer. Est ci-dessous une configuration d'échantillon où docile est un Catalyst 6500/6000, qui a un MSFC appelé plus docile-msfc. Le routage entre le VLAN 11 et 12 est configuré sur le MSFC sans commande simple liée à MLS. Maintenez dans l'esprit que l'engine de superviseur n'aura aucune configuration de MLS-particularité.

tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
! 
router eigrp 1 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
! 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end

Lecture des show mls entry et vérifier de base

Est ci-dessous la sortie que vous devriez obtenir en émettant le show mls commandez sur l'engine de superviseur.

tamer (enable) show mls 
Total packets switched = 8      

!--- Number of packet shortcuted by MLS.

Total Active MLS entries = 0      

!--- Number of flows currently existing.

MSFC 11.1.1.2 (Module 15) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Destination flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 

IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11      

!--- MSFC recognized by the switch.

La sortie de commande de show mls devrait toujours avoir un ID IP MSFC. Si vous ne voyez pas que l'ID IP MSFC quand vous émettez le show mls commandent, vérifiez ce qui suit :

  • MSFC est en service (non collé en mode de ROMmon, par exemple).

  • MLS est encore activé sur le MSFC.

Vous pouvez vérifier ceci en émettant les commandes suivantes sur le MSFC :

tamer-msfc#show mls status 
MLS global configuration status: 
global mls ip:                     enabled     

!--- Should be enabled for unicast IP.

global mls ipx:                    enabled 
global mls ip multicast:           disabled 
current ip flowmask for unicast:   destination only 
current ipx flowmask for unicast:  destination only 

En émettant la commande d'état de show mls, vous pouvez déterminer si MLS est activé pour l'IP, l'IPX, et le Protocole IP Multicast. Ces caractéristiques devraient toujours être activées par défaut ; cependant, ils peuvent être désactivés en émettant la commande suivante dans le mode de configuration :

no mls ip

L'aucune commande de mls ip ne devrait seulement être utilisée pour l'élimination des imperfections. La commande est également disponible comme commande masquée dans le mode de configuration globale. Vous pouvez également désactiver MLS sur une base de l'interface par-VLAN en n'émettant l'aucune commande de mls ip dans le mode de configuration d'interface

Remarque: N'émettez pas la commande de show mls rp sur le MSFC. Cette sortie de commande indique que MLS est désactivé. Cependant, la sortie de commande de show mls a émis sur ce qui précède d'engine de superviseur indiqué que MLS fonctionnait correctement. Cette anomalie se produit parce que la commande de show mls rp devrait être utilisée en faire le MLS-RP en même temps qu'un commutateur de Catalyst 5000.

tamer-msfc#show mls rp 
ip multilayer switching is globally disabled 
ipx multilayer switching is globally disabled 
ipx mls inbound acl override is globally disabled 
mls id is 00d0.d39c.9e04 
mls ip address 0.0.0.0 
mls ip flow mask is unknown 
mls ipx flow mask is unknown 
number of domains configured for mls 0

Un paquet candidat est un paquet qui peut potentiellement initier l'installation d'un raccourci MLS. Son adresse MAC de destination est égale à l'adresse MAC d'un routeur exécutant MLS. Dans ce cas, l'adresse MAC du MSFC est 00-d0-d3-9c-9e-3c (vu en émettant la commande de show mls). Pour vérifier que le commutateur sait que cette adresse MAC est une adresse MAC de routeur, émettez les mac_address de show cam commandent, comme affiché ci-dessous.

tamer (enable) show cam 00-d0-d3-9c-9e-3c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 
VLAN  Dest MAC/Route Des    [CoS]  Destination Ports or VCs / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-d0-d3-9c-9e-3c R#          15/1 
12    00-d0-d3-9c-9e-3c R#          15/1 
Total Matching CAM Entries Displayed = 2

Cette sortie confirme que le commutateur sait que cette adresse MAC est une entrée de routeur liée au port 15/1 (port MSFC dans emplacement 1).

Si vous ne voyez toujours pas le MSFC quand vous émettez le show mls de commande sur l'engine de superviseur de commutateur, émettez la commande suivante :

tamer (enable) show mls rlog l2 
SWLOG at 815d0c50: magic 1008, size 51200, cur 815d4170, end 815dd460 
Current time is: 08/08/00,17:13:25 

118 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 12 Earl AL =0 
117 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 12, i/f 1, proto 0, LC 3 
116 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 11 Earl AL =0 
115 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 11, i/f 1, proto 0, LC 3

Cette commande montre vous les messages que le commutateur reçoit du MSFC, et cela les entrées de routeur sont ajoutés.

Lecture des Tableaux de sortie de show mls

Émettez la commande de show mls entry de visualiser la pleine table MLS avec tous les raccourcis. La sortie ci-dessous affiche tous les écoulements reçus.

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
10.68.5.1       -               -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        -               -     -      -      00-00-0c-09-50-66 11   ARPA 
ESrc DPort  SPort  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 1/3    7/3    4          400         00:00:02 00:00:02 
ARPA 7/4    7/3    4          400         00:00:08 00:00:08 
ARPA 7/3    7/4    9          900         00:00:08 00:00:08 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 2 
tamer (enable)

Remarque: Un écoulement est créé par destination. Un ping de 12.1.1.1 à 11.1.1.1 créera deux écoulements (un pour chaque direction), comme indiqué par les deux dernières lignes dans le résultat présenté ci-dessus.

Ce qui suit sont quelques descriptions des informations qui sont trouvées dans la table :

  • L'IP de destination, le source ip, le protocole, le DstPrt, et le SrcPrt sont les champs utilisés pour créer des raccourcis. Dans ce cas, l'écoulement de destination seulement est utilisé. Seulement l'adresse IP de destination d'un écoulement est cachée. Ceci peut être changé en modifiant le flowmask, qui est décrit plus tard dans ce document.

  • Le MAC de destination est l'adresse MAC qui sera utilisée pour réécrire le MAC de destination du paquet. L'adresse MAC source est réécrite avec l'adresse MAC du MSFC.

  • Le VLAN indique le VLAN de destination requis pour atteindre cette adresse IP. Le VLAN de destination est important, par exemple, si le paquet doit être envoyé sur un joncteur réseau.

  • DPort et sport sont la destination et le port de source de l'écoulement.

  • Les Stat-paquets et les Stat-octets te donnent des statistiques sur le nombre de paquets qui ont utilisé ce raccourci puisque la création de l'écoulement.

  • La disponibilité est le temps puisque l'écoulement a été créé.

  • L'âge est le temps écoulé puisque l'écoulement était employé le dernier.

Changez l'écoulement à la destination-source. La sortie de commande de show mls entry affiche l'adresse IP source et l'adresse IP de destination cachent. Un écoulement différent pour chaque adresse IP source communiquant à la même adresse IP de destination est maintenant créé, comme affiché ci-dessous.

tamer (enable) set mls flow destination-source 
Configured IP flowmask is set to destination-source flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
tamer (enable) 2000 Aug 09 17:05:12 %MLS-5-FLOWMASKCHANGE:IP flowmask changed 
 from DEST to DEST-SRC 

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        -     -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        10.68.5.1       -     -      -      00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        11.1.1.1        -     -      -      00-00-0c-8c-70-88 12   ARPA 
MSFC 0.0.0.0 (Module 16): 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:02 00:00:02 
ARPA 7/3    1/3    4          400         00:00:32 00:00:32 
ARPA 1/3    7/3    4          400         00:00:32 00:00:32 
ARPA 7/4    7/3    4          400         00:00:02 00:00:02 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Pkts  Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 0.0.0.0 (Module 16): 


Total entries displayed: 4
tamer (enable)

La troisième option est set mls en grand. Exécutez quelques pings et sessions de telnet pour voir comment les différents écoulements sont créés pour chaque port TCP. Est ci-dessous comment la table MLS devrait s'occuper de faire quelques pings et sessions de telnet. Utilisant le flux complet, le nombre d'écoulements créés augmente très rapidement. Les informations de port TCP sont cachées, et apparaissent dans la table MLS.

tamer (enable) set mls flow full 
Configured IP flowmask is set to full flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
Tamer (enable) 2000 Aug 09 17:30:01 %MLS-5-FLOWMASKCHANGE:IP flowmask changed
 from DEST to FULL 

tamer (enable) 
tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        12.1.1.1        TCP   11001  Telnet 00-00-0c-09-50-66 11   ARPA 
12.1.1.1        11.1.1.1        TCP*  Telnet 11001  00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        10.68.5.1       TCP   11002  Telnet 00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        ICMP  -      -      00-d0-00-3f-a3-ff 8    ARPA 
10.68.5.1       11.1.1.1        TCP*  Telnet 11002  00-d0-00-3f-a3-ff 8    ARPA 
11.1.1.1        10.68.5.1       ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
ARPA 7/3    7/4    16         688         00:00:26 00:00:24 
ARPA 7/4    7/3    18         757         00:00:26 00:00:24 
ARPA 7/3    1/3    61         4968        00:00:16 00:00:06 
ARPA 1/3    7/3    4          400         00:00:33 00:00:33 
ARPA 1/3    7/3    69         2845        00:00:17 00:00:06 
ARPA 7/3    1/3    4          400         00:00:33 00:00:33 
ARPA 7/3    7/4    4          400         00:00:32 00:00:31 

  
Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 8

Notes

  • Dans un réseau vivant, le nombre d'écoulements créés peut être jusqu'à plusieurs milliers. Émettez l'IP de show mls entry [destination|commande de source] d'afficher l'écoulement spécifique au lieu d'afficher la table de flux complet, comme affiché ci-dessous.

    tamer (enable) show mls entry ip destination 12.1.1.1 
    
    Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
    --------------- --------------- ----- ------ ------ ----------------- ---- ---- 
    
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
    
    
    ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
    ---- ------ ------ ---------- ----------- -------- -------- 
    ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
    
  • Vous pouvez vérifier les statistiques pour l'écoulement en émettant le show mls statistics de commande, comme affiché ci-dessous.

    tamer (enable) show mls statistics entry ip 15 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      9          900 
    11.1.1.1        10.68.5.1       TCP  11005  Telnet 20         913 
    11.1.1.1        10.68.5.1       TCP  11004  Telnet 0          0 
    10.68.5.1       11.1.1.1        ICMP -      -      4          400 
    10.68.5.1       12.1.1.1        ICMP -      -      9          900 
    12.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      9          900

Dépannage d'une connexion spécifique

Si vous avez un problème de Connectivité à une adresse IP spécifique ou entre deux hôtes spécifiques, essayez le suivant pour dépanner :

  • Émettez l'IP de show mls entry [destination|commande de source] de voir si l'écoulement a été créé.

  • Émettez l'entrée de show mls statistics [source|commande de destination] plusieurs fois dans une ligne de voir si les compteurs de la stat-pakts pour ce raccourci augmentent.

  • Vérifiez l'écoulement approprié.

Par exemple, pour une session de FTP d'un gros fichier entre le serveur 12.1.1.1 TFTP et le client 11.1.1.1 TFTP, vous devez vérifier les deux écoulements suivants :

  • Un avec la destination 12.1.1.1 qui devrait être frappée seulement par l'accusé de réception TFTP (petit paquet) (source d'écoulement 12.1.1.1 si flux destination-source utilisé).

  • Un avec la destination 11.1.1.1 qui devrait être frappée par beaucoup de grands paquets (le transfert de fichiers réel) (source d'écoulement 11.1.1.1 si le flux destination-source est utilisé).

    C'est un exemple de TFTP entre 12.1.1.1. et 11.1.1.1 d'un fichier d'environ 7.6 Mo. Être suit la table stat MLS avant le début du TFTP :

    tamer (enable) show mls statistics entry 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      4          400 
    12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894
    

Le TFTP a juste commencé. Les deux écoulements supplémentaires créés pour le trafic TFTP (port UDP 69) sont affichés ci-dessous.

tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  343        10997 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     343        186592 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

Le transfert TFTP juste fini. Approximativement 8.1 Mo sont transférés du serveur vers le client en 14,903 paquets, qui crée une taille moyenne de 544 octets par paquet. Dans l'autre direction, le même montant de paquets sont reçus avec une taille moyenne de 476,949 divisés par 14,904, qui fait 33 octets.

Tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  14904      476949 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     14903      8107224 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

Ces tables devraient te donner une idée de ce que ressembler à votre structure de trafic devrait.

Exemple 2 : Deux MSFCs dans le même châssis configuré pour le HSRP

Est ci-dessous la configuration en cours des deux MSFCs configuré pour le HSRP et la sortie de la commande de show standby. Le MSFC dans l'emplacement 15 est en activité pour le VLAN 12, et le MSFC dans l'emplacement 16 est en activité pour le VLAN 11.

Emplacement 15 Emplacement 16
tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:
  c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.120 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.2 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
 no ip redirects 
 standby 11 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
 no ip redirects 
 standby 12 priority 105 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end
tamer-msfc-2#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc-2 
! 
boot system flash
  bootflash:c6msfc-jsv-mz.121-2.E.bin 
! 
ip subnet-zero 
!
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.121 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.4 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.4 255.255.255.0 
 no ip redirects 
 standby 11 priority 105 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.4 255.255.255.0 
 no ip redirects 
 standby 12 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless!  
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end


tamer-msfc>show standby 
Vlan11 - Group 11 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:00.814 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is 11.1.1.4 expires in 00:00:09 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0b 
  4 state changes, last state change 00:06:36 
Vlan12 - Group 12 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.380 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is local 
  Standby router is 12.1.1.4 expires in 00:00:09 
  Standby virtual MAC address is 0000.0c07.ac0c 
  2 state changes, last state change 00:12:22
tamer-msfc-2#show standby 
Vlan11 - Group 11 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.846 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is local 
  Standby router is 11.1.1.2 expires in 00:00:08 
  Standby virtual MAC address is 0000.0c07.ac0b 
  2 state changes, last state change 00:07:02 
Vlan12 - Group 12 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.518 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is 12.1.1.2 expires in 00:00:07,
   priority 105 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0c 
  4 state changes, last state change 00:04:08

Toutes les informations dans l'exemple précédent sont encore valides. Pour vérifier ce qui a changé après avoir configuré le HSRP, visualisez la sortie des commandes MLS ci-dessous.

Émettre des commandes de show mls

tamer (enable) show mls 
Total packets switched = 29894 
Total Active MLS entries = 0 
  MSFC 11.1.1.2 (Module 15) entries = 0 
  MSFC 10.200.11.121 (Module 16) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Full flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 
IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11,8,1 
                            00-00-0c-07-ac-0c 12 

10.200.11.121   16     2    00-d0-bc-f0-07-b0 1,8,11,12 
                            00-00-0c-07-ac-0b 11 
  

IPX Multilayer switching aging time = 256 seconds 
IPX flow mask is Destination flow 
IPX max hop is 15 
Active IPX MLS entries = 0 

IPX MSFC ID     Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    -                 - 

10.200.11.121   16     2    -                 -
  • Il y a maintenant deux Routeurs MLS vus par le PFC.

  • Pour chaque routeur vu, l'adresse MAC utilisée par le groupe de HSRP est 00-00-0c-07-ac-xx. Ces adresses MAC sont les adresses MAC virtuelles utilisées par HSRP. Vous voyez seulement l'adresse MAC du groupe 11 joint au routeur qui est en activité pour ce groupe (emplacement 15 pour le VLAN 12 et emplacement 16 pour le VLAN 11). Cela signifie qu'en plus des paquets avec l'adresse MAC de destination étant l'adresse MAC MSFC, des paquets candidats sont également considérés, qui sont des paquets avec le MAC de destination étant l'adresse de HSRP.

  • Comme stipulé dans le premier exemple, vous devez également voir ces l'adresse de HSRP dans la table de CAM de la couche 2 indiquant le MSFC.

tamer (enable) show cam 00-00-0c-07-ac-0c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
12    00-00-0c-07-ac-0c R#          15/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable) 

tamer (enable) show cam 00-00-0c-07-ac-0b 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-00-0c-07-ac-0b R#          16/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable)

Émettre des commandes de show mls entry

tamer (enable) show mls entry
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
MSFC 10.200.11.121 (Module 16): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-10-7b-3b-af-3b 12   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:03 00:00:03 
ARPA 7/4    7/3    4          400         00:00:04 00:00:03 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 10.200.11.121 (Module 16):

  • Il y a maintenant deux tables raccourcies : un pour des écoulements créés par le premier MSFC, et un pour des écoulements créés par le deuxième MSFC.

  • Par le cinglement entre 11.1.1.1 et 12.1.1.1, qui sont deux PC configurés avec l'adresse de HSRP en tant que leur passerelle par défaut, des paquets de 12.1.1.1 à 11.1.1.1 étant livré dans le VLAN 12 sur le commutateur shortcuted par le MSFC dans l'emplacement 15 (car c'est le routeur HSRP actif pour le VLAN 12), et un raccourci pour la destination 11.1.1.1 est créé par le MSFC dans l'emplacement 15. Les raccourcis pour des paquets de 11.1.1.1 à 12.1.1.1 ont été créés sur l'autre extrémité par le MSFC dans l'emplacement 16.

Conseils de dépannage

Création des écoulements

Si un écoulement n'a pas été créé, utilisez les conseils de dépannage suivants :

  • Est-ce queengine de superviseur voit-elle le MSFC avec toutes les adresses MAC prévues en émettant le show mls commandent ?

    • Si oui, passez à l'étape suivante.

    • Si aucun, assurez-vous que le MSFC n'est pas coincé en mode de ROMmon. Vérifiez que MLS est activé sur le MSFC en émettant l'état de show mls de commande.

  • L'adresse MAC du MSFC est-elle présente en émettant la commande de show cam ? Apparaît-il comme entrée de CAM de routeur (R#) ?

  • Vérifiez que vous n'avez pas configuré une caractéristique sur le MSFC qui désactive MLS.

    • Vérifiez les caractéristiques qui peuvent affecter MLS en examinant les notes de mise à jour pour la version de logiciel que vous exécutez.

    • Des exemples des restrictions sont affichés dans la table ci-dessous.

      Restrictions d'ordre de routeur IP

      Commande Comportement
      clear ip route Efface toutes les entrées de cache MLS pour tous les Commutateurs exécutant le commutation de couche 3 pour ce MSFC.
      Routage IP Le forme no purge toutes les entrées de cache MLS et désactive IP MLS sur ce MSFC.
      Sécurité d'IP (toutes les formes de cette commande) IP MLS de débronchements sur l'interface.
      ip tcp compression-connections IP MLS de débronchements sur l'interface.
      ip tcp header-compression IP MLS de débronchements sur l'interface.

  • Vérifiez que vous avez activé une liste d'accès qui demande le logiciel manipulant au lieu de l'traitement par des raccourcis matériels. Référez-vous à la manipulation de matériel et de logiciel du pour en savoir plus IOS ACLs.

Si vous êtes passé par tous les conseils répertoriés ci-dessus, et avez toujours des problèmes, vérifiez que le MSFC est toujours en train d'être frappé par beaucoup de paquets.

  • Quelque chose peut causer les entrées d'être purgée continuellement. Quelques causes possibles de purger la table d'écoulement peuvent inclure ce qui suit :

    • Lien instable ou quels d'artère instabilité de la couche 3.

    • Le cache d'ARP change sur le MSFC.

    • Flowmask a changé sur l'engine de superviseur.

    • Le VLAN de destination est supprimé.

    • L'interface VLAN est arrêt sur le MSFC.

  • Quelques autres raisons pour l'expédition de logiciel (paquet frappant le MSFC) au lieu des raccourcis matériels peuvent inclure ce qui suit :

    • Paquet avec l'option IP réglée.

    • Paquet avec TTL inférieur ou égal à 1.

    • Paquet qui doit être fragmenté.

  • Vous pouvez avoir jusqu'à 128 K d'écoulement, cependant, un algorithme de hachage est utilisé. Si vous dépassez 32 écoulements K, vous pouvez commencer à avoir la collision d'informations parasites qui entraînera des paquets conduit par le logiciel.

    • Une manière d'éviter d'avoir trop d'écoulements est de configurer un vieillissement rapide pour le mls flow.

  • Souvenez-vous que vous pouvez seulement avoir MLS pour l'IP, l'IPX, et le Protocole IP Multicast. Si vous avez d'autres types de trafic (par exemple, AppleTalk), ils seront logiciel conduit, et peuvent entraîner des crêtes CPU sur le MSFC ou le paquet excessif frappant sur le MSFC.

  • Comme spécifié, IP MLS et IPX MLS sont activés par défaut, cependant, le Protocole IP Multicast MLS n'est pas activé par défaut. Si vous utilisez le Protocole IP Multicast, veillez à activer MLS pour la Multidiffusion comme spécifiée dans le guide de configuration.

Remarque: Une notification de modification de topologie de spanning tree (TCN) ou des ports instables sur un commutateur de gamme Catalyst 6500/6000 ne causera pas la table de mls flow d'être effacée, de même que le point de droit pour MLS sur des Commutateurs de Catalyst 5000.

L'ip accounting exclut le trafic MLS

Dans la gamme Cisco Catalyst 6500, la plusieurs commutation de couche (MLS) est déployée de telle manière qu'une fois qu'un écoulement est établi, le trafic soit directement commuté au PFC (matériel-commuté) et ne soit pas traité par le MSFC, par conséquent le manque de comptabilité continue. Seulement de nouveaux ou commutés par processus écoulements (logiciel-commutés) est enregistrés par ip accounting une fois activés, et même seulement jusqu'à l'entrée puis est écrits dans la base de données. Ainsi, le message d'avertissement précédent est normalement affiché quand vous activez l'ip accounting sur une telle plate-forme.

6500(config)#int fa8/40
6500(config-if)#ip accounting
Accounting will exclude mls traffic when mls is enabled.

La Fonction Netflow Accounting est la méthode préférée. Référez-vous à configurer le NetFlow pour plus d'informations sur au NetFlow.

Incapable de configurer interface-plein Flowmask

C6500#mls flow ip interface-full
%  Unable to configure flow mask for ip protocol: interface-full. Reset
to the default flow mask type: none

Émettez la commande de détail de flowmask de fie de show fm et la vérifiez si NAT est activé et utilise le masque de flux complet d'Intf.

C6500#show fm fie flowmask detail

!--- Part of the output not shown

Primary Flowmasks registered by Features
----------------------------+------------------------+------------------
---
          Feature                   Flowmask             Flowmask Status
----------------------------+------------------------+------------------
---
 IP_ACCESS_INGRESS               Intf Full Flow		Disabled/Unused
 IP_ACCESS_EGRESS                Intf Full Flow		Disabled/Unused
 NAT_INGRESS                     Intf Full Flow            Enabled
 NAT_EGRESS                      Intf Full Flow            Enabled

!--- Remaining part of the output not shown

Si NAT utilise le masque de flux complet d'Intf et quand vous essayez de configurer l'interface-plein pour le NetFlow, il y a une question, car il y a un conflit de flowmask. Si vous voulez utiliser la stat de NetFlow, vous pouvez essayer d'utiliser l'interface-destination-source (commande d'interface-destination-source d'IP de mls flow), qui n'est pas en conflit avec l'utilisation de masque de NetFlow.

NDE suppose que tous les écoulements sont créés avec le même masque de flux. En raison de cette restriction, NDE ne peut pas être activé avec certaines configurations qui exigent les masques de flux contradictoires. Un cas spécifique est NAT matériel-accéléré. NDE et NAT matériel-accéléré sont mutuellement - exclusivité.

NDE échoue si l'un de ces événements se produisent :

  • NAT Matériel-accéléré est activé.

  • Deux caractéristiques ou plus avec les masques de flux contradictoires ont été configurées sur le commutateur.

Réciproquement, une fois que NDE est avec succès configuré, NAT ne peut pas être configuré pour fonctionner dans le matériel et deux caractéristiques différentes avec des conditions requises contradictoires de masque de flux ne peuvent pas être configurées sur le commutateur.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10566