Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

Tunnels MPLS sur VP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Un fournisseur de services te donne normalement un ou plusieurs tunnels du chemin virtuel (VP) pour connecter vos périphériques ensemble au lieu d'un lien physique point par point. Ce document explique les étapes nécessaires pour configurer le Commutation multiprotocole par étiquette (MPLS) quand vous utilisez des tunnels VP.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10476/mpls_vptunnel-1.gif

Dans cette installation, le fournisseur de services a fourni deux tunnels VP :

  • Un entre les ischions et le Capri avec VPI = 3 (identifiant de chemin virtuel)

  • Un entre Alcazaba et Capri avec VPI = 4

Les ischions et l'Alcazaba sont deux Routeurs de Cisco 7200 qui exécutent la version de logiciel 12.1(3a)E de Ý de Cisco IOS. Capri est un commutateur-routeur multiservices de Catalyst 8540 (MSR) cette version de passages 12.0(10)W5(18c). Capri est un voisin de protocole de distribution de balise (Protocole TDP) d'Alcazaba et d'ischions.

Remarque: Vous devez exécuter la release 12.0(3)T ou plus élevé afin de configurer cette caractéristique.

Les configurations utilisées ici sont pour un Catalyst 8500 MSR, ou LightStream 1010, et un routeur.

Configurations

Ce document utilise les configurations suivantes :

Ischions
ip cef 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.0 
! 
interface ATM2/0.3 tag-switching 
 ip address 3.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 3 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 1.1.1.1 0.0.0.0 area 0 
 network 3.0.0.0 0.0.0.255 area 0 

Alcazaba
 ip cef 
! 
interface Loopback0 
 ip address 2.2.2.2 255.255.255.0 
! 
interface ATM4/0.4 tag-switching 
 ip address 4.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 4 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 2.2.2.2 0.0.0.0 area 0 
 network 4.0.0.0 0.0.0.255 area 0 

Capri
 interface ATM3/1/1 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 atm pvp 3 
 atm pvp 4 
! 
interface ATM3/1/1.3 point-to-point 
 ip address 3.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 
! 
interface ATM3/1/1.4 point-to-point 
 ip address 4.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 

Remarque: Cette configuration est semblable aux configurations de routeur standard que vous pouvez trouver ici. La seule différence est que vous devez spécifier au routeur que vous utilisez un tunnel vp. Vous pouvez faire ceci avec la commande de vpi de vp-tunnel atmosphère de balise-commutation, où le vpi est la valeur VPI qui est associée avec le tunnel qui finit sur ce routeur.

Remarque: Pour le LightStream 1010 et le Catalyst 8500 MSR, vous devez configurer un ou plusieurs chemins virtuels permanents (PVPs) pour chaque tunnel vp avec la commande de vpi d'atm pvp. Voyez ici pour une configuration d'échantillon. Une sous-interface est associée avec chacun de ces tunnels. Par exemple, l'interface atmosphère 3/1/1.3 est associée avec PVP=3. Vous devez configurer cette sous-interface avec la balise-commutation, comme vous faites sur l'interface principale.

Vérifiez

Utilisez ces commandes show de balise-commutation de tester que votre réseau fonctionne correctement :

  • affichez le voisin de TDP de balise-commutation

  • affichez les attaches d'atmosphère-TDP de balise-commutation — Ceci affiche les informations dynamiques de balise atmosphère.

  • affichez l'expédition-table de balise-commutation — Ceci affiche le Forwarding Information Base de balise (TFIB).

  • affichez le détail atmosphère d'interfaces de balise-commutation [nombre international] — ceci les informations de commutation détaillées par expositions de balise pour chaque interface.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Cette sortie est un résultat de ces commandes sélectionnées sur les périphériques affichés dans le schéma de réseau.

Ischia#show tag-switching tdp neighbor
Peer TDP Ident: 10.200.10.57:1; Local TDP Ident 1.1.1.1:1
        TCP connection: 3.0.0.2.11001 - 3.0.0.1.711
        State: Oper; PIEs sent/rcvd: 92/93; ; Downstream on demand
        Up time: 01:16:52
        TDP discovery sources:
          ATM2/0.3
 
Ischia#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Headend Router ATM2/0.3 (1 hop) 3/33  Active, VCD=127
 Destination: 1.1.1.0/24
    Tailend Router ATM2/0.3 3/33 Active, VCD=127
 Destination: 2.2.2.2/32
    Headend Router ATM2/0.3 (2 hops) 3/34  Active, VCD=128
 
Ischia#show tag-switching forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
26     3/33        4.0.0.0/24        0          AT2/0.3    point2point  
27     3/34        2.2.2.2/32        0          AT2/0.3    point2point   
 
Ischia#show tag-switching interfaces detail 
Interface ATM2/0.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        Tagswitching turbo vector
        MTU = 4470
        ATM tagging:
                Tag VPI = 3 (VP Tunnel)
                Tag VCI range = 33 - 65535
                Control VC = 3/32
 
Capri#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Tailend Switch ATM3/1/1.3 3/33 Active -> Terminating Active
 Destination: 1.1.1.1/32
    Transit ATM3/1/1.4 4/33 Active -> ATM3/1/1.3 3/33 Active
 Destination: 3.0.0.0/24
    Tailend Switch ATM3/1/1.4 4/34 Active -> Terminating Active
 Destination: 2.2.2.2/32
    Transit ATM3/1/1.3 3/34 Active -> ATM3/1/1.4 4/33 Active
 
Capri#show tag-switching tdp neighbor 
Peer TDP Ident: 1.1.1.1:1; Local TDP Ident 10.200.10.57:1
        TCP connection: 3.0.0.1.711 - 3.0.0.2.11001
        State: Oper; PIEs sent/rcvd: 95/94; ; Downstream on demand
        Up time: 01:18:49
        TDP discovery sources:
          ATM3/1/1.3
Peer TDP Ident: 2.2.2.2:1; Local TDP Ident 10.200.10.57:2
        TCP connection: 4.0.0.1.711 - 4.0.0.2.11002
        State: Oper; PIEs sent/rcvd: 93/95; ; Downstream on demand
        Up time: 01:18:22
        TDP discovery sources:
          ATM3/1/1.4
 
Capri#show tag-switching interfaces detail 
Interface ATM3/1/1.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 3, Control VC = 3/32
Interface ATM3/1/1.4:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 4, Control VC = 4/32

Cette sortie est semblable à la sortie standard de balise-commutation, mais une importante différence est qu'elle indique l'interface de tunnel vp.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10476