Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

MPLS sur ATM : Fusion de circuits virtuels

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon de Commutation multiprotocole par étiquette (MPLS) au-dessus d'atmosphère utilisant la fusion de circuit virtuel (circuit virtuel).

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous avez une compréhension de base d'atmosphère, de MPLS, et de Protocole OSPF (Open Shortest Path First).

Composants utilisés

Utilisez un de ces Routeurs afin d'implémenter cette configuration :

  • Affilez le routeur de commutateur d'étiquette (LSR) — n'importe quel routeur atmosphère qui exécute la version de logiciel 12.0 ou ultérieures de Cisco IOSÝ, avec des configurations MPLS. Cette configuration utilise les Routeurs de gamme Cisco 3600 qui exécutent le Logiciel Cisco IOS version 12.1(3)T et un routeur de Cisco 7200 qui exécute le Logiciel Cisco IOS version 12.0(8)S.

  • Atmosphère LSR — Tout commutateur ATM tel que le LightStream 1010 ou le Catalyst 85xx MSR. Cisco recommande que vous utilisiez la version de logiciel WA4.8d ou plus tard. Le LightStream 1010 exige une queue de PerFlow de carte fonctionnelle (FC-PFQ).

Vous pouvez trouver une description plus précise des Plateformes prises en charge en concevant le MPLS pour l'atmosphère.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Référez-vous à ces liens pour plus d'informations sur la configuration et les conventions MPLS :

  • L'installation de fusion de circuit virtuel est normalisée dans l'architecture à commutation d'étiquettes multiprotocole de l'Internet Engineering Task Force (IETF) et le MPLS utilisant le protocole de distribution d'étiquette (LDP) et le circuit virtuel atmosphère commutant des documents. Vous pouvez accéder à chacun des deux documents de la charte IETF MPLSleavingcisco.com .

  • Vous pouvez trouver des instructions de configuration dans le MPLS au-dessus de la documentation atmosphère.

  • Le calcul des dimensions du nombre de VCs l'a utilisé dans un réseau MPLS est couvert dans la section de l'espace de circuit virtuel de mpls label de calcul des dimensions de concevoir le MPLS pour l'atmosphère.

Informations générales

L'installation de fusion de circuit virtuel permet à un commutateur pour agréger de plusieurs écoulements entrants avec la même adresse de destination dans un écoulement sortant simple. Partout où la fusion de circuit virtuel se produit, plusieurs étiquettes entrant sont tracées à une étiquette sortante simple. Des cellules des différents indentifiants de canal virtuel (VCIs) qui vont à la même destination sont transmises au même circuit virtuel sortant avec l'utilisation des connexions multipoint à point. Ce partager des étiquettes réduit le nombre total de VCs a exigé pour la commutation par étiquette. Sans fusion de circuit virtuel, chaque chemin (avec le même routeur d'entrée et la même classe d'équivalence de transfert (FEC)) consomme un circuit virtuel d'étiquette sur chaque interface le long du chemin. La fusion de circuit virtuel réduit la pénurie de l'espace d'étiquette en partageant des étiquettes pour différents écoulements avec la même destination, c.-à-d., la même FEC.

Cette figure affiche un exemple de fusion de circuit virtuel. Dans cette figure, les Routeurs A et le B envoient le trafic pour préfixer 171.69.0.0/16 sur le routeur C. Le commutateur ATM au milieu est configuré avec une limite VCI 50 sortante simple pour préfixer 171.69.0.0/16. Les flux de données des Routeurs A et B rassemblent dans le commutateur ATM et partagent le même circuit virtuel sortant. Des cellules qui proviennent VCI 40 et VCI 70 sont mises en mémoire tampon dans les files d'attente d'entrée du commutateur ATM jusqu'à ce que les trames AAL5 complètes soient reçues. La trame complète alors est expédiée au routeur C sur VCI 50.

/image/gif/paws/10475/mpls_vcmerge1.gif

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise cette configuration du réseau.

/image/gif/paws/10475/mpls_vcmerge2.gif

Configurations

Dans cet exemple, des identifiants de chemin virtuel ATM (VPIs) 2, 3, ou 4 sont utilisés. Mais, il n'est pas obligatoire de spécifier que des chemins virtuels (VPs) sont utilisé pour le MPLS.

Configurez le Technologie Cisco Express Forwarding (CEF) IP sur les Routeurs. Si vous utilisez un routeur de Cisco 7500, vous devez s'assurer que la commande distribuée d'ip cef est activée.

Ce document utilise les configurations suivantes.

Routeur 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

Routeur 2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

Routeur 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Routeur 4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

Commutateur ATM 1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

Commutateur ATM 2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • affichez la capacité d'atmosphère-TDP de balise-commutation

  • affichez les attaches d'atmosphère-TDP de balise-commutation

  • show atm vc

Émettez la commande d'atmosphère-TDP de balise d'exposition afin d'obtenir les informations sur le fusionnement de circuit virtuel. Cette sortie, générée par la commande de capacité d'atmosphère-TDP de balise-commutation d'exposition, prouve que le fusionnement de circuit virtuel est activé sur ces interfaces :

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

Vous pouvez également vérifier la fusion de circuit virtuel pour une FEC particulière ? par exemple, 100.100.1.1/32 ? comme vu dans cette sortie :

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

Si la fusion de circuit virtuel ne fonctionne pas (ou s'il est désactivé avec l'aucune commande de circuit virtuel-fusion atmosphère de balise-commutation), vous recevez cette sortie de commande :

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

Vous pouvez voir de cette sortie que désactiver la fonction de fusion de circuit virtuel mène au système utilisant des beaucoup plus VCs.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10475