Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

Classe de service (CoS) MPLS sur ATM : Multi-VC TBR (avec CAR)

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le mécanisme multiprotocole de classe de service de commutation par étiquette (cos MPLS) est une caractéristique qui assure la Différenciation de services au-dessus de l'atmosphère. Il permet au réseau atmosphère pour traiter différents paquets basés sur le champ (expérimental) d'EXP (également appelé CoS) de l'en-tête MPLS, qui a les mêmes propriétés et qui peut être tracée à la Priorité IP.

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|               Label                   | EXP |S|      TTL      |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Ce document explique comment se servir de ce mécanisme dans un réseau de noyau MPLS qui reçoit des paquets IP (sans bits de priorité réglés) de différentes sources.

Conditions préalables

Débit binaire étiqueté par circuit Multi-virtuel (Multi-VC TBR)

Le Multi-VC TBR emploie des différents chemins et des classes de nouveau-service pour prendre en charge le traitement différent au-dessus de l'atmosphère. Cette méthode se compose de jusqu'à quatre circuits virtuels parallèles d'étiquette (LVCs) (ou de « circuit virtuel de balise » en vieille terminologie) et de cartes au cos MPLS. Cette table affiche le mappage par défaut :

Type de circuit virtuel d'étiquette Classe de service Type de service IP
Disponible 0 0,4
Standard 1 1,5
Premium 2 2,6
Contrôle 3 3,7

Chaque routeur de commutateur d'étiquette (LSR) a un certain nombre de VCs (d'un à quatre) qui correspond pour la même destination ou « multi-circuit virtuel ». Ces LVCs parallèle sont installés par le routeur en amont de périphérie avec le protocole de distribution d'étiquette.

Afin de prendre en charge le LVCs au niveau de commutateur, quatre nouvelles catégories de cos ont été introduites. Ils s'appellent les classes étiquetées du débit binaire (TBR) et sont des services minimaux (comme avec débit binaire non spécifié traditionnel (UBR)). Ils peuvent être configurés de la même manière. C'est-à-dire, leurs poids de parent ou les limites de leurs seuils peuvent être changés.

Classe de services d'ATM Forum Cos Poids relatif de classe Circuit virtuel d'étiquette
CBR 2 Sans objet
VBR-RT 2 8
Vbr-nrt 3 1
ABR 4 1
UBR 5 1
TBR_1 (WRR_1) 1 1 Disponible
TBR_2 (WRR_2) 6 2 Standard
TBR_3 (WWR_3) 7 3 Premium
TBR_4 (WWR_4) 8 4 Contrôle

Remarque: Les nouvelles catégories de cos sont en gras.

Mécanisme

La périphérie LSR place le cos MPLS mettent en place avec le Fonction Committed Access Rate (CAR) sur l'interface d'arrivée correcte. Le CAR peut être configuré pour agir selon un contrat ou n'importe quelle autre règle spécifique. Le LSR à la périphérie du réseau atmosphère aligne les cellules qui contiennent le paquet dans la file d'attente correcte (disponible, standard, de la meilleure qualité, ou contrôle), dépendantes du cos trace. Les cellules transitent alors par le réseau atmosphère MPLS avec le même LVC. Le résultat est que, à n'importe quelle atmosphère LSR, les cellules reçoivent un traitement par cos :

  • Par cos le Mise en file d'attente pondérée (WFQ) est proportionnel aux poids relatifs de classe.

  • Par cos l'EPD pesé (WEPD) est une méthode pour jeter des paquets quand les files d'attente se remplissent (semblable au Détection précoce directe pondérée (WRED)).

En conséquence, pour le LS1010 et le 8540MSR, ceci par comportement de cos est émulé plus de par queue de circuit virtuel.

L'espace de circuit virtuel

Fusions standard de circuit virtuel de supports de cos MPLS. Afin d'utiliser moins VCs, vous pouvez réduire le LVC utilisé (de quatre à deux, par exemple). Référez-vous au cos MPLS au-dessus de l'atmosphère : Carte de cos pour une configuration d'échantillon.

Le sujet du nombre de VCs est traité en concevant le MPLS pour l'atmosphère : Dimensionnement de l'espace de circuit virtuel de mpls label.

Matériel et versions de logiciel

Cette configuration a été développée et testée avec les versions de logiciel et de matériel suivantes :

Périphérie LSR

  • Logiciel - Version de logiciel 12.1(3)T de½ du¿Â du Cisco IOSï ; la caractéristique de Multi-circuit virtuel est apparue dans le Logiciel Cisco IOS version 12.0(5)T.

  • Matériel - Routeurs de Cisco 7200 avec PA-A1.

Remarque: Cette caractéristique fonctionne seulement avec Cisco 7200s et 7500s avec PA-A1.

Principale atmosphère LSR

  • Logiciel - Toute version logicielle qui prend en charge le MPLS ; les dernières versions sont recommandées.

  • Matériel - Le LS1010 et le 8540MSR.

Remarque: Un par-écoulement de carte fonctionnelle s'alignant (FC-PFQ) est obligatoire pour le LS1010.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10469/mpls_cos_atm1.gif

Procédure de configuration

Ce document utilise cette procédure de configuration :

  1. Afin d'installer quatre LVCs par défaut (avec le mappage par défaut), ajoutez cette instruction à la configuration de sous-interface atmosphère de la périphérie LSRs :

    tag-switching atm multi-vc
    
  2. Le LVCs parallèle a installé automatiquement sur les Commutateurs ATM. Afin de classifier les paquets, CAR d'utilisation (référez-vous à la documentation de CAR) pour placer le champ expérimental de l'en-tête MPLS à la valeur désirée. Cet exemple place le cos de tous les paquets entrant sur des Ethernets 1/1 interface à 1 (et place la carte à la « norme ») :

    interface Ethernet1/1
     rate-limit input 8000 1500 200 conform-action set-mpls-exp-transmit 1 exceed-action set-mpls-exp-transmit 1
    
  3. Vous pouvez également exécuter le contrôle de trafic et placer le cos à 2 (carte au « premium ») pour le trafic qui se conforme et à 0 (carte à « disponible ») pour le trafic qui dépasse :

    interface Ethernet1/1
     rate-limit input 64000 8000 16000 conform-action set-mpls-exp-transmit 2 exceed-action set-mpls-exp-transmit 0
    

    Remarque: Vous pouvez également utiliser la commande du vpi 2-4 atmosphère de balise-commutation, mais il n'est pas obligatoire de spécifier que des identifiants de chemin virtuel (VPIs) sont utilisé pour le MPLS.

    Remarque: Souvenez-vous pour configurer l'ip cef (ip cef distribué sur un Cisco 7500) sur la configuration générale des Routeurs.

Exemples de configuration

Ce document utilise les configurations suivantes :

Rapide
 !
 interface Loopback0
  ip address 223.0.0.12 255.255.255.255
 !
 interface Loopback2
  ip address 7.7.7.7 255.255.255.0
 !
 !
 interface FastEthernet0/1
  ip address 150.150.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 !
 router ospf 1
  network 7.7.7.7 0.0.0.0 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.0 0.0.0.255 area 0
 !      

Alcazaba
 !
 ip cef
 !
 !
 interface Loopback0
  ip address 223.0.0.3 255.255.255.255
 !
 interface Loopback1
  ip address 1.1.1.1 255.255.255.255
 !
 interface Ethernet1/1
  ip address 150.150.0.1 255.255.255.0
  rate-limit input 64000 32000 64000 conform-action set-mpls-exp-transmit 2 
  exceed-action set-mpls-exp-transmit 1
  no ip mroute-cache
 !
 !
 interface ATM4/0
  no ip address
  no ip mroute-cache
  no atm ilmi-keepalive
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.13 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 1
  network 1.1.1.1 0.0.0.0 area 0
  network 10.0.0.0 0.0.0.255 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.3 0.0.0.0 area 0
 !

Capri
 !
 interface Loopback1
  ip address 223.0.0.6 255.255.255.255
  no ip directed-broadcast
 !
 !
 interface ATM3/0/2
  ip address 10.0.0.14 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 interface ATM3/1/2
  ip address 10.0.0.10 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 2
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.6 0.0.0.0 area 0
 !

Goldorak
 !
 interface Loopback0
  ip address 223.0.0.2 255.255.255.255
  no ip directed-broadcast
 !
 interface ATM0/1/0
  ip address 10.0.0.9 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 !
 interface ATM0/1/3
  ip address 11.0.0.1 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 !
 router ospf 1
  network 10.0.0.0 0.0.0.255 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.2 0.0.0.0 area 0
 !

Ischions
 !         
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.11 255.255.255.255
 !
 interface Loopback1
  ip address 2.2.2.2 255.255.255.255
 !
 !
 interface ATM3/0.158 tag-switching
  ip address 11.0.0.2 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 router ospf 1
  log-adjacency-changes
  network 2.2.2.2 0.0.0.0 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.11 0.0.0.0 area 0
 !

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Commandes show

Sur un routeur LSR :

  • affichez l'expédition-table de balise-commutation

  • affichez le détail d'expédition-table de balise-commutation

Sur un commutateur ATM :

  • affichez les attaches d'atmosphère-TDP de balise-commutation

  • <interface> <vci/vpi> d'interface de show atm vc

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Exemple de sortie avec show

Afin de vérifier le multi-circuit virtuel sur une périphérie LSR, la commande traditionnelle d'expédition-table de balise-commutation d'exposition peut être utilisée. Afin de vérifier spécifiquement l'identifiant du descripteur (VCD) ou du chemin virtuel de circuit virtuel/indentifiant de canal virtuel (VPI/VCI), la commande doit être spécifique à une destination et doit finir avec le détail de mot.

Alcazaba#show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
16     Untagged    7.7.7.0/24        0          Et1/1      150.150.0.2  
17     Untagged    10.0.0.0/16       0          Et1/1      150.150.0.2  
18     Untagged    158.0.0.0/8       0          Et1/1      150.150.0.2  
19     Untagged    223.0.0.12/32     0          Et1/1      150.150.0.2  
20     Untagged    7.7.7.7/32        570        Et1/1      150.150.0.2  
21     Multi-VC    10.0.0.8/30       0          AT4/0.1    point2point  
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
32     Multi-VC    223.0.0.2/32      0          AT4/0.1    point2point  
34     Multi-VC    223.0.0.6/32      0          AT4/0.1    point2point  
36     Multi-VC    11.0.0.0/30       0          AT4/0.1    point2point  
37     Multi-VC    223.0.0.11/32     0          AT4/0.1    point2point 

Alcazaba#show tag-switching forwarding-table 2.2.2.2 32 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
        available 2/61(882), standard 2/62(883), premium 2/63(884), control 2/64(885), 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{Multi-VC}
        04F48847 004F4000
    Per-packet load-sharing 

Sur n'importe quelle atmosphère LSR, vous pouvez également tracer le VCs différent d'une interface à l'autre (avec la commande d'obligatoirex d'atmosphère-TDP de balise-commutation d'exposition) avec leurs classes de services respectives (la commande de <vci> de <vpi> d'interface> d'interface <ATM de show atm vc).

Capri#show tag-switching atm-tdp bindings
 Destination: 2.2.2.2/32
    Transit ATM3/0/2 2/61 Active -> ATM3/1/2 2/69 Active, CoS=available
    Transit ATM3/0/2 2/62 Active -> ATM3/1/2 2/70 Active, CoS=standard
    Transit ATM3/0/2 2/63 Active -> ATM3/1/2 2/71 Active, CoS=premium
    Transit ATM3/0/2 2/64 Active -> ATM3/1/2 2/72 Active, CoS=control
 Destination: 10.0.0.8/30
    Tailend Switch ATM3/0/2 2/97 Active -> Terminating Active, CoS=available
    Tailend Switch ATM3/0/2 2/98 Active -> Terminating Active, CoS=standard
    Tailend Switch ATM3/0/2 2/99 Active -> Terminating Active, CoS=premium
    Tailend Switch ATM3/0/2 2/100 Active -> Terminating Active, CoS=control
[...]
Capri#show atm vc interface atm3/0/2 2 63
 
Interface: ATM3/0/2, Type: oc3suni 
VPI = 2  VCI = 63
Status: UP
Time-since-last-status-change: 02:07:24
Connection-type: TVC(O) 
Cast-type: multipoint-to-point-output
Packet-discard-option: enabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 0
OAM-configuration: disabled
OAM-states:  Not-applicable
Cross-connect-interface: ATM3/1/2, Type: oc3suni 
Cross-connect-VPI = 2 
Cross-connect-VCI = 147
Cross-connect-UPC: pass
Cross-connect OAM-configuration: disabled
Cross-connect OAM-state:  Not-applicable
Threshold Group: 9, Cells queued: 0
Rx cells: 0, Tx cells: 0
Tx Clp0:0,  Tx Clp1: 0
Rx Clp0:0,  Rx Clp1: 0
Rx Upc Violations:0, Rx cell drops:0
Rx pkts:0, Rx pkt drops:0
Rx connection-traffic-table-index: 63998
Rx service-category: WRR_3 (WRR Bit Rate)
Rx pcr-clp01: none
Rx scr-clp01: none
Rx mcr-clp01: none
Rx      cdvt: 0 (from default for interface)
Rx       mbs: none
Tx connection-traffic-table-index: 63998
Tx service-category: WRR_3 (WRR Bit Rate)
Tx pcr-clp01: none
Tx scr-clp01: none
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: none

Dans les configurations d'échantillon, tous les paquets qui se conforment sont envoyés par le premium LVC. Tous les paquets qui dépassent la règle de CAR sont envoyés par le LVC standard. Dans ces premières sorties, un ping standard est fait et répété 158 fois :

rapid#ping        
Protocol [ip]: 
Target IP address: 2.2.2.2
Repeat count [5]: 158
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 158, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (158/158), round-trip min/avg/max = 1/1/5 ms

Vous pouvez vérifier si tous les paquets passent par le premium LVC avec la commande de show atm vc sur la périphérie LSR comme dans la sortie témoin. Dans cet échantillon, la sortie de la meilleure qualité VCD est 884.

Alcazaba#show atm vc 884
ATM4/0.1: VCD: 884, VPI: 2, VCI: 63
UBR, PeakRate: 155000
AAL5-MUX, etype:0x8847, Flags: 0x40C84, VCmode: 0x0
OAM frequency: 0 second(s)
InARP DISABLED
InPkts: 0, OutPkts: 158, InBytes: 0, OutBytes: 17064
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 158, InAS: 0, OutAS: 0
Giants: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
Tag VC: local tag: 0

Vous pouvez également vérifier tout commutateur ATM avec la commande du <interface> <vpi/vci> d'interface du trafic de show atm vc. Dans cet échantillon, chaque paquet de ping est transporté en trois cellules : 158*3 = 474 cellules.

Capri#show atm vc traffic interface atm 3/0/2 2 63
Interface    VPI     VCI      Type      rx-cell-cnts     tx-cell-cnts
ATM3/0/2     2       63        TVC(O)             0                0
ATM3/0/2     2       63        TVC(I)           474                0

Informations connexes


Document ID: 10469