Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

Commutation multiprotocole par étiquette (MPLS) sur ATM sans la commande VC-merge

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document montre un réseau de Commutation multiprotocole par étiquette (MPLS) avec l'atmosphère. Puisque la Circuit virtuel-fusion n'est pas utilisée, il y a un circuit virtuel alloué par artère comme déterminé par le préfixe dans la table de routage.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • La version de logiciel 12.0 ou ultérieures de ½ du ¿  de Cisco IOSï est pour le MPLS sur le Guilder et le Damme.

  • Cette installation utilise un commutateur ATM qui est utilisée en tant que routeur de commutateur d'étiquette (LSR). Dans cet exemple, c'est un Catalyst 8540MSR. Ce peut également être un LS1010. Cisco recommande la version de logiciel WA4.8d ou plus tard le LS1010. N'importe quel logiciel sur le 8540MSR est suffisant.

  • Le Technologie Cisco Express Forwarding (CEF) doit être activé sur les Routeurs qui exécutent la commutation MPLS/Tag. Dans cet exemple, le Guilder et le Damme sont Cisco 3600s. Si des 7500 est utilisés, l'ip cef distribué doit être activé.

Remarque: Bien que pas une condition requise, ce document utilise VPI 2, 3, ou 4 pour tous étiquettent VCs dans cet exemple.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10467/mpls_basic2.gif

Remarque: Des interfaces de bouclage ont été placées sur tous les Routeurs/LSRs. Ils ne sont pas affichés dans le schéma de réseau dans l'intérêt de la simplicité.

Configurations

Ce document utilise les configurations suivantes :

Dièse
!         
interface Loopback0
 ip address 100.100.0.1 255.255.0.0
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 123.123.0.2 255.255.0.0
 no ip directed-broadcast
!         
router ospf 1
 network 100.100.0.0 0.0.255.255 area 1.1.1.1
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
!

Guilder
!
ip cef
!
interface Loopback0
 ip address 102.102.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 123.123.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM1/0.1 tag-switching
 ip address 129.129.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 102.102.0.0 0.0.255.255 area 0.0.0.0
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Capri (8540MSR)
!
interface Loopback0
 ip address 103.103.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM3/0/0
 ip address 128.128.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM3/0/3
 ip address 129.129.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 103.103.0.0 0.0.255.255 area 0.0.0.0
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Damme
!
ip cef
!
interface Loopback0
 ip address 104.104.0.1 255.255.0.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 125.125.0.1 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed 10
 tag-switching ip
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !        
 pvc 0/5 qsaal
 !
!
interface ATM1/0.2 tag-switching
 ip address 128.128.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 104.104.0.0 0.0.255.255 area 0.0.0.0
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
!

Lire
!
interface Loopback0
 ip address 101.101.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 125.125.0.2 255.255.0.0
 no ip directed-broadcast
!
router ospf 1
 network 101.101.0.0 0.0.255.255 area 2.2.2.2
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
!

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • affichez l'expédition-table de balise-commutation — Affiche le Forwarding Information Base de balise (TFIB).

  • affichez les attaches d'atmosphère-TDP de balise-commutation — Affiche l'atmosphère dynamique étiquetant les informations.

  • affichez le détail atmosphère de la balise-commutation international [nombre international] — les informations de commutation détaillées par expositions de balise de par-interface.

Cette sortie prouve que la table de routage est complète sur le Guilder :

Guilder#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     102.0.0.0/16 is subnetted, 1 subnets

C       102.102.0.0 is directly connected, Loopback0

     103.0.0.0/32 is subnetted, 1 subnets

O       103.103.0.1 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

     100.0.0.0/32 is subnetted, 1 subnets

O       100.100.0.1 [110/11] via 123.123.0.2, 23:45:47, Ethernet0/1

     101.0.0.0/32 is subnetted, 1 subnets

O IA    101.101.0.1 [110/13] via 129.129.0.2, 23:13:01, ATM1/0.1

O    128.128.0.0/16 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

C    129.129.0.0/16 is directly connected, ATM1/0.1

     125.0.0.0/16 is subnetted, 1 subnets

O IA    125.125.0.0 [110/12] via 129.129.0.2, 23:13:08, ATM1/0.1

     123.0.0.0/16 is subnetted, 1 subnets

C       123.123.0.0 is directly connected, Ethernet0/1

     104.0.0.0/32 is subnetted, 1 subnets

O       104.104.0.1 [110/3] via 129.129.0.2, 23:14:32, ATM1/0.1

Vérifiez le préfixe au mappage label/VC avec la commande d'expédition-table de balise-commutation d'exposition.

Guilder#show tag-switching forwarding-table 

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    

tag    tag or VC   or Tunnel Id      switched   interface              

26     Untagged    100.100.0.1/32    570        Et0/1      123.123.0.2  

27     2/33        103.103.0.1/32    0          AT1/0.1    point2point  

28     2/34        128.128.0.0/16    0          AT1/0.1    point2point  

29     2/35        104.104.0.1/32    0          AT1/0.1    point2point  

30     2/37        125.125.0.0/16    0          AT1/0.1    point2point  

31     2/38        101.101.0.1/32    0          AT1/0.1    point2point 

Sur Capri (l'atmosphère LSR), vous pouvez vérifier le TVC pour conduire l'attache avec la commande d'obligatoirex d'atmosphère-TDP de balise d'exposition. Un TVC est utilisé pour chaque entrée de table de routage.

Capri#show tag atm-tdp bindings 

 Destination: 103.103.0.0/16

    Tailend Switch ATM3/0/0 2/34 Active -> Terminating Active

    Tailend Switch ATM3/0/3 2/34 Active -> Terminating Active

 Destination: 129.129.0.0/16

    Tailend Switch ATM3/0/0 2/35 Active -> Terminating Active

 Destination: 101.101.0.1/32

    Transit ATM3/0/3 2/33 Active -> ATM3/0/0 2/36 Active

 Destination: 104.104.0.1/32

    Transit ATM3/0/3 2/35 Active -> ATM3/0/0 2/37 Active

 Destination: 125.125.0.0/16

    Transit ATM3/0/3 2/36 Active -> ATM3/0/0 2/38 Active

 Destination: 128.128.0.0/16

    Tailend Switch ATM3/0/3 2/37 Active -> Terminating Active

 Destination: 102.102.0.1/32

    Transit ATM3/0/0 2/53 Active -> ATM3/0/3 2/33 Active

 Destination: 100.100.0.1/32

    Transit ATM3/0/0 2/54 Active -> ATM3/0/3 2/34 Active

 Destination: 123.123.0.0/16

    Transit ATM3/0/0 2/55 Active -> ATM3/0/3 2/35 Active

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 10467