Mode de transfert asynchrone (ATM) : Émulation LAN (LANE)

Exemple de configuration de l'émulation LAN (LANE)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document montre comment configurer des services et des clients d'Émulation LAN (LANE) sur des Routeurs de Cisco, des Commutateurs de Catalyst, et des Commutateurs ATM.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10457/lane_config1.gif

Dans cette installation :

  • Router1 et Router2 sont Cisco 4500 Routeurs exécutant la version de logiciel 12.1(4) de Cisco IOSÝ. Chacun des deux agissent en tant que clients d'émulation LAN (LECs).

  • Le LightStream 1010 est Logiciel Cisco IOS version 12.0(10)W5(18b) courant. Il agit en tant que serveur de configuration d'émulation LAN (LECS).

  • Le commutateur ethernet est un Catalyst 5000 avec une lame de RUELLE dans slot4. Cette lame de RUELLE agit en tant que LEC et en tant que serveur de diffusion et inconnu de RUELLE (LES/BUS).

  • Les services de RUELLE ont été configurés conformément aux recommandations en matière de conception LANE.

  • Deux LANs émulés (elans) ont été configurés : test-elan et test-elan2.

  • Router1 a un LEC dans chaque ELAN. Le commutateur ethernet a un LEC dans test-elan2. Le Router2 et le LightStream 1010 ont un LEC dans le test-elan.

  • Sur le commutateur ethernet, le RÉSEAU LOCAL virtuel, VLAN2, est lié à test-elan2.

  • Router1 est responsable de faire le routage entre les deux elans.

C'est l'installation logique :

lane_config2.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Seulement les parties des commandes de configuration qui sont appropriées à la RUELLE sont incluses.

LightStream 1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

Le test de lane database définit l'adresse du point d'accès aux services réseau (NSAP) du LES/BUS pour chaque ELAN. Ces adresses dans la configuration de LightStream 1010 indiquent la lame de RUELLE de commutateur ethernet :

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

Remarque:  ** représente le numéro de sous-interface d'octets dans le format hexadécimal.

Remarque: Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Une fois que vous avez défini le lane database, appliquez-le sur l'interface principale du LECS utilisant la commande de nom de la base de données de lane config database. C'est une explication des trois commandes qui sont configurées sur le LECS :

  • adresse NSAP de lecs-adresse-par défaut atmosphère — Définit qui adressent le commutateur annoncent en tant qu'étant les LECS NSAP à ses périphériques connectés par l'Interface ILM (Interim Local Management). Dans ce cas, l'adresse configurée est l'adresse NSAP assignée à l'interface ATM0 du LightStream 1010. Émettez la commande de par défaut de show lane d'obtenir cette adresse :

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    Remarque:  ** représente le numéro de sous-interface d'octets dans le format hexadécimal.

  • automatique-config-atmosphère-adresse de config de ruelle — Indique si le LECS répond aux établissements d'appel faits à sa vraie adresse NSAP.

  • nom de la base de données de lane config database — Définit que le lane database le LECS utilise.

Une fois que vous vous êtes appliqué la configuration ci-dessus à l'interface principale, le LECS est haut et en activité.

Vérifier l'état LECS

Émettez la commande de show lane config de vérifier l'état LECS :

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Router1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

Vérifier l'état LEC

Émettez ces commandes de vérifier l'état LEC :

  • show lane client [nombre d'interface atm [.subinterface-number]]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • show atm ilmi-status — Vérifie si le client a correctement enregistré son adresse NSAP par l'ILMI.

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    Référez-vous à ces documents pour plus d'informations sur la commande de show atm ilmi-status :

Router2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

Lame de RUELLE de commutateur ethernet

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

La commande d'elan-nom d'Ethernets de lane server-bus configure ce périphérique comme le LES/BUS pour l'ELAN a nommé l'elan-nom.

Remarque: Il peut seulement y avoir un serveur-bus par sous-interface multipoint.

Commandes supplémentaires

Ce sont quelques commandes utiles de les utiliser en configurant la RUELLE. Il n'est pas nécessaire d'employer ces commandes afin d'implémenter la RUELLE.

Sur le LECS

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • réparer-config-atmosphère-adresse de config de ruelle — Indique que le LECS répond aux établissements d'appel faits à l'adresse NSAP réputée. L'adresse NSAP réputée est 47.007900000000000000000000.00A03E000001.00.

  • config-atmosphère-adresse NSAP de config de ruelle — Indique que les réponses LECS aussi aux établissements d'appel faits à l'adresse NSAP configurée 47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01.

Sur le LES

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • lane config-atm-address NSAP — Force le LES/BUS pour se connecter au LECS à l'adresse de NSAP, au lieu d'utiliser l'adresse LECS apprise de l'ILMI.

  • lane server-atm-address NSAP et lane bus-atm-address NSAP — Permettez-vous pour configurer statiquement l'adresse NSAP du LES et du BUS respectivement.

Référez-vous aux adresses atmosphère de Dur-codage pour le pour en savoir plus LES/LEC/BUS/LECS.

Sur le LEC

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • lane fixed-config-atm-address — Force le LEC pour se connecter au LECS utilisant l'adresse NSAP réputée, au lieu d'utiliser l'adresse NSAP LECS apprise de l'ILMI.

  • lane config-atm-address NSAP — Force le LEC pour se connecter au LECS à l'adresse de NSAP, au lieu d'utiliser l'adresse LECS apprise de l'ILMI.

  • lane server-atm-address NSAP — Force le LEC pour se connecter directement au LES à l'adresse de NSAP sans se connecter au LECS d'abord.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10457