Mode de transfert asynchrone (ATM) : Réseautage ATM à relais de trames

Interopérabilité des services de Frame Relay à ATM (FRF.8 - Mode traduction)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Relais de trames (franc) à la fonction d'interfonctionnement de service ATM permet la transmission entre un utilisateur final franc et un utilisateur final atmosphère. Il est basé sur l'accord d'implémentationleavingcisco.com de Frame Relay Forum (FRF.8), qui spécifie qu'une station d'extrémité franc peut communiquer avec une station d'extrémité atmosphère à condition que il y ait un routeur exécutant les caractéristiques données dans FRF.8 en logiciel entre les deux stations d'extrémité.

Ce document présente une configuration d'échantillon de franc à l'interworking de service ATM utilisant FRF.8 (à mode de traduction) sur le LightStream 1010. Cette configuration travaille également au Catalyst 8510 MSR ou 8540 MSR.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur la version de Ý de Cisco IOS 12.0(3c)W5(9).

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10409/frf8.gif

Les paramètres de formatage du trafic franc utilisés dans cette configuration d'échantillon dans le routeur 1 sont :

  • Débit de données garanti (CIR) = 64 Kbits/s

  • Rafale validée (Bc) = 8000

  • Rafale excédentaire (soyez) = 8000

Remarque: Pour une explication détaillée sur la façon dont dépanner des connexions de Formatage du trafic de relais de trames, référez-vous aux commandes show pour le Formatage du trafic de relais de trames.

Configurations

Ce document utilise les configurations suivantes :

Remarque: Ces configurations contiennent les informations appropriées seulement pour le Relais de trames à l'interworking de service ATM.

Routeur 1
controller E1 5/0 
 channel-group 30 timeslots 1-31 
! 
interface Serial5/0:30 
 ip address 12.12.12.2 255.255.255.0 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF. It should match the switch.
 
 no fair-queue 
 frame-relay traffic-shaping

!--- Enabling FR traffic shaping on this interface.
          
 frame-relay class test-iwf 
 frame-relay map ip 12.12.12.1 123 broadcast 
! 
map-class frame-relay test-iwf 
 no frame-relay adaptive-shaping

!--- Traffic shaping parameters configured.

 frame-relay cir 64000 
 frame-relay bc 8000 
 frame-relay be 8000

Commutateur ATM
frame-relay connection-traffic-table-row index 123 64000 
8000 128000 8000 vbr-nrt 123 
! 
controller E1 4/0/0 
 clock source free-running 
 channel-group 30  timeslots 1-31 
! 
interface Serial4/0/0:30 
 no ip address 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF.

 no arp frame-relay 
 frame-relay intf-type dce

!--- Interface type is dce, because it is providing clocking.

 frame-relay pvc 123 rx-cttr 123 tx-cttr 123 service translation 
 interface  ATM0/0/0 0 123 

!--- This command makes the translation from          
!--- Frame Relay to ATM PVC 123.

Routeur 2
interface ATM2/0.123 point-to-point 
 ip address 12.12.12.1 255.255.255.0 
 no ip directed-broadcast 
 pvc 0/123

!--- Configured ATM PVC 0/123 with traffic shaping and          
!--- oam-pvc management enabled.
 
 vbr-nrt 163 81 49 
 broadcast 
 oam-pvc manage 
 encapsulation aal5snap

Les paramètres de formatage du trafic sur le Router2 peuvent être obtenus de la table du trafic de connexion de Relais de trames sur le commutateur ATM (voyez la section).

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show frame-relay lmi

  • show frame-relay map

  • show frame-relay pvc

  • interface atm 0/0/0 de show atm vc

  • affichez la connexion-trafic-table-ligne de Relais de trames

  • affichez la connexion-trafic-table atmosphère

  • affichez les tout-informations de l'interface série 4/0/0:30 de ressource en interface de Relais de trames

Le résultat présenté ci-dessous est un résultat d'écrire les commandes ci-dessus sur les périphériques affichés dans le schéma de réseau. Cette sortie prouve que le réseau fonctionne correctement.

Routeur 1

Remarque: En connectant un routeur de Cisco à une tiers connexion, il est préférable d'utiliser l'interface de gestion locale de l'Internet Engineering Task Force (IETF) (LMI). Notez que le LMI est Cisco et le Relais de trames est DTE car il reçoit la synchronisation du commutateur.

Router1# show frame-relay lmi 
 
LMI Statistics for interface Serial5/0:30 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1222             Num Status msgs Rcvd 1222
  Num Update Status Rcvd 0              Num Status Timeouts 2

Pour vérifier que le dlci est haut et tracé à l'adresse IP correspondante, utilisez la commande de show frame-relay map.

Router1# show frame-relay map 

Serial5/0:30 (up): ip 12.12.12.1 dlci 123(0x7B,0x1CB0), static,
              broadcast,
              IETF, status defined, active

Pour vérifier le statut du PVC de Relais de trames, utilisez la commande de show frame-relay pvc. Dans la sortie ci-dessous nous pouvons voir qu'elle est en activité.

Router1# show frame-relay pvc 
 
PVC Statistics for interface Serial5/0:30 (Frame Relay DTE)
 
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0:30
 
  input pkts 786           output pkts 549          in bytes 742312    
  out bytes 684503         dropped pkts 6           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 1          out bcast bytes 608       
  pvc create time 03:25:16, last time pvc status changed 03:09:30

Commutateur ATM

Remarque: Le terme ATM-PX/Y/Z se rapporte à la pseudo interface.

ATMswitch# show atm vc interface atm 0/0/0
Interface         VPI  VCI   Type   X-Interface      X-VPI X-VCI Encap  Status 
ATM0/0/0          0    5     PVC    ATM2/0/0          0    43    QSAAL  UP
ATM0/0/0          0    16    PVC    ATM2/0/0          0    35    ILMI   UP
ATM0/0/0          0    101   PVC    ATM0/1/0          0    101          UP
ATM0/0/0          0    102   PVC    ATM0/1/0          0    102          UP
ATM0/0/0          0    123   PVC    ATM-P4/0/0        30   155          UP

Pour afficher le Relais de trames aux connexions atmosphère dans le commutateur, utilisez la commande de connexion-trafic-table-ligne de Relais de trames d'exposition, comme affiché ci-dessous :

ATMswitch# show frame-relay connection-traffic-table-row 
Row            cir      bc     be      pir      fr-atm Service-category    ATM Row
                                            
100           64000   32768   32768   64000            vbr-nrt              100       
123           64000   8000    8000    128000           vbr-nrt              123       


ATMswitch# show atm connection-traffic-table 
Row      Service-category    pcr        scr/mcr       mbs         cdvt
1            ubr          7113539        none                     none
2            cbr              424                                 none
3            vbr-rt           424         424          50         none
4            vbr-nrt          424         424          50         none
5            abr              424           0                     none
6            ubr              424        none                     none
10           cbr            50000                                 none
11           cbr             1000                                 none
12           cbr            11700                                 none
100          vbr-nrt           81          81-0        50         none
123          vbr-nrt          163          81-0        49         none 
<-- (*)

2147483645*  ubr                0        none                     none
2147483646*  ubr                1        none                     none
2147483647*  ubr          7113539        none                     none

(*) Quand vous créez la connexion-trafic-table-ligne de Relais de trames, vous associez un index de ligne de table atmosphère où les paramètres de Formatage du trafic ATM sont automatiquement calculés utilisant la spécification large bande de l'interface d'Inter-transporteur (B-ICI), V2.0 (voir les formules).

ATMswitch# show frame-relay interface resource serial 4/0/0:30 all-information 
Encapsulation: FRAME-RELAY
Resource Management configuration:
    Input queues (PAM to switch fabric):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Output queues (PAM to line):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Overflow servicing for VBR: enabled
  Available bit rates (in bps):
     1920000 vbr-nrt RX, 1920000 vbr-nrt TX
     1920000 abr RX,     1920000 abr TX
     1920000 ubr RX,     1920000 ubr TX
    Overbooking: disabled
Resource Management state:  Allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX
  Actual allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10409