Mode de transfert asynchrone (ATM) : Classe de service IP à ATM

Mise en file d'attente pondérée basée sur les classes par circuit virtuel (Per-VC CBWFQ) sur les routeurs Cisco 7200, 3600 et 2600

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Mise en file d'attente pondérée (WFQ) a été mis en application pour les liens à basse vitesse (tels que l'interface série) pour fournir un traitement équitable pour chaque type de trafic. Pour réaliser son travail, WFQ classifie le trafic dans différents écoulements basés sur l'informations des couches 3 et 4 associé (adresses IP, ports TCP, et ainsi de suite). Vous n'avez pas besoin de définir des Listes d'accès pour que ceci travaille. Avec WFQ, le trafic de faible bande passante a la priorité efficace au-dessus du trafic de bande passante élevée. Les partages du trafic de bande passante élevée les supports de transmission proportionnellement aux poids assignés.

WFQ a les limites suivantes :

  • Si la circulation augmente de manière significative, WFQ ne peut pas s'ajuster parce qu'il n'est pas extensible.

  • WFQ n'est pas disponible sur les interfaces à grande vitesse, telles que l'atmosphère.

Une nouvelle caractéristique, la mise en file d'attente pondérée basée sur classe (CBWFQ), a été développée pour adresser les limites de WFQ. À la différence de WFQ, CBWFQ te permet pour définir des classes du trafic. Une fois que des classes ont été définies, les paramètres peuvent alors être appliqués. Ces paramètres inclut la bande passante et la queue-limit.

En utilisant CBWFQ, le poids spécifié pour une classe devient le poids de chaque paquet qui apparie les critères de classe. Ce poids est dérivé de la bande passante que vous assignez à la classe. WFQ est alors appliqué à ces classes au lieu de l'application aux écoulements eux-mêmes. Les classes peuvent inclure plusieurs écoulements.

Est ci-dessous un résumé de Disponibilité du Par-circuit virtuel CBWFQ sur les 7200, 3600, et 2600 Routeurs :

  • 7200 : Versions 12.0(5)T de Cisco IOSÝ, 12.0(5)XE, 12.1(1), 12.1(1)T, 12.1(1)E et plus tard utilisant un PA-A3.

  • 7200 avec NSE : Version 12.1(7)E et ultérieures de Cisco IOS.

  • 7200 avec NSE-1 entretient l'accélérateur : Version 12.2(4)B1 de Cisco IOS.

  • 2600/3600 avec les modules NM-1A-T3/E3 prennent en charge LLQ/CBWFQ sur la version 12.1(5)T et ultérieures de Cisco IOS.

  • 2600/3600 avec les modules réseau DS3/E3 : Version 12.1(2)T de Cisco IOS.

Remarque: Le Technologie Cisco Express Forwarding (CEF) commutant la fonctionnalité doit être utilisé parce que CBWFQ surveille seulement les paquets CEF-commutés.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel suivantes :

  • Cisco 7200, 3600, et Routeurs de gamme 2600

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10395/7200-1.gif

  • 1/130 est la valeur affectée VPI/VCI sur les deux extrémités du PVC entre les 7200 et de routeur A.

  • Le générateur du trafic est connecté pour relier les Fast Ethernet 3/0.

  • Les 7200 exécute la version 12.0(5)T de Cisco IOS.

  • Le routeur A est utilisé comme périphérique d'évier pour les tests.

  • La configuration est exécutée sur des 7200, mais elle est semblable sur un 2600/3600.

Exemple de configuration

Est ci-dessous la configuration 7200 nécessaire pour implémenter CBWFQ :

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

Sont ci-dessous quelques commentaires sur la configuration :

  • Les class map classifient et assignent des poids pour trafiquer. Des paramètres et les class map de classification sont définis au même lieu. Dans ce cas, une classe est appliquée à tout le trafic entrant sur les Fast Ethernet 3/0 (le trafic du générateur du trafic). L'autre classe est liée au trafic entre les bouclages (définis sur les 7200 et routeur A).

  • Après avoir défini les paramètres de classification, vous pouvez employer une carte de stratégie pour s'appliquer des paramètres du trafic à ces écoulements classifiés. Dans ce cas, l'écoulement du générateur du trafic « est alloué » une bande passante de 40 Mbits/s et une profondeur de la file d'attente de 40 paquets. Le trafic entre les bouclages est alloué une bande passante de 10 Mbits/s.

  • La profondeur de la file d'attente est le nombre de paquets qui peuvent être enregistrés pour une classe particulière avant que les baisses se produisent. La valeur par défaut est 64 (qui est également la profondeur de la file d'attente maximum).

  • Après que les paramètres du trafic aient été définis pour chaque classe, CBWFQ est appliqué sur une Circuit virtuel-base utilisant la commande suivante : service-stratégie [entrée|stratégie-MAP-nom de sortie].

  • Le trafic n'appariant pas un des class map définis sera assigné une carte de classe par défaut (par défaut de classe) qui est définie dans la carte de stratégie. Tout le trafic non-classifié sera appliqué les paramètres définis sous cette classe par défaut. Dans ce cas, la mise en file d'attente pondérée normale est configurée.

  • Pour cette configuration d'échantillon, CBWFQ est appliqué sur un circuit virtuel, mais il peut être aussi bien utilisé sur un ensemble de PVC. En outre, CBWFQ peut être associé avec Weighted Random Early Discard (WRED) comme mécanisme de baisse (quand la queue-limit est atteinte).

Important :

Avant d'exécuter les tâches de configuration dans cette section, vous devez d'abord créer les classes qui seront utilisées pour différencier le trafic sur le circuit virtuel, puis définissez une carte de stratégie pour les inclure. Vous pouvez configurer des stratégies de classe pour autant de classes comme sont définis sur le routeur -- jusqu'au maximum de 64. Cependant, la quantité totale de bande passante allouée de circuit virtuel (pour toutes les classes incluses dans une carte de stratégie) ne doit pas dépasser 75 pour cent de la bande passante disponible du VC.

Puisque CBWFQ fournit une garantie de bande passante minimale, vous pouvez seulement s'appliquer CBWFQ à VCs avec des classes de service autres que l'UBR et l'UBR+.

Vous ne pouvez pas s'appliquer le par-circuit virtuel WFQ et CBWFQ à l'UBR et à l'UBR+ VCs parce que chacun des deux classes de services sont des classes de meilleur effort qui ne garantissent pas la bande passante minimale. Quand CBWFQ est activé pour un circuit virtuel, toutes les classes configurées comme partie de la stratégie de service sont installées dans le système de mise en file d'attente équitable.

Si vous vous appliquez une stratégie de service à un circuit virtuel atmosphère et la stratégie inclut une caractéristique qui n'est pas Parallel Express Forwarding (PXF) - activé, les paquets seront donnés un coup de volée au prochain chemin de commutation inférieur. Exécutez la commande résumé CRNA de pxf d'exposition et recherchez une valeur de incrémentation pour des coups de volée devant « sortir la caractéristique. »

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

Configuration avancée CBWFQ sur 7200 Routeurs

Sur des Routeurs de Cisco 7200 exécutant la version 12.1(5)E de Cisco IOS, 12.1(5)T et plus tard, nous pouvons grouper les classes de carte pour former des class map plus compliqués. Supplémentaire, nous pouvons associer des opérations logiques aux paramètres de class map (pour déterminer si le trafic apparie une classe).

Regardons les class map suivants pour clarifier ce concept :

Configuration avancée CBWFQ
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

La différence entre le correspondance-tout et le match any est comme suit :

  • correspondance-tout : un écoulement est associé avec un class map si toutes les conditions associées sont vérifiées.

  • le match any signifie : un écoulement est associé avec un class-map si UN QUELCONQUE de conditions associées est vérifié (pas nécessairement toutes les conditions).

Nous pouvons voir ici qu'un class map peut inclure des tests contre d'autres class map configurés. Dans ce cas, un écoulement est associé avec ftp1 s'il apparie toutes les conditions définies sous l'ixia et le class map ftp2 de class map.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • atmosphère x/y [.z] de show policy-map interface — Cette commande te permet pour voir les statistiques par file d'attente, telle que les baisses. Il est utile pour surveiller les résultats d'une service-stratégie créée avec l'interface de ligne de commande de la qualité de service modulaire de Cisco (QoS) (CLI) (MQC). Pour plus d'informations détaillées sur la façon interpréter la sortie de cette commande, référez-vous compréhension derrière des compteurs de paquet dans la sortie de show policy-map interface.

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    Remarque: Voyez les explications suivantes concernant les deux types de baisses :

    • Écarts : baisses totales de ceci file d'attente.

    • Pertes de destination : les baisses de ceci s'alignent seulement quand une autre file d'attente fait « diminuer » un paquet entrant avec le numéro de séquence WFQ et le système WFQ atteint le nombre de paquets définis dans max-queue-limit.

  • atmosphère x/y [.z] vc de show policy-map interface [vcd | vpi/vci] — cette commande donne plus de finesse pour VCs spécifique.

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

Vous pouvez également utiliser d'autres commandes comme le show class-map ou le show policy-map class d'obtenir plus d'informations détaillées sur les classes de carte.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10395