WAN : Protocole point à point (PPP)

Multilink PPP sur des routeurs dos à dos avec plusieurs interfaces série

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans quelques environnements, il peut être nécessaire d'empaqueter des liaisons série pour agir en tant que bande passante agrégée simple. Ce document décrit comment configurer un serveur d'accès de Cisco 2503 pour empaqueter deux interfaces série avec deux différentes méthodes :

Ces configurations peuvent être utilisées pour les Routeurs reliés par des lignes louées ou les Routeurs qui ont l'unité de service de canal ou l'unité de service de données (CSU/DSU) ou l'adaptateur terminal RNIS (MERCI) configuré pour composer. (Des Routeurs de Cisco n'ont pas été configurés pour composer des numéros de téléphone.) Vous pouvez ajouter des fonctionnalités supplémentaires à cette configuration pour adapter à vos besoins.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur Cisco 2503

  • Version de logiciel 12.2(7b) de Cisco IOSÝ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut être utilisée avec deux Routeurs quelconques avec deux interfaces série WAN chacun. Vous pouvez utiliser WIC-1T, WIC-2T, ou interfaces série WAN fixes.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10382/pppmultilink.gif

Configurations

Cette configuration a été testée avec le Logiciel Cisco IOS version 12.2(7b) sur le Routeurs de la gamme Cisco 2500. Les mêmes concepts de configuration appliqueraient à une topologie semblable de routeur ou à d'autres versions logicielles de Cisco IOS.

Exemple 1 : Interface dialer

Exemple 2 : Modèle virtuel

Exemple 1 : Interface dialer

Router1 - Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

1Remarque d'exemple

La commande de légende de ppp direction est une commande masquée utilisée quand un routeur est confus quant à qui a composé qui (quand dos à dos connectés ou relié par des lignes louées et le CSU/DSU ou le RNIS MERCI sont configurés pour composer). La commande de callin de ppp direction peut également être utilisée. Utilisez l'un ou l'autre de ces commandes.

  • Pour un routeur local, légende de ppp direction d'utilisation.

  • Pour un routeur distant, callin de ppp direction d'utilisation.

Si vous n'utilisez pas cette commande, le routeur pendant un instant et puis se connecte des débranchements.

La configuration ci-dessus décrit deux Routeurs, Router1 et Router2, qui ont deux interfaces série à empaqueter pour agir en tant que bande passante agrégée simple. Sur les deux Routeurs, le bouclage d'interface est configuré et intégré avec l'interface dialer utilisant l'ip unnumbered loopback0. Les deux interfaces série sont configurées pour aucune adresse IP. Les interfaces physiques Serial0 et Serial1 sont configurées avec le groupe rotatif de routeurs d'appels et associées avec un numéroteur simple d'interface logique.

Le dialer-list 1 définit le trafic intéressant, qui déclenche consécutivement la commande du dialer-group 1 sur l'interface dialer 1 d'évoquer le lien. L'instruction de mappage de numéroteur définie sur les deux Routeurs trace l'interface dialer 1 à l'adresse IP du routeur de pair, et l'adresse Internet définie sert dans l'authentification CHAP. L'artère statique définie conduit le trafic à la destination.

Les commandes enables de CHAP d'authentification de ppp la négociation PPP. La commande de dialer load-threshold place un chargement ce des déclencheurs pour apporter la deuxième ligne série. Les commandes de ppp multilink et de groupe rotatif de routeurs d'appels ont été configurées de sorte que les deux interfaces série puissent être empaquetées ensemble en tant qu'une interface d'accès virtuel pour la bande passante agrégée. La commande de légende de ppp direction détermine quel côté doit faire une légende pendant la négociation PPP et l'authentification CHAP.

Vérifiez l'exemple 1

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

Dépannez l'exemple 1

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

commandes de débogage

Sur Router1, la commande de debug ppp authentication affiche le succès du CHAP.

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

Sur le Router2, la commande de debug ppp authentication affiche « attendre le pair…."

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

Exemple 2 : Modèle virtuel

Router1 - Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

La configuration ci-dessus décrit le modèle virtuel configuré sur Router1 et Router2. Dans cet exemple, les deux Routeurs sont configurés avec les modèles virtuels. Les Routeurs sont dos à dos connecté, et la session de multilink ne tourne pas au ralenti. Aucune artère de charge statique n'est nécessaire : une route hôte est installée après des négociations PPP.

Utiliser Logiciel Cisco IOS version 11.3 d'utilisation ou plus tard le modèle virtuel pour le ppp multilink.

La commande virtuelle de modèle crée dynamiquement une interface d'accès virtuelle et les applique aux interfaces série physiques avec la commande de multilink virtual-template. Les paramètres (tels que le CHAP d'authentification de ppp) configurés dans le modèle virtuel d'interface sont appliqués pour les deux interfaces série. La commande de ppp multilink dans l'interface virtual-template empaquette les interfaces série physiques pour former virtuel-Access afin d'agréger la bande passante.

Vérifiez l'exemple 2

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

Ces commandes peuvent également aider :

  • show ip route connecté — Pour voir si l'artère IP pour virtuel-Access est installée.

  • affichez l'interface virtuel-Access X — Pour vérifier le statut d'une interface d'accès virtuel particulière. Dans l'exemple ci-dessus, le nombre d'interface d'accès virtuel est 1.

Dépannez l'exemple 2

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

Configurez les horodateurs en configuration globale comme suit :

service timestamps debug datetime msec
service timestamps log datetime msec

Utilisez ces commandes de dépanner :

  • debug ppp negotiation — Pour voir si un client passe la négociation PPP. Vous pouvez également vérifier qui des options (rappel, PPP à liaisons multiples [MLP], et ainsi de suite) et que les protocoles (IP, IPX, et ainsi de suite) sont négocié.

  • debug ppp authentication — Pour voir si un client passe l'authentification.

  • debug vtemplate — Pour voir quelles configurations de modèle virtuel sont utilisées.

  • mettez au point vprofile — Pour voir quelles options de configuration sont appliquées à l'interface d'accès virtuel.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10382