Composition et accès : Routage à établissement de connexion à la demande (DDR)

Routage DDR RNIS utilisant l'encapsulation HDLC

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Il y a deux manières différentes d'utiliser le High-Level Data Link Control (HDLC) au-dessus du RNIS :

  • Définissez l'interface physique pour exécuter le HDLC. En d'autres termes, aucune encapsulation n'est définie puisque le HDLC est l'encapsulation par défaut utilisée par le logiciel de ½ du ¿  de Cisco IOSïÂ. C'est la manière d'origine de configurer le HDLC avec le Routage à établissement de connexion à la demande (DDR) et est discutée dans ce document.

  • Interface de numérotation d'utilisation pour lier le protocole que vous voulez (dans cet exemple, HDLC) à un numéroteur spécifique. C'est la méthode plus nouvelle et tient compte pour qu'une interface physique spécifique manipule de plusieurs protocoles (par exemple, protocole point-à-point [PPP] et HDLC). Puisque le protocole est configuré sur l'interface de numérotation, l'interface physique n'est pas limitée. Cette méthode est connue comme encapsulations multiples dynamiques et est discutée dans le RNIS DDR utilisant l'encapsulation HDLC avec des encapsulations multiples dynamiques.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Le taxbol de Routeurs, et le goya sont des Routeurs de gamme 2500 utilisés dans un environnement de travaux pratiques avec des configurations effacées.

  • Le Logiciel Cisco IOS version 11.2(22) est utilisé sur les deux Routeurs.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Pourquoi utilisation HDLC ?

La raison pour laquelle un utilisateur a besoin du HDLC sur le RNIS n'est pas évidente, puisqu'elle a beaucoup d'inconvénients comparés au PPP. Le seul but est de simplifier la configuration. Cependant, il simplifie également l'accès au routeur pour tous les pirates informatiques. Le HDLC ne prend en charge aucun genre d'authentification, par conséquent la meilleure protection ici serait de vérifier le numéro d'appel avec l'ordre d'appelant RNIS sur votre interface. Référez-vous à configurer le filtrage CLI ou l'authentification RNIS et le rappel avec l'Identification de l'appelant pour information les informations complémentaires. L'authentification basée d'ID ligne appelant (CLID) suppose que votre compagnie de téléphone fournit le numéro d'appel dans les messages de configuration RNIS. Cependant, puisque beaucoup de compagnies de téléphone ne fournissent pas le CLID, vérifiez avec votre compagnie de téléphone avant que vous configuriez le filtrage basé sur clid. Si le CLID n'est pas fourni par la compagnie de téléphone, alors tous les appels entrant dans le routeur échouent.

Un autre inconvénient de HDLC est que le routeur n'installe pas une carte dynamique. Par conséquent, une carte de numéroteur doit être configurée (sur chaque extrémité) pour le pair HDLC.

Remarque: Si seulement un côté fait l'appel (par exemple, un routeur toujours reçoit l'appel et ne fait pas dialout) s'assurer que vous incluez un nom pour le pair distant dans l'instruction de mappage de numéroteur du côté réception. Cependant, le nom peut être un faux nom puisque le routeur n'a aucune manière d'authentifier le nom de pair pour déterminer s'il apparie le map name de numéroteur.

Par exemple, c'est une description et cet isdn number est 8130.

  ip address 172.16.1.6 255.255.255.252 
  isdn caller 8129 

  !--- This is to accept only calls from 8129. 

  dialer map ip 172.16.1.5 name bogus_to_accept_command

  !--- This is a dialer-map with a fake name. 

  dialer-group 1 

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/10369/bri_ddr_hdlcencap.gif

Configurations

goya
Current configuration:
!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname goya
!

isdn switch-type basic-net3 

!--- The switch-type used is basic-net3. If you are in the United States,  
!--- configure the correct switch-type (for example
!--- isdn switch-type basic-5ess). In the US, you also need to
!--- configure the spids under the Basic Rate Interface (BRI) interface.
  
! 
interface Ethernet0 
 ip address 10.1.1.1 255.255.255.0 
 no ip redirects 
! 
interface BRI0 

 !--- If you are in the US do not forget the SPID 
!--- (for example isdn spid1 01555.....) 

 description This ISDN number is 8129 
 ip address 172.16.1.5 255.255.255.252 
 dialer idle-timeout 60
 
!--- The idle is set to 60 seconds. 
 
  isdn caller 8130 
 
!--- Verify the incoming number since there is no authentication on HDLC. 

 dialer map ip 172.16.1.6 8130

 !--- This side is making the call to 8130.  

 dialer-group 1 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.1.6 
access-list 105 permit icmp any any

!--- This access-list is to debug ICMP only. 

dialer-list 1 protocol ip permit 
! 
line con 0 
 exec-timeout 0 0 
 transport input none 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 no login 
! 
end

traxbol
Current configuration: 
! 
version 11.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname traxbol 
! 

isdn switch-type basic-net3 

!--- The switch-type used here is basic-net3. If you are in the United States,  
!--- configure the correct switch-type (for example
!--- isdn switch-type basic-5ess). In the United States, you also need to
!--- configure the SPIDs under the BRI interface. 
  
! 
Interface Ethernet0 
 ip address 10.1.2.1 255.255.255.0 
 no ip redirects 
! 
interface BRI0 

 !--- If you are in the United States, do not forget the SPID 
!--- (for example isdn spid1 01555.....). 

 description This ISDN number is 8130 
 ip address 172.16.1.6 255.255.255.252 
 isdn caller 8129 

 !--- Verify the incoming number since there is no authentication on HDLC. 

 dialer map ip 172.16.1.5 name goya

 !--- This side will not make any calls, but "name goya" is added to complete the
 !--- command. This is because a static dialer map is necessary.

 dialer-group 1 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.1.5 
access-list 105 permit icmp any any

!--- This access-list is to debug ICMP only. 

dialer-list 1 protocol ip permit 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password ww 
 login 
! 
end

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • nombre de show interfaces bri - Spécifier seulement le nombre affiche le canal D pour cela interface BRI.

    Commande Description
    nombre Nombre d'interface. La valeur est 0 à 7 si le routeur a un 8-port BRI NIM, ou à 0 à 15 si le routeur a deux 8-port BRI NIMs. Les valeurs de nombre d'interface varient, basé sur la plate-forme matérielle utilisée. Le routeur de gamme Cisco 3600 par exemple, peut avoir jusqu'à 48 interfaces.

Aucune encapsulation n'a été définie dans la configuration, ainsi par défaut c'est HDLC. Ceci peut être vérifié avec la commande d'interface d'exposition comme affiché ici :

 goya#show interfaces bri 0 
  BRI0 is up, line protocol is up (spoofing) 
   Hardware is BRI 
   Description: This ISDN number is 8129 
   Internet address is 172.16.1.5/30 
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255 
   Encapsulation HDLC, loopback not set 
   
!--- HDLC is configured automatically
 
   Last input 00:00:00, output 00:00:00, output hang never 
   Last clearing of "show interface" counters never 
   Input queue: 0/75/0 (size/max/drops); Total output drops: 0 
   Queueing strategy: weighted fair 
   Output queue: 0/1000/64/0 (size/max total/threshold/drops)   
    Conversations  0/1/256 (active/max active/max total) 
    Reserved Conversations 0/0 (allocated/max allocated) 
    5 minute input rate 0 bits/sec, 0 packets/sec 
    5 minute output rate 0 bits/sec, 0 packets/sec 
      3933 packets input, 20462 bytes, 0 no buffer 
      Received 15 broadcasts, 0 runts, 0 giants, 0 throttles 
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
      3926 packets output, 26100 bytes, 0 underruns 
      0 output errors, 0 collisions, 10 interface resets 
      0 output buffer failures, 0 output buffers swapped out 
      7 carrier transitions

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • mettez au point le numéroteur

  • détail 105 de debug ip packet — Utilisé pour mettre au point les paquets IP qui sont seulement ICMP (voir la liste d'accès 105 dans la configuration).

  • debug isdn q931 — Utilisé pour voir l'événement et des paquets RNIS Q.931.

  • mettez au point l'interface série — Utilisé pour mettre au point le HDLC.

Des exemples de debug des deux Routeurs sont affichés ici :

La sortie du goya :

goya#debug dialer 
Dial on demand events debugging is on 
goya#debug ip packet detail 105 
IP packet debugging is on (detailed) for access list 105 
goya#debug isdn q931 
ISDN Q931 packets debugging is on

!--- Verify that the map is correctly configured. 

goya#show dialer map 
Static dialer map ip 172.16.1.6 name traxbol (8130) on BRI0 
goya#ping? 172.16.1.6 

!--- Ping to the remote destination. 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds: 
*Mar? 1 05:40:07.230: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), len 100, sending

!--- The Ping attempts to leave the router. 

*Mar? 1 05:40:07.234:???? ICMP type=8, code=0 
*Mar? 1 05:40:07.238: BRI0: Dialing cause ip (s=172.16.1.5, d=172.16.1.6) 
*Mar? 1 05:40:07.238: BRI0: Attempting to dial 8130 

!--- The dialer attempts the call. 

*Mar? 1 05:40:07.242: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100,
   encapsulation failed

!--- This is because the HDLC is not ready. 
!--- Therefore,  the encapsulation failed.
  
*Mar? 1 05:40:07.246:???? ICMP type=8, code=0 
 
*Mar? 1 05:40:07.258: ISDN BR0: TX ->? SETUP pd = 8? callref = 0x37 
*Mar? 1 05:40:07.258:???????? Bearer Capability i = 0x8890 
*Mar? 1 05:40:07.262:???????? Channel ID i = 0x83 
*Mar? 1 05:40:07.266:???????? Called Party Number i = 0x80, '8130' 
*Mar? 1 05:40:07.318: ISDN BR0: RX <-? CALL_PROC pd = 8? callref = 0xB7 
*Mar? 1 05:40:07.322:???????? Channel ID i = 0x89 
*Mar? 1 05:40:07.470: ISDN BR0: RX <-? CONNECT pd = 8? callref = 0xB7 
*Mar? 1 05:40:07.486: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 05:40:07.514: ISDN BR0: TX ->? CONNECT_ACK pd = 8? callref = 0x37

!--- The call is made.

*Mar? 1 05:40:07.!!!! 

!--- One ping packet was lost because the encapsulation was not ready. 

Success rate is 80 percent (4/5), round-trip min/avg/max = 52/58/76 ms 
goya#.518: dialer Protocol up for BR0:1 
*Mar? 1 05:40:07.526: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up 
*Mar? 1 05:40:09.230: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.234:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.278: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.278:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.282: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.286:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.330: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.334:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.338: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.338:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.406: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:09.410:???? ICMP type=0, code=0 
*Mar? 1 05:40:09.414: IP: s=172.16.1.5 (local), d=172.16.1.6 (BRI0), Len 100, sending 
*Mar? 1 05:40:09.418:???? ICMP type=8, code=0 
*Mar? 1 05:40:09.462: IP: s=172.16.1.6 (BRI0), d=172.16.1.5 (BRI0), Len 100, rcvd 3 

!--- Other four ping packets are successful.

*Mar? 1 05:40:09.466:???? ICMP type=0, code=0 
goya# 
*Mar? 1 05:40:13.674: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8130
   traxbol 
!? 

!--- View the dialer.

!
goya#show dialer 

BRI0 - dialer type = ISDN 
Dial String????? Successes?? Failures??? Last called?? Last status 
8130?????????????????? 299???????? 10??? 00:00:11?????? successful 
0 incoming call(s) have been screened. 
BRI0:1 - dialer type = ISDN 
Idle timer (60 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is data link layer up 

!--- The next two lines tell who triggered the call 
!--- and the time remaining before disconnect. 

Dial reason: ip (s=172.16.1.5, d=172.16.1.6) 
Time until disconnect 50 secs 
Connected to 8130 (traxbol) 

BRI0:2 - dialer type = ISDN 
Idle timer (60 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is idle 
goya# 
!

!--- View the HDLC.

!
goya#debug serial interface? 
Serial network interface debugging is on 
goya#ping 172.16.1.6
 Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/93/328 ms 
goya# 
*Mar? 1 06:35:03.266: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 06:35:03.814: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
*Mar? 1 06:35:04.822: BRI0:1: HDLC myseq 0, mineseen 0, yourseen 0, line up? 
*Mar? 1 06:35:09.846: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8130
   traxbol 
*Mar? 1 06:35:14.826: BRI0:1: HDLC myseq 1, mineseen 1*, yourseen 1, line up? 
*Mar? 1 06:35:24.838: BRI0:1: HDLC myseq 2, mineseen 2*, yourseen 2, line up? 
*Mar? 1 06:35:34.842: BRI0:1: HDLC myseq 3, mineseen 3*, yourseen 3, line up? 
*Mar? 1 06:35:44.846: BRI0:1: HDLC myseq 4, mineseen 4*, yourseen 4, line up? 
*Mar? 1 06:35:54.850: BRI0:1: HDLC myseq 5, mineseen 5*, yourseen 5, line up? 
*Mar? 1 06:36:03.862: %ISDN-6-DISCONNECT: Interface BRI0:1? disconnected from
   8130 traxbol, call lasted 60 seconds 
*Mar? 1 06:36:03.974: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down 
*Mar? 1 06:36:04.858: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to down 
goya#undebug all 
All possible debugging has been turned off 
goya# 

La sortie du traxbol :

traxbol#debug dialer 
Dial on demand events debugging is on 
traxbol#debug ip packet detail 105 
IP packet debugging is on (detailed) for access list 105 
traxbol#debug isdn q931 
ISDN Q931 packets debugging is on 

!--- Verify that the map is correctly configured. 

traxbol#show dialer map 
Static dialer map ip 172.16.1.5 name goya (8129) on BRI0 
traxbol# 

!--- A call is received, notice that the calling party 
!--- matches the ISDN caller configuration.

*Mar? 1 05:40:30.898: ISDN BR0: RX <-? SETUP pd = 8? callref = 0x15 
*Mar? 1 05:40:30.898:???????? Bearer Capability i = 0x8890 
*Mar? 1 05:40:30.902:???????? Channel ID i = 0x89 
*Mar? 1 05:40:30.906:???????? Calling Party Number i = 0xA1, '8129' 
*Mar? 1 05:40:30.906:???????? Called Party Number i = 0xC1, '8130' 
*Mar? 1 05:40:30.918: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 05:40:30.954: ISDN BR0: TX ->? CONNECT pd = 8? callref = 0x95 
*Mar? 1 05:40:30.958: dialer Protocol up for BR0:1 
*Mar? 1 05:40:31.014: ISDN BR0: RX <-? CONNECT_ACK pd = 8? callref = 0x15 
*Mar? 1 05:40:31.018:???????? Channel ID i = 0x89 
*Mar? 1 05:40:31.862: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up 

!--- debug ip packet detail 105 shows the ICMPs on this router. 

*Mar? 1 05:40:32.794: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.798:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.802: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.802:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.850: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.854:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.854: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.858:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.926: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.930:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.930: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.934:???? ICMP type=0, code=0 
*Mar? 1 05:40:32.982: IP: s=172.16.1.5 (BRI0), d=172.16.1.6 (BRI0), Len 100, rcvd 3 
*Mar? 1 05:40:32.982:???? ICMP type=8, code=0 
*Mar? 1 05:40:32.986: IP: s=172.16.1.6 (local), d=172.16.1.5 (BRI0), Len 100, sending 
*Mar? 1 05:40:32.990:???? ICMP type=0, code=0 
*Mar? 1 05:40:36.994: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8129 goya
! 

!--- On the dialer, the call is received.
!--- There is no dial reason. However, the idle has been using the
!--- default 120 seconds since nothing was configured. 
!--- The router GOYA closes
!--- the call earlier because the idle is set to 60 seconds on that side.

!
traxbol#show dialer 

BRI0 - dialer type = ISDN 

Dial String????? Successes?? Failures??? Last called?? Last status 
8129???????????????????? 0????????? 0??? never?????????????????? - 
10 incoming call(s) have been screened. 

BRI0:1 - dialer type = ISDN 
Idle timer (120 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is data link layer up 
Time until disconnect 103 secs 
Connected to 8129 (goya) 

BRI0:2 - dialer type = ISDN 
Idle timer (120 secs), Fast idle timer (20 secs) 
Wait for carrier (30 secs), Re-enable (15 secs) 
Dialer state is idle 
traxbol# 
!

!--- View the HDLC.

!
traxbol#debug serial interface 
Serial network interface debugging is on 
traxbol# 
*Mar? 1 06:35:26.674: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
*Mar? 1 06:35:26.698: Ser-Autodetect BR0:1: no autodetect configuration 
*Mar? 1 06:35:27.534: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
*Mar? 1 06:35:31.554: BRI0:1: HDLC myseq 0, mineseen 0*, yourseen 1, line up? 
*Mar? 1 06:35:33.578: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8129
   goya 
*Mar? 1 06:35:41.598: BRI0:1: HDLC myseq 1, mineseen 1*, yourseen 2, line up? 
*Mar? 1 06:35:51.702: BRI0:1: HDLC myseq 2, mineseen 2*, yourseen 3, line up? 
*Mar? 1 06:36:01.746: BRI0:1: HDLC myseq 3, mineseen 3*, yourseen 4, line up? 
*Mar? 1 06:36:11.790: BRI0:1: HDLC myseq 4, mineseen 4*, yourseen 5, line up? 
*Mar? 1 06:36:21.894: BRI0:1: HDLC myseq 5, mineseen 5*, yourseen 6, line up? 
*Mar? 1 06:36:27.510: %ISDN-6-DISCONNECT: Interface BRI0:1? disconnected from 8129
   goya, call lasted 60 seconds 
*Mar? 1 06:36:27.514: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down 
*Mar? 1 06:36:27.922: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to down 
traxbol#undebug all 
All possible debugging has been turned off 
traxbol# 

Informations connexes


Document ID: 10369