Composition et accès : Connexions asynchrones

Connexion de routeurs dos à dos par le biais des ports AUX

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cet exemple de configuration illustre comment connecter directement deux routeurs sans modem ou sans autre équipement de transmission de données. Pour plus d'informations sur la façon configurer des Modems sur des ports d'auxiliaire (AUX.) ou de console, voir le support technique de Guide de connexion modem-routeur ou de numéro d'accès.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Informations générales

Dans cette configuration, deux Routeurs de Cisco sont dos à dos connecté par les ports auxiliaires asynchrones à l'aide d'un câble null modem (câble inversé). Les ports auxiliaires des deux Routeurs sont directement connectés à l'aide d'un câble inversé au Protocole point à point (PPP) s'exécutant sur le lien. Les ports auxiliaires sont des périphériques de l'équipement pour terminal de données (DTE). Vous exigerez d'un câble null modem (câble inversé) de connecter le DTE aux périphériques DTE.

Un câble plat renversé (null modem) (numéro de pièce CAB-500RJ=) est habituellement équipé de chaque routeur de Cisco pour tenir compte de la Connectivité de console de RJ-45. Si le port auxiliaire est un DB-25, utilisez un « terminal » RJ-45-to-DB-25 marqué par adaptateur avec le câble null modem (câble inversé).

Remarque: Assurez-vous que la longueur du câble est moins de 50 pieds de dû (autrefois connu sous le nom de RS-232) aux limites EIA/TIA-232.

Pour plus d'informations sur le câblage, référez-vous au guide de câblage pour la console de RJ-45 et les ports auxiliaires et les câbles de RJ-45.

Routeurs avec les ports auxiliaires DB-25

Pour des Routeurs avec un port auxiliaire DB-25 (par exemple, Cisco 4500, 7200 et 7500), vous avez besoin d'un câble null modem DB-25-to-DB-25. Ce câble peut être acheté de la plupart des points de vente d'accessoires électroniques détaillants.

Remarque: En raison des paires de signalisation incorrecte, vous NE POUVEZ PAS utiliser un câble satiné plat RJ-45-to-RJ-45 roulé avec les adaptateurs RJ-45-to-DB-25 (numéro de pièce CAB-25AS-MMOD) sur les deux extrémités.

Vérifiez si votre câble null modem DB-25-to-DB-25 a les connexions de broche indiquées dans le tableau 1.

Tableau 1 ? Connexions Pin du câble null modem DB-25-to-DB-25

DB-25 DB-25
RxD 2 3 TXD
TxD 3 2 RxD
CTS 4 5 RTS
RTS 5 4 CTS
DTR 6 20 CD
DSR 8
CD 20 6 DTR
8 DSR
GND 7 7 GND

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/10365/auxback.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Cette connexion a été configurée avec des adresses IP sur les ports auxiliaires pour (« cloué vers le haut de ») une connexion permanente.

Routeur 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Routeur 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Procédure de dépannage

Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

Procédez comme suit :

  1. Utilisez la commande de show line de déterminer l'interface asynchrone des ports auxiliaires.

    Bien que la plupart des Routeurs aient le port auxiliaire comme interface 1 async, les serveurs d'accès ont l'interface de port AUX après les lignes TTY. Par exemple, si votre routeur a 16 async/lignes du modem, le port auxiliaire est la ligne 17. En pareil cas, le port auxiliaire doit être configuré sur l'interface 17 async. Configurez le port auxiliaire basé sur les sorties de show line. Voici un exemple à vérifier que la configuration du port AUX est sur l'interface Async1 sur vos Routeurs :

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. Émettez commandes aux. de show line les 0.

  3. Vérifiez que tous les signaux sont (par exemple, Clear to Send (CTS), Request To Send (RTS), terminal de données prêt (DTR), et Détection Onde Porteuse (CD)).

    Si rien n'apparaît à côté de eux, ils sont. Si « non » apparaît à côté de eux (par exemple, NO--CTS), il signifie qu'ils sont vers le bas. S'ils sont vers le bas, vérifiez la configuration de chaque côté. Vérifiez que vous avez l'interface asynchrone et la ligne du port auxiliaire configuré (comme affiché ci-dessus).

    Remarque: Si la sortie de commande de show line indique que DSR n'est pas (noDSR), vous devez vérifier que la chaque extrémité sur le câble null modem DB-25-to-DB-25 a les bornes 6 et 8 physiquement de câble pour borne 20 de l'autre extrémité. Référez-vous au 1par de table les sorties correctes.

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. Si la configuration semble correcte, remplacez le câble inversé entre le routeur.

  5. N'utilisez l'arrêt et aucune commande shutdown sur l'interface asynchrone de remettre à l'état initial la connexion.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Utilisez ces commandes de débogage de vérifier que le lien est soulevé correctement.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • debug ppp negotiation — l'affiche des informations sur le trafic PPP et les échanges comme négociation du Link Control Protocol (LCP), de l'authentification, et du protocole de contrôle de réseau (NCP) est en cours. Une négociation PPP réussie ouvre tout d'abord l'état LCP, puis procède à l'authentification, pour terminer par la négociation de NCP. Si CONFREQs sont envoyés, mais aucun CONFACKs ne sont reçus, vérifient si le câblage est correct, et si la ligne correcte est configurée (émettez la commande d'interface async x pour ceci).

  • le debug ppp authentication — des messages du protocole d'authentification de PPP d'affichages (si l'authentification est configurée), et inclut des échanges de paquet de protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) et des échanges de Password Authentication Protocol (PAP). Dans cette configuration l'authentification n'est pas configurée. Par conséquent, cette commande de débogage n'est pas nécessaire.

  • debug ppp error — erreurs de protocole et statistiques sur les erreurs d'affichages associées avec la négociation et l'exécution de connexion PPP.


Informations connexes


Document ID: 10365