Composition et accès : Connexions asynchrones

Configuration de l'accès sortant avec le module de modem analogique NM-8AM ou NM-16AM

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document affiche comment configurer le dialout utilisant un modem avec le module réseau de modem analogique NM-AM. Dans ce scénario, un routeur avec le module modem NM-8AM compose l'accès primaire (PRI) du routeur de lieu d'exploitation principal.

Ce document suppose que vous avez une bonne compréhension des diverses questions associées avec des configurations de modem. Si vous avez besoin de plus d'informations sur ces questions, référez-vous s'il vous plaît au Guide de connexion modem-routeur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous :

  • Un routeur de Cisco 3640 avec la carte NM-8AM exécutant la version de logiciel 12.1(5)T de ½ du ¿  de Cisco IOSïÂ.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/10316/dialout-nmam.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

Routeur 1 (Cisco 3640)
Current configuration : 1676 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
enable password ww
!
username router2 password 0 ww

!--- username for remote router (Router 2) and shared secret
!--- shared secret(used for CHAP authentication) must be the same on both sides

ip subnet-zero
!
chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!--- chat script "async" used for the dialout connection

!
!
interface Ethernet2/0
 ip address 10.200.20.51 255.255.255.0
 half-duplex
!
interface Async104	

!--- async interface corresponding to the modem 
!--- This was determined using the show line command.

 ip address 10.10.0.2 255.255.255.252

!--- IP address of this async interface

 encapsulation ppp
 dialer in-band
 dialer wait-for-carrier-time 180
 dialer map ip 10.10.0.1 name router2 modem-script async 8214

!--- dialer map statements for the remote router 
!--- The name must match the one used by the remote router to identify itself.
!--- use modem chat script "async" for this connection

 dialer-group 1
!--- apply interesting traffic definition from dialer-list 1
 async mode dedicated

!--- Place the line into dedicated asynchronous network mode.
!--- This interface is now automatically configured for PPP connections.

 ppp authentication chap
!--- use chap authentication
!
ip classless
ip route 10.10.0.0 255.255.0.0 10.10.0.1

!--- Traffic for the 10.10.0.0/16 network uses a next hop of 10.10.0.1

ip route 10.10.0.1 255.255.255.255 Async104	

!--- the next hop for 10.10.0.1/32 (which is also the next hop for the 
!--- previous route) is interface Async104.

!
dialer-list 1 protocol ip permit

!--- All IP traffic is defined interesting.
!--- This is applied to Async104 using dialer-group 1.

!
!
line con 0
 exec-timeout 0 0
 password ww transport input none
line 33 38
line 97 103
 modem InOut transport input all
line 104		

!--- line interface configuration for Async 104

 modem InOut	

!--- allow incoming and outgoing modem calls on this line
	
 transport input all
 transport output lat pad v120 lapb-ta telnet rlogin udptn
 flowcontrol hardware
line aux 0
line vty 0 4
 password ww
 login
!
end

Dans des ce 3600 châssis, la carte NM-8AM est installée dans l'emplacement 3. se rapportant à comment des lignes asynchrones sont numérotées dans des Routeurs document de gamme Cisco 3600, nous s'assurent que l'emplacement 3 a la ligne 97 à 128 réservés. Pour déterminer quelle interface asynchrone spécifique vous devriez configurer, utilisez la commande de show line de découvrir les lignes disponibles. Dans cette configuration, notez que seulement les lignes 97-104 (8 lignes) sont disponibles dans cette marge. Par conséquent, pour configurer le premier modem in la carte configurent la ligne 97 (et interface async97) tandis que le dernier modem est line/async104.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannage de la connexion analogique

Terminez-vous ces étapes afin de dépanner la connexion de dialout :

  1. Vérifiez la configuration de modem.

    Vérifiez la configuration du modem. Vous devriez vérifier la ligne configuration correspondant au modem aussi bien que l'interface async.

  2. Renversez le telnet au modem et initiez un dialout.

    Renversez le telnet le port au modem, et employez le positionnement de commande AT pour composer et se connecter au périphérique distant. Ceci peut être utilisé pour vérifier que le circuit de matériel et de téléphone de modem fonctionnent. Dans cet exemple, puisque le port de modem est sur la ligne 104, renversez le telnet au port 2104 sur le routeur. Pour plus d'informations sur des telnets inverses, référez-vous à établir une session Reverse Telnet à un modem.

    router1#telnet 10.200.20.51 2104 
    Trying 10.200.20.51, 2104  ... Open
    User Access Verification
    Username: admin
    Password: 
    
    !--- Authentication performed by local router for the reverse telnet
    
    at
    OK
    atdt 81690
    
    !--- The modem dials (81690) and connects.
    !--- This takes approximately 30-45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connect speed and protocols that were negotiated
    
    User Access Verification
    Username: admin
    Password:
    
    !--- Authentication performed by remote router for the incoming call
     
    router2>
    
    !--- Remote router's prompt
    
    

    Vous pouvez également appliquer d'autres commandes AT afin de vérifier les paramètres du modem. Référez-vous à la commande AT réglée et à la récapitulation du registre pour des modules réseau de modem analogique pour plus d'informations sur la commande AT disponible pour les modules de modem analogique.

  3. Lancez le script de conversation manuellement et initiez un cadran.

    Employez la commande de start-chat afin de lancer le script de conversation et initier un cadran. La commande de start-chat exige de vous de spécifier le nom du script de conversation à lancer, du numéro de téléphone à composer, et de l'interface de modem pour composer pour sortir en fonction.

  4. Vérifiez qu'il y a une artère à l'interface asynchrone.

    Employez la commande de show ip route afin de vérifier s'il y a une artère à l'interface asynchrone. S'il n'y a aucune artère, créez une artère statique. Un exemple est montré :

    ip route 10.10.0.1 255.255.255.255 Async104 
  5. Générez un ping destiné pour le réseau du prochain saut spécifié dans l'étape 4.

    Un ping pour le routeur distant, qui est spécifié utilisant le réseau du prochain saut de l'étape 4, fait composer le routeur le périphérique distant.

    router1#ping 10.10.0.1
    

Référez-vous aux appels sortants de dépannage pour plus d'informations sur la façon dépanner votre connexion.

Erreurs communes

  • Vérifiez que le nom de script de conversation est identique à celui spécifié dans l'instruction de mappage de numéroteur. Vérifiez également que le numéro de téléphone à composer est correctement spécifié.

  • Vérifiez pour voir que le trafic intéressant est correctement défini. Le trafic intéressant est spécifié avec la commande de dialer-list.

  • Assurez-vous que la définition du trafic intéressant est appliquée à l'interface asynchrone. Ceci est fait utilisant l'ordre de dialer-group, où le nombre de groupe doit apparier la définition du trafic intéressant spécifiée avec la commande de dialer-list.

  • Vérifiez que le nom d'utilisateur et mot de passe pour l'authentification PAP/CHAP sont correct.

  • Vérifiez pour s'assurer que l'instruction de mappage de numéroteur a le nom, l'adresse IP, et le numéro de téléphone corrects à composer.

commandes de débogage

Avant d'émettre des commandes debug, reportez-vous aux Informations importantes sur les commandes de débogage.

  • mettez au point le numéroteur - Pour afficher les informations de débogage au sujet des paquets reçus sur une interface de numérotation. Quand le routage sur demande de cadran (DDR) est activé sur l'interface, les informations au sujet de la cause de n'importe quel appel (appelé la cause d'appel) sont également affichées. Le pour en savoir plus, voient les informations de numéroteur de débogage dans la documentation de commandes de debug.

  • debug modem - Pour afficher l'activité de ligne du modem, le contrôle de modem, et les messages d'activation de processus sur le routeur.

  • mettez au point la conversation - Pour surveiller l'exécution du script de conversation quand la composition async/POTS est initiée. Référez-vous à la technologie d'accès commuté : Pour en savoir plus de techniques de dépannage.

  • debug ppp negotiation - Pour afficher les informations sur le trafic PPP et des échanges tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le protocole de contrôle de réseau (NCP). Une négociation PPP réussie d'abord ouvrira l'état LCP, puis authentifie, et négocie finalement le NCP.

  • debug ppp authentication - Pour afficher les messages du protocole d'authentification de PPP, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP).

Exemple de sortie de débogage

router1#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
Generic IP:
  ICMP packet debugging is on
PPP:
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
router1#
router1#ping 10.10.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.0.1, timeout is 2 seconds:
*Mar  1 00:22:58.663: As104 DDR: Dialing cause ip (s=10.10.0.2, d=10.10.0.1)

!--- Dialing reason is the ping for 10.10.10.1
!--- The dialout is using Async104.

*Mar  1 00:22:58.663: As104 DDR: Attempting to dial 8214

!--- Phone number to be dialed

*Mar  1 00:22:58.663: CHAT104: Attempting async line dialer script
*Mar  1 00:22:58.663: CHAT104: Dialing using Modem script: async & System script: none

!--- Use chat script named "async"

*Mar  1 00:22:58.663: CHAT104: process started
*Mar  1 00:22:58.667: CHAT104: Asserting DTR
*Mar  1 00:22:58.667: CHAT104: Chat script async started

!--- Chat-script "async" is started.

*Mar  1 00:22:58.667: CHAT104: Sending string: AT
*Mar  1 00:22:58.667: CHAT104: Expecting string: OK
*Mar  1 00:22:58.739: CHAT104: Completed match for expect: OK
*Mar  1 00:22:58.739: CHAT104: Sending string: ATDT\T<8214>
*Mar  1 00:22:58.739: CHAT104: Expecting string: CONNECT
*Mar  1 00:22:58.751: Modem 3/7 Mcom: in modem state 'Dialing/Answering'
*Mar  1 00:23:10.775: Modem 3/7 Mcom: in modem state 'Waiting for Carrier'
*Mar  1 00:23:21.903: Modem 3/7 Mcom: in modem state 'Connected'
*Mar  1 00:23:22.323: Modem 3/7 Mcom: CONNECT at 26400/24000(Tx/Rx), V34, LAPM, V42bis,
 Originate

!--- Connect speeds, protocols and so forth, and so on negotiated for the connection
!--- Note that the modem used is 3/7 which is equivalent to line 104.
!--- Refer to How Async Lines are Numbered in Cisco 3600 Series Routers.

*Mar  1 00:23:22.375: CHAT104: Completed match for expect: CONNECT
*Mar  1 00:23:22.375: CHAT104: Sending string: \c
*Mar  1 00:23:22.375: CHAT104: Chat script async finished, status = Success

!--- Chat script is successful. Notice the Expect/Send attributes and the time elapsed.

*Mar  1 00:23:22.375: Modem 3/7 Mcom: switching to PPP mode
*Mar  1 00:23:22.379: TTY104: no timer type 1 to destroy
*Mar  1 00:23:22.379: TTY104: no timer type 0 to destroy
*Mar  1 00:23:22.379: As104 IPCP: Install route to 10.10.0.1
*Mar  1 00:23:24.379: %LINK-3-UPDOWN: Interface Async104, changed state to up
*Mar  1 00:23:24.379: As104 DDR: Dialer statechange to up
*Mar  1 00:23:24.379: As104 DDR: Dialer call has been placed
*Mar  1 00:23:24.379: As104 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 00:23:24.379: As104 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar  1 00:23:24.379: Modem 3/7 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0
*Mar  1 00:23:24.379: As104 LCP: O CONFREQ [Closed] id 17 len 25
*Mar  1 00:23:24.379: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.379: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.379: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.379: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.379: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: I CONFREQ [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: O CONFACK [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.555: As104 LCP: I CONFACK [ACKsent] id 17 len 25
*Mar  1 00:23:24.555: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.555: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.559: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.559: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.559: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.559: As104 LCP: State is Open

!--- LCP negotiation is complete.

*Mar  1 00:23:24.559: Modem 3/7 Mcom: PPP escape map: Tx map = A0000, Rx map = 0
*Mar  1 00:23:24.559: As104 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

!--- Two-way PPP authentication begins.

*Mar  1 00:23:24.559: As104 CHAP: O CHALLENGE id 4 len 28 from "router1"
*Mar  1 00:23:24.691: As104 CHAP: I CHALLENGE id 1 len 28 from "router2"
*Mar  1 00:23:24.691: As104 CHAP: O RESPONSE id 1 len 28 from "router1"
*Mar  1 00:23:24.707: As104 CHAP: I RESPONSE id 4 len 28 from "router2"
*Mar  1 00:23:24.707: As104 CHAP: O SUCCESS id 4 len 4
*Mar  1 00:23:24.815: As104 CHAP: I SUCCESS id 1 len 4

!--- Incoming and outgoing CHAP authentication is successful.

*Mar  1 00:23:24.815: As104 PPP: Phase is UP [0 sess, 0 load]
*Mar  1 00:23:24.819: As104 IPCP: O CONFREQ [Closed] id 6 len 10
*Mar  1 00:23:24.819: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.835: As104 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:23:24.835: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.839: As104 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:23:24.839: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.931: As104 IPCP: I CONFACK [ACKsent] id 6 len 10
*Mar  1 00:23:24.931: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.931: As104 IPCP: State is Open

!--- IP Control Protocol (IPCP) negotiation is complete.

*Mar  1 00:23:24.931: As104 DDR: dialer protocol up
*Mar  1 00:23:25.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async104,
 changed state to up

!--- Interface is up.


Informations connexes


Document ID: 10316