Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration de la connectivité d'un modem avec un routeur Cisco 3640 BRI

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires


Contenu


Introduction

Cette configuration prend en charge des utilisateurs distants (par exemple, un utilisateur privé ou un employé de déplacement) se connectant au réseau à un modem commuté analogique utilisant le protocole V.90. Utilisant un PC et un modem analogique, l'utilisateur se connecte par le PPP commuté à un accès de base (BRI) sur un routeur de Cisco 3640. Un BRI assure une connexion et des coûts de modem à grande vitesse moins qu'un accès primaire (PRI).

Remarque: Seulement deux utilisateurs asynchrones peuvent introduire dans chaque BRI à la fois dû aux limites de canal sur un BRI.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous.

  • Cisco 3640

  • Module de réseau BRI de Cisco (utilisation une du suivant) :

    • NM-4B-S/T - Module de réseau BRI à quatre orifices RNIS, version 800-01236-03 minimum

    • NM-4B-U - Le RNIS à quatre orifices BRI avec le module réseau NT-1 intégré, version 800-01238-06 minimum

    • NM-8B-S/T - module de réseau BRI du Huit-port le RNIS, version 800-01237-03 minimum

    • NM-8B-U - Huit-port le RNIS BRI avec le module réseau NT-1 intégré, version 800-01239-06 minimum

  • Module de réseau de modems numériques (utilisation une de ce qui suit : NM-6DM, NM-12DM, NM-18DM, NM-24DM, ou NM-30DM)

  • Carte d'interface de RÉSEAU LOCAL

  • Version de logiciel 12.0(2)XC de ½ du ¿  de Cisco IOSïÂ

Pour plus d'informations sur la configuration matérielle minimale et les logiciels nécessaires (par exemple, des numéros de pièce et des nombres de révision), voyez l'utilisation configurante de modem au-dessus de la documentation RNIS BRI.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Cette configuration utilise une liste d'utilisateur local pour la Sécurité d'accès sur le routeur de Cisco.

Sont ci-dessous les sections afférentes de la sortie de commande de show version avec la version de logiciel de Cisco IOS et les versions de microprogramme du modem utilisées pour implémenter cette configuration :

Cisco Internetwork Operating System Software IOS (tm) 3600 Software (C3640-I-M),
   Version 12.0(5)XK1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 
   System image file is "flash:c3640-i-mz.120-5.XK1"   
   MICA-6DM Firmware: CP ver 2310 - 6/3/1998, SP ver 2310 - 6/3/1998.

Utilisez la commande EXEC de show diag de déterminer le type de matériel installé dans votre routeur. La commande de show diag affiche le numéro de version aussi bien que le numéro de pièce des modules de matériel dans le routeur. Être suit la section afférente de la sortie témoin de la commande EXEC de show diag :

maui-nas-04#show diag

Slot 1:
BRI (U) port adapter, 4 ports
Serial number 17156199 Part number 800-01238-06

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande IOS

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/integrated-services-digital-networks-isdn-channel-associated-signaling-cas/10307-bri-3640.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

Cisco 3640
maui-nas-04#show run
Building configuration...
Current configuration:
!
! Last configuration change at 10:11:43 CST Thu Apr 13 2000 
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-04
!
aaa new-model
AAA authentication login default group tacacs+ local
AAA authentication ppp default if-needed group tacacs+ local
!
enable secret <deleted>
!
username admin privilege 15 password 7 0213100D52050024
!
modem country mica 
<country>


!-- The country information is mandatory for the configuration to work

!
clock timezone CST -6
clock summer-time CST recurring
!
ip subnet-zero
ip domain-name maui-onions.com
ip name-server 172.22.53.210
!
isdn switch-type basic-ni

! --- Global ISDN switchtype

!
!
process-max-time 200
!
interface Loopback0
 ip address 172.22.87.4 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI1/0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/2
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/3

! --- Active BRI

 no ip address
 no ip directed-broadcast
 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111 
 isdn spid2 51255522220101 5552222 
 isdn incoming-voice modem

! --- Direct incoming voice calls to the modems
! --- Add the above command to all BRIs that will accept analog calls

!
interface Group-Async1
 ip unnumbered Loopback0

! --- Loopback0 is assigned above
 
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 peer default ip address pool default

! --- Use local pool defined below

 ppp authentication pap

! --- Use PAP authentication

 group-range 65 66

! --- Line range is configured below

!
router eigrp 69
network 172.22.0.0
!
ip local pool default 172.22.84.2 172.22.84.253

! --- IP address pool assignment

ip default-gateway 172.22.80.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.80.1
ip http server
ip http authentication local
!
tacacs-server host 172.22.53.201
tacacs-server key <deleted>
!
line con 0
 transport input all
 line 65 66

! --- This must match the group-range in the Group-Async Interface
! --- Use the show line command to determine which lines are to be configured for dialin

 autoselect during-login
 autoselect ppp
 modem Dialin
line 67 70
line aux 0
line vty 0 4
password 
!
ntp clock-period 17179861
ntp server 172.22.255.1 prefer

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • stat de show isdn - L'état devrait être :

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    Si la couche 1 n'est pas en activité, l'adaptateur ou le port de câblage ne peut être endommagé ou branché. Si la couche 2 est dans un état de TEI_Assign, le routeur ne parle pas au commutateur.

  • show line - Pour afficher les paramètres des lignes. Utilisez la commande de show line de décider que pour quelles lignes doivent être configurées connectez-vous.

  • utilisateurs d'exposition - Pour afficher le numéro de ligne, le nom de la connexion, le temps d'inactivité, et l'emplacement terminal.

  • show diag - Pour déterminer le type de matériel installé dans votre routeur.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • debug modem - Pour observer l'activité de ligne du modem sur un serveur d'accès.

  • debug modem csm - Pour mettre au point l'ordinateur d'état d'appel utilisé pour connecter des faire appel au modem.

  • debug isdn q931 - Pour vérifier des connexions RNIS comme utilisateurs connectez-vous pour voir ce qui se produit avec l'appel RNIS (par exemple, si la connexion est abandonnée).

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10307