WAN : Relais de trames

Configuration d'une sauvegarde RNIS pour des liaisons WAN en utilisant des routes statiques flottantes

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cette configuration d'échantillon t'affiche comment sauvegarder un lien de Relais de trames avec Integrated Services Digital Network (le RNIS) à l'aide des Routes statiques flottantes et de l'acheminement de routage à établissement de connexion à la demande (DDR).

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous.

  • Routeurs Cisco 2503

  • La version de logiciel 12.2(7b) de Cisco IOSÝ s'exécutait sur les deux Routeurs

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Théorie générale

Un but d'implémentation des liens WAN est de fournir une manière pour sauvegarder le lien, si il échoue. Le RNIS fournit fréquemment cette sauvegarde. Cisco fournit les stratégies de sauvegarde qui peuvent réaliser la même fonctionnalité mais dans différentes manières. Si les informations de routage sont passées à travers le lien de Relais de trames, une Route statique flottante peut évoquer la liaison de sauvegarde si le lien de Relais de trames cesse de passer les informations.

Remarque: Cet exemple affiche une sauvegarde pour le Relais de trames utilisant des Routes statiques flottantes. Cependant, vous pouvez également utiliser cette sauvegarde de méthode n'importe quel lien WAN.

D'autres solutions peuvent utiliser une Interface de sauvegarde (voyez configurer une Interface de sauvegarde pour une sous-interface) ou la Fonction Dialer Watch. Si vous utilisez l'approche de commande backup interface, les sous-interfaces point par point sont avantageuses parce que les interfaces principales ou multipoints peuvent demeurer dans un état up/up même si des connexions virtuelles permanentes (PVCs) sont vers le bas assorties au Relais de trames.

Pour plus d'informations sur configurer la sauvegarde DDR, référez-vous au document configurant et dépannant la sauvegarde DDR. Vous pouvez également se référer derrière les Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch de document évaluation pour la sauvegarde DDR pour plus d'informations sur les diverses méthodes de sauvegarde DDR.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande pour l'IOS.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/10214/fr_isdn_backup.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

Cette configuration a été testée utilisant le Logiciel Cisco IOS version 12.2(7b) sur des Routeurs de gamme 2500. Les mêmes concepts de configuration appliqueraient à une topologie semblable de routeur ou à d'autres releases de Cisco IOS.

Router1 (Routeur Cisco 2503)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Une charge statique flottante a été configurée pour Router1. La Route statique flottante a une distance administrative assignée de 200. Une artère pour le même sous-réseau sera également apprise au-dessus du lien de Relais de trames par l'intermédiaire du Protocole EIGPR (Enhanced Interior Gateway Routing Protocol), qui souligne la nature supplémentaire ou redondante de la route flottante. L'artère apprise par EIGRP sera installée dans la table de routage en raison de sa distance administrative inférieure 90, comparée à celle de l'artère statique 200. En cas de la panne de lien de Relais de trames, l'artère EIGRP disparaîtra de la table de routage, la Route statique flottante est installée. N'importe quel trafic intéressant à envoyer à travers la connexion RNIS évoque la ligne. Quand la Connectivité est restaurée au-dessus du Relais de trames, l'artère est apprise de nouveau par l'EIGRP. Cette artère remplace l'artère statique et se dirige le trafic de nouveau au-dessus du circuit en relais de trame.

Le trafic de protocole de routage est marqué en tant qu'inintéressant dans la liste d'appels de sorte qu'il ne fasse pas se connecter ou demeurer la ligne RNIS connectée. Cependant, une fois le lien est en hausse, les paquets EIGRP peuvent croiser le lien et les deux Routeurs peuvent permuter les informations de routage. Le mot clé broadcast a été inclus dans l'instruction de mappage de numéroteur pour permettre le passage du trafic de protocole de routage au-dessus de la liaison RNIS. Si vous ne voulez pas que l'EIGRP permute les informations de routage même si la liaison RNIS est en hausse, n'incluez pas le mot clé broadcast dans l'instruction de mappage de numéroteur.

La commande de dialer load-threshold place un chargement qui déclenchera un appel simultané à placer sur le deuxième canal B. Le Protocole point à point (PPP) de Multilien a été configuré (ppp multilink) de sorte que les deux canaux RNIS B puissent être empaquetés ensemble en tant qu'une interface d'accès virtuel pour la bande passante agrégée.

En configuration en cours, seulement Router1 est configuré pour placer un appel. Le Router2 reçoit des appels de Router1. Si vous voulez que les deux côtés évoquent le lien, ajoutez les commandes de carte de numéroteur et de dialer load-threshold à la configuration du Router2.

Router2 (Routeur Cisco 2503)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Modifications de Tableau de routage

Remarque: Certaines commandes show sont prises en charge par l'outil d'Output Interpreter, qui te permet pour visualiser une analyse de sortie de commande show ;

Observez les tables de routage ci-dessous de Router1. Notez que la Route statique flottante a remplacé la route apprise EIGRP, après que le Router2 soit devenu inaccessible au-dessus du lien de Relais de trames.

Affichée ci-dessous est la table de routage de Router1, quand le lien de Relais de trames est en hausse.

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Quand la Connectivité au-dessus du lien de Relais de trames est perdue, Router1 installe la Route statique flottante dans sa table de routage comme affiché ci-dessous.

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

N'importe quel trafic intéressant au réseau 172.16.4.0/24 apporte maintenant la connexion RNIS. Par exemple, de Router1, un ping à 172.16.4.1 évoque la liaison RNIS comme affiché ci-dessous.

Remarque: Si vous rendez le protocole de routage intéressant, alors le trafic périodique évoque le lien automatiquement. Le du côté incliné de ceci est que le lien demeurera indéfiniment, probablement ayant pour résultat les taxations élevées.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

Puisque la ligne RNIS est en hausse, l'EIGRP commence maintenant les informations de routage exchaging au-dessus de la connexion RNIS. Ceci fait installer Router1 l'artère EIGRP dans sa table de routage, indiquant le prochain-saut 172.16.3.2.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

Le trafic intéressant est le trafic qui initiera l'appel RNIS et est défini par la commande de dialer-list. Dans la configuration ci-dessus, le dialer-list indique le nombre de listes d'accès 100 qui permet tous les paquets IP excepté des paquets EIGRP. Ce les moyens, tous les paquets IP, à moins que des paquets EIGRP, peuvent évoquer la connexion RNIS. Une fois que le rapport est établi, en trafiquent, y compris le trafic EIGRP, sont laissés aller à travers le lien. Mais si aucun trafic intéressant ne croise la liaison RNIS pour la durée du temporisateur d'inactif de numéroteur, le lien sera réduit et aucune artère EIGRP ne sera permutée. En ce moment, la Route statique flottante sera de nouveau installée dans la table de routage Router1.

Dépannez

Pour les informations sur dépanner la Route statique flottante référez-vous au document configurant et dépannant la sauvegarde DDR. Ce document adresse des symptômes communs comme :

  • La liaison de sauvegarde n'est pas composée quand la liaison principale descend.

  • Les cadrans de liaison de sauvegarde mais ne se connecte pas à l'autre côté.

  • La liaison de sauvegarde n'est pas désactivée quand la liaison principale récupère.

  • La liaison de sauvegarde n'est pas stable (par exemple, elle s'agite) quand l'interface principale est en baisse.

Pour le dépannage spécifique de Relais de trames référez-vous à configurer la sauvegarde en relais de trame

Les commandes suivantes peuvent aider à dépanner la liaison de sauvegarde. :

Avant de tenter des commandes de débogage ci-dessus l'unes des, voir s'il vous plaît les informations importantes sur des commandes de debug.

Sortie de débogage

Le trafic de protocole de routage (EIGRP) est marqué en tant qu'inintéressant par la commande de liste d'appels, ainsi en tant que lui n'évoquera pas le lien ou le gardera. Cependant, quand le lien est en activité, l'acheminement des mises à jour sera permuté. La commande de paquet de numéroteur de débogage peut vérifier si le trafic correct peut évoquer un lien. La sortie est affichée ci-dessous.

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

Le trafic intéressant (échos de Protocole ICMP (Internet Control Message Protocol) dans ce cas) remettra à l'état initial le temporisateur de veille et gardera le lien en tant que ci-dessous. Le trafic inintéressant est passé mais ne gardera pas le lien si le temporisateur de veille expire.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

Cependant marqué en tant qu'inintéressant, les paquets EIGRP croisent la liaison RNIS, parce que le rapport est déjà établi par le trafic intéressant d'ICMP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10214