Composition et accès : Routage à établissement de connexion à la demande (DDR)

Exemple de configuration : Utilisation de routes statiques flottantes et du routage à établissement de connexion à la demande

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

L'objectif de ce document est de configurer un accès de base (BRI) RNIS pour la composition et l'acheminement du trafic vers un site distant en cas d'une faille logique du circuit Frame Relay.

Le Protocole EIGPR (Enhanced Interior Gateway Routing Protocol) ne s'exécute pas sur le BRIs. Au lieu de cela, l'exemple dans ce document utilise des Routes statiques flottantes pour réorienter le trafic au-dessus du BRI seulement si des artères normales apprises par l'EIGRP au-dessus du circuit en relais de trame sont perdues.

Dans des tous les Routeurs, assurez-vous que l'ip classless est activé.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Ces configurations sont des extraits des configurations complètes.

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Figure 1 - Diagramme de réseau

/image/gif/paws/10212/bri0-1.gif

Configurations

Ce document utilise les configurations suivantes :

  • Routeur #1 de couche de distribution

  • Routeur #2 de couche de distribution

  • Routeur de la couche d'accès

  • Routeur du site distant

Le routeur C194u est l'un des deux Routeurs de couche de distribution. Dans cet exemple, le routeur C194u a le BRI au site distant. L'autre routeur de couche de distribution, C194n, a l'interface série d'assistance au site distant.

Routeur #1 de couche de distribution
hostname c194u                                                    
!   

!--- Create a username for the router at the remote site. 

username c194s password 7 XXXXXXXX                                            
!                                                                               
ip subnet-zero                                                                  
isdn switch-type basic-dms100                                                   
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.141 255.255.255.252                                      
!                                                                               
interface Ethernet0                                                             
 ip address 163.241.222.93 255.255.255.0                                        
 media-type 10BaseT                                                             
!                                                                               
interface BRI0                                                                  
 description to Remote Site c194s, (this end 08358662 08358664)                 
 ip address 192.168.11.138 255.255.255.252                                      
 no ip mroute-cache                                                             
 encapsulation ppp                                                              
 no ip route-cache                                                              
 isdn spid1 0835866201                                                          
 isdn spid2 0835866401                                                          
 dialer idle-timeout 600                                                        
 dialer wait-for-carrier-time 10                                                
 dialer map ip 192.168.11.137 name c194s broadcast 8358661                      
 dialer map ip 192.168.11.137 name c194s broadcast 8358663                      
 dialer hold-queue 5                                                            
 dialer load-threshold 128  outbound                                            
 dialer-group 1                                                                 
 no fair-queue                                                                  
 ppp authentication chap                                                        
 ppp multilink                                                                  
!                                                                               
router eigrp 65535

!--- We redistribute the static routes listed below, so if the Frame Relay
!--- network fails, the other routers in this autonomous system (AS) will 
!--- begin to see the remote networks advertised from this router.  
!--- Normally these routes are learned through EIGRP across the Frame Relay link.
!--- Make the BRI interfaces passive. An alternative is to use a dialer-list 
!--- to identify EIGRP packets as "uninteresting" packets. 

redistribute static                                              
 passive-interface BRI0                                           
 network 192.168.11.0                                                           
 network 163.241.0.0                                                            
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless

!--- Both distribution layer routers have a default route to their Null 
!--- interfaces so that they advertise the 0/0 network to all other routers
!--- in the AS. 

ip route 0.0.0.0 0.0.0.0 Null0

!--- There must be a static route for each network behind the C194s 
!--- router at the remote site. Use the IP address of the BRI interface 
!--- of router C194s, and ensure that the administrative distance is 240.
!--- Note: Summarize these routes if your addressing scheme lends itself 
!--- to summarization. If the Frame Relay network fails, this will force 
!--- packets destined to the remote site out the BRI interface, and will cause 
!--- it to dial and restore connectivity.  

ip route 192.168.11.0 255.255.255.224 192.168.11.137 240          
ip route 192.168.11.32 255.255.255.224 192.168.11.137 240         
ip route 192.168.11.64 255.255.255.224 192.168.11.137 240         
ip route 192.168.11.132 255.255.255.252 192.168.11.137 240        
!                                                                               
access-list 100 deny   icmp any any                                             
access-list 100 permit ip any any                                            
dialer-list 1 protocol ip list 100                                              
!                                                                               
end

Voici une sortie de commande de show dialer témoin pour le routeur C194u :

Routeur #1 de couche de distribution
c194u#show dialer                                                                
                                                                                
BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last called   Last status
8358663                  4       1311    01:32:08           failed
8358661               1874       1315    00:02:07       successful
0 incoming call(s) have been screened. 
                                                                                
BRI0:1 - dialer type = ISDN
Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (5 secs), Re-enable (15 secs)
Dialer state is physical layer up
Dial reason: ip (s=192.168.11.138, d=192.168.11.137)

Le prochain routeur, C194n, est le deuxième routeur de couche de distribution parce que. Dans cette illustration, c'est le routeur de liaison de trame. Il n'a aucune configuration spéciale. Il a seulement le default route redistribué dans l'EIGRP.

Routeur #2 de couche de distribution
hostname c194n                                                    
!                                                                                
!                                                                               
interface Ethernet0                                                             
 ip address 163.241.222.98 255.255.255.0                                        
!                                                                               
interface Serial1                                                               
 no ip address                                                                  
 bandwidth 1544                                                                 
 no ip mroute-cache                                                             
 encapsulation frame-relay                                                      
 no fair-queue                                                                  
!                                                                               
interface Serial1.301 point-to-point                                            
 ip address 192.168.11.130 255.255.255.252                                      
 bandwidth 32                                                                   
 frame-relay interface-dlci 301                                                 
!                                                                               
router eigrp 65535                                                              
 redistribute static                                              
 network 192.168.11.0                                                           
 network 163.241.0.0                                                            
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless                                                                    
ip route 0.0.0.0 0.0.0.0 Null0                                    
!

Le prochain routeur, C194s, est le routeur du site distant, le routeur de la couche d'accès. Il connecte le réseau distant au circuit principal par l'intermédiaire du routeur de couche de distribution.

Routeur de la couche d'accès
!                                                                               
hostname c194s                                                    
!

!--- Create a username for the distribution layer router.

username c194u password 7 XXXXXXXXX                                            
!                                                                               
isdn switch-type basic-dms100                                                   
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.133 255.255.255.252                                      
!                                                                               
interface Ethernet0                                                             
 ip address 192.168.11.2 255.255.255.224                                        
!                                                                               
interface Serial0                                                               
 no ip address                                                                  
 bandwidth 64                                                                   
 encapsulation frame-relay                                                      
!                                                                               
interface Serial0.300 point-to-point                                            
 ip address 192.168.11.129 255.255.255.252                                      
 bandwidth 32                                                                   
 frame-relay interface-dlci 300                                                 
!                                                                               
interface BRI0                                                                  
 description to Hub Site c194u, (this end 08358661 08358663)                    
 ip address 192.168.11.137 255.255.255.252                                      
 no ip mroute-cache                                                             
 encapsulation ppp                                                              
 no ip route-cache                                                              
 isdn spid1 0835866101                                                          
 isdn spid2 0835866301                                                          
 dialer idle-timeout 600                                                        
 dialer wait-for-carrier-time 10                                                
 dialer map ip 192.168.11.138 name c194u broadcast 8358662                      
 dialer map ip 192.168.11.138 name c194u broadcast 8358664                      
 dialer hold-queue 5                                                            
 dialer load-threshold 128                                                      
 dialer-group 1                                                                 
 no fair-queue                                                                  
 ppp multilink                                                                  
 ppp authentication chap                                                        
!                                                                               
router eigrp 65535

!--- Redistribute the static route, so any routers which you could have attached 
!--- to the Ethernet network 192.168.11.0/27 will see this router as their way 
!--- out to the remainder of the network. However, do not allow this default 
!--- route back into your distribution layer routers. Use a distribute list 
!--- to block the advertisement.

redistribute static                                              
 passive-interface BRI0                                           
 network 192.168.11.0                                                           
 default-metric 64 200 255 1 1500
 distribute-list 2 out Serial0.300                                              
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless

!--- Use the IP address of the BRI interface of the distribution layer router to 
!--- Add a default route. When the frame network goes down, this will 
!--- push your traffic out the BRI interface, and cause it to dial and
!--- restore connectivity. 

ip route 0.0.0.0 0.0.0.0 192.168.11.138 240                       
!                                                                               
access-list 1 permit any                                                        
!           
access-list 2 deny   0.0.0.0
access-list 2 permit any  
!                                                                    
dialer-list 1 protocol ip list 1                                                
!                                                                               
end                                                                             
!

Le prochain routeur représente le réseau du site distant. Rien aux besoins particuliers soit fait ici, autre que participer au protocole de routage dynamique d'IGP, EIGRP, du routeur de la couche d'accès.

Routeur du site distant
hostname c194ec                                                   
!                                                                                
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.65 255.255.255.224                                       
!                                                                               
interface Ethernet0                                                             
 ip address 192.168.11.1 255.255.255.224                                        
!                                                                               
interface Ethernet1                                                             
 ip address 192.168.11.33 255.255.255.224                                       
!                                                                               
!                                                                               
router eigrp 65535                                                              
 network 192.168.11.0                                                           
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless                                                                    
!                                                                               
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Avec le réseau de Relais de trames vers le bas, essayez une traceroute du réseau au site distant. Basé sur le schéma de réseau (voir le schéma 1), l'adresse IP de cible est l'interface de bouclage du routeur du site du concentrateur.

c194ec#trace                                                                    
Target IP address: 192.168.11.141 
Source address: 192.168.11.65 
Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2  *  *  * 
  3  *  *  
    192.168.11.138 24 msec

Avis comment il a exigé de plusieurs paquets d'obtenir l'interface BRI. Émettez la commande traceroute de nouveau, avant que le BRI disparaisse inactif et des paquets sont perdus :

c194ec#traceroute 192.168.11.141 

Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2 192.168.11.138 20 msec *  20 msec 

Évoquez le commutateur de trame de nouveau. Avec le réseau de Relais de trames maintenant opérationnel, vous n'utilisez pas le RNIS :

c194ec#traceroute 192.168.11.141
Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2 192.168.11.130 36 msec 36 msec 32 msec 
  3 163.241.222.93 36 msec *  32 msec

Les tables de routage pour le réseau opérationnel de Relais de trames sont affichées ci-dessous. Avis comment différentes artères sont apprises par l'EIGRP pour des réseaux au site du concentrateur. Il y a également un default route appris par l'EIGRP.

c194ec#show ip route  

Gateway of last resort is 192.168.11.2 to network 0.0.0.0 

     163.241.0.0 255.255.255.0 is subnetted, 1 subnets 
D       163.241.222.0 [90/2221056] via 192.168.11.2, 00:02:09, Ethernet0 
     192.168.11.0 is variably subnetted, 7 subnets, 2 masks 
C       192.168.11.64 255.255.255.224 is directly connected, Loopback0 
C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1 
C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0 
D       192.168.11.128 255.255.255.252 
           [90/2195456] via 192.168.11.2, 00:02:13, Ethernet0
D       192.168.11.132 255.255.255.252
           [90/409600] via 192.168.11.2, 01:23:14, Ethernet0 
D       192.168.11.136 255.255.255.252 
           [90/40537600] via 192.168.11.2, 01:23:14, Ethernet0 
D       192.168.11.140 255.255.255.252 
           [90/2349056] via 192.168.11.2, 00:02:10, Ethernet0 
D*EX 0.0.0.0 0.0.0.0 [170/40614400] via 192.168.11.2, 00:02:10, Ethernet

Les tables de routage pour quand le réseau de Relais de trames est en baisse sont affichées ci-dessous. Il y a toujours un default route, mais quelques différentes artères des réseaux soutiennent au site du concentrateur sont perdues. Mais parce que l'ip classless est activé, et vous ayez un default route, vous peut obtenir toujours partout dans le réseau.

c194ec#show ip route 

Gateway of last resort is 192.168.11.2 to network 0.0.0.0 

     192.168.11.0 is variably subnetted, 5 subnets, 2 masks 
C       192.168.11.64 255.255.255.224 is directly connected, Loopback0 
C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1 
C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0  
D       192.168.11.132 255.255.255.252 
           [90/409600] via 192.168.11.2, 01:25:27, Ethernet0 
D       192.168.11.136 255.255.255.252
           [90/40537600] via 192.168.11.2, 01:25:27, Ethernet0
D*EX 0.0.0.0 0.0.0.0 [170/40076800] via 192.168.11.2, 00:00:15, Ethernet

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10212