Qualité de service (QoS) : Réglementation QoS

Application des fonctions QoS à des sous-interfaces Ethernet

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 avril 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment appliquer le Mise en file d'attente pondérée basée sur les classes (CBWFQ) et d'autres caractéristiques articulées autour d'un logiciel de Qualité de service (QoS) de Ý de Cisco IOS sur une sous-interface d'Ethernets. Une sous-interface Ethernet est une interface logique dans Cisco IOS. Vous pouvez employer l'interface de ligne de commande (CLI) modulaire QoS (MQC) pour créer et appliquer une stratégie de service à une sous-interface Ethernet.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Logiciel 12.2(2)T de Cisco IOS

  • Routeur de Cisco 2620 avec un module de réseau Fast Ethernet

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Application d'une stratégie de service

Choisir généralement où appliquer une stratégie dépend des caractéristiques de QoS que votre stratégie lance. Une sous-interface d'Ethernets prend en charge ce qui suit :

  • maintien de l'ordre basé sur classe - Si vous vous appliquez une stratégie avec l'ordre de police à l'interface et à la sous-interface, seulement le régulateur de sous-interface est en activité pour le trafic qui apparie la classe. Référez-vous au pour en savoir plus de Réglementation du trafic.

  • Fonction Class-based Marking — référez-vous au pour en savoir plus d'aperçu de classification.

  • formation basée sur classe — référez-vous à configurer le pour en savoir plus de formation basé sur classe.

  • queue basée sur classe — La queue est un cas particulier pour des sous-interfaces d'Ethernets. Voyez le reste de ce pour en savoir plus de section.

Un routeur commence à faire la queue des paquets quand le nombre de paquets qui doit être transmis une interface dépasse le débit sortant de cette interface. Les paquets excédentaires sont alors alignés. Une méthode de mise en file d'attente peut être appliquée aux paquets attendant d'être transmis.

Les interfaces logiques de Cisco IOS ne prennent pas en charge un état de congestion de façon inhérente et ne prennent pas en charge l'application directe d'une stratégie de service qui applique une méthode de mise en file d'attente. Au lieu de cela, vous le premier besoin de s'appliquer la formation à la sous-interface utilisant le Formatage du trafic générique (GTS) ou la formation basée sur classe. Référez-vous à maintenir l'ordre et à former le pour en savoir plus.

Le routeur imprime ce message de log quand une sous-interface d'Ethernets est configurée avec une stratégie de service qui applique la queue sans formation :

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

Notez que la même règle s'applique à une sous-interface de Gigabit Ethernet.

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

En d'autres termes, vous devez configurer une politique hiérarchique avec la commande de forme au niveau de parent. Utilisez la commande bandwidth pour CBWFQ, ou la commande prioritaire pour la basse latence s'alignant (LLQ) aux niveaux plus bas. la formation basée sur classe limite le débit sortant et (nous pouvons supposer) mène à un état congestionné sur la sous-interface logique. La sous-interface qu'applique la « contre-pression, » et le Cisco IOS commence alignant les paquets excédentaires qui sont tenus par le modélisateur.

Application d'une politique hiérarchique

Suivez ces étapes pour appliquer une politique hiérarchique :

  1. Créez un enfant ou une stratégie de plus bas niveau qui configurent un mécanisme de mise en file d'attente. Dans l'exemple ci-dessous, nous configurons LLQ utilisant la commande prioritaire et CBWFQ utilisant la commande bandwidth. Référez-vous au pour en savoir plus de vue d'ensemble de la gestion d'encombrement.

    policy-map child 
     class voice 
      priority 512
  2. Créez un parent ou une stratégie de niveau supérieur qui appliquent la formation basée sur classe. Appliquez la stratégie enfant comme commande dans le cadre de la stratégie de parent puisque le contrôle d'admission pour la classe enfant est fait a basé sur le taux de mise en forme pour la classe parente.

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Appliquez-vous la stratégie de parent à la sous-interface.

    interface ethernet0/0.1
     service-policy parent 

Configurer la formation basée sur classe

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Configuration

Routeur 2620A
hostname 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • show policy-map {nom de stratégie} - Affiche la configuration de toutes les classes pour une carte de stratégie de service indiquée.

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
  • show policy-map interface rapide - Les affichages apparient des compteurs pour toutes les classes d'une carte de stratégie de service indiquée.

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any

Remarque: la formation basée sur classe fonctionne au niveau d'interface et de sous-interface. Le Cisco IOS 12.2(2.5) introduit la capacité de configurer la formation sur l'interface principale et les adresses IP sur les sous-interfaces.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10104