Qualité de service (QoS) : Gestion de l'encombrement de QoS (mise en file d'attente)

Configuration de la mise en file d'attente pondérée basée sur les classes (CBWFQ) et de LLQ sur des interfaces MLPPP et de numéroteur

18 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (2 octobre 2014) | Commentaires


Contenu


Introduction

La commande de service-stratégie applique normalement une carte de stratégie configurée avec les commandes de l'Interface MQC (Modular QoS CLI) à une interface principale, à une sous-interface, ou à un circuit virtuel. Vous pouvez également s'appliquer cette commande à une interface de modèle virtuel, à l'interface multiliaison, et à une interface de numérotation configurée avec l'encapsulation et le Multilink PPP (MLPPP) de Protocole point à point (PPP). De telles interfaces ont comme conséquence une interface d'accès virtuel, où la queue fonctionellement a lieu. Ce document fournit une seule référence pour comprendre des configurations recommandées et des mises en garde associées pour s'appliquer la mise en file d'attente pondérée basée sur classe (CBWFQ) et le Fonction Low Latency Queuing (LLQ) aux interfaces et aux interfaces de numérotation de paquet MLPPP.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Appliquez-vous la Mise en file d'attente aux interfaces avec un grand choix de bandes passantes

RFC 1990leavingcisco.com définit le PPP à liaisons multiples, qui combine un ou plusieurs interfaces physiques dans une interface virtuelle de « paquet ». La bande passante de l'interface de paquet est égale à la somme de la bande passante des liens composants. Ainsi, l'interface de paquet a une valeur de bande passante maximum qui varie à un instant instantané.

Initialement, la bande passante et les commandes prioritaires ont pris en charge seulement une valeur absolue de Kbps. Si vous vous appliquiez une stratégie de service avec CBWFQ et LLQ à une interface de paquet et la première interface active ne prenait en charge pas la valeur absolue de Kbps, la stratégie de service a manqué contrôle d'admission. Le routeur a enlevé la stratégie de service et a imprimé des messages d'erreur semblables à cette sortie :

May 18 17:32:34.766 MEST: CBWFQ: Not enough available bandwidth for all 
classes Available 48 (kbps) Needed 96 (kbps) 
May 18 17:32:34.766 MEST: CBWFQ: Removing service policy on Dialer100

En date de la version de logiciel 12.2T de Cisco IOS®, de routeur les essais maintenant pour réappliquer la stratégie quand elle la détecte qu'une interface supplémentaire (telle qu'un deuxième canal B BRI) est ajoutée au paquet. Une approche supérieure est de configurer la priorité et les commandes bandwidths comme pour cent de la bande passante disponible. L'utilisation d'une valeur de pourcentage configure le routeur pour assigner une quantité de bande passante relative qui s'ajuste pendant que le paquet contient un ou plusieurs liaisons membres. Le Logiciel Cisco IOS version 12.2(2)T a introduit le soutien de la commande de pourcentage prioritaire sur le Routeurs de la gamme Cisco 7500 et d'autres Plateformes. Le pour en savoir plus, se rapportent à la basse Mise en file d'attente de latence avec le support de pourcentage prioritaire.

CBWFQ et LLQ sur des interfaces de numérotation

Le Routage à établissement de connexion à la demande (DDR) peut être configuré de deux manières :

  • Legs DDR — S'applique le cadran et les paramètres du protocole directement à l'interface physique.

  • Profils de composeur — S'applique le cadran et les paramètres du protocole dynamiquement à une interface de numérotation, qui lie consécutivement aux interfaces physiques. Par exemple, une interface de numérotation inclut un ou plusieurs chaînes de cadran pour atteindre un type de site distant, d'authentification de PPP, et MLPPP.

Le legs DDR initialement l'a pris en charge d'abord dedans, d'abord (FIFO) s'alignant seulement quand une interface série ou interface RNIS a été configuré avec MLPPP. Cette restriction appliquée même lorsque les deux extrémités de la connexion n'ont pas négocié MLPPP et ont utilisé l'interface physique comme interface de non-paquet qui exécute l'encapsulation PPP. Le Mise en file d'attente pondérée (WFQ) traditionnel par l'intermédiaire de la commande de foire-file d'attente est maintenant pris en charge.

Si vous choisissez de configurer des Profils de composeur, l'interface de numérotation et les interfaces physiques sous-jacentes prennent en charge la commande de service-stratégie. Si vous appliquez une stratégie sur l'interface physique, émettez la commande séquentielle de show policy-map interface ou la commande du bri de show policy-map interface 0/0:1 (et bri0/0:2) de confirmer la configuration. Le canal D, identifié dans l'IOS comme BRI0/0, prend en charge la signalisation et pas le trafic de données. Si vous vous appliquez une stratégie à l'interface de numérotation, émettez la commande du cadran <0-255> de show queueing interface de confirmer la configuration.

Les versions du logiciel Cisco IOS 12.2(4) et le 12.2(4)T ont introduit le soutien des stratégies de service basées sur Mise en file d'attente sur des interfaces d'accès virtuel créées d'une interface de numérotation configurée avec MLPPP. Dans des releases précédentes, les paramètres de service-stratégie ne sont pas copiés plus de sur l'interface d'accès virtuel copiée, où la queue a lieu réellement. Cette sortie illustre ces symptômes :

Router#show policy interface dialer1
  Dialer1 
   Service-policy output: foo 

     Class-map: class-default (match-any) 
       0 packets, 0 bytes 
       5 minute offered rate 0 bps, drop rate 0 bps 
       Match: any 
       Weighted Fair Queueing 
         Flow Based Fair Queueing 
         Maximum Number of Hashed Queues 256 
         (total queued/total drops/no-buffer drops) 0/0/0 

Router#show policy interface virtual-access 2
 Router#

Remarque: La version du logiciel Cisco IOS 12.2(8) et les 12.2(8)T sont recommandés pour éviter l'ID de bogue Cisco CSCdu87408, qui résout des routeurs rechargés comme effet secondaire rare de cette configuration.

Cette configuration d'échantillon affiche comment s'appliquer CBWFQ et LLQ à une interface de numérotation. Cette configuration a comme conséquence :

  • Emploie une interface de numérotation pour appliquer dynamiquement les paramètres du protocole de la connexion aux interfaces RNIS BRI. L'interface de numérotation est dite la « limite » aux interfaces RNIS BRI.

  • Endroits deux interfaces RNIS BRI dans un ensemble multiliaison.

  • Utilise le dialer load-threshold load [sortant | d'arrivée | l'un ou l'autre] de commande de déterminer quand le routeur doit lancer les canaux B supplémentaires et augmenter la bande passante de l'interface de paquet.

  • Crée une interface d'accès virtuel avec la commande de ppp multilink.

  • S'applique une stratégie de service avec CBWFQ et LLQ à l'interface d'accès virtuel par l'interface de numérotation.

Exemple de configuration
access-list 101 permit udp any any range 16384 32767
access-list 101 permit tcp any any eq 1720
!
access-list 102 permit tcp any any eq 23
! 
class-map voice
    match access-group 101

!--- Traffic that matches ACL 101 is classified as class voice.

class-map data
    match access-group 102

!--- Traffic that matches ACL 102 is classified as class data.

policy-map mlppp 
   class voice 
      priority percent 50 
   class data 
      bandwidth percent 25 
   class class-default 
     fair-queue 
!
interface BRI2/1  
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
! 
interface BRI2/2 
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Member of dialer pool 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
!  
interface Dialer2  
  ip unnumbered Loopback0  
  encapsulation ppp  
  dialer pool 1  
  dialer load-threshold 1 either  
  
!--- Load level (in either direction) for  
  !--- traffic at which additional connections  
  !--- are added to the MPPP bundle 
  !--- load level values that range from 1 (unloaded)  
  !--- to 255 (fully loaded).

  dialer string 6113 
  dialer string 6114  
  dialer-group 1  
  ppp authentication chap  
  ppp multilink  

!--- Allow MLPPP for the four BRI channels.

  service-policy output mlppp 
  
!--- Apply the service policy to the dialer interface.

LLQ et CBWFQ avec le MLPPP distribué

La gamme Cisco 7500 utilise une architecture distribuée qui assure le débit élevé de paquet en déplaçant les décisions de transfert de paquets du processeur de commutation routage (RSP) aux Versatiles Interfaces Processor (VIPs). Cette architecture active également le déploiement des Services IP améliorés par à grande échelle, tels que QoS, en se propageant la charge du traitement à travers les plusieurs processeurs indépendants des VIPs.

Basé sur le matériel d'interface, la gamme Cisco 7500 prend en charge deux formes de QoS :

QoS Comment activé Là où pris en charge Là où traité
Basé sur RSP Automatiquement sur les processeurs d'interface existants. Processeurs d'interface existants. Peut plus n'être activé sur des VIPs. CPU RSP
Basé sur VIP (distribué) Automatiquement quand ces deux commandes sont configurées :
  • La commande distribuée d'ip cef en mode de configuration globale.
  • La commande distribuée d'ip route-cache dans le mode de configuration d'interface.
VIPs CPU DE VIP

Les mécanismes basés sur VIP de QoS appliqués par l'intermédiaire de l'Interface MQC (Modular QoS CLI) sont introduits dans des ces trois logiciel Cisco IOS séries de version :

  • Version du logiciel Cisco IOS 12.0(XE), qui est devenue la version du logiciel Cisco IOS 12.1(E)

  • Logiciel Cisco IOS version 12.0(9)S

  • Logiciel Cisco IOS version 12.1(5)T, qui est devenu le mainline et la version du logiciel Cisco IOS 12.2T de Logiciel Cisco IOS version 12.2

La caractéristique de MLPPP distribué te permet pour combiner la bande passante des plusieurs interfaces T1/E1 sur un VIP dans une interface de paquet. Le pour en savoir plus, se rapportent au protocole point-à-point distribué de Multilien pour le Routeurs de la gamme Cisco 7500. Le Logiciel Cisco IOS version 12.2(13)T introduit le soutien du MLPPP distribué (dMLPPP) sur les adaptateurs non-canalisés de port, tels que le PA-4T+ et le PA-8T.

Soutien introduit par Logiciel Cisco IOS version 2.2(8)T de LLQ distribué et de CBWFQ sur des interfaces de paquet de dMLPPP sur les adaptateurs canalisés de port tels que PA-MC-xT1/E1 et PA-MC-xT3/E3. Comme la version non-distribuée de cette caractéristique, le dMLPPP emploie une interface multilink pour créer une interface d'accès virtuel où la queue fonctionellement a lieu. Référez-vous aux informations nouvelles et changées pour la version du logiciel Cisco IOS 12.2T. Quand vous appliquez la Mise en file d'attente distribuée avec le dMLPPP, la version du logiciel Cisco IOS 12.2(10)T ou plus tard est recommandée afin d'éviter l'ID de bogue Cisco CSCdw47678.

Seulement CBWFQ et LLQ comme appliqué avec la commande de service-stratégie est pris en charge avec dMLPPP/dLFI. Des fonctionnalités de mise en file d'attente existantes, telles que la Mise en file d'attente équitable avec la commande de foire-file d'attente, file d'attente à priorité déterminée avec l'ordre de priority-group, et Mise en file d'attente faite sur commande avec la commande de file d'attente-liste, ne sont pas prises en charge.

Le FlexWAN pour la gamme Cisco 7600 prend en charge le dLLQ sur des interfaces de non-paquet. Il ne prend en charge pas le dLLQ sur des interfaces de paquet MLPPP. Ce support est disponible avec la version du logiciel Cisco IOS 12.2S.

Cette configuration d'échantillon applique le dLLQ sur une interface multilink :

Configuration d'échantillon de dLLQ sur une interface de paquet MLPPP
Interface 
! 
access-list 100 permit udp any any range 16384 32000
access-list 100 permit tcp any any eq 1720
access-list 101 permit tcp any any eq 80
access-list 102 permit tcp any any eq 23
!
class-map voip 
   match access-group 100
class-map data1
    match access-group 101
class-map data2 
    match access-group 102
!
policy-map llq-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15 
    class data2 
     bandwidth 15
    class class-default 
     fair-queue
!
policy-map set-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15
    class data2 
     bandwidth 15 
    class class-default 
     fair-queue
!
interface Serial5/0/0:0 
   no ip address 
   encapsulation ppp 
   keepalive 10 
   ppp chap hostname G2 
   ppp multilink 
   multilink-group 2 
!  
interface Serial5/1/0:0 
  no ip address 
  encapsulation ppp 
  keepalive 10 
  ppp chap hostname G2 
  ppp multilink 
  multilink-group 2 
!  
interface Multilink2 
  ip address 106.0.0.2 255.0.0.0 
  ppp multilink 
  service-policy output llq-policy 
  service-policy input set-policy 
  multilink-group 2

Le Fonction Link Fragmentation and Interleaving (LFI) ajoutent les commandes de ppp multilink fragment delay et de ppp multilink interleave à une interface virtual-template configurée avec MLPPP et une stratégie de service. Cette configuration réduit le retard sur des liens plus à basse vitesse en cassant de grands datagrammes et en intercalant des paquets du trafic de bas-retard avec les paquets plus petits qui résultent du datagramme fragmenté. Le pour en savoir plus, se rapportent à configurer la fragmentation de liaison et à l'intercaler pour le Relais de trames et les circuits virtuels ATM.

Le soutien introduit par Logiciel Cisco IOS version 2.2(8)T de LFI distribué (dLFI) sur-a canalisé des lignes série sur la gamme Cisco 7500 avec des VIPs. Cette caractéristique est également disponible avec les Commutateurs de gamme Catalyst 6500 et le Routeurs de la gamme Cisco 7600. Pour les informations sur les releases qui prennent en charge le dLFI, référez-vous au navigateur de fonctionnalité (clients enregistrés seulement) et aux notes de mise à jour pour les Produits respectifs. Pour plus d'informations sur cette caractéristique, référez-vous à la fragmentation de liaison et à l'interfoliage distribués au-dessus des lignes louées.

Le FlexWAN pour la gamme Cisco 7600 avec la logiciel Cisco IOS série de version 12.1E ne prend en charge pas le dLFI.

Après que vous configuriez le retard maximum de fragment avec la commande de <msec> de ppp multilink fragment delay, la caractéristique de dLFI calcule la taille de fragment réelle sur les interfaces série canalisées avec l'utilisation de cette formule (où la bande passante est dans le Kbps) :

fragment size = bandwidth x fragment-delay  / 8

En outre, la taille de fragment est calculée a basé sur la liaison membre avec la plus petite quantité de bande passante. Par exemple, dans une configuration avec des liaisons membres de 64 k et de 128 k, la taille de fragment est calculée a basé sur le lien 64 k.

CBWFQ et LLQ avec PPPoA et MLPPPoA

Soutien introduit par 12.2(8) de version du logiciel Cisco IOS du par-circuit virtuel s'alignant sur des circuits virtuels ATM configurés avec le PPP générique au-dessus de l'encapsulation atmosphère (PPPoA). Ces paragraphes te donnent les exemples de configuration de la Fonction Class-based Marking, maintenant l'ordre, et s'alignant.

1. Fonction Class-based Marking

La commande de service-stratégie peut être reliée à l'interface de modèle virtuel ou au PVC atmosphère pour la Fonction Class-based Marking.

Dans cet exemple, le class map PEER2PEER est défini, la carte MARK_PEER2PEER de stratégie est créée, et le par défaut de dscp est configuré pour la classe PEER2PEER ; alors la service-stratégie est reliée au modèle virtuel ou au PVC atmosphère.

Router(config)#class-map PEER2PEER
Router(config-cmap)#match access-group 100
Router(config-cmap)#exit

Router(config)#policy-map MARK_PEER2PEER
Router(config-pmap)#class PEER2PEER
Router(config-pmap-c)#set dscp default
Router(config-pmap-c)#end


Attaching Service-policy to Virtual Template


Router(config-subif)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 1

Router(config)#interface Virtual-Template1
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output MARK_PEER2PEER 


Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.1 point-to-point
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#pvc 1/50
Router(config-if-atm-vc)#service-policy output MARK_PEER2PEER

2. Maintien de l'ordre basé sur classe :

La commande de service-stratégie peut être reliée à l'interface de modèle virtuel ou au PVC atmosphère pour le maintien de l'ordre basé sur classe.

Router(config)#policy-map POLICE_PEER2PEER
Router(config-pmap)#class PEER2PEERRouter(config-pmap-c)#police 8000 conform-action transmit exceed-action drop

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 2

Router(config)#interface Virtual-Template2
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output POLICE_PEER2PEER 



Attaching Service-policy to ATM pvc

Router(config)#int atm1/0.2 multipoint
Router(config-subif)#no ip address
Router(config-subif)#pvc 1/100
Router(config-if-atm-vc)#service-policy output POLICE_PEER2PEER

3. Mise en file d'attente basée sur classe :

Pour la Mise en file d'attente basée sur classe, c.-à-d., la bande passante, la forme, la priorité, et le random-detect, la commande de service-stratégie peuvent être reliés au modèle virtuel ou au PVC atmosphère.

Router(config)#policy-map QUEUE_PEER2PEER
 Router(config-pmap)#class PEER2PEER
 Router(config-pmap-c)#bandwidth 768

Attaching Service-policy to Virtual Template

Router(config-subif)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#encapsulation aal5mux ppp virtual-Template 3

Router(config)#interface Virtual-Template3
Router(config-if)#ip address negotiated
Router(config-if)#service-policy output QUEUE_PEER2PEER

Attaching Service-policy to ATM pvc 

Router(config)#int atm1/0
Router(config-subif)#no atm ilmi-keepalive
Router(config-subif)#pvc 1/150
Router(config-if-atm-vc)#service-policy output QUEUE_PEER2PEER

Remarque: Quand vous utilisez une combinaison de Fonction Class-based Marking ou maintien de l'ordre basé sur classe et Mise en file d'attente basée sur classe, la commande des exécutions est ceci :

  1. La commande de service-stratégie configurée sur l'interface de modèle virtuel marque ou maintient l'ordre les paquets.

  2. La commande de service-stratégie sur le PVC atmosphère aligne les paquets.

Référez-vous à cet exemple :

policy-map MARK_PEER2PEER
  class PEER2PEER
   set dscp default
! 
 interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 1/100
  encapsulation aal5mux ppp Virtual-Template1
  service-policy output QUEUE_PEER2PEER
!
interface Virtual-Template1 
ip address negotiate
service-policy output MARK_PEER2PEER

Si vous exécutez un Cisco IOS plus tôt version logicielle, vous pouvez configurer sur le circuit virtuel atmosphère avec l'encapsulation de MLPPPoA et s'appliquer une stratégie de service basée sur Mise en file d'attente à l'interface de modèle virtuel. Le pour en savoir plus, se rapportent à la fragmentation de liaison et l'interfoliage pour le Relais de trames et les circuits virtuels ATM et l'aperçu de mécanismes d'efficacité de lien.

Le Logiciel Cisco IOS version 12.2(4)T3 introduit une version distribuée de cette caractéristique pour la gamme Cisco 7500. Pour plus d'informations sur cette caractéristique, référez-vous à la fragmentation de liaison et à l'interfoliage distribués pour l'atmosphère et le Relais de trames.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 10102