Commutation LAN : VLAN

Création de réseaux VLAN Ethernet sur des commutateurs Catalyst

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit les informations de base sur la façon dont créer des VLAN sur les Commutateurs de Catalyst qui exécutent le SYSTÈME D'EXPLOITATION de Catalyst (CatOS) et le logiciel système de ½ du ¿  de Cisco IOSïÂ. Les exemples de commandes de chaque section utilisent un commutateur Catalyst de chaque section de configuration.

Conditions préalables

Conditions requises

Cisco recommande de prendre connaissance des informations contenues dans cette section.

Les VLAN sont un mécanisme permettant aux administrateurs réseau de créer des domaines de diffusion logiques qui peuvent s'étendre sur un seul ou plusieurs commutateurs, quelle que soit la proximité physique. Cette fonction est utile pour réduire la taille des domaines de diffusion ou permettre à des groupes ou des utilisateurs d'être regroupés de façon logique sans qu'ils se trouvent nécessairement au même endroit.

Pour créer des VLAN, vous devez décider de la façon de configurer les éléments suivants :

  • Quel nom de domaine VTP (VLAN Trunking Protocol) et quel mode VTP utiliser sur ce commutateur

  • Quels ports du commutateur appartiennent à quel VLAN

  • S'il doit exister, ou non, une communication entre les VLAN, ou s'ils sont isolés

    Si une communication est requise entre les VLAN, vous devez utiliser un périphérique de routage de couche 3, tel qu'un routeur Cisco externe ou un module de routage interne. Voici quelques exemples :

    • Carte WS-X4232 de couche 3 pour les commutateurs Catalyst 4500/4000 avec Supervisor Engine I et Supervisor Engine II

    • Commutateur de route (RSM) ou carte commutateur de routage (RSFC) pour les commutateurs Catalyst 5500/5000

    • Commutateur multicouche (MSM) ou carte de commutation multicouche (MSFC) pour les commutateurs Catalyst 6500/6000

    Certains des commutateurs ont une prise en charge intégrée dans le logiciel et le matériel pour effectuer un routage inter-VLAN. Avec le routage inter-VLAN, aucun périphérique, aucun module ou aucune carte fille externe n'est requis. Voici quelques exemples de tels commutateurs :

    • Catalyst 3550/3750/6500 avec Supervisor Engine 720

    • Catalyst 4500/4000 avec Supervisor Engine II+, Supervisor Engine III et Supervisor Engine IV

Pour plus d'informations sur la configuration du routage inter-VLAN sur une MSFC, un RSM, une RSFC ou un routeur externe, reportez-vous aux documents suivants :

Remarque: Ce document suppose que vous disposez d'une connectivité de base au commutateur, soit via la console soit via un accès TELNET. Pour plus d'informations sur la façon d'obtenir une connectivité de base aux commutateurs, reportez-vous aux documents suivants :

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur Catalyst 6009 qui exécute le logiciel CatOS 5.5(x)

  • Commutateur Catalyst 3524XL qui exécute le logiciel Cisco IOS Version 12.0(5.x)XU

  • Commutateur Catalyst 4507 avec Supervisor Engine IV (WS-X4515) qui exécute le logiciel Cisco IOS Version 12.1(13)EW1

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Les informations de ce document peuvent également être utilisées avec les commutateurs suivants :

  • Commutateurs Catalyst 4500/4000/2948G/2980G/4912G

  • Commutateurs de la gamme Catalyst 5000/2926G

  • Commutateurs de la gamme Catalyst 6500/6000

  • Commutateurs Catalyst 2900XL/3500XL/2950/3550/3750

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Différence entre CatOS et la plate-forme logicielle Cisco IOS

CatOS sur le moteur de superviseur et le logiciel Cisco IOS sur la MSFC (hybride) : il est possible d'utiliser une image CatOS comme plate-forme logicielle pour exécuter le moteur de superviseur sur les commutateurs Catalyst 6500/6000. Si la MSFC facultative est installée, une image de logiciel Cisco IOS distincte est utilisée pour exécuter la MSFC.

Logiciel Cisco IOS sur le moteur de superviseur et la MSFC (natif) : une seule image du logiciel Cisco IOS peut être utilisée comme logiciel système pour exécuter le moteur de superviseur et la MSFC sur les commutateurs Catalyst 6500/6000.

Remarque: Pour plus d'informations, reportez-vous à Comparaison des systèmes d'exploitation Cisco Catalyst et Cisco IOS pour le commutateur de la gamme Cisco Catalyst 6500.

Configurer le VLAN sur les commutateurs Catalyst qui exécutent CatOS

Créer des VLAN et des ports

Pour créer un VLAN, exécutez les étapes mentionnées dans cette section.

Pour pouvoir créer un VLAN, le commutateur doit être en mode de serveur VTP ou en mode VTP transparent. Si le commutateur est un serveur VTP, vous devez définir un nom de domaine VTP avant de pouvoir ajouter des VLAN.

  1. Définissez un nom de domaine VTP.

    Vous devez définir le nom de domaine VTP indépendamment des points suivants :

    • Le nombre de commutateurs dans le réseau, qu'il y en ait un ou plusieurs

    • Que vous utilisiez, ou non, VTP pour propager des VLAN sur d'autres commutateurs du réseau

    Voici la configuration de VTP par défaut sur le commutateur :

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Pour définir le nom et le mode du domaine, émettez la commande set vtp.

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified

    Remarque: Pour plus d'informations sur le protocole VTP, reportez-vous à Présentation du protocole VTP (VLAN Trunking Protocol).

  2. Pour vérifier la configuration VTP, émettez la commande show vtp domain.

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Remarque: Si vous disposez de la sortie d'une commande show vtp domain émise par votre périphérique Cisco, vous pouvez utiliser l'interpréteur de sortie (réservé aux clients inscrits) afin d'afficher les problèmes potentiels et des correctifs.

  3. Après avoir défini et vérifié le domaine VTP, commencez à créer des VLAN sur le commutateur.

    Par défaut, il n'y a qu'un seul VLAN pour tous les ports. Ce VLAN est appelé default. Vous ne pouvez pas renommer ou supprimer le réseau VLAN 1.

    Pour afficher les paramètres pour tous les VLAN configurés dans le domaine administratif, émettez la commande show vlan.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    1. Pour créer des VLAN, émettez la commande set vlan.

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
    2. Pour vérifier la configuration des VLAN, émettez la commande show vlan.

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75      
      1002 fddi-default                     active    6       
      1003 token-ring-default               active    9       
      1004 fddinet-default                  active    7       
      1005 trnet-default                    active    8       
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Output suppressed.
      
      
    3. Si vous voulez ajouter des ports au VLAN, émettez la commande set vlan vlan_number mod/ports.

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1

      Remarque: Vous pouvez également créer le VLAN et y ajouter les ports avec toutes les informations dans une seule commande.

      Par exemple, si vous voulez créer le troisième VLAN, puis affecter les ports 3/13 à 3/15 à ce VLAN, émettez la commande suivante :

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
  4. Pour vérifier la configuration des VLAN, émettez la commande show vlan.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Output suppressed.
    
    

Supprimer des ports ou des VLAN

Pour supprimer des ports d'un VLAN, émettez la commande set vlan vlan_number mod/ports et placez les ports dans un autre VLAN. Cette suppression est essentiellement ce qui se produit quand vous affectez un port à un VLAN car tous les ports appartiennent initialement au réseau VLAN 1.

Pour supprimer un VLAN, émettez la commande clear vlan. Les ports sont désactivés car ils continuent à être une partie de ce VLAN, lequel n'existe plus. Le commutateur affiche un avertissement et vous permet d'annuler la demande actuelle.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Output suppressed.

Remarque: Les ports 3/13 à 3/15 n'apparaissent pas dans la sortie de la commande show vlan car la suppression du réseau VLAN 3 désactive ces ports. Les ports n'apparaissent pas tant que vous ne les ajoutez pas à nouveau dans un autre VLAN.

Conseils de dépannage

Cette section fournit des conseils de dépannage pour les problèmes courants que vous pouvez rencontrer lors de la création de VLAN sur les commutateurs Catalyst qui exécutent CatOS :

  • Si vous créez un VLAN alors qu'aucun nom de domaine VTP n'est défini, le message d'erreur suivant s'affiche :

    Cannot add/modify VLANs on a VTP server without a domain name.

    Pour corriger ce problème, créez un nom de domaine VTP sur le commutateur. La procédure à suivre est indiquée dans la section Créer des VLAN et des ports.

  • Si vous créez un VLAN sur un commutateur qui est en mode client VTP, le message d'erreur suivant s'affiche :

    Cannot add/modify VLANs on a VTP client.

    Remarque: Un commutateur ne peut créer des VLAN que s'il est en mode serveur VTP ou en mode VTP transparent. Pour plus d'informations sur le protocole VTP, reportez-vous à Présentation du protocole VTP (VLAN Trunking Protocol).

  • Les ports sont dans l'état inactive dans la sortie de la commande show port mod/port. Cet état signifie que le VLAN auquel les ports appartenaient initialement a été supprimé, généralement en raison du protocole VTP. Vous pouvez soit recréer ce VLAN, soit corriger la configuration VTP de sorte que le VLAN soit rétabli dans le domaine VTP. Voici un exemple de sortie de la commande show port mod/port :

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Output suppressed.
    
    

    Si vous disposez de la sortie d'une commande show-tech support émise par votre périphérique Cisco, vous pouvez utiliser l'interpréteur de sortie (réservé aux clients inscrits) afin d'afficher les problèmes potentiels et des correctifs.

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
  • Les interfaces de VLAN créées dans les modules de routage (RSM, RSFC, MSM ou MSFC) apparaissent uniquement lorsque le VLAN correspondant est disponible dans le commutateur. Afin que l'interface de VLAN soit totalement active, ce qui signifie qu'elle est administrativement active et que le protocole de ligne est actif, assurez-vous que vous avez au moins un port en tant que membre de ce VLAN, avec un périphérique actif connecté au port. Consultez la section Spécifications de ce document pour obtenir des directives de configuration.

Configurer le VLAN sur les commutateurs de la gamme Catalyst 2900XL, 3500XL, 2950, 2970 et 2940

Créer des VLAN et des ports

Remarque: La sortie que vous voyez peut être en partie différente de la sortie de commande affichée dans cette section. La différence dépend du modèle de votre commutateur.

Pour créer un VLAN, exécutez les étapes suivantes.

  1. Déterminez si vous voulez utiliser le protocole VTP dans votre réseau.

    Avec VTP, vous pouvez apporter des modifications de configuration de manière centrale sur un seul commutateur, et vous pouvez communiquer ces modifications automatiquement à tous les autres commutateurs du réseau. Le mode VTP par défaut sur les commutateurs Catalyst 2900XL, 3500XL, 2950, 2970 et 2940 est le mode serveur. Pour plus d'informations sur le protocole VTP, reportez-vous à Présentation du protocole VTP (VLAN Trunking Protocol).

    Remarque: Pour vérifier l'état VTP sur les commutateurs de la gamme XL, émettez la commande show vtp status.

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- This is the default mode.
    
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70 
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
  2. Après avoir défini et vérifié le domaine VTP, commencez à créer des VLAN sur le commutateur.

    Par défaut, il n'y a qu'un seul VLAN pour tous les ports. Ce VLAN est appelé default. Vous ne pouvez pas renommer ou supprimer le réseau VLAN 1.

    Pour vérifier les informations relatives au VLAN, émettez la commande show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

    Pour créer un autre VLAN, émettez l'ensemble de commandes suivant en mode privilégié :

    3524XL#vlan database
    
    !--- You must enter into VLAN database in order to configure any VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- You can skip this command if the switch is already in server mode and you
    !--- want the switch to be in server mode.
    
    

    Remarque: Un commutateur ne peut créer des VLAN que s'il est en mode serveur VTP ou en mode VTP transparent. Pour plus d'informations sur le protocole VTP, reportez-vous à Présentation du protocole VTP (VLAN Trunking Protocol).

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- You must exit from the VLAN database in order for the changes 
    !--- to be committed.
    
    APPLY completed.
    Exiting....
    3524XL#

    Remarque: Le mode VTP peut passer du mode client au mode transparent si le commutateur tente d'apprendre ou de faire passer un nombre de VLAN supérieur à ce qu'il peut prendre en charge. Vérifiez toujours que les commutateurs qui s'exécutent en mode client prennent en charge le même nombre de VLAN que ceux envoyés par les commutateurs en mode serveur.

  3. Pour vérifier que le réseau virtuel local est créé, émettez la commande show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
  4. Vous pouvez ajouter des ports (interfaces) dans le VLAN nouvellement créé.

    Vous devez passer en mode de configuration d'interface pour chacune des interfaces que vous voulez ajouter à un nouveau VLAN.

    Remarque: Vous pouvez affecter les ports d'un commutateur Catalyst de couche 2 à plusieurs VLAN, mais le commutateur ne prend en charge qu'une seule interface active de VLAN de gestion à la fois, et les autres interfaces virtuelles commutées (SVI) n'ont pas un état up/up en raison des fonctionnalités de la couche 2. Par conséquent, le commutateur prend en charge une seule adresse active de la couche 3 de gestion. Sur un commutateur Catalyst de couche 2, vous pouvez émettre la commande de gestion facultative sous la nouvelle SVI afin d'arrêter automatiquement le réseau VLAN 1 et transférer l'adresse IP au nouveau VLAN.

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down    
    VLAN2                      20.0.0.2        YES manual up       up      
    FastEthernet0/1            unassigned      YES unset  up       up      
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Output suppressed.
    
    

    Émettez cet ensemble de commandes en mode privilégié afin d'ajouter une interface particulière dans le VLAN :

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/2 to VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/3 to VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- This saves the configuration.
    
    Building configuration...
  5. Pour vérifier la configuration des VLAN, émettez la commande show vlan.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Supprimer des ports ou des VLAN

Pour supprimer des ports du VLAN, émettez la commande no switchport access vlan vlan_number en mode de configuration d'interface. Une fois le port supprimé du VLAN qui n'est pas VLAN 1 (le VLAN par défaut), ce port est automatiquement ajouté de nouveau au VLAN par défaut.

Par exemple, si vous voulez supprimer l'interface Fast Ethernet 0/2 de cisco_vlan_2 (VLAN 2), émettez cet ensemble de commandes en mode privilégié :

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- These two commands remove interface Fast Ethernet 0/2 from VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Note: Fast Ethernet 0/2 is added back to the default VLAN.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Pour supprimer le VLAN, émettez la commande no vlan vlan_number en mode de base de données de VLAN. Les interfaces présentes dans ce VLAN continuent en faire partie, et sont désactivées car elles n'appartiennent plus à aucun VLAN.

Par exemple, si vous voulez supprimer cisco_vlan_2 du commutateur, émettez cet ensemble de commandes en mode privilégié :

3524XL#vlan database

!--- This command enters you into the VLAN database mode.

3524XL(vlan)#no vlan 2

!--- This command removes the VLAN from the database.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Output suppressed.

Notez que le port Fast Ethernet 0/3 n'apparaît pas dans la sortie de la commande show vlan. La suppression du réseau VLAN 2 désactive ce port. À moins d'ajouter à nouveau ce port dans un autre VLAN, le port n'est ni affiché, ni utilisable.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Output suppressed.

Pour rendre l'interface utilisable, vous devez vous assurer qu'elle appartient à un VLAN. Dans le cas de cette section du document, vous devez ajouter l'interface Fast Ethernet 0/3 au VLAN par défaut (VLAN 1) afin de rendre cette interface utilisable.

Si vous disposez de la sortie d'une commande show-tech support émise par votre périphérique Cisco, vous pouvez utiliser l'interpréteur de sortie (réservé aux clients inscrits) afin d'afficher les problèmes potentiels et des correctifs.

Remarque: Dans le cas des commutateurs Catalyst 3550, vous pouvez toujours utiliser l'interface sans ajouter l'interface à un VLAN. Cependant, vous devez faire de cette interface une interface de couche 3. Pour plus d'informations sur les interfaces de couche 3 sur les commutateurs Catalyst 3550, reportez-vous à la section Configuration d'interfaces de couche 3 de Configuration des caractéristiques des interfaces.

Configurer un port à VLAN multiple sur Catalyst 2900XL/3500XL

La fonctionnalité de port à VLAN multiple sur les commutateurs Catalyst 2900XL/3500XL vous permet de configurer un seul port dans deux VLAN, ou plus. Cette fonctionnalité permet aux utilisateurs de différents VLAN d'accéder à un serveur ou à un routeur sans l'implémentation de la capacité de routage inter-VLAN. Un port à VLAN multiple remplit les fonctions de commutation normales dans l'ensemble des VLAN qui lui sont affectés. Le trafic des VLAN sur le port à VLAN multiple n'est pas encapsulé car il est en mode Trunk.

Remarque: Les limitations de l'implémentation des fonctionnalités du port à VLAN multiple sont les suivantes :

  • Vous ne pouvez pas configurer un port à VLAN multiple lorsqu'un tronc est configuré sur le commutateur. Vous pouvez connecter le port à VLAN multiple uniquement à un routeur ou à un serveur. Le commutateur passe automatiquement en mode VTP transparent lorsque la fonctionnalité de port à VLAN multiple est activée, ce qui désactive la fonction VTP. Aucune configuration VTP n'est nécessaire.

  • La fonctionnalité de port à VLAN multiple est prise en charge uniquement sur les commutateurs de la gamme Catalyst 2900XL/3500XL. Cette fonctionnalité n'est pas prise en charge sur les commutateurs de la gamme Catalyst 4500/4000, 5500/5000 ou 6500/6000, ou sur tout autre commutateur Catalyst.

  1. Déterminez quel port configurer en tant que port à VLAN multiple.

    Ici, trois VLAN sont créés sur un commutateur Catalyst 3512XL, et un port du commutateur est connecté à un routeur externe. Cet exemple configure le port qui est connecté au routeur en tant que port à VLAN multiple.

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active

    Dans l'exemple, le port Fast Ethernet 0/1 est connecté à un routeur externe. Pour plus d'informations sur la façon de créer des VLAN et de leur affecter des ports, consultez la section Configurer le VLAN sur les commutateurs de la gamme Catalyst 2900XL, 3500XL, 2950, 2970 et 2940 de ce document.

  2. Configurez le port Fast Ethernet 0/1 en mode de VLAN multiple, et ajoutez des VLAN affectés au port à VLAN multiple.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- This command changes the port Fast Ethernet 0/1 mode to multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- This command assigns VLANs 1, 2, and 3 to multi-VLAN port Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
     
    6-3512xl#
  3. Pour vérifier la configuration, émettez la commande show interface interface_id switchport et la commande show vlan.

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- The port is in multi-VLAN mode.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Note: Previously, port Fast Ethernet 0/1 was only in VLAN 1.
    !--- Now the port is assigned to multiple VLANs 1, 2, and 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
  4. Pour vérifier l'opération de VLAN multiple, émettez la commande ping du commutateur vers le routeur.

    La commande ping reçoit une réponse du routeur chaque fois que l'adresse IP de gestion est affectée à l'un des VLAN VLAN 1, 2 ou 3.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- The management IP address is assigned to VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- The management IP address is removed from VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- The management IP address is assigned to VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- The management IP address is removed from VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- The management IP address is assigned to VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Configurer le VLAN sur les commutateurs Catalyst 3550, 3750, 4500/4000 et 6500/6000 qui exécutent le logiciel Cisco IOS

Créer des VLAN et des ports

Cette section utilise le commutateur Catalyst 4500 pour les exemples de commandes de configuration, mais les tâches de configuration s'appliquent également à d'autres commutateurs qui exécutent la couche 3 (ou le logiciel Cisco IOS). Ces autres commutateurs sont notamment les commutateurs de la gamme Catalyst 3550, 3570 et 6500 qui exécutent le logiciel Cisco IOS. Pour pouvoir créer un VLAN, le commutateur doit être en mode de serveur VTP ou en mode VTP transparent. Si le commutateur est un serveur VTP, vous devez définir un nom de domaine VTP avant d'ajouter des VLAN. Vous devez définir un nom de domaine VTP indépendamment des points suivants :

  • Le nombre de commutateurs dans le réseau, qu'il y en ait un ou plusieurs

  • Que vous utilisiez, ou non, VTP pour propager des VLAN sur d'autres commutateurs du réseau

Pour plus d'informations sur la façon de configurer VTP sur les modules de Supervisor Engine Catalyst 4500/4000 reposant sur le logiciel Cisco IOS, reportez-vous à Présentation et configuration de VTP. Reportez-vous au guide de configuration logicielle relatif à la plate-forme de commutateur prise en compte pour les informations de configuration VTP pour d'autres plates-formes de commutation Catalyst. Pour accéder au guide de configuration logicielle, reportez-vous aux Pages de support technique pour les réseaux locaux.

Vous pouvez créer des VLAN soit en mode de base de données de VLAN, soit en mode de configuration globale. Vous devez créer des VLAN dont le numéro est supérieur à 1005 en mode de configuration globale. Pour créer ces VLAN, le mode VTP défini doit être le mode VTP transparent. Les VLAN dont le numéro est supérieur à 1005 ne sont pas annoncés par VTP. De plus, les VLAN dont le numéro est supérieur à 1005 sont stockés dans le fichier de configuration du commutateur, et non pas dans le fichier .dat du VLAN. L'emplacement par défaut du fichier .dat d'un VLAN dans les commutateurs Catalyst 4000 avec Supervisor Engine IV est le répertoire cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Remarque: Un commutateur Catalyst 6500 qui exécute le logiciel Cisco IOS vous permet de créer des VLAN en mode serveur sans nom de domaine VTP.

La commande show vtp status affiche les informations relative à VTP dans le commutateur.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. Pour vérifier les informations relatives au VLAN, émettez la commande show vlan.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Output suppressed.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports 
    ------- --------- ----------------- ------------------------------------------
  2. Passez dans le mode approprié : soit le mode de base de données, soit le mode de configuration globale.

    Pour passer en mode de base de données de VLAN, émettez la commande vlan database en mode privilégié.

    Switch#vlan database
    
    Switch(vlan)#
  3. Pour configurer un VLAN, émettez la commande vlan vlan_number.

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.

    Remarque: Pour que la configuration prenne effet, vous pouvez soit émettre la commande apply, soit quitter le mode de base de données de VLAN. Le mot clé end et les méthodes de sortie Ctrl-Z ne fonctionnent pas en mode de base de données de VLAN. Pour quitter le mode de base de données de VLAN, émettez la commande exit.

    Pour effectuer la configuration du VLAN en mode de configuration globale, émettez les commandes suivantes :

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
  4. Pour afficher les VLAN dont le numéro est supérieur à 1005 dans la configuration en cours, émettez la commande show run.

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Output suppressed.
    
    

Dans le logiciel Cisco IOS, les interfaces sont dans l'état shutdown par défaut, contrairement aux commutateurs CatOS. Dans CatOS, le port devient actif s'il sent la présence d'une liaison physique.

Par défaut, les interfaces de logiciel Cisco IOS sont des interfaces de couche 2 sur les commutateurs de la gamme Catalyst 3550, 3750 et 4500. Les interfaces sont des interfaces de couche 3 sur les commutateurs de la gamme Catalyst 6500/6000. Vous pouvez configurer l'interface en tant qu'interface de couche 2 avec la commande switchport en mode de configuration d'interface. Si l'interface est en mode de couche 3, vous devez émettre cette commande avant d'affecter une interface à un VLAN. La commande permettant d'affecter une interface à un VLAN est switchport access vlan vlan_number.

Remarque: Si l'interface est configurée en tant qu'interface de couche 3, ce qui signifie que la commande no switchport est configurée, vous ne pouvez pas affecter l'interface à un VLAN.

Pour associer les ports à des VLAN dans le logiciel Cisco IOS, la configuration minimale suivante est requise :

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- This command is required if the interface is in Layer 3 mode.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Pour vérifier l'état de l'interface de couche 2, émettez la commande show interface gigabitethernet module/interface switchport.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Si le port est configuré en tant que jonction, qui est un port pouvant comporter plusieurs VLAN, la commande switchport trunk native vlan peut être utile. C'est notamment le cas si les valeurs par défaut du VLAN natif de l'interface ont été modifiées ou doivent l'être. Le VLAN natif est le VLAN qui est utilisé si l'interface doit devenir une interface de couche 2. Si vous ne définissez pas explicitement un VLAN natif, le réseau VLAN 1 devient le VLAN natif par défaut. Gardez à l'esprit qu'aucun en-tête IEEE 802.1Q n'est ajouté lorsque des données sont envoyées sur le VLAN natif. Assurez-vous que les ports de tronc sur les deux périphériques connectés ont le même VLAN natif. Une non-correspondance des VLAN natifs peut entraîner, entre autres, des problèmes de routage inter-VLAN.

Le message suivant s'affiche lorsque le VLAN natif est discordant sur les deux commutateurs Cisco :

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

Dans cet exemple de message, le VLAN natif est VLAN 2 sur l'un des commutateurs, mais le commutateur voisin a le réseau natif VLAN 1.

Pour afficher les informations relatives au VLAN natif, à l'encapsulation et au VLAN de tronc, émettez la commande show interfaces module/interface trunk.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Si vous utilisez la configuration par défaut, le VLAN indigène est placé à VLAN 1. afin de changer le VLAN indigène sur l'interface qui est jonction, émettent la commande de vlan_number de switchport trunk native vlan.

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Pour vérifier, émettez la commande suivante :

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Affecter plusieurs ports à un seul VLAN

Vous pouvez affecter les différentes interfaces présentes sur un commutateur à un seul VLAN. Émettez les commandes suivantes :

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

Remarque: La commande interface range n'est pas prise en charge dans toutes les versions de logiciel. La commande interface range est prise en charge dans le logiciel Cisco IOS Version 12.1(13)EW et ultérieures.

Supprimer des VLAN

Pour supprimer un VLAN de la base de données de VLAN, émettez la commande no vlan vlan_number en mode de base de données de VLAN ou en mode de configuration globale. L'exemple suivant utilise le mode de base de données de VLAN pour supprimer VLAN 2.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

Le mode de configuration globale ne consigne aucun message indiquant la suppression du VLAN dans un journal sur la console. Cependant, vous pouvez émettre la commande show vlan pour vérifier la suppression du VLAN.

Renommer des VLAN

Pour renommer un VLAN de la base de données de VLAN, émettez la commande name nom_vlan en mode de base de données de VLAN ou en mode de configuration globale.

L'exemple suivant utilise le mode de base de données de VLAN pour renommer VLAN 3 :

Switch#vlan database

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Switch(vlan)#apply

APPLY completed.

L'exemple suivant utilise le mode de configuration globale pour renommer le réseau VLAN 3 :

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Pour vérifier, émettez la commande show vlan brief ou show vlan-switch brief.

switch#show vlan brief

VLAN  Name                             Status    Ports
---- -------------------------------- --------- -----------
 3    CISCO                            active    Fa0/3

Remarque: Lorsque vous renommez le VLAN, il n'est pas nécessaire de supprimer le VLAN affecté au port à l'aide de la commande switchport access vlan vlan_number.

Comment isoler la communication entre deux VLAN

Cette section ne traite pas des VLAN privés. Les VLAN privés fournissent un isolement de couche 2 entre les ports du même VLAN privé (VLAN isolé) ou entre les VLAN privés (VLAN de communauté).

Deux scénarios sont possibles lorsque vous tentez d'isoler deux VLAN.

Isolement entre deux VLAN de couche 2

Un VLAN de couche 2 est le VLAN créé dans le commutateur et non configuré avec la commande interface vlan <vlan_number>. Les hôtes dans les différents VLAN de couche 2 ne peuvent pas communiquer entre eux.

Pour créer un VLAN de couche 2 et l'isoler des VLAN plus anciens, exécutez les étapes suivantes :

  1. Créez le nouveau VLAN dans la base de données. Quand vous quittez le mode de base de données de VLAN, les modifications de configuration sont appliquées.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode in order to 
    !--- configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Assurez-vous que le VLAN est créé dans la base de données de VLAN. Le nouveau VLAN doit apparaître dans la sortie de la commande show vlan.

  3. N'affectez pas d'adresse IP aux VLAN nouvellement créés.

  4. Configurez les interfaces physiques qui connectent les clients au VLAN correspondant.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. Affectez à chacun hôte une adresse IP statique et un masque de sous-réseau, et ne définissez pas de passerelle par défaut. Sinon, les hôtes sur les ports fa 2/1 et 2/2 ne peuvent pas communiquer entre eux. Les périphériques qui appartiennent à un VLAN n'atteignent que les périphériques se trouvant dans le même VLAN.

Isolement entre deux VLAN de couche 3

Lorsque vous créez un VLAN et que vous affectez une adresse IP avec la commande interface vlan <vlan_number>, le VLAN devient un VLAN de couche 3. Dans les commutateurs de couche 3, les hôtes entre les deux VLAN peuvent communiquer entre eux (si les hôtes sont configurés avec la passerelle par défaut comme adresse IP d'interface de VLAN). Vous pouvez utiliser des listes de contrôle d'accès (ACL) pour interdire la communication entre les VLAN.

Cette section présente un exemple de la façon d'isoler la communication entre un VLAN de couche 3 nouvellement créé et un VLAN plus ancien.

Dans cet exemple, le commutateur 3750 a deux anciens VLAN (VLAN 1 et VLAN 2). Le VLAN de création récente est VLAN 5. VLAN 1, VLAN 2 et VLAN 5 sont la couche 3 VLAN. Les listes de contrôle d'accès sont implémentées pour interdire le trafic afin que VLAN 1 et VLAN 2 ne puissent pas communiquer avec VLAN 5 et que VLAN 5 ne communique pas avec VLAN 1 ou VLAN 2.

  • VLAN 1 - 10.10.10.0 /24

  • VLAN 2 - 172.16.1.0 /24

  • VLAN 5 - 192.168.1.0 /24

  1. Créez le nouveau VLAN dans la base de données. Dans le cas présent, le nouveau VLAN est VLAN 5. Quand vous quittez le mode de base de données de VLAN, les modifications de configuration sont appliquées.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode
    !--- in order to configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Assurez-vous que le VLAN est créé dans la base de données de VLAN. Vérifiez la sortie de la commande show vlan.

  3. Définissez une adresse IP pour le VLAN nouvellement créé.

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. Configurez les interfaces physiques qui connectent les clients au VLAN correspondant.

    Switch(config)#interface fastEthernet 2/1 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    Vous devez configurer trois listes d'accès, une pour chaque VLAN.

    • La liste d'accès suivante refuse le trafic qui provient de VLAN 1 pour accéder à VLAN 5.

      
      !--- Some of the commands in this output are wrapped
      !--- to a second line due to spatial reasons.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny 
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • La liste d'accès suivante refuse le trafic qui provient de VLAN 2 pour accéder à VLAN 5.

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • La liste d'accès suivante refuse le trafic qui provient de VLAN 5 pour accéder à VLAN 1 et VLAN 2.

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    Une fois les listes d'accès configurées, appliquez-les à l'interface VLAN 1, à l'interface VLAN 2 et à l'interface VLAN 5.

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Comment configurer des VLAN de portée étendue dans un commutateur de la gamme Catalyst 6500

Pour configurer des VLAN étendus sur les commutateurs de la gamme Catalyst 6500 exécutant Cisco IOS, vous devez entrer la commande spanning-tree extend system-id. Le VLAN étendu doit alors être créé en mode de configuration et non pas en mode de base de données de VLAN.

Pour créer des VLAN étendus sur les commutateurs de la gamme Catalyst 6500 qui exécutent Cisco IOS, exécutez les étapes suivantes :

  1. Placez la console dans le commutateur :

    Switch>enable
    Switch#
  2. Passez en mode de configuration :

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
  3. Entrez la commande spanning-tree extend system-id en mode de configuration :

    Switch(config)#spanning-tree extended system-id
    
  4. Entrez la commande vtp mode transparent en mode de configuration :

    Switch(config)#vtp mode transparent
    
  5. Créez le VLAN en mode de configuration :

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. Quittez le mode de configuration :

    Switch(config)#exit
    
  7. Pour vérifier les informations relatives au VLAN, émettez la commande show vlan.

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    1311 VLAN1311                         active    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0   
    101  enet  100101     1500  -      -      -        -    -        0      0   
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   
    1311 enet  101311     1500  -      -      -        -    -        0      0   

Conseils de dépannage

Cette section fournit des conseils de dépannage pour les problèmes courants que vous pouvez rencontrer lors de la création de VLAN sur les commutateurs Catalyst qui exécutent le logiciel Cisco IOS.

Sur les commutateurs qui exécutent le logiciel Cisco IOS, vous pouvez utiliser le commutateur lui-même pour le routage inter-VLAN, plutôt qu'un routeur externe. La création d'une SVI ne crée pas automatiquement un VLAN dans la base de données de couche 2. Pour qu'une SVI apparaisse, vous devez créer un VLAN en mode de base de données de VLAN ou (dans les versions ultérieures du logiciel Cisco IOS) en mode de configuration globale. Afin que l'interface SVI soit totalement active, ce qui signifie qu'elle est administrativement active et que le protocole de ligne est actif, assurez-vous que vous avez au moins un port en tant que membre de ce VLAN, avec un périphérique actif connecté au port.

Le même problème se pose lorsque vous copiez des configurations d'un commutateur différent ou que vous restaurez des configurations avec des VLAN qui ont été créés en mode de base de données de VLAN. Vous devez également remplacer le fichier de base de données VLAN (vlan.dat), ou vous devez recréer les VLAN, car la procédure dans la section de CreateVLANs et de ports de ce document affiche. Si vous copiez la configuration d'un autre commutateur, la base de données de VLAN n'est pas copiée.

Si le VLAN de couche 2 n'est pas créé sur le commutateur, les interfaces SVI apparaissent comme étant UP/DOWN dans la sortie de la commande show ip interface brief quand la configuration est appliquée au commutateur. Assurez-vous que tous les VLAN précédents qui ont été créés en mode de base de données de VLAN ou en mode de configuration globale existent toujours une fois la configuration copiée sur le commutateur.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Erreur de valeurs TLB incohérentes sur les commutateurs IOS

L'erreur de valeurs LTB (Translational Bridging) incohérentes se produit lorsque vous créez un VLAN sur un commutateur Cisco IOS qui a récemment reçu une mise à jour de VTP d'un commutateur CatOS ou qui a été converti à partir de CatOS. En effet, CatOS et Cisco IOS ont certaines valeurs par défaut différentes pour le VLAN du pont de traduction. Les VLAN de translation traduisent FDDI (Fiber Distributed Data Interface) ou Token Ring en Ethernet. Les VLAN du pont de traduction (tb) pour les réseaux VLAN 1, 1002 et 1003 sont différents dans CatOS et leur valeur est 0 par défaut. Les VLAN du pont de traduction par défaut du fabricant dans les commutateurs Cisco IOS sont les suivants :

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

Un commutateur Cisco IOS qui a récemment reçu une mise à jour de VTP d'un commutateur CatOS ou qui a été converti à partir de CatOS remplace les valeurs TB par défaut. Lorsque vous tentez de créer un VLAN après cela, le message d'erreur suivant est généré :

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Pour contourner ce problème, modifiez les valeurs par défaut TB du commutateur Cisco IOS pour VLAN 1, 1002 et 1003 afin qu'elles correspondent aux valeurs CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Récupérer le fichier vlan.dat sur les commutateurs IOS

Pour les commutateurs Cisco Catalyst qui exécutent le logiciel Cisco IOS, les informations relatives aux VLAN se trouvent dans un fichier distinct nommé vlan.dat. Si le fichier vlan.dat est supprimé accidentellement et que le commutateur est rechargé, tous les VLAN qui étaient disponibles sur le commutateur sont perdus. Les informations relatives aux VLAN sont présentes dans le commutateur jusqu'au rechargement du commutateur.

Pour récupérer le fichier vlan.dat, exécutez les étapes suivantes :

  1. Pour vérifier la disponibilité des informations relatives aux VLAN, émettez la commande show vlan.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
  2. Si le commutateur est en mode serveur VTP ou en mode transparent, apportez toutes les modifications nécessaires à la base de données de VLAN.

    Les modifications apportées à la base de données de VLAN peuvent être l'une des suivantes :

    • Créer un VLAN.

    • Supprimer un VLAN.

    • Modifier les propriétés de tout VLAN existant.

    Si le commutateur est en mode client VTP, apportez les modifications à la base de données de VLAN sur tous les serveurs VTP du même domaine.

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#

    Une fois qu'une modification a été apportée à la base de données de VLAN, le commutateur crée automatiquement le fichier vlan.dat.

  3. Émettez la commande show flash: pour vérifier la création du fichier vlan.dat.

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)

Échec de création de VLAN dans une portée étendue

Erreur 1

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

Le port LAN de couche 3, les interfaces et sous-interfaces WAN, ainsi que certaines fonctionnalités logicielles, telles que RSPAN, utilisent des VLAN internes dans la portée étendue. Vous ne pouvez pas utiliser un VLAN de portée étendue qui est alloué pour un usage interne.

Pour afficher les VLAN utilisés en interne, émettez la commande show vlan internal usage. Vous pouvez configurer une allocation de VLAN internes croissante (1006 et valeurs supérieures) ou allocation de VLAN internes décroissante (4094 et valeurs inférieures).

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Enter the ascending keyword to allocate internal VLANs from 1006 and up. 
!--- Enter the descending keyword to allocate internal VLAN from 4094 and down.

Switch(config)#end 
Switch#reload

attention Attention : Il n'est pas nécessaire d'émettre la commande reload immédiatement. Émettez la commande reload pendant une période de maintenance planifiée. La stratégie d'allocation de VLAN internes est appliquée uniquement après un rechargement.

Si le rechargement d'un périphérique n'est pas une option, vous pouvez, pour contourner le problème, utiliser la traduction de VLAN. Sur les ports de tronc, vous pouvez traduire un numéro de VLAN en un autre numéro de VLAN, ce qui transfère tout le trafic reçu dans un VLAN vers l'autre VLAN. Pour plus d'informations, reportez-vous à la section Configuration de la traduction de VLAN de Configuration de VLAN.

Remarque: Les commutateurs qui exécutent les logiciels de la famille de produits Catalyst ne prennent pas en charge la configuration des VLAN 1006-1024. Si vous configurez es VLAN 1006-1024, assurez-vous que les VLAN ne s'étendent pas à un commutateur qui exécute les logiciels de la famille de produits Catalyst.

Erreur 2

%Failed to commit extended VLAN(s) changes

Ce message peut s'afficher quand vous tentez de créer des VLAN étendus en mode serveur ou client de VTP.

Assurez-vous que le périphérique (commutateur ou routeur) est en mode transparent lorsque vous créez des VLAN de portée étendue. Pour plus d'informations, reportez-vous à la section Directives sur le protocole VTP (VLAN Trunking Protocol) de ID de VLAN étendus.

Échec de configuration de VLAN à partir de startup-config

SW-VLAN-4-BAD-STARTUP-VLAN-CONFIG-FILE: Failed to configure VLAN from 
startup-config. Fallback to use VLAN configuration file from non-volatile memory

Ce message indique que le logiciel de VLAN n'a pas pu utiliser la configuration des VLAN figurant dans le fichier de configuration de démarrage. La configuration des VLAN est stockée dans le fichier vlan.dat. Le fichier vlan.dat réside dans la mémoire non volatile. Lorsque le module superviseur est remplacé, vlan.dat est vide (0). Au démarrage, le commutateur compare le nom de domaine de VTP et le mode VTP dans le fichier de configuration de démarrage et dans le fichier vlan.dat. Si les valeurs ne correspondent pas, le commutateur utilise la configuration du fichier vlan.dat.

Pour effectuer une sauvegarde complète de votre configuration, le fichier vlan.dat doit être inclus dans la sauvegarde avec la configuration. Pour restaurer la configuration complète, l'administrateur réseau doit télécharger le fichier vlan.dat et le fichier de configuration.

Sauvegarde et restauration de vlan.dat sur les commutateurs Cisco IOS

Pour sauvegarder le fichier vlan.dat, exécutez l'étape suivante :

Copiez le fichier vlan.dat de la NVRAM du périphérique vers un serveur TFTP ou une carte PCMCIA externe.

copy const_nvram:vlan.dat tftp:

Remarque: L'emplacement de la mémoire où est stocké le fichier vlan.dat varie d'un périphérique à l'autre. Dans les commutateurs de la gamme Cisco Catalyst 6500/6000, c'est const_nvram. De la même façon pour les commutateurs Catalyst 4500/4000, c'est cat4000_flash. Référez-vous à la documentation du produit respective avant d'émettre le copycommand.

Pour restaurer le fichier vlan.dat, exécutez les étapes suivantes :

  1. Copiez le fichier vlan.dat dans la NVRAM du périphérique à partir d'un serveur TFTP ou d'une carte PCMCIA externe.

    copy tftp: const_nvram:
  2. Rechargez le commutateur, car vlan.dat est lu uniquement pendant le processus de démarrage.

Échec de création de VLAN avec message d'erreur indiquant que le VLAN parent du VLAN 1003 est manquant

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
VLAN 1003 parent VLAN missing
APPLY VLAN changes failed.
Switch(config)#end
Switch#

Une configuration incorrecte sur un commutateur peut entraîner l'échec des mises à jour de configuration du VTP. Dans la plupart des cas, le problème est que le nouveau VLAN créé dans le commutateur serveur VTP ne se propage pas aux commutateurs clients VTP, ce qui crée des problèmes de connectivité à l'hôte.

Une incompatibilité de versions entre les commutateurs dans un domaine VTP constitue une cause fréquente de ce problème. Le VTP version 1 et le VTP version 2 ne peuvent pas interagir sur les périphériques réseau dans le même domaine VTP. Un périphérique réseau compatible avec le VTP version 2 peut fonctionner avec un périphérique réseau qui exécute le VTP version 1, à condition que le VTP version 2 soit désactivé sur le périphérique réseau compatible avec le VTP version 2. Le VTP version 2 est désactivée par défaut. Chaque périphérique réseau dans le domaine VTP doit utiliser la même version de VTP. Vérifiez la version de VTP qui est exécutée sur un commutateur. Si le VTP version 2 est activé, désactivez-le pour résoudre ce problème.

Vérifiez si le commutateur est correctement configuré pour les autres paramètres de VTP :

  • Vérifiez que les commutateurs sont connectés via des liaisons de jonction, car les mises à jour de VTP sont échangées uniquement via des liaisons de jonction.

  • Vérifiez que le nom de domaine VTP est exactement le même sur les commutateurs appropriés. Le nom respecte la casse. Les mises à jour de VTP sont échangées uniquement entre les commutateurs du même domaine VTP.

  • Vérifiez que le mot de passe du VTP est exactement le même sur tous les commutateurs du domaine. Le mot de passe respecte la casse. Si un mot de passe est configuré, il doit l'être sur tous les commutateurs du domaine et doit être à chaque fois le même.

En cas de problème de convergence de VTP, où un client VTP ne met pas à jour les informations relatives au VLAN, la solution de contournement consiste à forcer une convergence de VTP en créant, puis en supprimant un VLAN factice sur le serveur VTP. Cela incrémente le numéro de révision et force tous les clients VTP à mettre à jour leur base de données VLAN.


Informations connexes


Document ID: 10023