Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration de NFAS avec quatre contrôleurs T1

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

La signalisation associée parinstallation RNIS (NFAS) permet à un canal D simple pour contrôler de plusieurs accès primaires (PRIs). Vous pouvez configurer un canal D de sauvegarde quand le canal D primaire NFAS échoue. Quand vous configurez les contrôleurs canalisés de t1 pour le PRI RNIS, vous devez seulement configurer le canal D primaire NFAS ; sa configuration est distribuée à tous les membres du groupe associé NFAS.

À l'aide d'un canal D simple pour contrôler plusieurs PRIs, un canal supplémentaire sur chaque interface est libre de porter le trafic de données. N'importe quelle panne dure du canal primaire de D-signalisation a comme conséquence un basculement immédiat au canal D de sauvegarde sans déconnecter actuellement des utilisateurs connectés.

Remarque: Si vous configurez un canal D de sauvegarde, seulement 23 canaux B peuvent être utilisés sur le contrôleur de sauvegarde de t1 parce que le canal D sur la sauvegarde est indisponible. Par conséquent, seulement ceux T1 qui ne sont ni primaires ni de sauvegarde peuvent avoir 24 canaux B disponibles. Dans cette configuration, le contrôleur 4/0 de t1 est le primaire et a 23 canaux disponibles B, et le contrôleur 4/1 de t1 est la sauvegarde et a 23 canaux disponibles B. Les contrôleurs 5/0 et 5/1 de t1 ont 24 canaux disponibles B.

Conditions préalables

Conditions requises

Les préalables à NFAS sont comme suit :

  • NFAS est pris en charge seulement avec un contrôleur canalisé de t1 et, en conséquence, les contrôleurs de t1 doivent également être configurés pour le PRI RNIS avant de mettre en application NFAS. Pour plus d'informations sur configurer le RNIS, référez-vous à la page d'assistance RNIS.

  • Le routeur configuré pour NFAS doit se connecter à un 4ess, dms250, dms100, ou à un type national de commutateur RNIS.

    Remarque: NFAS n'est pas pris en charge sur des Commutateurs de type primary-5ess. Consultez votre fournisseur de services ou compagnie de téléphone pour déterminer si NFAS peut être configuré pour votre ligne de t1.

  • NFAS doit être configuré sur le commutateur RNIS de votre compagnie de téléphone.

  • Vous devez utiliser la version de logiciel 11.3T ou ultérieures de ½ du ¿  de Cisco IOSïÂ.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • La configuration suivante a été testée avec un Logiciel Cisco IOS version 12.0(5) courant de routeur Cisco 7507.

  • Cette configuration illustre comment installer quatre membres NFAS dans le même groupe. L'interface primaire NFAS est le t1 4/0, et la sauvegarde est le t1 4/1. Les contrôleurs 5/0 et 5/1 de t1 ont 24 canaux B disponibles à eux

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

Terminologie NFAS

Les termes utilisés généralement NFAS sont comme suit :

  • NFAS - Un service RNIS qui permet à un canal D simple pour contrôler plusieurs PRIs. Utilisant un canal D simple contrôler plusieurs PRIs permet à un canal B sur chaque interface pour porter l'autre trafic.

  • 24 interfaces à attachement canal B - Un groupe de canaux PRI configuré pour n'avoir aucun canal D NFAS ; tous les 24 canaux sont des canaux B. Ce t1 particulier utilise le canal D configuré dans le contrôleur primaire pour la signalisation.

  • Groupe NFAS - Un groupement de canal PRI (le groupe d'interfaces) sous le contrôle d'un canal D simple. Le groupe de canaux peut inclure tous les canaux RNIS sur de plusieurs contrôleurs de t1.

    Remarque: NFAS peut être configuré avec des membres dans différents emplacements sur le routeur (par exemple, des membres NFAS ne sont pas limités à être sur le même emplacement ou module). En outre, dans un châssis unique, cinq groupes NFAS sont pris en charge. Dans les cas où T1 de plusieurs fournisseurs sont utilisés, ils sont souvent groupés par le fournisseur.

  • Membre NFAS - Un PRI dans un groupe NFAS. Par exemple, un groupe NFAS pourrait inclure des interfaces série 1/0:23, 1/1:23, et 2/0:23 si les contrôleurs de t1 1/0, 1/1, et 2/0 sont configurés dans un groupe NFAS. Pour afficher les membres de tout le NFAS groupez, utilisez la commande de privileged exec de show isdn nfas group.

Commande requise

Remarque: Les commandes de configuration normales de PRI RNIS n'apparaissent pas dans ce document. Voyez la section Informations connexes pour plus d'informations sur configurer le PRI RNIS.

group_number de nfas_group d'int_number de nfas_interface de fonction de nfas_d du pri-group timeslots 1-24

Cette commande de configuration de contrôleur assigne le contrôleur de t1 au groupe NFAS et indique sa fonction dans le groupe. Spécifiez les valeurs suivantes comme appropriées :

  • fonction - La fonction à exécuter par le créneau horaire 24, primaire, de sauvegarde, ou aucun. Chaque groupe NFAS doit avoir un primaire. Le routeur n'a pas besoin d'une sauvegarde, toutefois la plupart des réalisations NFAS ont un canal D de sauvegarde. Entrez en contact avec votre compagnie de téléphone pour déterminer si vous devriez configurer un canal D de sauvegarde pour votre groupe NFAS. Le reste des contrôleurs peut être configuré avec aucun, qui indique le 24ème créneau horaire comme canal B.

    Remarque: Configurez les canaux D primaires et de sauvegarde exactement comme spécifiés par votre compagnie de téléphone. Une erreur commune avec une configuration NFAS desginating inexactement quel t1 est le primaire et ce qui est la sauvegarde.

  • int_number - Une valeur affectée par le fournisseur de services et utilisée pour identifier seulement le PRI. La plage possible de valeurs de 0 au t1 le plus élevé disponible sur le routeur, sans un. Par exemple, si le routeur a 10 T1 le nombre d'interface NFAS peut s'étendre entre 0 et 9. Les 0 interfaces doivent être assignées au canal D primaire et à la 1 interface au canal D de sauvegarde.

    Remarque: Dans certains scénarios où l'installation NFAS n'utilise pas un canal D de sauvegarde, n'utilisez pas le nfas_interface 1 de mot clé comme il est réservé pour le canal D de sauvegarde. Configurez seulement les nfas_interfaces 0, 2, 3, 4 et ainsi de suite.

    Remarque: En configurant de plusieurs groupes NFAS, les 0 interfaces doivent être assignées à chaque canal D primaire et à la 1 interface à chaque canal D de sauvegarde, s'ils sont dans un nfas_group différent.

  • group_number - Identifiant de groupe seul sur le routeur. Les plusieurs groupes NFAS peuvent exister sur le routeur. Chaque groupe doit être configuré avec un contrôleur primaire et secondaire.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/9584/quadt1_nfas.gif

Configurations

Ce document utilise les configurations suivantes :

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • état de show isdn - Assurez-vous que le routeur communique correctement avec le commutateur RNIS. Dans le résultat, vérifiez que l'état de la couche 1 soit ACTIVE, et que l'état de la couche 2 = MULTIPLE_FRAME_ESTABLISHED s'affiche.

  • show isdn nfas group - Commande de privileged exec d'afficher les membres d'un groupe spécifié NFAS ou de tous groupes NFAS.

  • service de show isdn - Commande de privileged exec d'afficher l'état et l'état du service de chaque canal RNIS. Les canaux D sont indiqués comme réservés. Cette commande peut être utilisée pour vérifier si différents canaux busied ou sont défectueux.

  • t1 de show controller - Affiche la particularité d'état du contrôleur au matériel de contrôleur. Il également affiche des informations pour dépanner la couche physique et les problèmes de couche de liaison. En fonctionnement le fonctionnement normal, la sortie devrait indiquer que le contrôleur est haut et qu'il n'y a aucune alarme.

Remarque: Assurez-vous que la connexion de t1 indiquée en tant que primaire par la compagnie de téléphone et en votre configuration de routeur sont connectées au port approprié. Une erreur commune a la ligne fausse de t1 (câbles) connectée au t1 le port primaire sur votre routeur.

Exemple de sortie avec show

Être suivent quelques sorties de commande show du routeur configuré avec NFAS.

Voici un exemple de la sortie de commande d'état de show isdn :

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

Remarque: L'état de show isdn a sorti seulement l'affiche des informations au sujet le du canal D pour les contrôleurs primaires et de sauvegarde. En outre, seulement les expositions primaires ACTIVE du canal D (Serial4/0:23) et PLUSIEURS TRAMES ÉTABLIES. L'état de canal D de sauvegarde (Serial4/1:23) apparaît comme DÉSACTIVÉ et TEI_ASSIGNED.

La sortie d'état de show isdn pour la couche 1 et la couche 2 pour le t1 5/0 et 5/1 sont indiquées PAS APPLICABLE parce que le 24ème canal (Serial5/0:23 et interface série 5/1:23) est utilisé comme canal B.

Voici la sortie de commande de show isdn nfas group :

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

Remarque: La sortie de show isdn nfas group affiche les membres du groupe. La sortie prouve que le contrôleur 4/0 est le primaire et 4/1 est la sauvegarde. Les contrôleurs 5/0 et 5/1 sont des membres du groupe et ont 24 canaux B disponibles à eux.

La sortie affiche également le nombre total de membres NFAS et de nombre de canaux disponibles. Il prouve que le canal D primaire est en service tandis que la sauvegarde est hors service.

Voici un exemple d'une sortie de commande de service de show isdn :

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

La sortie de service de show isdn prouve que les canaux D pour le primaire et secondaire sont dans l'état 3, qui correspond à réservé. Les canaux D pour les autres membres sont dans l'état 2, qui indique qu'ils sont occupés et en service comme canaux B. Un état de canal de 0 indique que le canal est disponible pour l'usage.

Remarque: Dans beaucoup des périphériques (le plus généralement serveurs d'accès) l'état de service pour le canal D est 2, indiquant que le canal est hors service. C'est une question cosmétique et ne devrait pas affecter votre connexion. Pour déterminer si le canal D est réellement utilisation de fonctionnement la commande d'état de show isdn comme décrit précédemment

Pour les contrôleurs qui ne sont pas indiqués en tant que primaire ou de sauvegarde (5/0 et 5/1), assurez-vous que le 24ème canal est dans l'état de veille ou occupé. Il ne devrait pas être dans l'état réservé.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug :

  • debug isdn q931 - Affichez l'établissement d'appel et démolissez de la connexion réseau RNIS (couche 3).

  • debug isdn q921 - Affichez les messages de la couche de liaison de transmission de données (couche 2) sur le canal D entre le routeur et le commutateur RNIS. Utilisez ceci mettent au point si la commande d'état de show isdn n'affiche pas la couche 1 et la couche 2.

Si le contrôleur est fermé

Que se produit quand le contrôleur appartenant à un groupe NFAS est fermé ? Tous les appels actifs sur celui contrôleur fermé seront effacés, et un du suivant s'appliquera :

  • Si le contrôleur fermé est le primaire et aucune sauvegarde n'est configurée, tous les appels actifs sur le groupe entier sont effacés.

  • Si le contrôleur fermé est le primaire, (EN SERVICE) le canal D actif est sur le primaire, et une sauvegarde est configurée, les Commutateurs de canal D actifs au contrôleur de sauvegarde.

  • Si le contrôleur fermé est le primaire et (EN SERVICE) le canal D actif est sur la sauvegarde, le canal D actif reste sur le contrôleur de sauvegarde.

  • Si le contrôleur fermé est la sauvegarde et le canal D actif est sur la sauvegarde, le canal D actif change en le contrôleur primaire.

Remarque: Le changement de canal D actif entre les contrôleurs primaires et de sauvegarde se produit seulement quand l'un ou l'autre des liens échoue et pas quand le lien est soulevé.


Informations connexes


Document ID: 9584