Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration de la fonction PPP Callback sur RNIS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour le rappel Point-to-Point Protocol (PPP) au-dessus d'Integrated Services Digital Network (le RNIS). Vous pouvez utiliser le rappel pour :

  • Fusion et centralisation de la facturation téléphonique.

  • Économies de coûts sur des appels interurbains.

  • Contrôle d'accès.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 11.0(3) ou ultérieures de Cisco IOSÝ.

  • Cisco 3640 (maui-nas-04) avec la version du logiciel Cisco IOS 12.0(5)XK1.

  • Cisco 1604 (maui-soho-01) avec le Logiciel Cisco IOS version 12.0(4)T.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Dans cette configuration d'échantillon, le rappel utilise le PPP et les équipements que RFC 1570leavingcisco.com spécifie. La fin de rappel de PPP RNIS se produit dans cette commande :

  1. Le routeur A évoque une connexion à commutation de circuits au routeur B.

  2. Les Routeurs A et B négocient le Link Control Protocol de PPP (LCP). Le routeur A peut demander un rappel ou le routeur B peut initier un rappel.

  3. Le routeur A s'authentifie au routeur B par le Password Authentication Protocol (PAP) ou le protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) de PPP. Le routeur B peut sur option authentifier au routeur A.

  4. Les deux Routeurs relâchent la connexion à commutation de circuits.

  5. Le routeur B évoque une connexion à commutation de circuits au routeur A.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/9575/isdn-ppp-callback.gif

Configurations

Ce document utilise les configurations suivantes :

maui-soho-01 : client de rappel
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local

!--- Basic AAA configuration for PPP calls.

!
username maui-nas-04 password 0 happy

!--- Username for remote router (maui-nas-04) and shared secret password.
!--- Shared secret (for CHAP authentication) must be the same on both sides.

username admin password 0 <deleted>
!
ip subnet-zero
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 172.22.85.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 ip address 172.22.82.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 172.22.82.1 name maui-nas-04 20007

!--- Dialer map statements for the remote router.
!--- The name must match the name that the remote router uses to identify itself.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 20009
 ppp callback request

!--- Request PPP callback from the server.

 ppp authentication chap

!--- Use CHAP authentication.

!
no ip http server
ip classless
ip route 172.22.80.0 255.255.255.0 172.22.82.1
!
dialer-list 1 protocol ip permit

!--- Interesting traffic definition.
!--- Apply this to BRI0 with dialer-group 1.

line con 0
 transport input none
 stopbits 1
line vty 0 4
!
end

maui-nas-04 : serveur de rappel
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-04
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin password <deleted>
username maui-soho-01 password happy

!--- Username for remote router (maui-soho-01) and shared secret password.
!--- Shared secret(for CHAP authentication) must be the same on both sides.

!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 10

!--- Assign BRI 1/1 to the rotary-group 10.
!--- Rotary-group properties are defined in interface Dialer 10.

 isdn switch-type basic-ni
 isdn spid1 20007
!
interface dialer10

!--- Interface for the dialer rotary-group 10 configuration.

 ip address 172.22.82.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer callback-secure 

!--- Disconnect calls that are not properly configured for callback.
!--- Disconnects any unconfigured dial-in users. 

dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009

!--- Dialer map statements for the callback.
!--- The name must match the name that the remote router uses to identify itself.
!--- Use map-class dialer dial1 for this connection.

 dialer-group 1
 ppp callback accept

!--- Allows the interface to accept a callback request to a remote host.

 ppp authentication chap
!
ip classless
ip route 172.22.85.0 255.255.255.0 172.22.82.2
no ip http server
!
map-class dialer dial1

!--- The dialer map statement uses this map class for the callback.

 dialer callback-server username

!--- Use authenticated username to identify return call dial string.

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line 65 70
line aux 0
line vty 0 4
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • nombre de type d'interface de show dialer — les informations générales de diagnostic d'affichages pour les interfaces que vous configurez pour le Routage à établissement de connexion à la demande (DDR). La source et les adresses de destination du paquet qui a initié la composition sont affichées dans la ligne raison d'appel. Cette commande affiche également les temporisateurs de connexion.

  • état de show isdn — s'assure que le routeur communique correctement avec le commutateur RNIS. Dans le résultat, vérifiez que l'état de la couche 1 soit ACTIVE, et que l'état de la couche 2 = MULTIPLE_FRAME_ESTABLISHED s'affiche. Cette commande affiche également le nombre d'appels actifs.

  • des secondes de dialer enable-timeout — active le délai d'attente du serveur de rappel, et détermine le temps entre le débranchement d'appel d'appel et l'initiation de rappel.

  • dialer hold-queue — permet au client de rappel et au serveur pour juger des paquets destinés à la destination distante jusqu'à ce que le rapport soit établi.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • debug ppp [paquet | négociation | erreur | authentification] — affiche des informations sur le trafic et échanges d'un interréseau qui implémente le PPP.

    • paquet — paquets PPP d'affichages étant envoyés et reçus. (Cette commande affiche des vidages mémoire de paquet à bas niveau.)

    • négociation — paquets PPP d'affichages transmis pendant le startup de PPP, où des options PPP sont négociées.

    • erreur — erreurs de protocole et statistiques sur les erreurs d'affichages associées avec la négociation et l'exécution de connexion PPP.

    • l'authentification — des messages du protocole d'authentification d'affichages, et inclut des échanges de paquet de protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) et des échanges de Password Authentication Protocol (PAP).

  • le debug isdn q931 — des expositions établissement d'appel et démolissent de la connexion réseau RNIS (couche 3).

  • debug isdn q921 — messages de la couche de liaison de transmission de données d'expositions (couche 2) sur le canal D entre le routeur et le commutateur RNIS. Utilisez cette commande de débogage si la commande d'état de show isdn n'affiche pas la couche 1 et la couche 2.

  • mettez au point le numéroteur [événements | paquets] — les informations de débogage de DDR d'affichages au sujet des paquets reçus sur une interface de numérotation.

Exemple de sortie de débogage


!--- maui-soho-01 (callback client:172.22.82.2) pings maui-nas-04. 
!--- (Callback server:172.22.80.4 - Ethernet interface).
!--- and starts the callback process.
!--- Debugs are collected on maui-soho-01.



maui-soho-01#debug dialer events 
maui-soho-01#show debugging 
Dial on demand: 
  Dial on demand events debugging is on
maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)    
   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007 
   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for
    server disconnect 
   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.    
   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created 
   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 
   Success rate is 0 percent (0/5) 

   
!--- A few seconds later, maui-soho-01 receives the callback from maui-nas-04. 

   
   maui-soho-01# 
   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated 
   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up 
   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007 
   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007 
   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
       changed state to up 
   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
       20007 maui-nas-04 
   
!--- Verifies that the connection was successful


maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 9575