Composition et accès : Connexions asynchrones

Accès commuté Multilink PPP asynchrone à partir de clients Microsoft Windows

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans cette configuration async de PPP à liaisons multiples, les utilisateurs distants de dialin avec Microsoft Windows 95/98 PC utilisent des plusieurs modems pour augmenter la vitesse d'accès disponible. Le PPP à liaisons multiples async peut également être configuré avec d'autres clients, tels que le Linux et l'Apple Macintosh, avec le logiciel approprié de PPP de client. La configuration du routeur pour le PPP à liaisons multiples est indépendant de la plate-forme de PC client.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Version de logiciel 12.07(T) courante de Ý de Cisco IOS de Cisco AS5300.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Théorie générale

Le PPP à liaisons multiples (MPPP) permet à des périphériques pour envoyer des données à la même destination au-dessus de plusieurs liaisons de données point par point en mettant en application une liaison virtuelle. La connexion MPPP a une bande passante maximum égale à la somme des bandes passantes des liens composants. MPPP peut être configuré pour les liens multiplexés, tels que le RNIS et le Relais de trames, ou pour des plusieurs lignes asynchrones.

Le PPP à liaisons multiples async peut être utilisé pour connecter des clients distants à une plus grande vitesse que cela disponible par une connexion analogique simple. Dans le MPPP asynchrone, le client distant utilise des plusieurs modems, et donc des plusieurs lignes de téléphone, au dialin au routeur central et accède au réseau. Puisque les plusieurs lignes de téléphone sont souvent meilleur marché que le service d'accès de base (BRI) RNIS, le MPPP asynchrone fournit une façon efficace d'augmenter la vitesse de connexion pour des utilisateurs distants tandis que le contrôle coûte. Le MPPP asynchrone est également une façon efficace d'obtenir des vitesses d'accès plus élevées pour les régions isolées qui ne peuvent pas être entretenues par le RNIS.

Le MPPP asynchrone empaquette ensemble des connexions de modem séparées à un serveur d'accès. Le logiciel de PPP sur chaque pair fragmente les paquets et transmet les parties à l'autre côté par les multiples connexions analogiques. L'extrémité réceptrice recueille les paquets des connexions distinctes et, basé sur les informations de PPP incluses dans elles, rassemble les parties dans les paquets de données valides, de ce fait fournissant à une liaison virtuelle de bout en bout la bande passante élevée. Le MPPP asynchrone peut être configuré entre deux Routeurs ou entre un routeur et un PC client.

Bien qu'il soit possible d'utiliser plus de deux Modems pour une connexion multiliaison d'un PC client, le temps système que les résultats de la fragmentation et du réassemblage des paquets sur le PC peuvent réaliser une inversion n'importe quelle bande passante supplémentaire gagnée.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/9553/async_multilink.gif

Configuration NAS

Dans cette configuration, un serveur AS5300 avec une connexion d'accès primaire (PRI) de t1 est utilisé comme serveur d'accès à distance analogique de dialin d'utilisateur (NAS). Puisqu'aucun des autres contrôleurs de t1 sur le ce NAS n'est configuré, ce serveur d'accès est utilisé exclusivement pour la connexion d'accès asynchrone. Cette configuration AS5300 utilise les modèles virtuels pour copier les interfaces d'accès virtuelles pour des appels d'arrivée. L'ensemble Multilink PPP réplique ses paramètres d'interface des définitions de modèle virtuelles.

Quelques commandes de base d'Authentification, autorisation et comptabilité (AAA) sont incluses comme exemples de méthodologie de pratique recommandée. Des noms d'utilisateur et les mots de passe pour des utilisateurs de dialin sont configurés sur le routeur. Les adresses IP assignées aux utilisateurs de dialin sont fournies d'un pool d'adresses.

Cisco AS5300
bobslake-nas-01#show running-config
Building configuration...

Current configuration:
!
! Last configuration change at 16:01:01 UTC Wed Jun 28 2000
! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000 
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- authenticate for PPP if not authenticated during login
!--- allows users with Terminal Window after Dial to initiate PPP!

username admin password <deleted> 
username charlie password <deleted> 
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
no ip source-route
ip domain-name the.net
!
multilink virtual-template 1

!--- use virtual-template 1 for multilink connections

async-bootp dns-server 172.22.53.210
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.21.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- summarizes addresses in address pool 
!--- Loopback 1 is in the same subnet as the address pool 

no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0  
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls
 
ppp authentication chap

!--- authenticate using Challenge Handshake Authentication Protocol (CHAP)

 ppp multilink
!

!--- configure D channel on PRI interface Serial0:23

 description Headquarters 324-1939 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1

!--- template to control all async interface configuration 

ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp

!--- use PPP encapsulation dialer in-band

 dialer-group 5
 async mode interactive
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls 

 no fair-queue
 no cdp enable
 ppp authentication chap callin

!--- CHAP authenticate for dialin users only 

 ppp multilink
 group-range 1 48

!--- assign modems 1-48 to the Group-Async 1 configuration template

 router eigrp 1
 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- define IP address pool range for dialin clients 

ip classless
no ip http server
!

access-list 105 permit ip any any
dialer-list 5 protocol ip list 105
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 autoselect during-login

!--- permits user login prompts after dialin 

 autoselect ppp

!--- automatically launch PPP on the line




 modem InOut

!--- modems can be used to dialin and dialout
!--- InOut may be replaced by Dialin 
!--- if NAS handles only incoming calls

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
 transport preferred none
 transport input telnet
 transport output telnet
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

bobslake-nas-01#

Configurer des clients de Windows 9x

La procédure suivante est une présentation rapide sur configurer vos clients de Windows 9x pour MPPP. Référez-vous au site Web de Microsoftleavingcisco.com si vous avez la difficulté.

Afin de configurer des clients de Microsoft Windows 9x pour MPPP, veillez-vous pour avoir l'appel la version 1.3 ou ultérieures de réseau installée.

Allez au pour en savoir plus de site Webleavingcisco.com de Microsoft et pour télécharger la dernière version de l'appel le réseau (DUN).

  1. Connectez et configurez chaque modem séparément.

    Du panneau de configuration de Windows, utilisez l'utilitaire « ajoutent nouveau matériel » pour ajouter les Modems au client. Si vous avez le problème ajoutant des Modems, contactez votre constructeur ou Microsoft PC pour des procédures de dépannage. Vérifiez que chaque modem est connecté correctement et est identifié par le système d'exploitation. Vous pouvez vouloir employer un terminal emulator pour vérifier que votre modem fonctionne correctement.

  2. Créez une nouvelle connexion d'accès par réseau commuté.

    Dans le double clic de Windows l'icône de « mon ordinateur » et naviguent vers le « accès réseau à distance. » Ensuite, le double clic « établissent le nouveau rapport. » Suivez les directions pour créer un appel la connexion utilisant le modem principal. Des caractéristiques de Multilien sont configurées plus tard. Testez la connexion en se connectant à votre fournisseur de services.

  3. Ajoutez les caractéristiques de multilink à votre connexion d'accès par réseau commuté.

    Double-cliquer l'icône de « mon ordinateur » et naviguez vers le « accès réseau à distance. » Cliquez avec le bouton droit l'icône de connexion qui a été juste installée. Du menu qui apparaît, sélectionnez « Properties. »

    Cliquez sur l'onglet de « Multilien », les « périphériques supplémentaires choisis d'utilisation, » et cliquez sur « ajoutent » le bouton. Sélectionnez un modem supplémentaire du menu déroulant et introduisez seulement le numéro de téléphone de sept chiffres du serveur d'accès, ou recevez le nombre affiché. N'incluez pas code postal en configurant le périphérique supplémentaire, même si c'est un appel longue distance. La connexion utilise automatiquement code postal configuré pour le premier modem. Cliquez sur « CORRECT » deux fois pour se terminer l'installation.

    Voici quelques captures d'écran pour une configuration de multilink de Windows :

    /image/gif/paws/9553/win95_mppp_1.gif

    win95_mppp_2.gif

  4. Initiez la connexion modem au serveur d'accès.

    Double-cliquer l'icône de connexion d'accès par réseau commuté qui a été juste créée. Écrivez le nom d'utilisateur et mot de passe configuré sur le routeur, puis cliquez sur « connectent » le bouton. L'appel le réseau composera le numéro configuré pour le modem principal spécifié pour la connexion. Quand la première connexion est établie, l'appel le réseau compose utilisant les Modems supplémentaires spécifiés dans la liste de périphériques supplémentaires.

    Quand toutes les connexions sont établies, vous pouvez ou visualiser les informations d'état au sujet du lien en double-cliquer sur l'icône « d'ordinateurs de communication » affichée dans la barre des tâches, ou vous pouvez déconnecter la connexion. Cliquez sur en fonction les « détails » pour vérifier que la connexion utilise de plusieurs périphériques. Quand vous sélectionnez un périphérique dans la liste déroulante, un interrompre ou un bouton reprise apparaît. Si un bouton d'interrompre apparaît, le périphérique est maintenant en service et « empaqueté » dans la connexion multiliaison. Cliquer sur sur « interrompent » les débranchements de bouton qui rayent et retirent la ligne des connexions empaquetées. Si le bouton de « reprise » apparaît, cliquez sur-le pour composer cette connexion et pour ajouter cette ligne au paquet. Vous pouvez dynamiquement interrompre et reprendre le multilink sans relâcher la connexion.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • show ppp multilink - Pour afficher les informations sur les ensembles multiliaisons qui sont en activité. Cette commande devrait être utilisée pour vérifier la connexion multiliaison.

  • show caller - Pour afficher les informations sur des utilisateurs individuels et les ressources consommées sur le NAS. Cette commande affiche des statistiques d'appel actif pour de grands groupes de connexions, et affiche l'absolu et les temps d'inactivité pour chaque utilisateur.

  • utilisateur de show caller - Pour afficher des paramètres pour l'utilisateur particulier tel que l'interface utilisée et asynchrone de ligne TTY (module/emplacement/port), le numéro de canal DS0, numéro de modem, adresse IP assignée, paramètres d'ensemble de PPP et de PPP, et ainsi de suite.

Pour aider à vérifier et à dépanner la connexion MPPP, référez-vous à ces suggestions :

  • Assurez-vous que des préfixes, tels qu'utiliser 9 avant de composer un fil extérieur, sont configurés correctement sur le PC client. Si ceci n'est pas configuré correctement, vous entendrez un signal d'occupation dès que les débuts de nombre pour composer.

  • Créez les clients BRUNS GRISÂTRE distincts pour chaque modem et les vérifiez que vous avez la connectivité complète à votre fournisseur de services. Utilisez chaque modem séparément avant de commencer avec dépanner votre connexion multiliaison.

  • Employez un terminal emulator pour se connecter au modem. Composez le nombre du NAS utilisant la commande d'atdt. Par exemple, dans le HyperTerminal écrivez l'atdt 55511111. Vérifiez que le modem compose correctement et se connecte au NAS. Si le modem ne se connecte pas, dépannez votre modem. Voyez l'utilisation de base à la documentation de commandesleavingcisco.com de modem sur le site Web de Microsoft pour plus d'informations sur des modems client de dépannage.

  • Si votre connexion principale se connecte correctement, mais la deuxième connexion d'accès par réseau commuté donne un signal d'occupation, vérifiez que le numéro de téléphone pour le modem supplémentaire est correctement configuré dans le DUN. Souvenez-vous, codes postaux ne devrait pas être ajouté à la configuration pour des périphériques supplémentaires. Référez-vous aux étapes de configuration dans la section configurante de clients de Windows 9x ci-dessus.

Exemple de résultat show and debug

Voici quelques exposition et sorties de débogage de l'AS5300. Les parties de met au point ont été retirées par souci de concision. Prêtez l'attention aux sections en gras et aux commentaires fournis dans les sorties.

Notez que l'appelant est connecté sur Async5 et Async6 jusqu'après l'authentification. Une adresse IP provisoire est fournie à l'appelant du pool d'adresses. L'appel est alors virtualisé ou attaché à un paquet virtuel existant. C'est parce que le serveur d'accès doit savoir qui l'appelant est pour déterminer si elles appartiennent à un paquet virtuel établi. Une fois que l'appelant est attaché au paquet, l'adresse IP provisoire est retirée et l'appelant utilise l'adresse IP du paquet virtuel.

bobslake-nas-01#
bobslake-nas-01#show ppp multilink 

Virtual-Access1, bundle name is charlie
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async5
    Async6


!--- Note that the bundle is using Async line 5 and 6 for multilink. 

bobslake-nas-01#show caller 
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        admin              Host connect  1w4d      16:50:19  
  tty 5        charlie             Async         00:04:34  00:01:54  
  tty 6        charlie             Async         00:02:00  00:00:57  
  vty 1        admin              VTY           00:13:43  00:00:00  
  As5          charlie             PPP           00:04:25  00:00:00  
  As6          charlie             PPP           00:01:53  00:00:00  
  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57  


!--- User charlie has two async lines, two tty, 
!--- and one virtual interface bundle.

bobslake-nas-01#show caller user charlie

  User: charlie, line tty 5, service Async

!--- shows hardware level settings for user charlie (first connection)

        Active time 00:04:43, Idle time 00:00:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 5, running PPP on As5

!--- user charlie is using tty 5

  DS0: (slot/unit/channel)=0/0/0  Line: Baud rate (TX/RX) is 115200/115200, 
no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line tty 6, service Async


!--- shows hardware level settings for user charlie (second connection)

        Active time 00:02:09, Idle time 00:01:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 6, running PPP on As6

!--- user charlie is using tty 6

  DS0: (slot/unit/channel)=0/0/1
  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line As5, service PPP

!--- PPP setting for user charlie (first connection).

        Active time 00:04:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async5
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 54 packets input, 4110 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          73 packets output, 4150 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

  User: charlie, line As6, service PPP

!--- PPP setting for user charlie (second connection).

        Active time 00:02:02, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is Open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async6
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 6 packets input, 462 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          20 packets output, 1129 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

    
User: charlie, line Vi1, service PPP Bundle


!--- Bundle information for user charlie

        Active time 00:04:34, Idle time 00:00:06
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, IPCP
  IP: Local 172.21.104.254, remote 172.21.104.2

!--- Remote IP address is obtained from IP pool.

  Counts: 50 packets input, 4034 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          80 packets output, 8750 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate
Virtual Template debugging is on
bobslake-nas-01#debug ppp multilink events 
Multilink events debugging is on
bobslake-nas-01#debug ppp negotiation 
PPP protocol negotiation debugging is on
bobslake-nas-01#debug ppp authentication 
PPP authentication debugging is on
bobslake-nas-01#debug ppp error 
PPP protocol errors debugging is on
bobslake-nas-01#debug modem
Modem control/process activation debugging is on
bobslake-nas-01#show debug
General OS:
  Modem control/process activation debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on

bobslake-nas-01#
Jun 28 15:41:46.281 UTC: TTY5: DSR came up
Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

!--- Modem responds to first dialin connection.

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate
Jun 28 15:41:48.537 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

!--- IP address for first link obtained from address pool.
!--- Route will be removed when link is virtualized later. 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin
Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open
Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

!--- LCP negotiation begins.

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46
...
Jun 28 15:41:51.549 UTC: Unthrottle 5
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7
...
Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47
Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size 
!--- that the peer will reconstruct.
!--- Both sides must agree on the packet size (MRRU).

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)
Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47
Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size that 
!--- the peer will reconstruct.

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)Jun 28 15:41:54.541 UTC: 
As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46
...
Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7
...
Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

!--- LCP negotiation is complete.

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

!--- CHAP authentication begins.

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful.

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending
Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

!--- Call is virtualized after authentication.

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046
Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup
Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

!--- Cloning from Virtual-Template.

interface Virtual-Access1
default ip address
no ip address
encap ppp
description Template for Multilink Users
ip unnumbered Loopback0
no ip directed-broadcast
no logging event link-status
no snmp trap link-status
peer default ip address pool addr-pool
ppp authentication chap
ppp multilink
ip unnum loop 1
end
Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line
Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37
...
Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP
Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

!--- First link in multilink bundle for user charlie is up.

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

!--- Temporary route to first link removed since link is virtualized.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40
...
Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

!--- IP address for virtual bundle obtained from address pool.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22
...
Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15
Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)
...
Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd
Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent
Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10
Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34
...
Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16
...
Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3
Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10
Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 
(0x0306AC156802)

!--- IP address of virtual bundle was previously obtained from 
!--- address pool.

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open
Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

!--- Add route for virtual bundle to routing table.

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired
Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

!--- Modem comes up for multilink connection.

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

!--- Async 6 is used for second connection.

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)
Jun 28 15:44:20.385 UTC: TTY6: EXEC creation
...
Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate
Jun 28 15:44:20.529 UTC: TTY6: EXEC creation
...Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

!--- IP address for second link is obtained from the pool.
!--- Route will be removed when link is added to the MPPP bundle.

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin
Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

!--- LCP negotiation begins.

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen
Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46
...
Jun 28 15:44:23.525 UTC: Unthrottle 6
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7
Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent
Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47
...
Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47
...
Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46
...
Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7
Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

!--- LCP negotiation is complete.
!--- CHAP authentication begins.

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end
Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful. 

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending
Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

!--- Link is virtualized.

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

!--- Multilink connection is up.

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

!--- Use IP address previously assigned to the bundle 
!--- (in this case, 172.21.104.2).

bobslake-nas-01#

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes Debug, référez-vous à Informations importantes sur les commandes Debug.

  • debug vtemplate - Les informations de clonage d'affichages pour une interface d'accès virtuelle du temps où elle est copiée d'un modèle virtuel au temps elle descend.

  • événements de multilink de debug ppp - Affiche des informations au sujet des événements affectant des ensembles multiliaisons.

  • debug ppp negotiation - Affiche des informations sur le trafic PPP et les échanges tandis que négociation de Link Control Protocol (LCP), authentification, et protocole de contrôle de réseau (NCP). Une négociation PPP réussie ouvre tout d'abord l'état LCP, puis procède à l'authentification, pour terminer par la négociation de NCP.

  • debug ppp authentication - Messages du protocole d'authentification de PPP d'affichages, y compris des échanges de paquet de protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) et des échanges de Password Authentication Protocol (PAP).

  • debug ppp error - Les erreurs de protocole et les statistiques sur les erreurs d'affichages ont associé avec la négociation et l'exécution de connexion PPP.

  • debug modem - Affiche l'activité de ligne du modem sur un serveur d'accès.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 9553