Commutation LAN : 802.1Q

Agrégation 802.1Q entre commutateurs Catalyst exécutant CatOS et le logiciel système Cisco IOS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit des configurations d'échantillon pour la jonction de 802.1Q d'IEEE entre les Commutateurs de Catalyst exécutant le logiciel système OS de Catalyst (CatOS) et les Commutateurs modulaires de la couche 3 (L3) exécutant le système Software.ÝSwitches de Cisco IOSÝ exécutant CatOS incluent le Catalyst 4500/4000, 5500/5000, et des Commutateurs de gamme 6500/6000. Les commutateurs modulaires L3 exécutant le logiciel Cisco IOS incluent les commutateurs des gammes Catalyst 4500/4000 et Catalyst 6500/6000. Les configurations d'échantillon utilisent un Catalyst 4000 (CatOS) et un Catalyst 6500 (logiciel de Cisco IOS), mais des Commutateurs l'uns des juste mentionnés pourraient avoir été utilisés pour réaliser les mêmes résultats.

L'agrégation est une manière de porter un trafic de plusieurs VLAN à travers un lien point à point entre deux périphériques. Deux manières que la jonction Ethernet peut être mise en application sont :

  • Liaison Inter-Switch Link le protocole (ISL) (protocole propriétaire de Cisco)

  • 802.1Q (norme ieee)

Conditions préalables

Conditions requises

Pour des configurations système requises, les instructions et les restrictions liées au 802.1Q et à l'ISL sur des Commutateurs de Catalyst, se rapportent : Configurations système requises d'implémenter la jonction.

Composants utilisés

Pour créer les exemples dans ce document, ces Commutateurs ont été utilisés :

  • Commutateur de Catalyst 4000 avec Supervisor Engine II (WS-X4013) exécutant la version de logiciel 8.1.3 de CatOS

  • Catalyst 6509 avec la version du logiciel Cisco IOS courante 12.1(20)E2 de la carte de fonction de commutateur de l'engine 2/Multilayer de superviseur 2 (MSFC2) sur l'engine de superviseur et le MSFC2

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Théorie générale

Ce document contient uniquement les fichiers de configuration des commutateurs et la sortie des exemples de commande show associés. Pour des détails sur la façon dont configurer un joncteur réseau de 802.1Q entre les Commutateurs de Catalyst, référez-vous aux page de support technique pour les réseaux locaux.

Dans la jonction de 802.1Q, tous les paquets VLAN sont étiquetés sur la liaison agrégée, excepté le VLAN indigène. Les paquets indigènes VLAN sont envoyés à non-marqué sur la liaison agrégée. Par conséquent, le VLAN indigène devrait être identique sur les deux Commutateurs configurés pour la jonction. De cette façon, vous pouvez déduire à quel VLAN une trame appartient quand vous recevez une trame sans la balise. Par défaut, le VLAN 1 est le VLAN indigène sur tous les Commutateurs.

  • Dans CatOS, le VLAN indigène peut être changé en émettant le modèle de VLAN-id de set vlan/commande de port, où le modèle/port est le port de joncteur réseau.

  • En logiciel de Cisco IOS, le VLAN indigène peut être changé en émettant la commande d'interface de VLAN-id de switchport trunk native vlan qui est configurée sur le port de joncteur réseau.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Les configurations dans ce document ont été mises en application dans un environnement de laboratoire isolé. Assurez-vous d'avoir pris connaissance de l'impact potentiel des configurations ou des commandes sur votre réseau avant de les utiliser. Les configurations sur tous les périphériques ont été effacées avec tous le clear config et des commandes de write erase de s'assurer qu'elles ont eu une configuration par défaut.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).leavingcisco.com

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/8760/67-a.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Des commentaires et les explications sont affichés en les italiques bleu.

Commutateur de Catalyst 4000
#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- In this example, the VLAN Trunk Protocol (VTP) domain name is the same
!--- on both sides. This is required for the autonegotiation of the trunk
!--- by the Dynamic Trunking Protocol (DTP).


set vtp mode client vlan

!--- In this example, the VTP mode is set to client.
!--- Set the VTP mode according to your network requirements.

!--- For more details, refer to
!--- Understanding and Configuring VLAN Trunk Protocol (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- This is the IP address used for management.

!--- Output suppressed.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- Ports 5/13-24 have been assigned to VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- The trunking mode is set to desirable mode, which means
!--- the port automatically tries to form a trunk with a
!--- neighboring port set to desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the Dynamic Trunking Protocol section of
!--- Best Practices for Catalyst 4500/4000, 5500/5000, and 6500/6000 
Series Switches Running CatOS Configuration and Management.

!--- Output suppressed.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- The macro command set port host 5/2-24 was used to do three things:
!--- disable trunking, disable port channeling, and enable spantree portfast.

!--- For details on using the set port host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.

!
#module 6 empty
end

Commutateur Catalyst 6500
Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- This is the privileged mode password used in the example.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- The switchport command must be entered once,  
!--- without any keywords, to configure the interface as a Layer 2 port.
!--- The interface is now automatically configured with the default command
!--- switchport mode dynamic desirable.

!--- This means the interface is ready to autonegotiate trunking
!--- encapsulation and form a trunk link (using DTP) with a neighbor port
!--- in desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the "Dynamic Trunking Protocol" section of
!--- Best Practices for Catalyst 6500/6000 Series and Catalyst 4500/4000 
Series Switches Running Cisco IOS Software.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- The interface range fastethernet mod/beginport - endport 
!--- command is used to configure interfaces 3/2 - 24 at once.

!--- Next, the switchport command is issued (if this has not been done already).


switchport mode access
 spanning-tree portfast

!--- Next, issue the macro command switchport host 3/2 - 24 to automatically
!--- configure these ports as access ports and to enable spantree portfast.

!--- For details on using the switchport host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- Interfaces 3/13 - 24 are placed in VLAN 2
!--- using the switchport access vlan 2 command.


 switchport mode access
 spanning-tree portfast


!--- Output suppressed.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- Output suppressed.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- This is the IP address used for management.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- This is the Telnet password used in the example.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Commandes show

Certaines commandes show sont prises en charge par l'outilleavingcisco.com d'Output Interpreter (clients enregistrés seulement), qui te permet pour visualiser une analyse de sortie de commande show.

Sur des Commutateurs de Catalyst exécutant CatOS, utilisez ces commandes :

  • module/port de show port capabilities

  • module/port de show port

  • module/port de show trunk

  • show vtp domain

Sur des Commutateurs du Catalyst 6000 exécutant le logiciel de Cisco IOS, utilisez les commandes suivantes :

  • affichez le module d'interface-type d'interfaces/joncteur réseau de port

  • show vlan

Exemple de sortie de la commande show

Commutateur de Catalyst 4000

La commande de module/port de show port capabilities est utilisée de vérifier si le port est capable de la jonction.

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

La commande de module/port de show port affiche l'état d'un port particulier et si c'est jonction.

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

La commande de show trunk est utilisée de vérifier l'état d'agrégation et la configuration.

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

La commande de show vtp domain est utilisée de vérifier les informations VTP.

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Commutateur Catalyst 6500

La commande de joncteur réseau de module/port d'interface-type d'interfaces d'exposition indique si le port est jonction.

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

La commande show vlan fournit des informations sur les VLAN et les ports qui appartiennent à un VLAN particulier.

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- Output suppressed.
    
cat6500#

Remarque: Seulement ces ports qui sont configurés pendant que des ports de nontrunk de la couche 2 sont affichés.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 8760