Commutation LAN : Liaison inter-commutateurs (ISL)

Configuration de l'agrégation ISL entre commutateurs Catalyst exécutant CatOS et le logiciel système Cisco IOS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit des configurations d'échantillon pour la jonction de Liaison inter-commutateurs (ISL) entre un commutateur Cisco Catalyst 5000 qui exécute le SYSTÈME D'EXPLOITATION de Catalyst (CatOS) et un commutateur de Catalyst 6500 qui exécute le logiciel système de Cisco IOSÝ. Vous pouvez utiliser l'un de ces commutateurs dans ce scénario pour obtenir les mêmes résultats :

  • N'importe quel Catalyst 4500/4000, 5500/5000, ou gamme 6500/6000 commutent que des passages CatOS

  • N'importe quelle gamme Catalyst 4500/4000 ou Catalyst 6500/6000 commute que logiciel système de Cisco IOS de passages

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur de Catalyst 5000 qui exécute le logiciel de CatOS 6.1(1)

  • Commutateur du Catalyst 6509 qui exécute le Logiciel Cisco IOS version 12.1(4)E1

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Pour des informations sur l'environnement de travaux pratiques, voyez la section de schéma de réseau de ce document. Assurez-vous que vous comprenez l'impact potentiel de n'importe quelle configuration ou commande sur votre réseau avant que vous l'utilisiez. Les configurations sur tous les périphériques ont été effacées avec tous le clear config et des commandes de write erase afin d'assurer une configuration par défaut.

Théorie générale

La jonction est une manière de porter le trafic de plusieurs VLAN au-dessus d'un lien point par point entre deux périphériques. Voici deux façons d'implémenter l'agrégation Ethernet :

  • ISL (un protocole propriétaire de Cisco)

  • 802.1Q d'IEEE (une norme ieee)

Ce document contient uniquement les fichiers de configuration des commutateurs et la sortie des exemples de commande show associés. Pour des détails sur la façon dont configurer un joncteur réseau ISL entre les Commutateurs de Catalyst, référez-vous à ces documents :

Remarques importantes

  • Les Commutateurs de gamme Catalyst 4500/4000 (qui incluent le Catalyst 2948G et Catalyst 2980G) cette jonction de 802.1Q de support de CatOS de passage seulement. Ces Commutateurs ne prennent en charge pas la jonction ISL.

  • Le Catalyst 4000 commute avec une engine II+ de superviseur ou un plus défunt logiciel de Cisco IOS de passage par défaut. Ces Commutateurs prennent en charge l'ISL et les modes de jonction de 802.1Q sur toutes les interfaces excepté sur bloquer des ports de gigabit sur les modules WS-X4418-GB et S-X4412-2GB-T. Dans des ces cas, les Commutateurs prennent en charge seulement la jonction de 802.1Q. Les ports 3 à 18 sont des ports Gigabit de blocage sur le module WS-X4418-GB. Les ports 1 à 12 sont des ports Gigabit de blocage sur le module WS-X4412-2GB-T. Le terme « port de blocage » signifie que la connexion de port au fond de panier est oversubscribed.

  • N'importe quel port Ethernet sur une gamme Catalyst 6500/6000 commutent le 802.1Q de supports et l'encapsulation ISL.

  • Basé sur le module, les ports d'agrégation de Catalyst 5000 prennent en charge l'encapsulation ISL seulement ou prennent en charge l'ISL et le 802.1Q. La meilleure manière de déterminer les types d'encapsulation pris en charge est d'utiliser la commande de show port capabilities. La sortie de commande énonce explicitement la capacité de jonction, comme indiqué dans cet exemple :

    cat5000> show port capabilities 3
    Model                    WS-X5225R
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q, ISL
    
    !--- This particular port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(none)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  no
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • Soyez sûr que les modes de jonction s'assortissent à travers la liaison agrégée. Si vous configurez un côté du lien comme joncteur réseau ISL, vous devez configurer l'autre côté du lien comme ISL. De même, si vous configurez un côté du lien comme 802.1Q, vous devez configurer l'autre côté du lien comme 802.1Q.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/8759/66a.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Ce document affiche des commentaires et des explications en les italiques bleu dans les configurations.

Commutateur de Catalyst 5000
#version 6.1(1)
!
set option fddi-user-pri enabled
set password $2$h/BN$i3S54iNvIXknFelh6gOve0
set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
!
#errordetection
set errordetection portcounter enable
!
#system
set system name  cat5000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- In the example, the VLAN Trunk Protocol (VTP) mode is set to be transparent.
!--- Use your network as a basis to set the VTP mode.

set vtp mode transparent

!--- For details on VTP, refer to Configuring VTP.


set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 2
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip

!--- This is the IP address that is used for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
 
!
#set boot command
set boot config-register 0x10f
set boot system flash bootflash:cat5000-sup3.6-1-1.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 empty
!
#module 3 : 9-port Gigabit Ethernet
!
#module 4 : 24-port 10/100BaseTX Ethernet
!
#module 5 : 24-port 10/100BaseTX Ethernet

!--- Ports 5/13–24 have been assigned to VLAN 2.

set vlan 2 5/13-24


!--- The ISL trunking mode is set to "on".
!--- Use your network and requirements as a basis to set the trunking mode.

set trunk 5/1 on isl 1-1005

!--- For details on different trunking modes, refer to 
!--- Configuring VLAN Trunks on Fast Ethernet and Gigabit Ethernet Ports.


!--- PortFast has been enabled on the ports that are connected to the workstations.

set spantree portfast 5/2-24 enable

!--- For details on why to enable PortFast, refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.

end

Commutateur Catalyst 6500
Current configuration : 4207 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6000
!
boot buffersize 126968
boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
no logging console

!--- The example uses the privileged mode password.

enable password mysecret
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
no ip domain-lookup
!
ip cef
cns event-service server
!
!
!
interface gigabitethernet1/1
 no ip address
 shutdown
!
interface gigabitethernet1/2
 no ip address
 shutdown
!
interface fastethernet9/1
 no ip address


!--- Issue the switchport command once, without any keywords, 
!--- in order to configure the interface as a Layer 2 (L2) port for the Catalyst 6500.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 6500).
!--- On a Catalyst 4000 switch that runs Cisco IOS Software, all ports are 
!--- L2 ports by default. If there is no change to the default configuration, 
!--- you do not need to issue the switchport command.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 4000).

 switchport

!--- Configure trunk encapsulation as ISL.

 switchport trunk encapsulation isl


!--- Enable trunking on the interface.

 switchport mode trunk
!

!--- Interfaces Fast Ethernet 9/2 through 9/24 are configured to be in access mode.
!--- For details, refer to the "Layer 2 Interface Modes" section of
!--- Configuring Layer 2 Ethernet Interfaces.

interface fastethernet9/2
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/11
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/12
 no ip address
 switchport
 switchport mode access
!

!--- Interfaces Fast Ethernet 9/13 through 9/24 are placed in VLAN 2.

interface fastethernet9/13
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/14
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/23
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/24
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/25
 no ip address
 shutdown
!

!--- Output suppressed.

!
interface fastethernet9/48
 no ip address
 shutdown
!
interface vlan1

!--- This is the IP address that is used for management.

 ip address 10.10.10.3 255.255.255.0
!
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4

!--- This example uses the Telnet password.

 password mysecret
login
!
end

Remarque: Si vous affectez une interface à un VLAN qui n'existe pas, l'interface s'arrête jusqu'à ce que vous créiez le VLAN dans la base de données VLAN. Pour plus d'informations, consultez la section Création ou modification d'un VLAN Ethernet dans Configuration de VLAN.

Vérifiez

Commandes show

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Commutateurs de Catalyst 5000 ou de Catalyst 6000 qui exécutent CatOS

  • module/port de show port capabilities — Utilisez cette commande de vérifier si le port est capable de la jonction.

    cat5000> (enable) show port capabilities 5/1
    Model                    WS-X5234
    Port                     5/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  5/1-2,5/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • module/port de show port — Cette commande montre l'état d'un port particulier et si c'est jonction.

    cat5000> (enable) show port 5/1
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     5/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     5/1  disabled  shutdown             0        0        1 disabled      66
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     5/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • module/port de show trunk — Utilisez cette commande de vérifier l'état d'agrégation et la configuration.

    cat5000> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     5/1      on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     5/1      1-1005
     
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     5/1      1-2
     
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     5/1      1-2
    
  • show vtp domain — Utilisez cette commande de vérifier les informations VTP.

    cat5000> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.2      disabled disabled 2-1000

Commutateurs du Catalyst 6500/6000 ou Commutateurs du Catalyst 4500/4000 qui exécutent le logiciel de Cisco IOS

  • affichez le module d'interface_type d'interfaces/joncteur réseau de port — cette commande t'indique si le port est jonction.

    cat6000#show interfaces fastethernet 9/1 trunk
     
    Port      Mode         Encapsulation  Status        Native vlan
    Fa9/1     on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    Fa9/1     1-1005
     
    Port      Vlans allowed and active in management domain
    Fa9/1     1-2,1002-1005
     
    Port      Vlans in spanning tree forwarding state and not pruned
    Fa9/1     1-2,1002-1005
  • VLAN d'exposition — Cette commande fournit des informations au sujet des VLAN et les ports qui appartiennent à un VLAN particulier.

    cat6000#show vlan
     
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                    Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                    Fa9/10, Fa9/11, Fa9/12
    2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                    Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                    Fa9/21, Fa9/22, Fa9/23, Fa9/24
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    !--- Output suppressed.
    
    

Remarque: Seulement ces ports qui sont configurés pendant que des ports du nontrunk L2 sont affichés. Pour des détails, référez-vous aux interfaces Ethernet configurantes pour la section de commutation de la couche 2 de configurer des interfaces Ethernet de la couche 2.

Dépannez

Utilisez cette section pour dépanner votre configuration.

Le commutateur ne reçoit pas une modification de VLAN indigène sur un port de joncteur réseau puisque le port est un port Non-802.1Q

Cette question se produit parce que le port de joncteur réseau ne prend en charge pas l'encapsulation de 802.1Q. Un VLAN indigène exige le support de 802.1Q sur un port. Si le port n'a pas le support de 802.1Q, le commutateur ne permet pas une modification du VLAN indigène.

le soutien de 802.1Q de la jonction est un facteur matériel-dépendant. Émettez le show port capabilities commandent afin de vérifier le support de 802.1Q. L'option d'encapsulation dans la sortie des états de commande de show port capabilities le soutien de 802.1Q de la jonction.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 8759