IP : Protocole EIGPR (Enhanced Interior Gateway Routing Protocol)

Redistribution des protocoles de routage

6 septembre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (12 août 2014) | Commentaires


Contenu

RIP

Introduction

L'utilisation d'un protocole de routage d'annoncer les artères qui sont apprises par quelques autres moyens, comme par un autre protocole de routage, des artères de charge statique, ou directement des routes connectées, s'appelle la redistribution. Tandis que l'exécution d'un seul protocole de routage dans toute votre interconnexion de réseaux IP est séduisante, le routage multiprotocole est commun pour un certain nombre de raisons, telles que des fusions de société, des services différents contrôlés par plusieurs administrateurs réseau, et des environnements pluri-constructeurs. Exécuter les différents protocoles de routage est souvent une partie de la conception d'un réseau. Dans tous les cas, avoir un environnement à plusieurs protocoles fait de la redistribution une nécessité.

Les différences dans les caractéristiques du protocole de routage, telles que les métriques, la distance administrative, les capacités par classe et sans classe peuvent effectuer la redistribution. L'attention doit être accordée à ces différences pour que la redistribution soit un succès.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco IOS® Version du logiciel 12.2(10b)

  • Routeurs de la gamme Cisco 2500

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Mesures

Quand vous redistribuez un protocole dans un autre, rappelez-vous que les métriques de chacun jouent un rôle important dans la redistribution. Chaque protocole utilise des métriques différentes. Par exemple, la métrique du Protocole d'informations de routage (RIP) est basée sur le nombre de sauts, mais l'Interior Gateway Routing Protocol (IGRP) et l'Enhanced interior gateway routing protocol (EIGRP) utilisent une métrique composite basée sur la bande passante, le délai, la fiabilité, la charge, et l'unité maximale de transmission (MTU), où la bande passante et le délai sont les seuls paramètres utilisés par défaut. Quand des routes sont redistribuées, vous devez définir une métrique qui est compréhensible pour le protocole recevant. Il y a deux méthodes pour définir la métrique en redistribuant des routes.

/image/gif/paws/8606/redist-a.gif

Vous pouvez définir la métrique pour cette redistribution spécifique seulement :

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

Ou vous pouvez utiliser la même métrique comme métrique par défaut pour toutes les redistributions (l'utilisation de la commande default-metric nécessite moins de travail car elle élimine le besoin de définir la métrique séparément pour chacune redistribution) :

router rip
redistribute static
redistribute ospf 1
default-metric 1

Distance administrative

Si un routeur fait fonctionner plus d'un protocole de routage et apprend une route vers la même destination en utilisant les deux protocoles de routage, alors quelle route doit être sélectionnée comme meilleure route ? Chaque protocole utilise son propre type métrique pour déterminer la meilleure route. Comparer des routes ayant différents types de métriques est impossible. Les distances administratives se chargent de ce problème. Des distances administratives sont assignées aux sources de route de sorte que la route de la source préférée sera choisie en tant que meilleur chemin. Référez-vous à Sélection de route sur les routeurs Cisco pour plus d'informations sur des distances administratives et la sélection de route.

Les distances administratives aident à la sélection de la route parmi différents protocoles de routage, mais elles peuvent poser des problèmes pour la redistribution. Ces problèmes peuvent être sous forme de boucles de routage, de problèmes de convergence, ou de routage inefficace. Voir ci-dessous pour une topologie et une description d'un problème éventuel.

/image/gif/paws/8606/redist-b.gif

Dans la topologie ci-dessus, si R1 exécute RIP, et R2 et R5 exécutent RIP et IGRP et redistribuent RIP vers IGRP, alors il y a un problème potentiel. Par exemple, R2 et R5 se renseignent tous les deux sur le réseau 192.168.1.0 à partir de R1 qui utilise RIP. Ces connaissances sont redistribuées dans IGRP. R2 se renseigne sur le réseau 192.168.1.0 par R3, et R5 se renseigne sur lui par R4 en utilisant IGRP. IGRP a une distance administrative inférieure à celle de RIP (100 contre 120) ; donc, la route IGRP est utilisée dans la table de routage. Il y a maintenant une boucle de routage potentielle. Même si le découpage d'horizon, ou n'importe quelle autre caractéristique censée aider à empêcher les boucles de routage entre en jeu, il y a toujours un problème de convergence.

Si R2 et R5 redistribuent également IGRP dans RIP (connu sous le nom de redistribution mutuelle) et le réseau, 192.168.1.0, n'est pas directement connecté à R1 (R1 apprend des autres routeur en amont), alors il y a le problème potentiel que R1 apprenne le réseau à partir de R2 ou de R5 avec une meilleure métrique que la source d'origine.

Remarque: Les mécanismes de la redistribution de routes sont propriétaires sur les routeurs Cisco. Les règles pour la redistribution sur un routeur Cisco imposent que la route redistribuée soit présente dans la table de routage. Il ne suffit pas que la route soit présente dans la topologie de routage ou dans la base de données. Des routes avec une distance administrative inférieure (AD) sont toujours installées dans la table de routage. Par exemple, si une route statique est redistribuée dans IGRP sur R5, et IGRP ultérieurement redistribué dans RIP sur le même routeur (R5), la route statique n'est pas redistribuée dans RIP parce qu'elle n'a jamais été entrée dans la table de routage IGRP. Ceci est dû au fait que les routes statiques ont une AD de 1 et que les routes IGRP ont une AD de 100 et la route statique est installée dans la table de routage. Pour redistribuer la route statique dans IGRP sur R5, vous devez utiliser la commande redistribute static sous la commande router rip.

Le comportement par défaut pour RIP, IGRP et EIGRP est d'annoncer les routes connectées directement lorsqu'une instruction réseau sous le protocole de routage inclut le sous-réseau de l'interface connectée. Il existe deux méthodes pour obtenir une route connectée :

  • Une interface est configurée avec une adresse et un masque IP, ce sous-réseau correspondant est considéré comme une route connectée.

  • Une route statique est configurée avec seulement une interface de sortie, et non une IP par sauts successifs, elle est également considérée comme une route connectée.

Router#conf t
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end

   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Une commande réseau configurée sous EIGRP, RIP ou IGRP qui inclut (ou « couvre ») l'un ou l'autre de ces types de routes connectées inclut ce sous-réseau pour annonce.

Par exemple, si une interface a l'adresse 10.0.23.1 et le masque 255.255.255.0, le sous-réseau 10.0.23.0/24 est une route connectée et sera annoncée par ces protocoles de routage quand une instruction réseau est configurée comme suit :

router rip | igrp # | eigrp #
   network 10.0.0.0

Cette route statique, 10.0.77.0/24, est également annoncée par ces protocoles de routage, parce qu'elle est une route connectée route et est « couverte » par l'instruction réseau.

Consultez la section Éviter les problèmes causés par la redistribution de ce document pour des astuces sur la façon d'éviter ce problème.

Syntaxe et exemples de la configuration de redistribution

IGRP et EIGRP

Cette sortie montre un routeur IGRP/EIGRP redistribuant des routes statiques, Open Shortest Path First (OSPF), RIP, et IS-IS (Intermediate System-to-Intermediate System).

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

IGRP et EIGRP ont besoin de cinq métriques pour redistribuer d'autres protocoles : bande passante, délai, fiabilité, charge, et MTU, respectivement. Voici un exemple de métriques IGRP :

Mesure Valeur
bande passante En unités de kilobits par seconde ; 10 000 pour Ethernet
retard En dizaine d'unités de micro-secondes ; pour Ethernets c'est 100 x 10 micro-secondes = 1 ms
fiabilité 255 pour une fiabilité de 100 pourcents
chargement Charge réelle sur le lien exprimée avec un nombre de 0 à 255 (255 correspondant à une charge de 100 pourcents)
MTU MTU minimum du chemin ; habituellement égale à celle de l'interface Ethernet, qui est de 1 500 octets

Plusieurs processus IGRP et EIGRP peuvent s'exécuter sur le même routeur, avec redistribution entre eux. Par exemple, IGRP1 et IGRP2 peuvent s'exécuter sur le même routeur. Cependant, l'exécution de deux processus du même protocole sur le même routeur est rarement nécessaire, et peut consommer la mémoire et le CPU du routeur.

La redistribution d'IGRP/EIGRP dans un autre processus IGRP/EIGRP n'exige aucune conversion de métrique. Il n'y a donc aucun besoin de définir des métriques ou d'utiliser la commande default-metric pendant la redistribution.

Une route statique redistribuée a la priorité par rapport à la route récapitulative car la route statique a une distance administrative de 1 tandis que la route récapitulative Eigrp a une distance administrative de 5. Ceci se produit quand un itinéraire statique est redistribué avec l'utilisation de redistribute static dans le processus d'Eigrp et le processus d'Eigrp a une route par défaut.

OSPF

Cette sortie montre un routeur OSPF redistribuant des routes statiques, RIP, IGRP, EIGRP et IS-IS.

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

La mesure OSPF est une valeur de coût basée sur la bande passante 108 du lien dans le bits/seconde. Par exemple, le coût OSPF d'Ethernet est 10 : 108/107 = 10

Remarque: Si une métrique n'est pas spécifiée, OSPF attribue une valeur par défaut de 20 en redistribuant les routes à partir de tous les protocoles sauf les routes de Border Gateway Protocol (BGP), qui obtiennent une métrique de 1.

Quand il y a un réseau principal qui est en sous-réseau, vous devez utiliser le sous-réseau du mot clé pour redistribuer les protocoles vers OSPF. Sans ce mot clé, OSPF redistribue seulement les réseaux principaux qui ne sont pas en sous-réseau.

Il est possible d'exécuter plus d'un processus OSPF sur le même routeur. Cependant, l'exécution de plus d'un processus du même protocole est rarement nécessaire et consomme la mémoire et le CPU du routeur.

Vous n'avez pas besoin de définir une métrique ou d'utiliser la commande default-metric en redistribuant un processus OSPF dans un autre.

RIP

Remarque: Les principes dans ce document s'appliquent aux versions RIP I et II.

Cette sortie montre un routeur RIP redistribuant des routes statiques, IGRP, EIGRP, OSPF et IS-IS.

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

La métrique RIP se compose du nombre de sauts, et la métrique maximale valide est 15. Toute valeur supérieure à 15 est considérée comme infinie ; vous pouvez utiliser 16 pour décrire une métrique infinie dans le RIP. En redistribuant un protocole dans RIP, Cisco recommande que vous utilisiez une métrique peu élevée, telle que 1. Une métrique élevée, telle que 10, limitent davantage le RIP. Si vous définissez une métrique de 10 pour des routes redistribuées, ces routes peuvent seulement être annoncées aux routeurs jusqu'à 5 sauts plus loin, auquel point la métrique (nombre de sauts) dépasse 15. En définissant une métrique de 1, vous permettez à une route de voyager le nombre maximal de sauts dans un domaine RIP. Mais faire ceci augmente la possibilité de boucles de routage s'il y a plusieurs points de redistribution et si un routeur se renseigne sur le réseau avec une métrique provenant du point de redistribution, meilleure qu'une métrique provenant de la source originale, comme expliqué dans la section Distance administrative de ce document. Par conséquent, vous devez vous assurer que la métrique n'est ni trop élevée, ce qui l'empêche d'être annoncée à tous les routeurs, ou trop faible, ce qui peut provoquer des boucles de routage quand il y a plusieurs points de redistribution.

Redistribuer des artères de charge statique excepté la passerelle du dernier recours dans le RIP utilisant le mappage de route

Cette configuration est un exemple de redistribuer les artères statiques excepté la passerelle de la dernière station de vacances de passerelle dans le RIP par le routemap.

Configuration initiale pour cet exemple :

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

Terminez-vous ces étapes afin de configurer ceci :

  1. Créez une liste d'accès afin d'apparier tous les réseaux qui doit être redistribuée

    Router#show access-lists 10
    
    Standard IP access list 10
    
        10 permit 10.32.42.211
    
        20 permit 10.98.0.0, wildcard bits 0.0.0.255
    
        30 permit 10.99.0.0, wildcard bits 0.0.0.255
    
        40 permit 67.129.103.128, wildcard bits 0.0.0.15
    
        50 permit 156.55.231.0, wildcard bits 0.0.0.255
    
        60 permit 172.16.28.0, wildcard bits 0.0.3.255
    
        70 permit 192.168.248.0, wildcard bits 0.0.0.255
    
        80 permit 199.43.0.0, wildcard bits 0.0.0.255
    
        90 permit 204.103.0.0, wildcard bits 0.0.0.255
  2. Appelez cette liste d'accès dans un route-map.

    Route-map TEST
    
     Match ip address 10
  3. Redistribuez dans le RIP utilisant le route-map à et enlevez les informations par défaut lancent la commande du processus de déchirure.

    Router RIP
    
    version 2
    
    network 10.0.0.0
    
    redistribute static route-map TEST
    
    no auto-summary

IS-IS

Cette sortie montre un routeur IS-IS redistribuant des routes statiques, RIP, IGRP, EIGRP et OSPF.

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

La métrique IS-IS doit se situer entre 1 et 63. Il n'y a aucune option de métrique par défaut - Vous devez définir une métrique pour chaque protocole, comme dans l'exemple ci-dessus. Si aucune métrique n'est spécifiée pour les routes étant redistribuées dans l'IS-IS, une valeur métrique de 0 est utilisée par défaut.

Routes connectées

Redistribuer les réseaux directement connectés dans des protocoles de routage n'est pas une pratique courante et n'est pas montrée dans les exemples ci-dessus pour cette raison. Cependant, il est important de noter que cela peut être fait, directement et indirectement. Pour redistribuer directement les route connectées, utilisez la commande de configuration du routeur redistribute connected. Vous devriez également définir une métrique dans ce cas. Vous pouvez également redistribuer indirectement des routes connectées dans des protocoles de routage comme dans cet exemple.

/image/gif/paws/8606/redist-cnctd.gif

Dans cet exemple, le routeur B a deux interfaces Fast Ethernet. FastEthernet 0/0 est dans le réseau 10.1.1.0/24 et FastEthernet 0/1 est dans le réseau 20.1.1.0/24. Le routeur B exécute l'EIGRP avec le routeur A, et l'OSPF avec le routeur C. Router B redistribue mutuellement entre les processus EIGRP et OSPF. Voici les informations de configuration pertinentes pour le routeur B :

routeur B
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Si vous regardez la table de routage pour le routeur B, vous voyez ce qui suit :

routerB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

Trois choses sont à noter dans la configuration et la table de routage ci-dessus :

  • Les réseaux en question sont dans la table de routage du routeur B en tant que réseaux connectés directement.

  • Le réseau 10.1.1.0/24 fait partie du processus EIGRP et le réseau 20.1.1.0/24 fait partie du processus OSPF.

  • Le routeur B redistribue mutuellement entre EIGRP et OSPF.

Ci-dessous sont présentes les tables de routage pour les routeurs A et C.

routerA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

Le routeur A a appris du réseau 20.1.1.0/24 par l'intermédiaire d'EIGRP, qui est montré comme route externe, parce qu'il a été redistribué d'OSPF à EIGRP. Le routeur C a appris du réseau 10.1.1.0/24 par l'intermédiaire d'OSPF comme route externe, parce qu'il a été redistribué d'EIGRP à OSPF. Bien que le routeur B ne redistribue pas de réseaux connectés, il annonce le réseau 10.1.1.0/24, qui fait partie du processus EIGRP redistribué dans OSPF. De même, le routeur B annonce le réseau 20.1.1.0/24, qui fait partie du processus OSPF redistribué dans EIGRP.

Référez-vous à Redistribution de réseaux connectés dans OSPF pour plus d'informations concernant les routes connectées étant redistribuées dans OSPF.

Remarque: Par défaut, seules les informations apprises par EBGP peuvent être redistribuées dans IGP quand la commande redistibute bgp est lancée. Les routes IBGP ne sont pas redistribuées dans l'IGP avant que la commande bgp redistribute-internal soit configurée sous la commande router bgp. Mais des précautions doivent être prises pour éviter des boucles dans le Système autonome lorsque des routes IBGP sont redistribuées dans IGP.

Éviter les problèmes causés par la redistribution

Dans la section consacrée à la distance administrative vous avez vu comment la redistribution peut potentiellement poser des problèmes tels qu'un routage non optimal, des boucles de routage, ou une convergence lente. La prévention de ces types de problèmes est vraiment tout à fait simple — n'annoncez jamais les informations initialement reçues du processus de routage X de nouveau dans le processus de routage X.

Exemple 1

/image/gif/paws/8606/redist-b.gif

Dans la topologie précédente, R2 et R5 font la redistribution mutuelle. Le RIP est redistribué dans l'IGRP et l'IGRP redistribue dans le RIP, car cette configuration affiche.

R2 :

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5 :

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

Avec la configuration précédente vous avez le potentiel pour le tout les les problèmes précédemment décrits. Afin de les éviter, vous pouvez filtrer des mises à jour de routage comme suit :

R2 :

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5 :

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

Les listes de distribution ont ajouté aux configurations, comme affiché ci-dessus, filtrez toutes les mises à jour IGRP qui entrent dans l'interface de l'interface série 1 des Routeurs. Si les routes dans les mises à niveau sont permises par la liste d'accès 1, le routeur les accepte dans la mise à niveau ; autrement il ne le fait pas. Dans cet exemple, les routeurs ont l'instruction de ne pas apprendre du réseau 192.168.1.0 via les mises à niveau IGRP qu'ils reçoivent sur leur interface série 1. Par conséquent, la seule connaissance que ces routeurs ont du réseau 192.168.1.0 se fait par RIP via R1.

Gardez également à l'esprit que dans ce cas, il n'est pas nécessaire d'utiliser la même stratégie de filtrage pour le processus RIP parce que le RIP a une distance administrative plus élevée qu'IGRP. Si des routes qui proviennent du domaine IGRP étaient alimentées à nouveau vers R2 et R5 par RIP, les routes IGRP auraient toujours la priorité.

Exemple 2

/image/gif/paws/8606/redist-c.gif

Utilisant la topologie comme ci-dessus, une autre méthode, qui est parfois plus préférable, pour éviter des problèmes de redistribution peut être expliquée. Cette méthode utilise des route-map pour placer des étiquettes pour diverses routes. Les processus de routage peuvent alors redistribuer en se basant sur les étiquettes. Notez que la redistribution basée sur des étiquettes ne fonctionne pas avec la version 1 de RIP ou avec IGRP.

Un des problèmes que vous pouvez exécuter dans dans la topologie précédente est comme suit :

R1 annonce le réseau 192.168.1.0 à R2. R2 redistribue alors à EIGRP. R5 apprend le réseau via EIGRP et le redistribue à RIPv2. Selon la métrique que R5 place pour la route RIPv2, R6 pourrait préférer la route la moins souhaitable par R5 au lieu de par R1 pour atteindre le réseau. La configuration suivante aide à empêcher ceci en plaçant des étiquettes et puis en les redistribuant basées sur les étiquettes.

R2 :

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIP routes that are
 

!--- permitted by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and set the tags
 

!--- according to the eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag of "88"


!--- from being redistributed into EIGRP
  

!--- Notice the routes tagged with "88" should be the EIGRP
 

!--- routes that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag 


!--- on RIPv2 routes redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a
 

!--- tag of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2
 

!--- routes that are redistributed into EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP
 

!--- routes redistributed into RIPv2 to "88"

R5 :

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIPv2 routes that are permitted 


!--- by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and sets the tags 


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag
 

!--- of "88" from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP routes
 

!--- that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag on rip routes 


!--- redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a tag 


!--- of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2 routes
 

!--- that are redistributed into EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP routes 


!--- redistributed into RIPv2 to "88"

Avec la configuration ci-dessus exécutée, vous pouvez regarder quelques routes spécifiques dans la table de routage pour voir que les étiquettes ont été établies. Ci-dessous s'affiche la sortie de la commande show ip route pour des routes spécifiques sur R3 et R1 :

R3#show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1#show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

EIGRP emploie cinq variables différentes pour calculer la métrique. Cependant, les routes redistribuées n'ont pas ces paramètres, qui fait que ces routes ne sont pas établies uniformément. La meilleure méthode est de paramétrer une métrique par défaut en redistribuant des routes. En paramétrant la métrique par défaut, les performances d'EIGRP peuvent être améliorées. Pour EIGRP, les valeurs par défaut sont entrées avec cette commande :

Router(config-router)#default-metric 10000 100 255 100 1500

Exemple 3

La redistribution peut également avoir lieu parmi différents processus du même protocole de routage. La configuration suivante est un exemple d'une stratégie de redistribution utilisée pour redistribuer deux processus EIGRP fonctionnant sur le même routeur ou sur plusieurs routeurs :

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 5 into EIGRP 3, setting the tags 


!--- according to the route map "to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 3 into EIGRP 5


!--- Routes with tag 33 will not be redistributed
 

!--- due to route map "to_eigrp_5"
!--- Though the default-metric command is not required
!--- when redistributing between different EIGRP processes,
!--- you can use it optionally as shown above to advertise 
!--- the routes with specific values for calculating the metric.


route-map to_eigrp_3 deny 10
match tag 55

!--- Route-map statement used to deny any routes that have a tag
 

!--- of "55" from being redistributed into EIGRP 3


!--- Notice the routes tagged with "55" should be the EIGRP 3 routes
 

!--- that are redistributed into EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 5 to EIGRP 3 to "33"


route-map to_eigrp_5 deny 10
 match tag 33

!--- Route-map statement used to deny any routes that have a tag 


!--- of "33" from being redistributed into EIGRP 5


!--- Notice the routes tagged with "33" should be the EIGRP 5 routes
 

!--- that are redistributed into EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 3 to EIGRP 5 to "55"

Ce sont juste quelques exemples de stratégies de filtrage utilisées pour ce document. Cependant, il peut y avoir d'autres stratégies valides que vous pouvez utiliser. Référez-vous à la section sur les Informations de filtrage de routage dans Configuration de protocole de routage IP - Fonctionnalités indépendantes pour plus d'informations.

Exemple 4

Par exemple, vous avez deux routeurs, un est un routeur haut de gamme exécutant le protocole BGP, et l'autre est un routeur bas de gamme exécutant le protocole RIP. Quand vous redistribuez des routes BGP dans RIP, il est possible que vous voyiez des paquets se perdre.

La redistribution de BGP dans le protocole RIP n'est généralement pas recommandée et les protocoles comme iBGP, OSPF, et EIGRP sont évolutifs et ont une fourchette plus large d'options disponibles.

Au cas où vous rencontreriez ce scénario, qui est la redistribution entre BGP et RIP, et perdriez certains paquets, il est possible que vous deviez configurer cette commande dans le processus RIP :

Déchirure de Router(Config)#router

Router(Config-router)# input-queue 1024

Remarque: Considérez l'utilisation de la commande input-queue si vous avez un routeur haut de gamme qui envoie à grande vitesse à un routeur lent qui ne peut pas recevoir à grande vitesse. La configuration de cette commande aide à empêcher la perte d'informations à partir de la table de routage.

Exemple 5

/image/gif/paws/8606/redist-d.gif

Cet exemple montre redistribuer l'artère statique dans le protocole de routage de RIP. Selon la topologie, nous avons trois Routeurs (R1, R2, et R3). R1 et R2 ont le RIP configuré sur l'interface Fast Ethernet 0/0. R1 a une artère statique pour atteindre le Lo 0 interfaces (IP address 3.3.3.3/32) de routeur R3. Cette artère statique est redistribuée dans le protocole de routage de RIP. Le routeur R3 est configuré avec une artère 0.0.0.0 0.0.0.0 FastEthernet 0/0 d'IP du default route R3#.

R1(config)# ip route 3.3.3.3 255.255.255.255 10.13.13.3
R1(config)# router rip
R1(config-router) redistribute static metric 10

Sur le routeur R2, l'artère 3.3.3.3 peut être vue par l'intermédiaire de la commande de show ip route :

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0

Comment redistribuer une seule route statique

Afin de redistribuer une seule route statique, utilisez route-map pour sélectionner la route statique qui doit être redistribuée.

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10
Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <mask> metric <value>

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 8606