Routeurs : Routeurs de la gamme Cisco 800

Configuration du routeur Cisco 827 en tant que client PPPoE avec NAT

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans la version de logiciel 12.1(3)XG de ½ du ¿  de Cisco IOSïÂ, un PPP au-dessus de fonctionnalité client d'Ethernets (PPPoE) a été introduit pour le routeur de Cisco 827. Cette caractéristique permet la fonctionnalité de PPPoE à déplacer au routeur. Des PC de multiple peuvent être installés derrière le Cisco 827. Avant que leur trafic soit envoyé à la session de PPPoE, il peut être chiffré, filtré, et ainsi de suite. En outre, le Traduction d'adresses de réseau (NAT) peut fonctionner.

Ce document affiche un PPPoE Client configuré sur l'interface ATM (l'interface DSL) du routeur de Cisco 827. Cette configuration peut également être utilisée sur un routeur de Cisco 1700 avec une carte d'interface WAN de Ligne d'abonné numérique à débit asymétrique (ADSL) (WIC).

La configuration sur le processeur d'artère de noeud de Cisco 6400 (NRP) peut également être utilisée sur un autre routeur utilisé en tant qu'agrégateur et avec une interface ATM.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir plus d'informations sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés uniquement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/8514/827pppoe_client.gif

Configurations

Ce document utilise les configurations suivantes :

Le PPPoE est configuré sur le routeur de Cisco 827 avec les commandes privées virtuelles du réseau commuté (VPDN). Veillez-vous pour configurer ces commandes d'abord.

Remarque: Pour des informations sur la façon changer la taille du Maximum Transmission Unit (MTU), référez-vous à la taille de MTU de dépannage dans la Connectivité de Dialin de PPPoE.

Routeur de Cisco 827
! 
vpdn enable 
no vpdn logging

!--- This is the default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- This is the PPPoE client that requests to establish a session  
 !--- with the aggregation unit (6400 NRP). 
 
  protocol pppoe 
! 


!--- This is the Internal Ethernet network.
 
! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- The DSL interface.
 
! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 
!--- All defaults.

  


!--- PPPoE runs on top of AAL5SNAP. However, the 
!--- encap aal5snap command is not used.
  
! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that must be changed 
  !--- in order to match the value used by the ISP. 

 ! 



!--- The PPPoE client code ties into a dialer interface upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default -- 1492 + PPPoE headers = 1500

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.
  
 ppp authentication chap callin 
 ppp chap hostname <username> 
 ppp chap password <password> 
! 

!--- Note: The ISP  instructs you  about the 
!--- type of authentication to use. 
!--- In order to change from PPP CHAP to PPP PAP, replace
!--- ppp authentication chap callin 
!--- ppp chap hostname <username> 
!--- ppp chap password <password>   
!--- with ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>




!--- For NAT, overload on the Dialer1 interface 
!--- and add a default route out since dialer IP address can change. 
  
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400 NRP
*** local ppp user 

!--- Or,  use AAA.


username <username> password <password>



!--- Begin with the VPDN commands. 
!--- Notice that the PPPoE is bound here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE that begins  
!--- with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode.
 
  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.
  
! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- Needs the command on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface.
 
! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes debug, reportez-vous aux Informations importantes sur les commandes de débogage.

Débuggez le PPPoE Client

Afin de mettre au point le PPPoE Client sur le routeur ou le Cisco 6400 NRP de Cisco 827, vous devez considérer la pile de protocoles. Vous pouvez commencer à dépanner au bas.

1. Couche physique DSL

Assurez-vous que la ligne est en hausse et exercée.

show interface atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:    Showtime (DMTDSL_SHOWTIME) 

2. Couche atmosphère

Si l'interface ATM est en hausse, utilisez les paquets atmosphère de débogage commandent de voir si quelque chose entre de l'ISP.

Remarque: Vous ne voyez pas que des paquets sortants avec cette commande en raison de la manière les paquets sont traités.

Vous devez voir la sortie semblable à ceci, avec les mêmes champs de type, de SAP, CTL, et OUI qui prouvent que le paquet ATM entrant est AAL5SNAP.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 
TYPE:0007 Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 
000E C021 09AB 000C 0235 
03:21:32: 279F 0000 0000 
03:21:32: 

3. Couche Ethernet

Les trames Ethernet complètes sont dans les paquets AAL5SNAP. Il y a aucun mettent au point la commande de paquet Ethernet. Cependant, vous devez exécuter un certain VPDN met au point afin de voir les trames de PPPoE.

Pour la référence, une trame Ethernet qui est une trame de PPPoE contient l'un de deux Ethertypes :

  • 0x8863 Ethertype = paquet de contrôle de PPPoE (manipule la session de PPPoE)

  • 0x8864 Ethertype = paquet de données de PPPoE (contient des paquets PPP)

L'une information importante est qu'il y a deux sessions dans le PPPoE. La session de PPPoE qui est une session de type VPDN L2TP et la session PPP. Par conséquent, afin d'établir le PPPoE, vous avez une phase d'établissement de session de PPPoE et une phase d'établissement de session PPP.

L'arrêt implique habituellement une phase de terminaison de PPP et une phase de terminaison de PPPoE.

La phase d'établissement de PPPoE comprend l'identification du PPPoE Client et du serveur (les adresses MAC), et l'attribution d'un ID de session. Après que ce soit complet, l'établissement normal de PPP se produit juste comme n'importe quelle autre connexion PPP.

Afin de mettre au point, le PPPoE de l'utilisation VPDN met au point pour vous aider à déterminer si le PPPoE connectent la phase est réussi.

#debug vpdn pppoe-events 

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in  this case encapsulated in ATM) 
!--- that requests  a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server 
!--- (very similar to a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply that accepts the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation and the establishment completes.

L'établissement de PPP commence comme dans n'importe quelle autre initiation de PPP. Après que la session de PPPoE soit établie, employez les commandes de show vpdn afin d'obtenir l'état.

#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC 
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1

Vous pouvez obtenir les informations de compte de paquets utilisant le show vpdn session toute la commande.

show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

D'autres commandes de débogage :

  • debug vpdn pppoe-data

  • mettez au point les PPPoE-erreurs

  • mettez au point les PPPoE-paquets

Couche de PPP

Après que la session de PPPoE ait été établie, le PPP met au point sont identique que pour n'importe quel autre établissement de PPP.

Le mêmes debug ppp negotiation et commandes de debug ppp authentication sont utilisés. Voici un exemple de sortie.

Remarque: Dans cet échantillon, l'adresse Internet est "client1" et le nom du Cisco 6400 distant NRP est « nrp-b ».

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Débuggez le serveur de PPPoE

Afin de mettre au point le Cisco 6400 (le serveur de PPPoE), utilisez la même procédure d'approche par le bas utilisée pour le routeur de Cisco 827 (le client). La différence est dans la couche physique DSL, où vous devez vérifier le multiplexeur d'accès DSL (DSLAM).

1. Couche physique DSL

Afin de vérifier la couche physique DSL, vous devez voir les statistiques DSL sur le DSLAM. Pour des DSLAM Cisco, utilisez la commande d'interface de l'exposition DSL.

2. Couche atmosphère

Du côté de Cisco 6400, vous pouvez également utiliser une commande de paquet atmosphère de débogage et activer le Cisco 6400 pour un circuit virtuel permanent spécifique (PVC).

debug atm packet interface atm 0/0/0.182 vc 1/82

Vous devez voir la sortie semblable à ceci, avec les mêmes champs de type, de SAP, CTL, et OUI qui prouvent que le paquet ATM entrant est AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Remarque: Vous ne voyez pas que des paquets sortants avec cette commande en raison de la manière les paquets sont traités.

3. Couche Ethernet

Les mêmes commandes show VPDN et met au point utilisé sur le routeur de Cisco 827 peuvent être utilisées sur le Cisco 6400 NRP pour regarder l'établissement de PPPoE.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel
#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

D'autres commandes de débogage :

  • debug vpdn pppoe-data

  • mettez au point les PPPoE-erreurs

  • mettez au point les PPPoE-paquets

4. Couche de PPP

C'est sortie de débogage de PPP du Cisco 6400 NRP qui correspond au plus tôt mettent au point du routeur de Cisco 827.

debug ppp negotiation and debug ppp authentication
4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, 
changed state to up 

Informations connexes


Document ID: 8514