Câble haut débit : Systèmes de terminaison par modem câble (CMTS)

Comment télécharger un fichier de configuration IOS sur des modems câble Cisco via l'interface de ligne de commande du système CMTS de Cisco

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Les fichiers de configuration du logiciel de Cisco IOSÝ sont des fichiers texte qui contiennent la configuration à envoyer aux Routeurs. Dans le cas des modems câble Cisco, la configuration qui est envoyée typiquement contient des Listes d'accès, des adresses Internet, des chaînes de caractères de la communauté SNMP, des mots de passe, ou la configuration de routage qui diffère de la configuration traversière par défaut. Il est nécessaire de l'envoyer à un fichier de configuration Cisco IOS d'inclure le fichier dans le fichier de configuration de Data-over-Cable Service Interface Specifications (DOCSIS) que les Modems câble utilisent dans la partie TFTP de leur processus d'initialisation.

Il y a deux manières de télécharger un fichier de configuration Cisco IOS aux modems câble Cisco.

Le premier, qui est la plupart de manière courante, est d'utiliser un outil Configurator CPE DOCSIS. Veuillez voir le configurateur CPE de Cisco DOCSIS (clients enregistrés seulement). Les fichiers de configuration de DOCSIS 1.0 de bâtiment de document utilisant le Configurateur Cisco DOCSIS (clients enregistrés seulement) contient une explication détaillée sur la façon dont faire ceci.

La deuxième manière dans laquelle la même tâche peut faire est à l'aide de l'interface de ligne de commande (CLI) dans le Cisco IOS du système de terminaison par modem câble (CMTS).

Ce document explique en détail la deuxième manière de télécharger un fichier de configuration d'IOS aux modems câble Cisco sans besoin d'utiliser un outil de configurateur DOCSIS. Pour ceci nous utilisons une version améliorée de la configuration tout-en-un qui permet Cisco CMTS à configurer comme DHCP, ToD, et serveurs TFTP, aussi bien que pour configurer un fichier de configuration DOCSIS sur le CMTS lui-même.

Quand nous voulons envoyer un fichier de configuration aux Modems câble utilisant le CLI pour configurer le fichier de configuration DOCSIS, nous devons ajouter une option DHCP appelée l'option spécifique de l'information de constructeur DHCP, également connue sous le nom d'option 43.

L'avantage principal de configurer des Modems câble cette manière est que tout peut être fait du CMTS de Cisco, et aucun autre serveur (comme le DHCP, le TFTP, ou le ToD) et logiciel (comme l'outil Configurator CPE DOCSIS) ne sont requis d'envoyer avec succès des configurations Cisco IOS aux modems câble Cisco et de les obtenir opérationnels avec une configuration personnalisée.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Le lecteur devrait avoir une compréhension de base de :

  • Le protocole DOCSIS

  • Interface de ligne de commande de Cisco IOS (CLI) sur les routeurs de la gamme d'ubr

  • UNIX

  • Protocole DHCP (DHCP)

Composants utilisés

Veuillez voir la section configurer tous dans un config comprenant l'option 43 DHCP ci-dessous.

L'option spécifique DHCP de l'information de constructeur (option 43)

L'option 43 est une option DHCP utilisée par des clients et serveurs pour permuter les informations de particularité de constructeur.

Cette option est typiquement formatée dans un style de « Type-Longueur-valeur » où différentes informations peuvent être représentées par différents types de sous-option. La signification du champ de « valeur » est le fabricant vers la fin du périphérique défini. La figure 1 donne une représentation graphique de l'option 43.

Type Longueur Valeur Type Longueur Valeur
T1 n d1 d2 ......... T2 n D1 D2 ........

Figure 1 - La structure de Type-Longueur-valeur des données transmises dans l'option 43.

Pour télécharger des fichiers de configuration Cisco IOS aux modems câble Cisco, nous utilisons deux sous-options, à savoir ID de constructeur et option spécifique de l'information de constructeur (VSIF).

La sous-option d'ID de constructeur a le type 8. L'identifiant unique d'organisation de trois-octet (OUI) pour le constructeur est habituellement les trois premiers octets de l'adresse MAC du modem câble. Cette valeur est habituellement exprimée comme nombre hexadécimal. Ce champ devrait être 00:00:0C (dans l'hexa) pour le matériel de Cisco Systems. La figure 2 ci-dessous donne les nombres hexadécimaux pour la sous-option d'ID de constructeur.

Type Longueur Valeur
08 03 00:00:0C

Figure 2 - ID de constructeur de sous-option (en valeur hexadécimale)

La deuxième sous-option utilisée est la zone d'informations spécifique de constructeur (VSIF). Cette sous-option a le type 128 et elle contient toutes les valeurs arbitraires qui sont définies par le fabricant du modem câble. Le modem câble Cisco emploie ce champ pour identifier le nom du fichier de configuration Cisco IOS qui devrait être téléchargé (le cas échéant) à un routeur.

Des commandes Cisco IOS arbitraires peuvent également être spécifiées dans ce domaine. Ce champ est habituellement représenté dans notation-décimal. Le dotted decimal notation est la représentation décimale des lettres selon l'ASCII dans laquelle chaque lettre a une valeur décimale. Des « points » sont utilisés entre la représentation décimale pour la faciliter pour comprendre.

Dans ce document nous afficherons comment télécharger un fichier de configuration Cisco IOS appelé l'ios.cf. Le nom de ce fichier obtient converti de l'ASCII en notation-décimal.

Pour savoir ce qui est la traduction entre l'ASCII et notation-décimale, l'homme ASCII de commande UNIX peut être utilisé comme affiché ci-dessous. Cette commande donne plusieurs tables de conversion. Nous devons rechercher la décimale - Table de caractère.

sj-cse-494% man ascii
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)

 	 Decimal - Character

     |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
     |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
     | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
     | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
     | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
     | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
     | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
     | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
     | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
     | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
     | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
     | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
     | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
     |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
     |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
     |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

Par conséquent, la représentation notation-décimale d'ios.cf est 105.111.115.46.99.102as affiché ci-dessous dans la figure 3.

i o s . c f
105 111 115 46 99 192

Figure 3 - représentation Notation-décimale du nom du fichier ios.cf.

Puisque le VSIF est un type format de Longueur-valeur, la représentation notation-décimale complète du fichier de configuration Cisco IOS nommé ios.cf est 128.6.105.111.115.46.99.192. Comme vous pouvez voir, 128.6 a été additionnés à la représentation notation-décimale d'ios.cfshown sur le schéma 3. se souviennent que "128" est le type et "6" est la longueur.

128.6.105.111.115.46.99.192 est la valeur entrée dans le domaine VSIF de l'onglet de l'information de constructeur de l'outil Configurator V3.2 CPE DOCSIS suivant les indications de la figure 4 ci-dessous.

iosconfig_option43.jpg

Figure 4 - Zone d'informations de constructeur d'outil Configurator CPE DOCSIS.

Cependant, en faire cette fonction dans le Cisco IOS utilisant l'option 43 DHCP, les informations de la Type-Longueur-valeur (TLV) devraient être exprimées en valeurs hexadécimales. Ce document se concentre sur cette expression hexadécimale.

Pour découvrir la représentation hexadécimale des caractères ASCII, nous pouvons utiliser la commande d'Unix :

echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'

sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
69:6f:73:2e:63:66

Ou, vous pouvez avez également utilisé l'homme précédent ASCII de commande UNIX et trouvez la table de « caractère hexadécimal ».

sj-cse-494% man ASCII
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)


     Hexadecimal - Character

     | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
     | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
     | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
     | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
     | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
     | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
     | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
     | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
     | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
     | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
     | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
     | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
     | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
     | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
     | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
     | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

La figure 5 ci-dessous récapitule le notation-décimal aussi bien que la représentation hexadécimale de la zone d'informations spécifique de constructeur (VSIF).

Type Longueur Valeur
Notation-décimal 128 6 105.111.115.46.99.102
Hexadécimal 80 06 69:6F:73:2E:63:66

Figure 5 - Sous-option VSIF dans notation-décimal et hexadécimal.

Configurer tout dans un config comprenant l'option 43 DHCP

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous.

  • Cisco uBR10012 exécutant 12.2(2)XF

  • Cisco CVA120 exécutant 12.2(2)XA

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous fonctionnez dans un réseau vivant, assurez-vous que vous comprenez l'impact potentiel de n'importe quelle commande Cisco IOS avant de l'utiliser.

Première étape - Créez le fichier de configuration DOCSIS avec la chaîne de la bonne réponse 43

La première étape en configurant l'option 43 est de connaître la valeur hexadécimale nécessaire de l'ID de constructeur et la valeur hexadécimale nécessaire des sous-options VSIF de l'option 43 DHCP.

La table ci-dessous récapitule ces valeurs qui ont été discutées en détail dans la section Informations de particularité de constructeur.

Sous-option d'ID de constructeur Sous-option VSIF
TLV Type Longueur Valeur Type Longueur Valeur
Hexadécimal 08 03 00:00:0C 80 06 69:6F:73:2E:63:66
Signification Type d'ID de constructeur Longueur d'ID de constructeur L'ID de Cisco Type VSIF Longueur VSIF (nom du fichier) ios.cf

Figure 6

Une fois que nous savons quelle valeur nous écrirons, nous devons employer le CLI du CMTS de Cisco pour générer toutes les propriétés requises pour le fichier de configuration DOCSIS, y compris l'option 43 DHCP.

Pour créer le fichier de configuration DOCSIS que nous devons écrire le DOCSIS-FILE-nom de config-FILE de câble de commande globale. La sortie suivante affiche la création du fichier de configuration DOCSIS nommé platinum.cm. Toutes les configurations de platinum.cm sont expliquées ci-dessous.

Note: 
!--- Comments are in blue.


cable config-file platinum.cm  
  
!---  Name of the DOCSIS config file is platinum.cm

  service-class 1 priority 2  
  
!---  The Upstream Channel priority is 2

  service-class 1 max-upstream 128 
  
!---  The Maximum upstream value is 128Kbps

  service-class 1 guaranteed-upstream 10
  
!---  The Guaranteed Upstream is 10 Kbps

  service-class 1 max-downstream 10000 
  
!---  The Maximum Downstream is 10Mbps

  service-class 1 max-burst 1600
  
!---  The Maximum Upstream Transmit burst is 1600 bytes

  cpe max 10 
  
!---  The Maximum number of CPE's is 10

  timestamp
  
!---  Enable timestamp generation

  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
  
!---  Using option 43 to send the IOS Configuration file named "ios.cf" 
  !---  to cable modems.

attention Attention : La commande de config-FILE de câble a été introduite dans la version 12.1(2)EC1 de Cisco IOS pour l'uBR7200 et l'uBR7100, et sur la version 12.2(1)XF1 de Cisco IOS pour l'uBR10K.

Remarque: Soyez certain que vous avez correctement saisi les données TLV en utilisant l'option hexadécimale. Les données inexactement saisies ont pu faire pour remettre à l'état initial, aller off-line, ou pour arrêter le CMS, exigeant un arrêt et redémarrage avant de pouvoir continuer.

En second lieu étape - Créez le pool DHCP pour la configuration du serveur DHCP

Une fois que nous avons créé le fichier de configuration DOCSIS platinum.cm, nous devons configurer le CMTS pour être le serveur DHCP, et configurons les options requises pour la fonctionnalité DHCP. Veuillez voir le service du protocole DHCP de Cisco IOS (DHCP) sur un CMTS, qui explique la signification de chacune de la commande que nous utilisons pour la création du groupe DHCP. Ici nous juste récapitulerons la configuration et donnerons une brève description.

La configuration du pool DHCP est :

ip dhcp pool surf
  
!---  name of the dhcp pool. This scope is for the cable modems attached 
  !---  to interface cable 5/0/0

  network 10.1.4.0 255.255.255.0
  
!---  pool of addresses for scope from interface c5/0/0

  bootfile platinum.cm
  
!---  DOCSIS config file name associated with this pool

  next-server 10.1.4.1
  
!---  IP address of TFTP server which sends bootfile

  default-router 10.1.4.1
  
!---  default gateway for cable modems, necessary to get DOCSIS files

  option 7 ip 10.1.4.1
  
!---  Log Server DHCP option

  option 4 ip 10.1.4.1
  
!---  ToD server IP address

  option 2 hex ffff.8f80
  
!---  Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

  lease 7 0 10
  
!---  lease 7 days 0 hours 10 minutes

  ! 

Troisième étape - Configurez le CMTS comme serveur TFTP

La troisième étape est de configurer le CMTS pour être un serveur TFTP. Pour faire ceci que vous aurez besoin :

  1. Utilisez le tftp-server de commande

  2. Dites au serveur TFTP où le fichier ios.cf se trouve

Vous pouvez réaliser ceci avec le tftp-server disk0:ios.cf alias ios.cf de commande. Notez que cette commande met le fichier ios.cf dans disk0.

tftp-server server

!--- enable the cmts to act as a tftp server

tftp-server disk0:ios.cf alias ios.cf

!--- get the IOS config file called ios.cf that is pre-downloaded to disk0
!--- this IOS  config file was built with a text editor and tftp to disk0  


Pour mettre le fichier ios.cf dans votre éclair ou disk0 (pour uBR10012) vous devez tftp le fichier qui a été créé utilisant un éditeur de fichier texte. Pour faire ce premier s'assure que vous pouvez cingler le serveur de tftp où la configuration Cisco IOS se trouve.

Ensuite, le <device> de copy tftp de commande globale devrait être écrit pour placer le fichier à l'intérieur du CMTS. Habituellement l'éclair est utilisé pour l'uBR7200 ou l'uBR7100 ou l'uBR10K, cependant, des expositions de cet exemple comment utiliser disk0 pour uBR10012.

schooner#copy tftp disk0
Address or name of remote host []? 172.16.30.2
Source filename []? ios.cf
Destination filename [ios.cf]? 

Accessing tftp://172.16.30.2/ios.cf...
Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
[OK - 173/4096 bytes]

173 bytes copied in 0.152 secs

Pour s'assurer que le fichier de configuration d'IOS est enregistré sur le CMTS exécutez le dir de commande.

schooner#dir
Directory of disk0:/
    3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
 2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
47890432 bytes total (36274176 bytes free)

Pour visualiser quelles commandes sont configurées dans le fichier ios.cf la commande plus de <filename> peut être utilisé dans le CMTS comme suit :

schooner#more ios.cf
hostname SUCCEED
service linenumber
enable password cisco
interface ethernet 0
load 30
no shut
interface cable 0
load 30
no shut
line vty 0 4
password cisco
end

Quatrième étape - Configurer le CMTS comme serveur de ToD

Pour configurer ToD sur commandes globales CMTS de Cisco seulement deux soyez service udp-small-servers max-servers no-limit nécessaire et câblez le serveur temporel. La configuration ressemble à :

service udp-small-servers max-servers no-limit

!---  supports a large number of modems / hosts attaching quickly

cable timeserver

!---  permits cable modems to obtain Time of Day (ToD) from uBR10012


La configuration du CMTS

La configuration complète de l'uBR10012 est trouvée ci-dessous. Toutes les commandes en gras sont les commandes appropriées au but de ce document.

Schooner#show run
Building configuration...

Current configuration : 3522 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname schooner
!
logging rate-limit console all 10 except critical
enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file platinum.cm
 service-class 1 priority 2
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
 option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
!
redundancy
 main-cpu
  auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1oc12pos-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 5/0 2cable-mc28
card 7/0 2cable-mc28
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool surf
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1 
   default-router 10.1.4.1 
   option 7 ip 10.1.4.1 
   option 4 ip 10.1.4.1 
   option 2 hex ffff.8f80
   lease 7 0 10
!
interface FastEthernet0/0/0
 ip address 172.16.30.50 255.255.255.192
!
interface POS1/0/0
 no ip address
 crc 32   
 pos report all
 POs flag j0 1
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/0/0
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 40000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server trap-source Cable5/0/0
snmp-server packetsize 2048
snmp-server enable traps cable
snmp-server host 172.16.30.8 public  cable snmp
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
!
end

schooner#

D'autres constructeurs CMTS peuvent ne pas avoir la capacité d'installer toutes ces parties utilisant seulement leurs commandes CMTS tandis qu'elle peut être accomplie complètement dans le Cisco IOS.

Pour faire les Modems câble prendre les commandes spécifiées dans le fichier de configuration Cisco IOS a appelé ios.cf, il est nécessaire pour redémarrer les Modems câble en question. Ceci peut être fait du du CLI du CMTS à l'aide de remise clearcable d'adresse MAC de modem de commande de < IP address/>.

Schooner#clear cable modem 10.1.4.4 reset

attention Attention : Si vous avez un grand réseau et voulez envoyer un fichier de configuration différent à tous les Modems câble à votre usine, elle est recommandée de faire ainsi en quelques phases. Ceci réduira l'incidence des milliers de Modems câble tentant de faire un pas sur l'un l'autre tout en essayant d'obtenir en ligne en même temps.

Vérifier la configuration

Pour vérifier la configuration, effacez le modem câble avec la commande claire de modem câble. Quand le modem câble revient en ligne, le telnet à lui regardent la configuration.

Schooner#show cable modem 
MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                         State       Sid  (db)  Offset CPEs Enbld
0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no

!--- CVA120
 
0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

L'avis dans cet exemple que le fichier ios.cf commande les Modems câble pour avoir une adresse Internet SUCCEED, et en effet c'est le nom du fichier qui est vu quand nous telnet dans le modem câble.

Schooner#telnet 10.1.4.4
Trying 10.1.4.4 ... Open

SUCCEED line 1 


User Access Verification

Password: 
SUCCEED>en
Password: 
SUCCEED#

Pour vérifier que le fichier de configuration Cisco IOS a été téléchargé avec succès à l'utilisation de modem câble le show version de commande. La sortie ci-dessous affiche les informations concernant le fichier ios.cf en gras.

SUCCEED#show  version
Cisco Internetwork Operating System Software 
IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
TAC:Home:SW:IOS:Specials for info
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 27-Jun-01 02:02 by hwcheng
Image text-base: 0x800100A0, data-base: 0x80782844
ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SUCCEED uptime is 3 days, 3 hours, 21 minutes
System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
System restarted at 05:58:30 - Sat Oct 6 2001
System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
Host configuration file is "tftp://10.1.4.1/ios.cf"

cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
Processor board ID SAD043708GK
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
1 Universal Serial Bus (USB) interface(s)
8192K bytes of processor board System flash (Read/Write)
7296K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2

La configuration du CVA120 est affichée ci-dessous. Notez que les commandes en gras correspondent aux lignes dans le fichier ios.cf.

SUCCEED#show run
Building configuration...

Current configuration : 1429 bytes
!
! Last configuration change at 11:22:22 - Tue Oct 9 2001
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service linenumber
service internal
!
hostname SUCCEED
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable password cisco
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
interface Ethernet0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address docsis
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream mode annex-b
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface USB0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server chassis-id 
snmp-server manager
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
mgcp modem passthrough voaal2 mode 
no mgcp timer receive-rtcp
!
mgcp profile default
!
line con 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

Remarque importante

Il s'avère que la commande d'option pour la config-FILE de câble est cassée parce qu'on peut s'attendre aux commandes ci-dessous de donner la configuration valide.

option 43 instance 8 hex 00:00:0c
option 43 instance 128 ASCII ios.cf

Tandis que ces commandes sont reçues, il ne génère pas le fichier correct de config de Cisco IOS. Ce n'est pas une bogue ! Le problème ici est comment le terme « exemple » a été interprété comme « sous-option, » qui on ne l'a jamais censé être.

L'implémentation du « exemple » permet seulement la répétition des mêmes plusieurs temps d'option, comme quand vous avez des multiples instances de l'option 43 pour différents constructeurs ! Voici un exemple :

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67

!--- Config file cisco CM

option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67

!--- Some option for other CM

Notez que 11:22:33 est un ID aléatoire de constructeur d'une société factice. N'importe quelle correspondance avec un vrai ID de constructeur est une coïncidence pure.

Puisqu'on s'attend à ce que le terme « exemple » reflète des champs de sous-option TLV, et vous avez en effet des champs de sous-option TLV, vous devrez écrire la chaîne entière dans l'hexadécimal.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 8323