WAN : Protocole point à point (PPP)

Connexions dos à dos PPP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour une connexion dos à dos de PPP. Avec une telle configuration, vous pouvez vérifier que votre connexion et matériel fonctionnent correctement, et utilisez même le Routage IP pour du test.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cette configuration s'applique à toutes les versions logicielles de Cisco IOSÝ.

  • Le côté DCI est connecté à un câble du WAN DCI.

  • Le côté DTE est connecté à un câble du WAN DTE.

Pour plus d'informations sur des câbles du WAN DCI ou DTE, référez-vous à la documentation de câbles série.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Résumé de configuration

Dans cette configuration, Router1 utilise un câble V35-MT (Cisco mettent en référence est CAB-V35MT), et le Router2 utilise un câble V35-FC (Cisco mettent en référence est CAB-V35FC). Ceci signifie que l'horloge est fournie par Router2. Un rythme d'horloge de 64000 bps est utilisé en émettant la commande du rythme d'horloge 64000 sous l'interface de l'interface série 0.

Remarque: Une fois que cette commande est configurée, elle apparaît dans la configuration comme rythme d'horloge 64000. Les deux câbles sont maintenant connectés entre eux.

Les interfaces Ethernet sont configurées en n'émettant l'aucune commande de keepalive. De cette façon, il n'est pas nécessaire de les connecter au réseau de RÉSEAU LOCAL afin de les obtenir en service. Utilisant une artère statique sur chaque routeur te permet de cingler l'adresse IP de l'interface Ethernet du Router2, utilisant l'adresse IP de l'interface Ethernet de Router1 (ou du contraire). Naturellement, c'est utile dans un environnement de test.

Diagramme du réseau

Ce document est basé sur la configuration suivante :

/image/gif/paws/7923/ppp_backtoback.gif

Configurations

Ce document utilise les configurations suivantes :

Router1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.1.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
!
ip classless
ip route 10.2.0.0 255.255.255.0 10.0.0.2
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Router2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.2.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 encapsulation ppp
 no fair-queue
 clock rate 64000
!
ip classless
ip route 10.1.0.0 255.255.255.0 10.0.0.1
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • Émettez les shows controllers commandent de vérifier le câble et le rythme d'horloge :

    Ce qui suit est la sortie de la commande de shows controllers :

    Router1#show controllers serial 0 | i V.35
    buffer size 1524  HD unit 0, V.35 DTE cable
    Router1#
    
  • Émettez la commande du show interfaces serial 0 de vérifier que des paquets sont envoyés et reçus (voir les paquets entrer, la sortie de paquets, les 5 débits sortants de débit en entrée minute, et 5 minute. Pour les informations concernant l'encapsulation utilisée, voir l'encapsulation ppp.

    Ce qui suit est la sortie de la commande du show interfaces serial 0 :

    Router1#show interfaces serial 0
    Serial0 is up, line protocol is up
      Hardware is HD64570
      Internet address is 10.0.0.1/24
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Open
      Open: IPCP, CDPCP
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters 00:07:53
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/5/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 2000 bits/sec, 2 packets/sec
      5 minute output rate 2000 bits/sec, 2 packets/sec
         155 packets input, 55066 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         168 packets output, 60037 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    Router1#
    
  • Pour générer un ping à 10.2.0.2 utilisant l'adresse IP 10.2.0.1, vous pouvez émettre la commande ping :

    Ce qui suit est la sortie de la commande ping :

    Router1#ping
    Protocol [ip]:
    Target IP address: 10.2.0.1
    Repeat count [5]:
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface: 10.1.0.1
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds: Packet sent with a source address of 10.1.0.1 !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms Router1#
    

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • shows controllers — Affiche le câble et le rythme d'horloge.

  • show interfaces serial 0 — Vérifie que des paquets sont envoyés et reçus.

  • ping — Utilisé pour tester la connexion des périphériques.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 7923