Commutateurs : Cisco 6130 IP DSL Switch

Configuration d'une interface ATM Cisco 6400 avec RBE et DHCP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (11 novembre 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour un routeur connecté de la ligne d'abonné numérique de Cisco 827 (DSL) à un multiplexeur d'accès de ligne d'abonné numérique de Cisco 6130 (DSLAM), cela se termine sur un concentrateur d'accès universel de Cisco 6400 (UAC).

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Matériel de sites du client de Cisco 827-4V (CPE) avec la version de logiciel 12.1(1)XB de ½ du ¿  IOSïÂ.

  • Version de logiciel d'IOS Software du Cisco 6400 UAC-NRP 12.1(1)DC1 (serveur DHCP externe) ou 12.2(2)B (serveur DHCP IOS).

  • Version de logiciel d'IOS Software du Cisco 6400 UAC-NSP 12.0(4)DB.

  • Version de logiciel d'IOS Software du Cisco 6130 DSLAM-NI2 12.1(1)DA.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

Le Cisco 827 est configuré avec la transition et le Routage et mise en parallèle intégrés (IRB) RFC1483. Le Cisco 827 permet à des PC sur le segment d'Ethernets pour obtenir des adresses d'un serveur DHCP derrière les 6400, ou du serveur DHCP IOS 6400. En outre, l'adresse BVI a été également configurée pour obtenir une adresse et un default route du serveur DHCP. L'interface de Mode de transfert asynchrone (ATM) de Cisco 6400 est configurée avec l'encapsulation conduite de passerelle (RBE), et est configurée pour fonctionner avec un serveur DHCP externe ou le serveur DHCP IOS sur le NRP.

Pour le Cisco 6400, la caractéristique atmosphère RBE sur le processeur d'artère de noeud de Cisco 6400 (NRP) conduit l'IP au-dessus du trafic Ethernet RFC1483 traversier d'un LAN ponté stub. Des paquets IP traversiers reçus sur une interface ATM configurée en mode artère-jeté un pont sur sont conduits par l'en-tête IP. Les interfaces tirent profit des caractéristiques d'une topologie de RÉSEAU LOCAL de stub utilisée généralement pour l'accès DSL, et les performances accrues et la flexibilité d'offre au-dessus d'IRB.

En outre, des routes hôte pour des clients DHCP sont automatiquement ajoutées à la table de routage 6400 pendant que des adresses IP sont distribuées. Les routes hôte sont retirées de la table de routage quand l'adresse DHCP est libérée.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau affichée dans les figures 1 et 2 :

Figure 1 ? Scénario 1

/image/gif/paws/7208/fig1_7208.gif

Figure 2 ? Scénario 2

/image/gif/paws/7208/fig2_7208.gif

Configurations

Ce document utilise les configurations suivantes :

  • Cisco 827

  • Cisco 6400 NRP

  • Debug 6400 (utilisant RBE avec le serveur DHCP externe)

  • Debug 6400 (utilisant RBE avec le serveur DHCP IOS)

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 no ip address
 bridge-group 1

!--- Because the Ethernet0 is bridged to the WAN interface,
!--- PCs behind the ethernet0 can be setup as DHCP clients.
!--- They get their addresses from the DHCP server behind the 6400,
!--- or from the IOS DHCP server on the 6400.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address dhcp client-id Ethernet0

!--- This command tells the BVI interface to get the address
!--- from DHCP, and also to get the default route from DHCP.

! 
ip classless 

!--- Note: The default route will be inserted into
!--- the routing table automatically from the DHCP server, and
!--- no static routing statement is required.                         

no ip http server 
! 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP
Current configuration: 
! 
version 12.1
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 198.1.1.1 255.255.255.0 
 no ip directed-broadcast

!--- This address and mask must match the intended
!--- scope and network configured on the external DHCP server.

! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses IP
!--- unnumbered Loopback1 for its IP address requirements.

 ip unnumbered Loopback1 
 ip helper-address <dhcp server ip address>
 atm route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 

!--- Note: For every DHCP client that is relayed an address,
!--- a host route will be automatically inserted in the routing 
!--- table, and no host route statement for a DHCP client is required.

end 

Debug 6400 (utilisant RBE avec le serveur DHCP externe)
debug ip dhcp server events 

Looks for existing binding. . .

00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1
00:10:56:  find_or_create(): Creating new binding with data
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards DHCP DISCOVER packet from the client to the
!--- external DHCP server.

00:10:56: DHCPD: Received DHCPDISCOVER on UNNUM-IF
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP OFFER packet from the external DHCP server 
!--- to the client.

00:10:56: DHCPD: Unnum: Received DHCPOFFER
00:10:56:  DHCPD: Server Address = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1
00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards the DHCP REQUEST packet from the client to the external
!--- DHCP server.

00:10:56: DHCPD: Received DHCPREQUEST on UNNUM-IF
00:10:56:  DHCPD: request_on_unnumif ():Real Server = 200.200.200.2   
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP ACK packet from the DHCP server to the client.

00:10:56: DHCPD: Unnum: Received DHCPACK
00:10:56:  DHCPD: lease time = 86400

!--- Adds a dynamic host route to the client into the routing table.

00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56:  DHCPD: Adding new route to host 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_create_and_hash_route index = 126
00:10:56: DHCPD: dhcpd_add_route: lease = 86400 
00:10:56:  DHCPD: Server ID saved in Binding = 200.200.200.2
00:10:56:  DHCPD: Server ID saved in Route block = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1

Debug 6400 (utilisant RBE avec le serveur DHCP IOS)
debug ip dhcp server events 

Assigns an address to the client from the IOS DHCP server.

23:19:09: DHCPD: assigned IP address 124.124.124.3 to 
client 0063.6973.636f.2d30.3030.302e.3063.3036.2e32.3339.342d.4256.31.
23:19:10:  DHCPD: lease time = 86400

Adds a dynamic host route to the client into the routing table.

23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10:  DHCPD: Adding new route to host 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_create_and_hash_route index = 127
23:19:10: DHCPD: dhcpd_add_route: lease = 86400

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 7208