WAN : Protocole point à point (PPP)

Configuration des protocoles IP/PPP pour l'accès téléphonique des serveurs d'accès avec PPP V.120 dédié

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon pour l'accès distant IP/PPP de serveur d'accès V.120 dédié le PPP

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 11.2 ou ultérieures de ½ du ¿  de Cisco IOSïÂ, pour V.120 avec les interfaces Virtuel-asynchrones.

  • Logiciel Cisco IOS version 11.3 ou plus tard, pour V.120 avec des virtual-template.

  • Image d'entreprise de Cisco IOS pour configurer plus de cinq lignes VTY.

Utilisez l'outil Software Advisor (clients enregistrés seulement) pour déterminer quels ensembles de caractéristiques de logiciel de Cisco IOS prennent en charge V.120 la fonctionnalité. Dans l'outil, sélectionnez les caractéristiques suivantes : Soutien V.120, Conversion de protocole, et virtual-template pour la Conversion de protocole. Si vous avez besoin des fonctionnalités supplémentaires, sélectionnez-les au besoin.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

La recommandation de l'Union internationale des télécommunications - Secteur de la normalisation des télécommunications (ITU-T) V.120, tient compte du transport fiable des données transparentes synchrones, asynchrones, ou mordues au-dessus des canaux de support RNIS.

V.120 une connexion peut être en mode de PPP ou de non-PPP. C'est parce que beaucoup V.120 d'adaptateurs de terminal sont semblables aux Modems, et prend en charge quelques positionnements de commande AT. Le mode de non-PPP peut être utilisé pour vérifier si V.120 l'installation est correcte sur le client et le routeur. Le PPP peut alors être configuré sur ce lien. Voyez le vérifier V.120 dans le pour en savoir plus de section Mode de non-PPP.

Il y a deux méthodes primaires à implémenter V.120 :

  • Interfaces Virtuel-asynchrones

    Utilisant le Cisco IOS logiciel, vous pouvez configurer les caractéristiques asynchrones de protocole, telles que le PPP et le SLIP, sur des lignes VTY. Le PPP et le SLIP fonctionnent normalement seulement sur les interfaces asynchrones, pas sur des lignes VTY. Quand vous configurez une ligne VTY pour prendre en charge les caractéristiques asynchrones de protocole, vous créez les interfaces Virtuel-asynchrones sur les lignes VTY. Une interface Virtuel-asynchrone (également connue sous le nom de vty-async) est créée aux appels de support qui présentent le routeur par une interface non-physique. Par exemple, les appels asynchrones de flot de caractère se terminent, ou terre sur les interfaces non-physiques. Les interfaces Virtuel-asynchrones ne sont pas utilisateur configurable ; en revanche, ils sont dynamiquement créés, et démoli à la demande.

  • Virtual-template

    L'implémentation de virtual-template prend en charge le Tunnellisation du PPP, utilisant une Conversion de protocole en deux étapes. Quand V.120 un utilisateur se connecte par une ligne de terminal virtuelle, le routeur crée une interface d'accès virtuelle. L'interface d'accès virtuelle est une interface provisoire qui prend en charge la configuration asynchrone de protocole spécifiée dans le modèle d'interface virtuelle. Cette interface est créée dynamiquement en copiant l'interface de modèle virtuel dans la configuration. Cette interface d'accès virtuelle est libérée vers le haut de dès que la connexion chutera. Le virtual-template est plus flexible, parce qu'il donne plus d'options de configuration que l'implémentation Virtuel-asynchrone limitée.

Comment V.120 représentation de routeur d'affects

Cisco ne recommande pas que vous exécutiez le PPP plus de V.120 sur Micamodem, parce que V.120 le traitement est extrêmement CPU-intensif. Cisco AS5200 ne peut pas manipuler beaucoup simultanément de connexions PPP d'active V.120. D'autres Routeurs AS5xxx peuvent manipuler plus simultanément des connexions PPP d'active V.120. Comme alternative, Cisco recommande configurer l'adaptateur terminal RNIS de client (MERCI) pour faire « la conversion synchronisation-à-async de PPP » de sorte que la connexion entre dans le serveur d'accès à distance (NAS) en tant que PPP normal de sync au lieu de V.120.

Cependant, avec des modems Nextport, une nouvelle caractéristique a été ajoutée, pour débarquer V.120 des appels au processeur de signaux numériques de modem (DSP). Si vous utilisez le Logiciel Cisco IOS version 12.2 XB (et 12.2(11)T et plus tard), il est possible de terminer V.120 des faire appel au NextPort DSP au lieu de la CPU. Le pour en savoir plus, voient terminer V.120 des sessions sur le NextPort DSP.

Pourquoi PPP de mise en place plus de V.120 ?

Le PPP plus d'est V.120 CPU-intensif. Par conséquent, Cisco décourage une implémentation étendue. Cependant vous pouvez vouloir exécuter le PPP plus de V.120 pour les raisons suivantes :

  • Vous utilisez un adaptateur de terminal (MERCI) qui est relié à un matériel de terminal de données asynchrones (DTE), et ne pouvez pas faire la conversion synchronisation-à-async de PPP. Dans ce cas, vous devez utiliser V.120.

  • La configuration par défaut de vos ventres est V.120, et vous ne pouvez pas modifier vos VENTRES sans assistance de votre fournisseur de services Internet (ISP).

  • L'application veut faire commencer à la session PPP avec un dialogue terminal de caractère-cellule (par exemple, un défi et une réponse une fois spéciaux de mot de passe), ainsi vous ne voulez pas une session PPP pure de sync.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Cette section décrit également l'implémentation pour le vty-async et les virtual-template.

Remarque: Ces étapes supposent que le NAS est correctement configuré pour le RNIS de base ou l'accès async de Dialin, et que le client est correctement configuré pour le PPP plus de V.120.

Interfaces Virtuel-asynchrones (vty-async)

Pour implémenter le vty-async, terminez-vous ces étapes :

  1. Créez les interfaces Virtuel-asynchrones utilisant la commande de configuration globale de vty-async.

  2. Configurez l'authentification pour la connexion de vty-async. Utilisez le ppp de vty-async authen {CHAP | commande PAP}.

  3. Configurez d'autres paramètres de vty-async comme, des temporisateurs de keepalive, taille de mtu, compression d'en-tête, et ainsi de suite, au besoin, pour votre installation. Référez-vous à la Conversion de protocole et au pour en savoir plus virtuel de commandes d'appareil asynchrone.

  4. Configurez la détection automatique V.120 de l'encapsulation utilisant la commande de ppp de l'autodetect encapsulation v120. Cette commande doit être appliquée à l'interface physique de l'appel entrant (par exemple, interface bri 0, interface série 1:23 d'interface). Cependant, si appeler signale V.120 MERCI correctement V.120 dans le domaine inférieur de compatibilité de l'INSTALLATION Q.931, l'autodetect encapsulation n'est pas nécessaire. Malheureusement, beaucoup échouer TAS pour faire ceci.

  5. Désactivez la demande de nom d'utilisateur et mot de passe sous la configuration de ligne VTY. Vous pouvez faire ceci en ne configurant aucune procédure de connexion et aucun mot de passe dans le mode de configuration de ligne VTY. Si vous utilisez l'AAA, définissez une liste qui a la méthode aucun et puis appliquez-la à l'interface VTY. Exemple :

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configurez la commande de par défaut de ppp d'autocommand dans le mode de configuration de ligne VTY. Sans le ppp d'authentification de connexion et d'autocommand, le PPP d'initiés VTY dès que V.120 une connexion entrera. Ceci permet V.120 au pair pour commencer des négociations PPP immédiatement, sans devoir exécuter un script, ou écrivent le nom d'utilisateur et mot de passe dans un terminal window. La commande d'autoselect n'est pas prise en charge sur VTYs.

    Remarque: Puisque le PPP courant de début de VTYs dès que la connexion sera établie, vous ne pourra pas émettre la commande telnet sur le NAS à des fins administratives. Pour venir à bout cette restriction, appliquer la commande du transport input v120 sur le VTYs utilisé pour V.120 les connexions PPP, et appliquer la commande telnet de transport input sur ceux utilisés pour le telnet administratif.

Virtual-template

Pour implémenter des virtual-template, terminez-vous ces étapes :

  1. Créez et configurez un modèle d'interface virtuelle à l'aide de la commande d'interface virtual-template. Configurez cette interface virtuelle juste comme vous configureriez une interface régulière de série asynchrone. Pour faire ainsi, assignez au modèle d'interface virtuelle l'adresse IP d'une interface active (utilisant la commande d'interface d'ip unnumbered), et configurez l'adressage, juste comme vous le configureriez sur une interface asynchrone. Vous pouvez également sélectionner les commandes dans le mode de configuration d'interface qui compressent des en-têtes de TCP ou configurent l'authentification de protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) pour le PPP. Exemple :

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. Créez les interfaces Virtuel-asynchrones utilisant la commande de configuration globale de vty-async.

  3. Configurez les lignes de terminal virtuelles pour prendre en charge des fonctions asynchrones de protocole, basées sur la définition d'un modèle d'interface virtuelle. Vous pouvez faire ceci utilisant la commande de nombre de vty-async virtual-template en mode de configuration globale. Exemple :

    vty-async
    vty-async Virtual-Template 1
  4. Configurez la détection automatique V.120 de l'encapsulation utilisant la commande de ppp de l'autodetect encapsulation v120. Appliquez-vous cette commande à l'interface physique de l'appel entrant (par exemple, interface bri 0, interface série 1:23 d'interface). Cependant, si appeler signale V.120 MERCI correctement V.120 dans le domaine inférieur de compatibilité de l'INSTALLATION Q.931, l'autodetect encapsulation n'est pas exigé. Malheureusement, beaucoup échouer TAS pour faire ceci.

  5. Désactivez la demande de nom d'utilisateur et mot de passe sous la ligne configuration vty. Faites ceci en ne configurant aucune procédure de connexion et aucun mot de passe dans la ligne vty mode de configuration. Si vous utilisez l'AAA, définissez une liste qui a la méthode aucun et puis appliquez-la à l'interface vty. Exemple :

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configurez la commande de par défaut de ppp d'autocommand dans la ligne vty mode de configuration. Sans le ppp d'authentification de connexion et d'autocommand, le PPP d'initiés VTY dès que V.120 une connexion entrera. Ceci permettra V.120 au pair pour commencer des négociations PPP immédiatement, sans devoir exécuter un script ou écrire le nom d'utilisateur et mot de passe dans un terminal window. Notez que la commande d'autoselect n'est pas prise en charge sur VTYs.

    Remarque: Puisque le PPP courant de début de VTYs dès que la connexion sera établie, vous ne pourra pas émettre la commande telnet sur le NAS à des fins administratives. Pour venir à bout cette restriction, appliquer la commande du transport input v120 sur le VTYs utilisé pour V.120 les connexions PPP, et appliquer la commande telnet de transport input sur ceux utilisés pour le telnet administratif.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/6306/28a.gif

Configurations

Ce document utilise la configuration suivante :

  • Cisco AS5200 qui prend en charge des clients IP ou de PPP d'accès distant pour le PPP RNIS synchrone (pas multilink), le PPP asynchrone, et V.120 le PPP.

Cette configuration utilise la méthode Virtuel-asynchrone d'interfaces (vty-async) décrite ci-dessus.

V.120 (PPP) avec les interfaces Virtuel-asynchrones
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip route — affiche les entrées de table de Routage IP.

  • utilisateurs d'exposition — affiche des informations au sujet des lignes actives du serveur de réseau, y compris le numéro de ligne, les noms de la connexion, et l'emplacement terminal.

Vérifiez V.120 la connexion

Pour vérifier V.120 la connexion, terminez-vous ces étapes :

  1. L'utilisez mettent au point v120, et génèrent V.120 un appel entrant. Vous devriez voir cette sortie de débogage sur le NAS :

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    Si ce message n'apparaît pas, l'appel entrant n'était probablement pas V.120, et par conséquent le routeur ne l'a pas détecté en soi.

  2. Vérifiez si l'interface de vty-async est soulevée. Si vos utilisations de configuration V.120 avec des virtual-template, vérifient si une interface d'accès virtuel est créée. Dans la sortie suivante de log de console, la l'interface du vty-async 32 est en hausse :

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. Debug ppp negotiation et debug ppp authentication d'utilisation. pour s'assurer que des paramètres de PPP sont correctement négociés. Pour plus d'informations sur l'élimination des imperfections de PPP, voir la technologie d'accès commuté : Techniques de dépannage.

  4. Exécutez un show ip route et affichez que les utilisateurs vérifiaient que V.120 l'appel est correctement établi.

Les exemples suivants sont des sorties d'une installation où nous n'avons pas V.120 des virtual-template :

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

Remarque: L'appel est connecté sur le vty-async 32 d'interface, et il y a une artère au client.

Remarque: L'adresse IP du côté de NAS du lien sera celle ou des Ethernets ou les Fast Ethernet relient sur le NAS, en utilisant non l'option de configuration de modèle virtuel. Par conséquent vérifiez si l'interface d'Ethernets ou de Fast Ethernet est en hausse et peut être cinglée.

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

Remarque: L'appel est connecté sur le vty-async 32 d'interface, et l'adresse IP de pair est spécifiée.

Si vous utilisez l'option de virtual-template avec V.120 le show ip route et la sortie d'utilisateur d'exposition apparaît comme ceci :

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

Remarque: L'appel est connecté sur l'interface Virtuel-Access 1, et il y a une artère au client.

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

Remarque: L'appel est connecté sur l'interface Virtuel-Access 1.

Vérifiez V.120 en mode de Non-PPP

Beaucoup V.120 d'adaptateurs de terminal sont semblables aux Modems, et prennent en charge quelques positionnements de commande AT. Par conséquent, vous pouvez employer le mode de non-PPP pour vérifier si V.120 l'installation sur le client et le routeur sont corrects. Vous pouvez alors configurer le PPP sur ce lien. Le test nous permet V.120 par lui-même pour dépanner des problèmes V.120 relatifs sans ajouter la complexité du PPP.

Pour tester V.120 la connexion en mode de non-PPP, terminez-vous ces étapes :

  1. Activez la demande de nom d'utilisateur et mot de passe sous la ligne configuration vty. Utilisez la commande login d'activer la procédure de connexion. Utilisez la commande de password password de placer la ligne mot de passe. Si vous utilisez l'AAA, retirez la commande de liste d'authentification de connexion sous le vty.

  2. Retirez la commande de par défaut de ppp d'autocommand dans la ligne vty mode de configuration. Exemple :

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. Turn on mettent au point v120, et initient un appel du client. Le routeur devrait afficher ceci :

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. Continuez le reste V.120 de la configuration. Terminez-vous les étapes décrites dans la section de configurer.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Commandes de dépannage (facultatif)

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant que vous émettiez des commandes de débogage, référez-vous aux informations importantes sur le pour en savoir plus de commandes de debug.

  • mettez au point v120 — indique en traitant V.120 est commencé ou terminé, et l'interface sur lequel il s'exécute.

  • debug ppp negotiation — affiche des informations sur le trafic PPP et des échanges, tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le NCP. Une négociation PPP réussie d'abord ouvrira l'état LCP, puis authentifie, et négocie finalement le NCP (habituellement IPCP).

  • debug ppp authentication — affiche les messages du protocole d'authentification de PPP, y compris des échanges de paquet de CHAP et des échanges de Password Authentication Protocol (PAP).


Informations connexes


Document ID: 6306