Composition et accès : Connexions asynchrones

Configuration de WINS, DNS et DHCP sur les serveurs d'accès

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Certains clients entrants exigent des informations du serveur de Windows Internet Naming Service (WINS) et/ou du système de noms de domaine (DNS) afin de se connecter correctement au réseau. Il y a également plusieurs différents mécanismes pour fournir des adresses IP aux clients entrant sur des serveurs d'accès.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Configurez et vérifiez que le routeur peut recevoir l'asynchrone entrant et les appels RNIS. Utilisez la procédure de configuration spécifiée en configurant un serveur d'accès avec PRIs pour l'async de liaison multiple en entrée et les appels RNIS pour de plus amples informations.

  • Vérifiez que le DHCP, les DN et les serveurs WINS sont installés correctement. Entrez en contact avec votre pour en savoir plus d'administrateur système.

    Remarque: Cette configuration suppose que les WINS, les DN, et les serveurs DHCP sont différents serveurs. Ils peuvent en fait être un serveur, ou un serveur peut être des WINS et des DN courants avec le DHCP sur une autre case ou n'importe quelle autre combinaison des trois.

Composants utilisés

Cette configuration a été développée et testée utilisant ces matériel/périphériques :

  • Cisco AS5200 avec deux circuits de T1 PRI

  • Serveur DNS

  • Serveur WINS

  • Serveur DHCP pour assigner des adresses IP au client

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Ce des commandes de configuration de DN, DHCP et de WINS peuvent être utilisées sur n'importe quel routeur qui prend en charge des appels entrants de PPP.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Théorie générale

Quelques choix possibles pour assigner des adresses IP aux clients incluent :

  • Assigner une adresse du pool d'IP local sur le serveur d'accès.

  • Utilisant un serveur externe du Dynamic Host Control Protocol (DHCP).

  • Utilisant le Service RADIUS (Remote Authentication Dial-In User Service) ou le Terminal Access Controller Access Control System (TACACS+).

Ce document décrit la procédure pour passer des WINS et des informations de serveur de DNS au client entrant par le serveur d'accès. Le serveur d'accès passera également l'adresse IP retournée par un serveur DHCP externe au client entrant.

Le pour en savoir plus, se rapportent aux documents dans la section Informations connexes de ce document

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/6303/winsdhcp.gif

Configurations

Ce serveur d'accès AS5200 est configuré avec deux accès primaires (PRIs) pour permettre l'asynchrone entrant et les utilisateurs RNIS. Des profils d'appel dynamique sont créés pour des utilisateurs RNIS. Sans TACACS+ ou RAYON configuré, un nom d'utilisateur et mot de passe doit être configuré pour chaque utilisateur que l'exigence se connectent l'accès. Toutes les adresses IP sont remises au client par le serveur DHCP. Le serveur d'accès passe l'adresse IP des DN et des serveurs WINS au client pendant la négociation du protocole de contrôle IP de PPP (IPCP).

Serveur d'accès AS5200
version 11.1
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service udp-small-servers
no service tcp-small-servers
!
hostname as5200
!
enable password letmein
!
username Jason password foo
username Laura password bar
username Russ password fake
username Syed password pseudo
username Tito password knockknock
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.16.209.65 255.255.255.192
!
interface Loopback1
 ip address 172.16.209.129 255.255.255.192
!
interface Ethernet0
 ip address 172.16.162.4 255.255.255.0

!
interface Serial0
 no ip address 
!
interface Serial1
 no ip address
!
interface Serial0:23
 no ip address
 isdn incoming-voice modem
 dialer rotary-group 1
 encapsulation ppp
 no fair-queue
!
interface Serial1:23
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn incoming-voice modem
 no fair-queue
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address dhcp

! -- Async dialup users will be assigned ip addresses from 
! -- the dhcp server. The dhcp server is specified with the
! -- ip dhcp-server command shown below.
! -- Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast 
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below.
! -- Refer to the section Command Summary for more information.

 ppp authentication chap
 group-range 1 48
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 peer default ip address dhcp

! -- ISDN dialup users will be assigned ip addresses from the dhcp server.
! -- The dhcp server specified with the ip dhcp-server command shown 
! -- below. Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast  
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below. 
! -- Refer to the section Command Summary for more information.

 dialer in-band
 dialer idle-timeout 300
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
router eigrp 222
 redistribute connected
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
async-bootp dns-server 172.16.224.100 172.16.154.101

! -- Specifies the primary and secondary DNS servers.
! -- The first IP address belongs to the primary DNS server.
! -- If you only have one DNS server you do not need to specify 
! -- a secondary DNS server.
! -- Refer to the section Command Summary for more information.

async-bootp nbns-server 172.16.224.10 172.16.4.2 

! -- Specifies the primary and secondary WINS  servers.
! -- The first IP address belongs to the primary WINS server.
! -- If you only have one WINS server you do not need to specify 
! -- a secondary WINS server.
! -- Refer to the section Command Summary for more information.

ip dhcp-server 172.16.162.10

! -- Specifies the dhcp server ip address. This command is required
! -- if the IP address for dialin clients is obtained from the server.
! -- Note: The dhcp server need not be on the same subnet as the 
! -- Ethernet interface. 
! -- It can be more than one hop away as long has it is reachable.

!
line con 0
 login 
line 1 48
modem InOut
transport input telnet
 autoselect during-login
 autoselect ppp
 flowcontrol hardware
line aux 0
line vty 0 4
 password secret
 login 
!
end

Résumé des commandes

C'est une description des commandes appropriées pour le DHCP, les DN et les WINS sur des serveurs d'accès :

  • adresse de helper-address d'IP — Les informations de protocole DHCP sont diffusées à l'intérieur de des paquets BOOTP. L'expédition d'émission de Protocole BOOTP de commandes enables d'adresse auxiliaire d'IP pour un ensemble de clients. L'adresse auxiliaire devrait spécifier l'adresse du serveur DHCP et devrait être configurée sur l'interface la plus proche du client (dans ce cas le group-async et les interfaces de numérotation). Si vous avez de plusieurs serveurs, vous pouvez configurer une adresse auxiliaire pour chaque serveur. Des adresses auxiliaires sont définies dans RFC 1531leavingcisco.com . Vous ne pouvez pas configurer de plusieurs noms de domaine dans le pool DHCP.

  • peer default ip address dhcp — Spécifie une adresse du mécanisme DHCP à retourner à un pair distant se connectant à cette interface. Ceci signifie que les clients se connectant sur cette interface seront assignent une adresse IP récupérée du serveur DHCP. Vous devriez également spécifier l'adresse IP du serveur DHCP, utilisant l'ip dhcp server de commande, duquel l'adresse IP de client sera obtenue.

  • async-bootp dns-server address — Configure l'adresse du serveur DNS avec lequel le NAS répond en ayant affaire avec les clients de PPP qui implémentent RFC1877leavingcisco.com . L'adresse IP de serveur DNS sera passée au client entrant pendant la négociation IPCP.

  • async-bootp nbns-server address — Spécifie l'adresse IP du serveur de service de nom de Windows (WINS). L'adresse IP de serveur WINS sera passée au client entrant pendant la négociation IPCP.

Vérifiez

Pour vérifier si le client a correctement reçu les paramètres appropriés du serveur d'accès, vous devez tester du client.

Par exemple, du client, cinglez une adresse résoluble de DN telle que www.cisco.com. Si le serveur DNS résout l'adresse, alors la configuration fonctionne correctement. Pour tester l'affectation de serveur WINS, Windows Networking d'utilisation pour parcourir le réseau.

Utilisez la commande de show dialer map après qu'une connexion RNIS soit établie, de voir si un profil d'appel dynamique était créé. Sans lui, vous ne pouvez pas conduire. Vous devriez voir une adresse attribuée au pair (l'adresse a été obtenue du serveur DHCP). Ceci vérifie que l'affectation d'adresses DHCP était réussie.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Ce document suppose que les couches RNIS 1, 2 et 3 fonctionnent correctement. Si vous avez des questions avec la couche inférieure RNIS émet. Référez-vous au document utilisant la commande d'état de show isdn pour le pour en savoir plus de dépannage BRI.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug ppp authentication — Pour voir si un client passe l'authentification. Si vous utilisez une version avant la version de logiciel 11.2 de ½ du ¿  de Cisco IOSïÂ, utilisez la commande de debug ppp chap à la place.

  • debug ppp negotiation — Pour voir si un client passe la négociation PPP ; c'est quand vous vérifiez la négociation d'adresse. La négociation IPCP affiche les DN et les informations de serveur WINS étant passés au client

  • debug ppp error — Pour afficher des erreurs de protocole et des statistiques sur les erreurs a associé avec la négociation et l'exécution de connexion PPP.

Les DN et l'affectation de serveur WINS peuvent être vus pendant la phase IPCP de la négociation PPP. Un résultat témoin est fourni ci-dessous.

Exemple de sortie de débogage

Cette sortie de commande de debug ppp negotiation (pour un appel entrant async) affiche la négociation IPCP pour le client. Dans cet exemple, seulement un serveur de DNS principal a été spécifié. Le serveur WINS n'est pas passé au client.

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
from "maui-nas-02"
Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
from "async_user"
Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]

! -- IPCP negotiation begins

Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2

! -- The IP address for the client is assigned.

Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
id 1 len 15
Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
0x00000001 
(0x120600000001)
Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
EXTENDED 
(0x1105000104)
Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
protocol CCP
Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
Sep 26 12:50:47.483: As97 LCP:  (0x04)
Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
using 172.22.60.2
Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)

! -- The IP address of the client and Primary DNS server's 
! -- IP address are negotiated.

Sep 26 12:50:50.687: As97 IPCP: State is Open

Informations connexes


Document ID: 6303