Interfaces et modules Cisco : Adaptateurs de service Cisco

Configuration et présentation du module de routeur pour la gamme Catalyst 4500/4000 (WS-X4232-L3)

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document décrit le module du routeur WS-X4232-L3 pour les Commutateurs de gamme Cisco Catalyst 4500/4000. En plus d'une description de l'architecture et de la configuration du WS-X4232-L3, ce document fournit également une configuration d'échantillon qui utilise une gamme Catalyst 4500/4000 commutent et le module de routeur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de SYSTÈME D'EXPLOITATION de Cisco Catalyst (CatOS) 5.5(1) ou plus tard

  • Version de logiciel 12.0(7)W5(15d) de Cisco IOSÝ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Le nom du fichier d'image de logiciel Cisco IOS pour le WS-X4232-L3 commence par "cat4232-". Vous pouvez trouver le fichier dans le le Catalyst 4232 sections du secteur de logiciel de téléchargement (clients enregistrés seulement) pour le logiciel de commutation LAN.

Remarque: Il y a soutien du module de routeur quand vous l'utilisez en même temps que l'engine 1 de superviseur et le Supervisor Engine 2. Cependant, il n'y a aucun soutien du module de routeur quand vous l'utilisez en même temps que l'engine 2+ de superviseur, 3, 4, ou 5.

Remarque: Référez-vous à la section de caractéristiques de la note d'installation et de configuration pour le Module de services de la couche 3 de Catalyst 4000 pour plus d'informations sur les caractéristiques de logiciel qui ont le support sur le module de routeur (WS-X4232-L3).

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Vue d'ensemble de l'architecture

Le module WS-X4232-L3 a 32 ports Fast Ethernet et deux ports Gigabit Ethernet.

Ces deux ports Gigabit Ethernet correspondent au gigabit 1 d'interfaces et au gigabit 2 en configuration de routeur. Ces ports Gigabit Ethernet sont les ports conduits.

Intérieurement, le module a deux interfaces de Gigabit Ethernet (gigabit 3 et gigabit 4) qui connectent le routeur au fond de panier de commutateur. Le fond de panier de commutateur emploie les deux premiers ports dans cet emplacement pour se connecter au module de routeur. Quand vous insérez le module WS-X4232-L3 dans l'emplacement 3, le Gigabit Ethernet relie 3 et 4 se connecte aux ports 3/1 et 3/2 du fond de panier. Les ports 3/1 et 3/2 sont des ports de la couche 2 avec la configuration sur l'engine de superviseur de commutateur. Les interfaces 3 et 4 de Gigabit Ethernet sont des ports de la couche 3 avec la configuration sur le module de routeur.

Il y a 32 ports Fast Ethernet sur le module de routeur. Ces ports sont des ports de la couche 2 et ne remplissent aucune fonction de la couche 3. Bien que les ports aient un emplacement physique sur le module de routeur, vous devez configurer les ports sur l'engine de superviseur de commutateur.

Ce diagramme fournit une explication visuelle de l'architecture. Pour cette installation, installez le module de routeur dans l'emplacement 2 du commutateur de Catalyst.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-a.gif

Configuration du WS-X4232-L3

Engine de superviseur

La commande de show port affiche les deux ports de gigabit et les 32 10/100 de ports Mbits/s avec les numéros 1 à 34.

Remarque: Les deux ports de gigabit que vous voyez de l'engine de superviseur ne sont pas les deux ports que vous voyez sur le panneau avant. Les ports que vous voyez de l'engine de superviseur sont les deux ports commutés qui connectent à l'engine d'artère. Vous devez configurer les ports physiques comme ports de commutateur. Cette configuration est semblable à la configuration du module de commutateur multicouche (MSM) sur les Commutateurs de gamme Catalyst 6500/6000. La configuration plus commune pour ces ports est de les placer comme Gigabit EtherChannel (GEC) et jonction. De cette façon, vous pouvez conduire entre tous les VLAN sur le routeur.

Remarque: Vous pouvez accéder au module de routeur de l'engine de superviseur si vous émettez la commande de module# de session. Cette action est semblable pour accéder à du module de route switch (RSM) dans une gamme Catalyst 5500/5000 commutent.

Routeur

Si vous voyez une demande de routeur, recherchez quatre interfaces de Gigabit Ethernet avec des nombres de 1 à 4 (gigabit 1, gigabit 2, gigabit 3, et gigabit 4) et une interface hors bande de Fast Ethernet.

C'est la configuration par défaut :

Router#show run 
Building configuration...  

Current configuration:  
!  
version 12.0  
service config  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname Router  
!  
!  
ip subnet-zero  
!  
!  
!  
interface FastEthernet1  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface gigabitEthernet1  
 no ip address  
 no ip directed-broadcast 

!--- Output suppressed.

Remarque: Dans cette configuration, le gigabit 3 et le gigabit 4 sont les connexions qui va au fond de panier. Le gigabit 1 et le gigabit 2 sont les ports d'utilisateur sur le panneau avant (ports conduits). Le plus souvent, comme sur un MSM, vous configurez le port 3 et le port 4 pour faire partie du même Port canalisé d'interface. En outre, vous configurez des sous-interfaces sur ce canal (avec liaison Inter-Switch Link le protocole [ISL] ou encapsulation de 802.1Q d'IEEE). Comme sur le MSM, la configuration du gigabit 3 et du gigabit 4 sur le module de routeur doit être compatible à la configuration du port slot/1 et slot/2 du côté de commutateur. Vous pouvez vérifier le trafic entre le routeur et le commutateur si vous émettez le show interface port-channel ou affichez des commandes de gigabitethernet d'interface.

Prise en charge de liste d'accès sur le WS-X4232-L3

Il y a soutien de Listes de contrôle d'accès (ACL) sur le module du routeur WS-X4232-L3, mais la configuration d'échantillon que ce document discute ne prend en charge pas ACLs. Référez-vous à configurer ACLs sur le module du routeur WS-X4232-L3 pour la famille de Catalyst 4000 pour plus d'informations sur des configurations d'ACL avec le soutien du module WS-X4232-L3.

Exemples de configuration

La configuration d'échantillon contient les éléments dans cette liste. (Voyez le schéma de réseau.)

  • Coup — Une gamme Catalyst 4500/4000 commute avec un module de routeur dans l'emplacement 3.

  • Liki — Un routeur qui se relie aux Gigabit Ethernet 1 sur le module de routeur.

  • Donald — Un routeur qui se relie dans le VLAN 2 sur le port 3/3 du coup. Le port 3/3 est l'un des ports de la couche 2 du module de routeur.

  • Daniella — Un routeur qui se relie dans le VLAN 3 sur le port 2/3 du coup.

Cette configuration inclut une connexion GEC entre le module de routeur et la gamme Catalyst 4500/4000 commutez. Vous configurez la jonction sur le GEC pour permettre à des VLAN multiples pour passer au routeur pour le routage d'interVLAN. Cette configuration GEC est la configuration standard. Toutes les commandes spécifiques à cette installation sont entrées dans les sous-interfaces de Port canalisé.

Quand vous utilisez le module de la couche 3, souvenez-vous que tout le trafic qui atteint le routeur sur le VLAN indigène est conduit en logiciel. Cette situation exerce un effet inverse sur la représentation du commutateur. Le microcode sur le WS-X4232-L3 ne traite pas le ce de paquets de 802.1Q entré sur le VLAN indigène sans balises. Au lieu de cela, les paquets vont à la CPU, et la CPU traite les paquets. Ce résultats de processus dans l'utilisation du CPU élevé si la CPU reçoit des paquets sans balises à un haut débit sur les sous-interfaces indigènes VLAN. , Créez par conséquent un VLAN factice (qui ne contient aucun trafic d'utilisateur) comme VLAN indigène. Dans cet exemple de configuration (le schéma de réseau), le VLAN 99 sert de VLAN indigène. Configurez seulement le VLAN indigène sur le GEC entre le routeur et le commutateur. Ne configurez aucun autre port sur le commutateur dans ce VLAN factice.

Remarque: Créez un VLAN factice comme VLAN indigène sur les liaisons agrégées entre le routeur et le commutateur. La CPU conduit en logiciel tout le trafic qui envoie en fonction le VLAN indigène, qui exerce un effet inverse sur la représentation du commutateur. Créez un VLAN supplémentaire que vous n'utilisez pas n'importe où ailleurs dans le réseau et faites à ce VLAN le VLAN indigène pour les liaisons agrégées entre le routeur et le commutateur.

Diagramme du réseau

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-b.gif

Les sections de configuration et de configuration du module de routeur d'engine de superviseur de commutateur de ce document présentent les configurations et la sortie de quelques commandes show. Les configurations sont sur le superviseur que l'engine de la gamme Catalyst 4500/4000 commutent et le module de routeur. Ceci permet le routage entre les trois sous-réseaux (VLAN 1, VLAN 2, et le routeur qui se relie aux Gigabit Ethernet 1).

Commutez la configuration d'engine de superviseur

La carte de commutation de routeur affiche 34 ports dans la commande de show module. Ces 34 ports incluent 32 ports commutés au panneau avant et à 2 ports de commutation Gigabit qui se connectent directement à deux des ports de routeur. Voici un échantillon :

bang> (enable) show module
Mod Slot Ports Module-Type                Model                Sub Status  
--- ---- ----- ------------------------- ------------------- ---  --------  
1   1    0     Switching  Supervisor      WS-X4012             no  ok  
2   2    34    10/100/1000  Ethernet      WS-X4232             no  ok  
3   3    34    Router Switch  Card        WS-X4232-L3          no  ok

Mod Module-Name         Serial-Num  
--- ------------------- --------------------  
1                        JAB02380AYG  
2                        JAB03210B6Y  
3                        JAB0417055S  

Mod MAC-Address(es)                         Hw     Fw          Sw  
--- -------------------------------------- ------ ---------- -----------------  
1   00-50-73-2a-f3-00 to 00-50-73-2a-f6-ff 1.0     4.5(1)     5.5(1)  
2   00-50-73-42-a9-68 to 00-50-73-42-a9-89 1.6  
3   00-01-42-06-73-a8 to 00-01-42-06-73-c9 1.0     12.0(7)W5( 12.0(7)W5(14.90

La seule configuration ajoutée du côté de Catalyst 4000 associe au joncteur réseau GEC au module de routeur, car cet échantillon affiche :

bang> (enable) show config

# ***** NON-DEFAULT CONFIGURATION *****  
!  
! 
!  
!  
!  
set port channel all distribution mac both  
!  
#ip  
set interface sl0 down  
set interface me1 down  
!  
#set boot command  
set boot config-register 0x102  
set boot system flash bootflash:cat4000.5-5-1.bin  
!  
#port channel  
set port channel 3/1-2 156  
!  
#module 1 : 0-port Switching Supervisor  
!  
#module 2 : 34-port 10/100/1000 Ethernet  

set VLAN 3    2/3

!  
#module 3 : 34-port Router Switch Card  
set VLAN 2    3/3
set VLAN 99   3/1-2

!--- This interface has a configuration for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the 
!--- router switch must match the one that you have configured on the router.
!--- VLAN 99 is a dummy native VLAN. For more information, 
!--- see the note in the Sample Configurations section.


set trunk 3/1  nonegotiate dot1q 1-1005


!--- Note: Trunk mode needs to be in no-negotiate status
!--- because the router module does not support Dynamic Trunking Protocol (DTP).


set trunk 3/2  nonegotiate dot1q 1-1005
set port channel 3/1-2 mode on


!--- Note: You need to force the channel mode to on because
!--- the router module does not support Port Aggregation Protocol (PAgP).
  
end

Sur le commutateur, la commande neighbor de show cdp affiche le module de routeur comme si le module étaient un routeur externe qui connecte par un joncteur réseau GEC sur les ports 3/1 et 3/2 de gigabit. Voici un échantillon :

bang> (enable) show cdp neighbor
* - indicates vlan mismatch.  
# - indicates duplex mismatch.  
Port     Device-ID                        Port-ID                    Platform  
-------- ------------------------------- -------------------------  ------------  
 2/3     daniella                         Ethernet0                  cisco 2500  
                                         
                                         
                                          
 3/3     donald                           Ethernet0                  cisco 2500

bang> (enable) show trunk 
* - indicates vtp domain mismatch  
Port      Mode          Encapsulation  Status        Native  vlan  
--------  -----------  -------------  ------------   -----------  
 3/1      nonegotiate  dot1q           trunking      99  
 3/2      nonegotiate  dot1q           trunking      99

Port      Vlans allowed on trunk  
--------  ---------------------------------------------------------------------  
 3/1      1-1005  
 3/2      1-1005

Port      Vlans allowed and active in management  domain  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Port      Vlans in spanning tree forwarding  state and not pruned  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Si vous avez la sortie d'une commande de show trunk de votre périphérique de Cisco, vous pouvez utiliser l'Output Interpreter Tool (clients enregistrés seulement) pour afficher des éventuels problèmes et des difficultés.

bang> (enable) show port channel
Port  Status     Channel               Admin Ch  
                  Mode                  Group Id  
----- ---------- -------------------- ----- -----  
 3/1  connected  on                      156   833  
 3/2  connected  on                      156   833  
----- ---------- -------------------- ----- -----

Port  Device-ID                        Port-ID                    Platform  
----- ------------------------------- -------------------------  ----------------  
 3/1  bang-rp                          GigabitEthernet3           cisco Cat4232  
 3/2   Not directly connected to switch  
----- ------------------------------- -------------------------  ----------------

Si vous avez la sortie d'une commande de show port channel de votre périphérique de Cisco, vous pouvez utiliser l'Output Interpreter Tool (clients enregistrés seulement) pour afficher des éventuels problèmes et des difficultés.

Configuration du module de routeur

bang-rp#show verify
Cisco Internetwork Operating System Software  
IOS (tm) L3 Switch/Router Software (CAT4232-IN-M), Version 12.0(7)W5(14.90)   INTERIM 
TEST SOFTWARE  
Copyright (c) 1986-2000 by cisco Systems, Inc.  
Compiled Fri 26-May-00 15:26 by integ  
Image text-base: 0x60010928, data-base: 0x605C8000  

ROM: System Bootstrap, Version 12.0(7)W5(15b) RELEASE SOFTWARE  

bang-rp uptime is 1 day, 22 hours, 7 minutes  
System restarted by power-on  
System image file is "bootflash:cat4232-in-mz.120-7.W5.14.90"  

cisco Cat4232 (R5000) processor with 57344K/8192K bytes of memory.  
R5000 processor, Implementation 35, Revision 2.1  
Last reset from power-on  
1 FastEthernet/IEEE 802.3 interface(s)  
4 Gigabit Ethernet/IEEE 802.3z interface(s)  
123K bytes of non-volatile configuration memory. 

16384K bytes of Flash internal SIMM (Sector size 256K).  
Configuration register is 0x1

bang-rp#show run
Building configuration...
Current Configuration:
!  
version 12.0  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname bang-rp  
!  
!  
ip subnet-zero  
!  
!  
!  
interface Port-channel1                    
 no ip redirects  
 no ip directed-broadcast  
 hold-queue 300 in  
!  
interface Port-channel1.2 


!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 2 tag.


encapsulation dot1Q 2
ip address 2.2.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast    
!  
interface Port-channel1.3

!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 3 tag.

encapsulation dot1Q 3  
ip address 1.1.1.2 255.255.255.0  
no ip redirects  
no ip directed-broadcast  
!
interface Port-channel1.99

!--- The configuration of this interface is for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the router 
!--- must match the one that you have configured on the switch. VLAN 99 is a dummy
!--- native VLAN. For more information, see the note
!--- in the Sample Configurations section.


encapsulation dot1Q 99 native
no ip address
no ip redirects
no ip directed-broadcast
!
interface FastEthernet1                  

!--- You can use this out-of-band interface for management.
  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet1  
 ip address 3.3.3.2 255.255.255.0  
 no ip directed-broadcast  
!  
interface GigabitEthernet2  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet3  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                         

!--- Both  Gigabit Ethernet 3 and Gigabit Ethernet 4 
!--- are part of channel group 1.
  
!  
interface GigabitEthernet4  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                          

!--- Both Gigabit Ethernet 3 and Gigabit Ethernet 4  
!--- are part of channel group 1.
  
!  
router eigrp 1  
 passive-interface FastEthernet1  
 network 1.0.0.0  
 network 2.0.0.0  
 network 3.0.0.0  
!  
ip classless  
!  
arp 127.0.0.2 0050.732a.f300 ARPA  
!  
line con 0  
 transport input none  
line aux 0  
line vty 0 4  
 login  
!  
end  
bang-rp#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route  Bridge  
                   S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce      Holdtme    Capability Platform  Port ID  
liki              Gig 1               
160         T S      
WS-C3508G-Gig 0/1                           

!--- Liki connects to gigabit 1 on the router. 
!--- You can only see Liki from the router; you cannot 
!--- see Liki from the Supervisor Engine.
  
JAB02380AYG(bang)Port-channel1      148          T S       WS-C4003  3/2  
JAB02380AYG(bang)Port-channel1      147          T S       WS-C4003  3/1

Dépannez

La session du superviseur au module 4232-L3 ne fonctionne pas après qu'elle fonctionne pour pendant quelque temps

Après que le commutateur fonctionne pour pendant quelque temps, une session du superviseur au module 4232-L3 échoue avec ce message d'erreur :

4006> (enable) session 2
Trying IntlgLineCard-2...
session: Unable to tunnel to IntlgLineCard-2 (57)

La cause la plus probable pour ceci est due à une contiguïté incorrecte formée dans la table de Protocole ARP (Address Resolution Protocol) de module de superviseur pour l'adresse MAC intrabande du module 4232-L3.

Cette question peut être résolue avec une mise à jour du logiciel système à une version de CatOS non affectée par l'ID de bogue Cisco CSCdx30617 (clients enregistrés seulement).

Si une mise à jour du logiciel système n'est pas possible, vous pouvez essayer ces contournements :

  • Au lieu de sessioning au module, telnet aux adresses IP l'unes des configurées là-dessus.

  • Une remise du module 4232-L3 peut récupérer le problème temporairement.

  • Un mouvement de l'interface sc0 dans un VLAN différent peut également résoudre ce problème.

Demandes périodiques TFTP de 4232-L3

Le module 4232-L3 continuellement essaye de charger une configuration du réseau et affiche ce message d'erreur :

%Error opening tftp://255.255.255.255/network-config (Timed out)

Le module L3 peut être configuré pour télécharger automatiquement le fichier de configuration d'un serveur TFTP quand vous émettez la commande de service config. Enregistrez les fichiers de configuration sur un serveur TFTP et téléchargez-les tout en amorçant. C'est utile quand la taille du fichier de configuration est plus grande que la taille du NVRAM sur le périphérique.

Quand le module L3 est configuré avec la commande de service config, il génère des demandes TFTP de télécharger sa configuration d'un serveur TFTP.

Dans un scénario où un IPS/IDS est utilisé, vous pourriez observer que le routeur envoie continuellement l'émission de tftp. Ceci est confirmé par l'adresse IP de la source et la destination est 255.255.255.255, le trafic est l'UDP 69 (TFTP).

Afin d'arrêter les messages de log d'être généré, émettez ces commandes :

Router#config terminal
Router(config)#no service config
Router(config)#exit
Router#copy running-config startup-config

Conclusion et conseils

Souvenez-vous ces points clé quand vous configurez le module de routage sur le Catalyst 4500/4000 :

  • Les interfaces de gigabit que vous voyez sur le panneau avant ne sont pas identiques comme les interfaces de gigabit que vous voyez quand vous émettez la commande de show port de l'engine de superviseur. Les interfaces sur le panneau avant sont les interfaces avec le gigabit 1 de noms et le gigabit 2 sur le routeur.

  • Assurez-vous que le VLAN indigène des joncteurs réseau entre le commutateur et le routeur est un VLAN factice. La CPU conduit en logiciel tout le trafic qui est sur le VLAN indigène. , Créez par conséquent un VLAN supplémentaire que vous n'utilisez pas ailleurs et faites à ce VLAN le VLAN indigène sur les liens entre le commutateur et le routeur.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 6198