Voix : H.323

Comment configurer la vidéo sur IP pour les unités vidéo Polycom

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Il traite de l'installation et de la configuration de réseaux de base pour la Polycom ViewStation128 (unité de vidéoconférence) avec des routeurs Cisco pour applications de vidéo sur IP. Il couvre également la qualité de service et le dépannage de la qualité vidéo en temps réel à travers les médias LAN et WAN.

Le Polycom Viewstation relie à une TV pour l'affichage de vidéo et audio capturé ; il a également une connexion au RÉSEAU LOCAL pour passer les paquets visuels comprimés au-dessus de l'IP. Le Polycoms sont les points finaux de h323 juste comme n'importe quelle autre passerelle. Le vidéo au-dessus de l'IP utilise les protocoles suivants :

  • H.225 pour la Messagerie de la signalisation de Contrôle d'appel

  • H.245 pour s'ouvrir et se fermer des canaux de flux multimédia

  • H.263 et H.261 pour des codecs vidéos avec l'image formate

  • G.723 pour le Codec audio, aux modes 5.3kpbs ou 6.3kpbs

Le logiciel pour le Polycom ViewStation128 devrait être récent et peut être téléchargé du site Web de Polycom au-dessus du RÉSEAU LOCAL. Le dernier micrologiciel disponible au moment de la publication de ce document était 7.0.1. http://www.polycom.com/home/ leavingcisco.com

Le ViewStation peut envoyer l'appel vidéo et audio comprimé aux débits 128k, 256k, 384k, 512k, 576k, ou 768k. Ce débit de compactage n'inclut pas les en-têtes IP et LAN/WAN ajoutées, ainsi en réservant la bande passante dans QoS, se souviennent pour expliquer ce temps système. Par exemple, audio (vidéo 64kbps)+ (704kbps)+IP(25% overhead)=960kbps.

Le retard optimal pour des applications vidéo est semblable pour exprimer : Round-Trip Time 125-150msec pour des résultats optimaux. La latence ajoutée est tolérable, mais signalé sur le Polycom comme erreur quand vous telnet dans elle.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

L'installation ci-dessous a été testée dans le laboratoire avec des versions de logiciel 12.1(5)T et 12.2(1a) de Cisco IOSÝ sur les Routeurs de Cisco 7200. Le Polycom ViewStation 128 a eu la version de microprogramme 7.0.1.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant : Le Polycoms sont dur codés à bidirectionnel-alterné et à 10Mbps. Le 2900XL a dans ce cas tous les ports dur-codés à l'automatique/à automatique, ainsi aucune modification n'était nécessaire sur le technicien de Cisco 7200 (interface rapide d'Ethernets), ainsi elle est placée à 100/Full. Si l'attache de Polycoms dans certains cas directement au routeur ou au Catalyst commute, les ports doivent être configurés pour apparier le duplex/vitesse en conséquence.

/image/gif/paws/6172/polycom_video_over_ip1.gif

Configuration et installation de Polycom ViewStation

Configurer nécessiter H.323 le ViewStation

Sous les informations système > l'installation d'admin, exécutez ces étapes :

  1. Sous LAN/H.323, et LAN/Intranet, configurez l'adresse IP du Polycom et de la passerelle par défaut.

  2. Sous LAN/H.323, et h323, configurez le nom de h323 pour ce ViewStation et n'importe quel ID E164, si désiré.

  3. (Facultatif) sous LAN/H.323, et h323, QoS peut être spécifié pour l'UDP ou les ports TCP spécifiques. La plage des ports TCP fixes est 3230-3231 et les ports UDP fixes est de 3230 à 3235 pour le trafic visuel. Vous pouvez placer la Priorité IP à essentiel sur les paquets ici, aussi.

  4. Sous la configuration générale, configurez les options standard telles que le nom de système, réponse automatique, numérotation automatique, langage.

Faire H.323 un appel à partir de ViewStation

Tous les appels ici sont faits utilisant l'adresse IP distante ; vous pouvez également utiliser les nombres E.164 si utilisant un garde-porte pour faire des appels vidéos. Sous l'écran principal, saisissez l'adresse IP pour le polycom distant, puis sélectionnez la vitesse de compactage ; ceci devrait s'assortir jusqu'à ce que vous avez placé en tant que par défaut du côté distant.

Configuration des Routeurs avec QoS pour le vidéo

Une des méthodes de QoS les plus efficaces aux utiliser pour VideoOverIP au-dessus de WAN est Fonction Low Latency Queuing (LLQ). Le policymap peut être basé sur quelques différents paramètres, discutés ci-dessous. La bande passante nécessaire peut être dédiée et le vidéo au-dessus d'autres applications IP peut être donné la priorité utilisant LLQ. En outre, le lien atmosphère devrait être VBR-NRT ou CBR pour une qualité vidéo plus élevée.

Configuration de 7206VXR

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


Alternativement, les configurations de liste d'accès suivantes pourraient avoir été utilisées.

  • Basé sur la source/IP address de destination des unités de ViewStation :

    hôte 192.168.1.90 de 192.168.3.90 d'hôte d'IP d'autorisation de la liste d'accès 101

    hôte 192.168.3.90 de 192.168.1.90 d'hôte d'IP d'autorisation de la liste d'accès 101

  • Basé sur la Priorité IP 5 :

    IP d'autorisation de la liste d'accès 101 toute toute priorité 5

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Quand un appel est établi, Polycom maintient tous les paquets visuels. Vous pouvez telnet dans le polycom et surveiller ce plan rapproché. Le Polycom signale la latence dans des paquets de h323, les paquets visuels ou sonores perdus. Le Polycom met au point sont accessible en lecture et indiquent des problèmes quand il peut être difficile de les noter sur un écran vidéo.

Certains des problèmes visuels les plus communs, tels que la congélation, proviennent le duplex Ethernet et/ou la non-concordance de vitesse. Si les compteurs d'Ethernets indiquent le grand nombre de paquets CRC/frame/deferred, la qualité vidéo dégradera considérablement, ainsi le premier point de reprise veille que toutes les interfaces de RÉSEAU LOCAL exécutent exempt d'erreurs.

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Vous pouvez vérifier les configs sur le polycom par l'affichage initial de l'information. Il y a informationnel met au point activé pour chaque action. Quand vous avez un appel vidéo, le Polycoms signalent automatiquement la latence calculée en paquets : en ont perdu des paquets, et ont remis en séquence des paquets en raison des paquets perdus.

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

Avant que QoS ait été appliqué, quand le vidéo et les données ont été exécutés en même temps, le résultat de telnet dans le polycom signalerait le suivant ; c'est une indication de problème claire dans le réseau et devrait se refléter de la qualité vidéo également.

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

La sortie suivante a été capturée dans les routeurs Cisco IOS que LLQ a été appliqué sur les interfaces ATM et des pings alors inondés ont été envoyés pour créer l'encombrement pendant l'appel vidéo. Quand il y a conflit pour la bande passante, LLQ donne la priorité dynamiquement au trafic visuel.

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

Avis dans la sortie suivante qu'il n'y a aucune perte de paquets dans la classe visuelle.

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 6172