Commutation multiprotocole par étiquette (MPLS) : MPLS

Configuration d'un VPN MPLS inter-AS (systèmes autonomes) avec des sessions VPNv4 eBGP entre ASBR

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 décembre 2015) | Commentaires


Contenu


Introduction

Ce document illustre un exemple de configuration pour une Commutation multiprocotole par étiquette (MPLS) pour VPN interautonome de base.

Conditions préalables

Conditions requises

Ce document suppose des connaissances pratiques de MPLS et de MPLS VPN. Veuillez voir la section « de l'information relative » de ce document pour des liens à d'autres documents MPLS VPN.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel suivantes :

  • Versions de logiciel 12.2 et 12.2T de ½ du ¿  de Cisco IOSïÂ

Remarque: Puisque cette configuration utilise une combinaison de codes, le protocole de distribution de balise (Protocole TDP) est utilisé plutôt que le protocole de distribution d'étiquette (LDP). Dans une installation pure LDP, le Forwarding Information Base de balise (TFIB) serait remplacé par le Forwarding Information Base d'étiquette (LFIB), la commande d'expédition de balise d'exposition deviendrait commande de show mpls forwarding, et ainsi de suite.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

http://www.cisco.com/c/dam/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/5811-interasvpn-01.gif

Configurations

Ce document utilise les configurations affichées ci-dessous pour les Routeurs dans le schéma de réseau ci-dessus.

Pulligny
version 12.2
!
hostname Pulligny
!
ip cef

!--- Cisco Express Forwarding (CEF) must be enabled for MPLS.

!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Paulliac
 ip address 10.1.1.2 255.255.255.252
 ip router isis
 tag-switching ip

!--- TDP or LDP needs to be enabled inside each AS.

 frame-relay interface-dlci 913
!
interface Serial0/0.2 point-to-point
 description to Pomerol
 ip address 10.1.1.10 255.255.255.252
 frame-relay interface-dlci 912

!--- No TDP, LDP, or routing protocols enabled on the inter-AS link.

!
router isis
 redistribute connected metric 20

!--- To get the host route created by the Border Gateway Protocol (BGP)
!--- into the Interior Gateway Protocol (IGP).

 net 47.0000.5555.5555.5555.00
 metric-style wide
!
router bgp 1
 no bgp default ipv4-unicast

!--- BGP is not used for IPv4 unicast.

 no bgp default route-target filter

!--- Needed to accept VPNv4 prefixes.

neighbor 10.1.1.9 remote-as 2

!--- External BGP (eBGP) to Pomerol.

 neighbor 10.10.10.4 remote-as 1
 neighbor 10.10.10.4 update-source Loopback0

!--- Internal BGP (iBGP) to PEscara.

 !
 address-family vpnv4
 neighbor 10.1.1.9 activate
 neighbor 10.1.1.9 send-community both
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community extended
 exit-address-family

!--- Address family to allow BGP to carry VPN-IPv4 protocols.

!
ip classless
!
end

PEscara
hostname PEscara
!
ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1

!--- Create a virtual routing and forwarding (VRF) instance called one 
!--- with a route distinguished value of 1:1. Routes with route target
!--- values of 1:1 will be imported into the VRF and exported out
!--- of the VRF.

ip cef

!--- CEF must be enabled for MPLS.

!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0/1.1 point-to-point
 description to Pauillac
 ip address 10.1.1.14 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 973
!
interface Serial0/1.2 point-to-point
 description to CEntrum
 ip vrf forwarding one

!--- Associates the interface with VRF one.

 ip address 120.0.0.1 255.255.255.0
 frame-relay interface-dlci 979
!
router isis
 net 47.0000.7777.7777.7777.00
 metric-style wide
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.10.10.2 remote-as 1
 neighbor 10.10.10.2 update-source Loopback0

!--- iBGP to Pulligny.

 !
 address-family ipv4 vrf one
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family

!--- Address family to allow BGP to carry IPv4 protocols for VRF one
!--- (each VRF that injects routes into BGP must be configured under
!--- the BGP process using its own address family).

 !
 address-family vpnv4
 neighbor 10.10.10.2 activate
 neighbor 10.10.10.2 send-community both
 exit-address-family

!--- Address family to allow BGP to carry VPN-IPv4 protocols.

!
ip classless
!
end

Pauillac

!--- The Pauillac router is a Provider router (p) and its configuration
!--- is quite simple. It is configured for Intermediate System-to-
!--- Intermediate System (IS-IS) and MPLS/Tag switching.

!
hostname Pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Pulligny
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 931
!
interface Serial0/0.3 point-to-point
 description to PEscara
 ip address 10.1.1.13 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 937
!
router isis
 net 47.0000.3333.3333.3333.00
 metric-style wide
!
ip classless
!
end

Pomerol

!--- The Pomerol router is an autonomous system boundary router (ASBR)
!--- like Pulligny and its configuration is very similar to Pomerol's. 

hostname Pomerol
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Pulligny
 ip address 10.1.1.9 255.255.255.252
 frame-relay interface-dlci 921
!
interface Serial0/0.3 point-to-point
 description to PEsaro
 ip address 10.1.1.21 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 925
!
router isis
 redistribute connected metric 20
 net 47.0000.2222.2222.2222.00
 metric-style wide
!
router bgp 2
 no bgp default ipv4-unicast
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 10.1.1.10 remote-as 1
 neighbor 10.10.10.6 remote-as 2
 neighbor 10.10.10.6 update-source Loopback0
 !
 address-family vpnv4
 neighbor 10.1.1.10 activate
 neighbor 10.1.1.10 send-community both
 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community extended
 exit-address-family
!
ip classless
!
end

PEsaro

!--- The PEsaro router is a PE router like the PEscara router, and its 
!--- configuration is very similar.

hostname PEsaro
!
ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/1.1 point-to-point
 description to Pomerol
 ip address 10.1.1.22 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 952
!
interface Serial0/1.2 point-to-point
 description to CErvela
 ip vrf forwarding one
 ip address 220.0.0.1 255.255.255.0
 frame-relay interface-dlci 958
!
router isis
 net 47.0000.5555.5555.5555.00
 metric-style wide
!
router bgp 2
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute connected
 neighbor 10.10.10.3 remote-as 2
 neighbor 10.10.10.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf one
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.10.10.3 activate
 neighbor 10.10.10.3 send-community both
 no auto-summary
 exit-address-family
!
ip classless
!
end

Notes de configuration

  • l'eBGP entre les les deux âne ne peut pas être de multi-alimentation.

  • Le LDP ou le Protocole TDP n'est pas exigé entre les les deux Ass.

  • Un IGP commun n'est pas exigé entre les les deux Ass. Chacun COMME peut utiliser son propre IGP distinct.

  • Le BGP crée une artère d'hôte connecté pour le pair d'eBGP dans le distant COMME une fois que la session qui doit être injectée dans l'IGP de chacun COMME monte.

  • À moins que l'ASBR soit un PE pour chaque VRF que vous voulez permuter, vous devrez ne configurer l'aucune commande de bgp default route-target filter de s'assurer que l'ASBR reçoit les préfixes BGP VPNv4 des autres Routeurs de PE à l'intérieur du AS. Le comportement par défaut est de refuser les préfixes VPNv4 entrants qui ne sont importés dans aucun VRF local.

Vérifier et comprendre Inter-COMME MPLS VPN

Cette section fournit les informations que vous pouvez employer pour confirmer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Pour plus d'informations sur les commandes utilisées ci-dessous, voyez s'il vous plaît comment dépanner le MPLS VPN.

Les exemples suivants affichent l'écoulement de paquet de 220.0.0.0/24 — ce qui est un VRF connecté un préfixe sur PEsaro — à 120.0.0.0/24 — ce qui est un VRF connecté un préfixe sur PEscara.

Routeur de PEsaro

Sont ci-dessous les artères pour VFR un dans le routeur de PEsaro.

PEsaro# show ip route vrf one
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    220.0.0.0/24 is directly connected, Serial0/1.2
     120.0.0.0/24 is subnetted, 1 subnets
B       120.0.0.0 [200/0] via 10.1.1.10, 00:26:49

PEsaro# show ip cef vrf one 120.0.0.1
120.0.0.0/24, version 10, cached adjacency to Serial0/1.1
0 packets, 0 bytes
  tag information set
    local tag: VPN-route-head
    fast tag rewrite with Se0/1.1, point2point, tags imposed: {17 22}
  via 10.1.1.10, 0 dependencies, recursive
    next hop 10.1.1.21, Serial0/1.1 via 10.1.1.10/32
    valid cached adjacency
    tag rewrite with Se0/1.1, point2point, tags imposed: {17 22}

Dans la sortie ci-dessus, vous pouvez voir que le prochain saut pour 120.0.0.0/24 est 10.1.1.10. Vous pouvez également voir que les balises imposées sont 17 et 22. Les informations TFIB et BGP (ci-dessous) t'affichent la source de ces balises : la route BGP pour 120.0.0.0/24 a une balise sortante de 22, et le prochain saut qui est associé avec 120.0.0.0/24 a une balise sortante de 17.

PEsaro# show ip bgp vpnv4 vrf one tags
   Network          Next Hop      In tag/Out tag
Route Distinguisher: 1:1 (one)
   120.0.0.0/24     10.1.1.10       notag/22

!--- VPN label.

   220.0.0.0        0.0.0.0         18/aggregate(one)

PEsaro# show tag forwarding 10.1.1.10
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
17     17          10.1.1.10/32      0          Se0/1.1    point2point

PEsaro# show ip route 10.1.1.10
Routing entry for 10.1.1.10/32
  Known via "isis", distance 115, metric 30, type level-2
  Redistributing via isis
  Last update from 10.1.1.21 on Serial0/1.1, 00:30:39 ago
  Routing Descriptor Blocks:
  * 10.1.1.21, from 10.10.10.3, via Serial0/1.1
      Route metric is 30, traffic share count is 1

10.1.1.10 est annoncé par Pomerol. C'est la route hôte BGP-créée, qui est importante parce qu'elle apparaît en tant qu'étant le bgp next-hop pour les préfixes du distant VPNv4, suivant les indications de la sortie ci-dessus. PEsaro envoie un paquet avec deux étiquettes à Pomerol ; l'étiquette « intérieure » ou de « IGP » est 17.

Routeur de Pomerol

Pomerol# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.6/32     0          Se0/0.3    point2point
17     Pop tag     10.1.1.10/32      540        Se0/0.1    point2point
18     18          1:1:220.0.0.0/24  1704       Se0/0.3    point2point

Pomerol# show ip route 10.1.1.10
Routing entry for 10.1.1.10/32
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via isis
  Advertised by isis metric 20 metric-type internal level-2
  Routing Descriptor Blocks:
  * directly connected, via Serial0/0.1
      Route metric is 0, traffic share count is 1

Remarque: L'artère de /32 pour 10.1.1.10 est créée dès que l'eBGP sera soulevé.

Dans la sortie ci-dessus, vous pouvez voir que Pomerol « sautera » l'étiquette supérieure s'il est 17 ; l'étiquette de l'eBGP VPN sera la seule étiquette laissée sur des paquets envoyés à Pulligny dans AS1.

Routeur de Pulligny

Pulligny# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.1.1.9/32       540        Se0/0.2    point2point
17     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
18     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
19     16          10.10.10.4/32     0          Se0/0.1    point2point
21     Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
22     16          1:1:120.0.0.0/24  1080       Se0/0.1    point2point

La sortie ci-dessus prouve que Pulligny a les balises locales et sortantes pour 120.0.0.0/24 ; considérez, cependant, l'entrée détaillée suivante TFIB :

Pulligny# show tag forwarding detail | begin 22
22     16          1:1:120.0.0.0/24  1080       Se0/0.1    point2point
        MAC/Encaps=4/12, MTU=1496, Tag Stack{16 23}
        E4118847 0001000000017000
        No output feature configured

La sortie ci-dessus prouve que Pulligny a une entrée VPNv4 dans son TFIB, qui est nécessaire parce qu'il y a seulement une étiquette au-dessus de inter-COMME le lien. Puisque Pomerol a sauté l'étiquette 17 de la pile d'étiquette, Pulligny reçoit un paquet avec l'étiquette 22. Il sautera l'étiquette 22 et poussera l'étiquette 23 et l'étiquette 16. En regardant les informations TFIB et BGP (affichées ci-dessous) vous pouvez voir que 16 est l'étiquette d'IGP à obtenir à PEscara, et 23 est l'étiquette VPN que PEscara annonce pour 1:1:120.0.0.0/24.

Pulligny# show ip bgp vpnv4 all tagging
   Network          Next Hop      In tag/Out tag
Route Distinguisher: 1:1
   120.0.0.0/24     10.10.10.4      22/23
   220.0.0.0        10.1.1.9        notag/18

Pulligny# show tagging for 10.10.10.4
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
19     16          10.10.10.4/32     0          Se0/0.1    point2point

Notez que Pulligny change l'étiquette VPN qu'il obtient de PEscara et annonce une étiquette différente à Pomerol. Ce faisant, il ajoute une entrée pour 1:1:120.0.0.0/24 à son TFIB. Ce comportement est le par défaut parce que l'étiquette change toutes les fois que le prochain-saut change (comme en des sessions d'eBGP entre les les deux âne) ; donc, l'ASBR aura une entrée TFIB pour chaque préfixe VPN à l'intérieur de ses gens du pays AS. La sortie ci-dessous prouve que Pauillac a un échange ou un bruit simple d'étiquette parce que le PE est le prochain-saut (saut pénultième sautant [PHP]).

Pauillac# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.4/32     111049     Se0/0.3    point2point
17     Pop tag     10.10.10.2/32     94769      Se0/0.1    point2point
18     Pop tag     10.1.1.8/30       0          Se0/0.1    point2point
19     16          10.1.1.9/32       560        Se0/0.1    point2point

Quand PEscara reçoit l'étiquette 23, il l'identifiera comme faisant partie de VRF un et lui exécutera une consultation IP pour l'expédier à l'interface appropriée (suivant les indications de la sortie ci-dessous).

PEscara# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.1.1.0/30       0          Se0/1.1    point2point
17     Pop tag     10.1.1.4/30       0          Se0/1.1    point2point
18     Pop tag     10.10.10.1/32     0          Se0/1.1    point2point
19     17          10.10.10.2/32     0          Se0/1.1    point2point
21     18          10.1.1.8/30       0          Se0/1.1    point2point
22     19          10.1.1.9/32       0          Se0/1.1    point2point
23     Aggregate   120.0.0.0/24[V]   1040

PEscara# show tag forwarding detail | begin 23
23     Aggregate   120.0.0.0/24[V]   1040
        MAC/Encaps=0/0, MTU=0, Tag Stack{}
        VPN route: one
        Feature Quick flag set

La sortie ci-dessous est un exemple d'un paquet étant envoyé utilisant l'écoulement de paquet expliqué ci-dessus.

Pomerol#
*Mar  1 19:49:59.103: TAG: Se0/0.3: recvd: CoS=0, TTL=255, Tag(s)=17/22
*Mar  1 19:49:59.103: TAG: Se0/0.1: xmit: CoS=0, TTL=254, Tag(s)=22

Pulligny#
*Mar  1 20:21:35: TAG: Se0/0.2: recvd: CoS=0, TTL=254, Tag(s)=22
*Mar  1 20:21:35: TAG: Se0/0.1: xmit: CoS=0, TTL=253, Tag(s)=16/23

Pauillac#
*Mar  1 19:56:39.627: TAG: Se0/0.1: recvd: CoS=0, TTL=253, Tag(s)=16/23
*Mar  1 19:56:39.627: TAG: Se0/0.3: xmit: CoS=0, TTL=252, Tag(s)=23

PEscara#
*Mar  1 19:57:00.463: TAG: Se0/1.1: recvd: CoS=0, TTL=252, Tag(s)=23

L'ordre de next-hop-self sur des ASBR

Si vous choisissez de configurer le next-hop-self que la commande vers l'iBGP scrute sur les ASBR, l'ASBR annonce une étiquette différente (parce qu'une nouvelle étiquette est annoncée quand les modifications de prochain-saut) aux pairs d'iBGP, ajoutant une entrée pour le distant EN TANT QU'artères VPNv4 dans son TFIB. Ceci crée un état supplémentaire dans les ASBR. Vous n'avez pas besoin de redistribuer la route hôte BGP-créée dans l'IGP. Comme affiché ci-dessous, l'ASBR a maintenant des entrées pour des préfixes locaux et distants VPN.

Pomerol# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.6/32     0          Se0/0.3    point2point
17     Pop tag     10.1.1.10/32      540        Se0/0.1    point2point
18     18          1:1:220.0.0.0/24  0          Se0/0.3    point2point
19     22          1:1:120.0.0.0/24  0          Se0/0.1    point2point

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 5811