Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration de l'interface de sauvegarde d'un accès de base (BRI) à l'aide de profils de numéroteur

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cette configuration explique l'utilisation d'un circuit d'accès de base (BRI) RNIS de sauvegarder une ligne louée, un WAN, ou une connexion série.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

La commande backup interface place l'interface dans le mode standby jusqu'au moment où l'interface principale descend. Pour plus d'informations sur la fonctionnalité d'interface de sauvegarde, référez-vous évaluation derrière des Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch pour la sauvegarde DDR.

Cet exemple utilise des Profils de composeur avec la fonctionnalité d'interface de sauvegarde. Utilisant la commande backup interface force l'examen médical ou l'interface logique configuré pour être dans le mode standby. Avec des Profils de composeur, seulement le logique (interface de numérotation) est placé dans le mode standby tandis que l'interface physique (BRI) peut encore être utilisée pour d'autres connexions par la fabrication lui d'un membre d'un autre groupe. Pour plus d'informations sur des Profils de composeur, référez-vous à configurer le RNIS DDR avec des Profils de composeur.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Configurer la sauvegarde de Routage à établissement de connexion à la demande (DDR) implique ces étapes distinctes :

  1. Configurez le DDR. Vous pouvez utiliser le DDR hérité (Cartes de composeur) ou les Profils de composeur. Cette configuration utilise des Profils de composeur. Vérifiez que votre connexion DDR fonctionne correctement avant de mettre en application la configuration de sauvegarde. Ceci te permet pour vérifier que la méthode de cadran utilisée, la négociation de Protocole point à point (PPP), et l'authentification sont réussies avant de configurer la sauvegarde. Pour une configuration de sauvegarde à base de cartes de numéroteur, référez-vous à la sauvegarde du document DDR utilisant BRIs et la commande backup interface.

  2. Configurez un des Routeurs pour initier la connexion DDR quand la liaison principale échoue. Cette configuration utilise une commande backup interface de déclencher le dialout.

  3. Définissez le trafic intéressant qui déclenchera la connexion de sauvegarde quand la liaison principale échoue.

Nous recommandons que vous vous référiez au document configurant et dépannant le pour en savoir plus de sauvegarde DDR.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/5721/bri-to-bri-backup.gif

Configurations

Cette configuration utilise un circuit BRI pour sauvegarder une liaison série. Il utilise également le protocole de routage de Protocole OSPF (Open Shortest Path First) entre les deux Routeurs. Une fois que la connexion de sauvegarde est lancée, vous devez s'assurer que la table de routage est mise à jour pour utiliser la nouvelle liaison de sauvegarde. Seulement un côté (maui-soho-01) est configuré pour composer pour sortir. L'autre côté (maui-nas-05) est configuré pour recevoir seulement l'appel.

Dans cette configuration nous avons un routeur Cisco 1604 connecté à un routeur de Cisco 3640 utilisant une connexion série. Les deux Routeurs sont également équipés des interfaces BRI qui sont utilisées pour la liaison de sauvegarde. Cisco 1604 exécute la version de logiciel 12.1(5)T de Cisco IOSÝ et le Cisco 3640 utilise le Cisco IOS 12.1(2).

Remarque: Configurez la connexion DDR (numéroteur 1 avec BRI0) et la vérifiez qu'il fonctionne correctement avant que vous configuriez l'Interface de sauvegarde et les commandes de sauvegarde de retard. Ceci te permettront pour gérer efficacement des Profils de composeur de dépannage, les questions RNIS, de PPP et d'authentification avant que vous configuriez la sauvegarde.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

Notez les points suivants dans la configuration de maui-soho-01 :

  • La liaison de sauvegarde utilise des Profils de composeur. Ceci permet l'Interface de sauvegarde (numéroteur 1) à être dans le mode standby alors que l'interface physique (BRI 0) n'est pas. Ceci permet à un pour utiliser l'interface physique (par la fabrication lui d'un membre du groupe de numérotation différent) tandis que la liaison principale est en activité. Pour plus d'informations sur des Profils de composeur, référez-vous au document configurant et dépannage des Profils de composeur.

  • Le routeur utilise l'OSPF comme protocole de routage. Vous pouvez utiliser n'importe quel autre protocole de routage (par exemple, RIP, EIGRP) ici aussi bien. Référez-vous au guide de configuration compétent IPC de protocole de routage : Partie : Protocoles de Routage IP. Assurez-vous que vous incluez le réseau d'interface principale et le réseau d'Interface de sauvegarde dans la configuration de protocole de routage de sorte que les informations puissent être propagées par le protocole de routage. Si vous souhaitez utiliser les artères statiques au lieu d'un protocole de routage, créez une artère statique avec le prochain saut étant l'interface du distant BRI (vous pouvez devoir lui faire une Route statique flottante selon le scénario).

  • Tout trafic IP déclenchera le cadran (basé sur dialer-list 1 et dialer-group 1). Ceci fonctionne bien dans un environnement de sauvegarde de l'Interface de sauvegarde DDR puisque la liaison de sauvegarde sera dans le mode standby et incapable de composer quand le primaire est de toute façon. Puisque la liaison de sauvegarde exige du trafic intéressant de composer la liaison de sauvegarde, vérifiez que vous avez une source de trafic générant le trafic intéressant. Dans cet exemple, les paquets HELLO OSPF déclencheront le cadran. Si vous n'utilisez pas un protocole de routage vous pouvez employer des pings d'ICMP pour composer la liaison de sauvegarde. Ajustez le trafic intéressant selon vos besoins.

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Vérifiez les points suivants dans la configuration du serveur maui-nas-05 (3640) :

  • La configuration est semblable à n'importe quelle configuration de dialin. En ce qui concerne le NAS la liaison de sauvegarde est juste un autre appel entrant.

  • L'interface de numérotation n'a pas une chaîne de numéroteur, par conséquent ne peut pas dialout.

  • Tout le trafic est intéressant. Puisque la liaison de sauvegarde ne peut pas dialout de toute façon (voyez que la puce précédente) ceci est acceptable. Si vous rendez le trafic intéressant plus restrictif (par exemple, le protocole de routage est inintéressant), alors il y a la possibilité que le NAS pourrait déconnecter l'appel si aucun trafic intéressant à travers le lien. Dans les scénarios de sauvegarde il est le meilleur de permettre un contrôle de côté (le dialout ou côté de dialin) la liaison de sauvegarde d'éviter l'instabilité de lien.

Test de la liaison de sauvegarde

L'Interface de sauvegarde exige que le protocole d'interface principale soit en baisse avant que l'Interface de sauvegarde soit même mise en évidence du mode standby. Par conséquent, il n'est pas possible de tester la liaison de sauvegarde sans saumurer physiquement la liaison principale vers le bas. Les options sont :

  • Utilisez la commande shutdown d'arrêter l'interface principale. Cependant, n'utilisez pas la commande shutdown sur le routeur avec la commande backup interface configurée. Ceci ne fera pas composer le logiciel de Cisco IOS la liaison de sauvegarde. Vous pouvez lancer la sauvegarde en arrêtant l'interface principale sur le routeur qui n'a pas la commande backup interface. Dans notre scénario, la commande backup interface est configurée sur maui-soho-01 (1600). Par conséquent, exécuter une commande shutdown sur l'interface principale de maui-nas-05 (3640) lancera la liaison de sauvegarde.

  • Réduisez physiquement la connexion principale en débranchant des câbles ou une certaine méthode équivalente afin d'évoquer l'Interface de sauvegarde.

Commandes show

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • état de show isdn - Assurez-vous que le routeur communique correctement avec le commutateur RNIS. Dans le résultat, vérifiez que l'état de la couche 1 soit ACTIVE, et que l'état de la couche 2 = MULTIPLE_FRAME_ESTABLISHED s'affiche. Cette commande affiche également le nombre d'appels actifs.

  • le show ip interface donnent des instructions - Ceci le show dialer 1 (sur maui-soho-01) dans le mode standby. Utilisant le numéroteur 1 pendant que l'Interface de sauvegarde signifie l'interface physique (BRI0) n'est pas dédiée à la sauvegarde. Par conséquent, BRI 0 peut être utilisé pour le DDR normal tandis que la liaison principale est en hausse.

Exemple de sortie avec show

Les sorties suivantes affichent la table de routage sur le côté client. La sortie ci-dessous affiche la table de routage avec l'active de liaison principale.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

La sortie du show ip route (affiché ci-dessus) affiche les artères OSPF apprises du pair utilisant la liaison principale (interface série 0). Permettez-maintenant nous réduisent la liaison principale et lancent la liaison de sauvegarde.

Après que la liaison de sauvegarde soit lancée, la table OSPF est permutée et les nouvelles routes utilisant la liaison de sauvegarde est installées. Le trafic circule maintenant à travers la liaison de sauvegarde.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Commandes de débogage

Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • mettez au point le numéroteur - Ceci est utilisé pour afficher les informations DDR au sujet des paquets reçus sur l'interface de numérotation.

  • debug isdn event - Ceci est utilisé pour voir l'activité RNIS se produire du côté utilisateur de l'interface RNIS.

  • debug isdn q931 - Les expositions établissement d'appel et démolissent de la connexion réseau RNIS (couche 3) entre le routeur et le commutateur RNIS.

  • debug ppp negotiation - Affiche des informations sur le trafic PPP et des échanges tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le NCP. Une négociation PPP réussie ouvre tout d'abord l'état LCP, puis procède à l'authentification, pour terminer par la négociation de NCP.

  • debug ppp authentication - Affiche les messages du protocole d'authentification de PPP, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP). Si vous observez une panne pour vérifier que le nom d'utilisateur et mot de passe de CHAP sont configurés correctement.

  • debug ppp error - Ceci est utilisé pour afficher des erreurs de protocole et des statistiques sur les erreurs associées avec la négociation et l'exécution de connexion PPP.

Dépannage de la sauvegarde DDR

Configurez et vérifiez que la connexion DDR (numéroteur 1 et BRI0) fonctionne correctement avant que vous configuriez l'Interface de sauvegarde et les commandes de sauvegarde de retard. Ceci te permet pour vérifier ce profil du numéroteur, le RNIS, PPP, et l'authentification fonctionne correctement avant de configurer une sauvegarde. Pour dépanner le lien DDR, référez-vous à la technologie d'accès commuté : Techniques de dépannage.

Maintenant que vous avez vérifié que la connexion DDR fonctionne correctement, vous pouvez poursuivre aux étapes de dépannage de sauvegarde suivantes tracées les grandes lignes ci-dessous :

  • Réduisez la liaison principale. N'utilisez pas la commande shutdown sur le routeur avec la commande backup interface configurée. Ceci ne fait pas composer le logiciel de Cisco IOS la liaison de sauvegarde. Vous pouvez lancer la sauvegarde en arrêtant l'interface principale sur le routeur qui n'a pas la commande backup interface. Dans notre scénario, la commande backup interface est configurée sur maui-soho-01 (1600). Par conséquent, exécuter une commande shutdown sur l'interface principale de maui-nas-05 (3640) lance la liaison de sauvegarde. En outre, vous pouvez physiquement réduire la connexion principale en débranchant des câbles ou une certaine méthode équivalente afin d'évoquer l'Interface de sauvegarde.

  • Vous devriez voir un message console indiquer que l'Interface de sauvegarde (l'interface dialer 1) est. Ce message apparaît seulement après l'intervalle spécifié par la commande de sauvegarde de retard a expiré. Dans cette configuration, le retard de sauvegarde de lancement est de 10 secondes. Si vous ne voyez pas ce message console, vérifiez le temporisateur du délai de sauvegarde.

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • Utilisez la commande de show ip route de visualiser la table de routage avec la liaison principale vers le bas. Vous devriez observer une artère direct-connectée au ping du numéroteur 1. l'adresse IP de l'interface de numérotation de routeur distant (qui est sur le même sous-réseau que l'interface dialer 1). Vous devriez voir le lien composer et se connecter.

    • Si le lien ne compose pas, vérifiez que votre définition du trafic intéressant permet l'ICMP (pings).

    • Si le lien est évoqué, nous pouvons conclure que le problème s'est posé parce qu'il n'y avait aucun trafic destiné pour ce sous-réseau. Cependant, il n'est pas réaliste pour forcer la liaison de sauvegarde pour composer basé sur un ping à un hôte spécifique. Pour venir à bout ce problème vous pouvez configurer une Route statique flottante pour le trafic par défaut.

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      Le default route ci-dessus a une adresse du prochain saut de l'interface de numérotation et d'une distance administrative de routeur distant de 200. Cette route flottante permet au routeur pour conduire des paquets à l'interface de numérotation si un meilleur default route (c'est-à-dire, avec une distance administrative inférieure) n'existe pas. Souvenez-vous que nous avons précédemment vérifié que les paquets conduits à l'interface de numérotation font composer le lien.

  • Si le routeur compose le lien, mais ne se connecte pas, alors ce n'est plus une question de sauvegarde DDR et vous devriez se référer à la technologie d'accès commuté : Technique de dépannage pour obtenir davantage d'aide.

Référez-vous à l'Interface de sauvegarde de dépannage de section dans le document configurant et dépannant la sauvegarde DDR pour plus d'information de dépannage.

Exemple de sortie de débogage

La sortie de débogage suivante (du client) affiche la liaison principale manquant et lançant de liaison de sauvegarde :

Remarque: Quelques lignes de sortie de débogage sont divisées en plusieurs lignes pour des raisons d'impression.

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 5721