Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration d'une sauvegarde DDR à l'aide d'accès de base (BRI) et de Dialer Watch

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique l'utilisation d'une ligne d'accès de base (BRI) RNIS de sauvegarder une ligne louée, un WAN, ou une connexion série utilisant la fonctionnalité Dialer Watch. Pour plus d'informations sur les caractéristiques de la Fonction Dialer Watch, référez-vous évaluation derrière des Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch pour la sauvegarde DDR.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Un Cisco 1604 avec 1 interface BRI U exécutant la version de logiciel 12.1(5)T de Cisco IOSÝ.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Cet exemple utilise le Routage à établissement de connexion à la demande (DDR) existant, qui utilise la commande de carte de numéroteur pour la connexion BRI. Vous pouvez également utiliser des Profils de composeur au lieu du DDR hérité (Cartes de composeur). Pour plus d'informations sur des Profils de composeur référez-vous à configurer le RNIS DDR avec des Profils de composeur.

Configurer la sauvegarde DDR implique deux étapes distinctes :

  1. Configurez le DDR avec le DDR hérité ou les Profils de composeur. Vérifiez que votre connexion DDR fonctionne correctement avant de mettre en application la configuration de sauvegarde. Ceci te permettra pour vérifier la méthode de cadran utilisée, la négociation de Protocole point à point (PPP), et l'authentification sont réussie avant de configurer la sauvegarde.

  2. Configurez le routeur pour initier la connexion DDR de sauvegarde quand la liaison principale échoue. Cette configuration emploie la fonctionnalité Dialer Watch pour déclencher le dialout.

Pour plus d'informations sur les étapes nécessaires pour configurer la sauvegarde référez-vous au document configurant et dépannant la sauvegarde DDR

Utilisation de Dialer Watch

Avec la Fonction Dialer Watch, le routeur surveille l'existence d'une artère spécifiée et si cette artère n'est pas présente, elle initie la composition de la liaison de sauvegarde. À la différence d'autres méthodes de sauvegarde (telles que l'Interface de sauvegarde ou les Routes statiques flottantes) la Fonction Dialer Watch n'exige pas du trafic intéressant de déclencher le cadran. Le processus utilisé par la Fonction Dialer Watch est décrit ci-dessous :

  • Quand une route surveillé est supprimée, la Fonction Dialer Watch vérifie au moins une artère valide pour les adresses IP ou les réseaux l'uns des étant observés.

    • S'il n'y a aucune artère valide, la ligne principale est considérée vers le bas et inutilisable.

      • La Fonction Dialer Watch initie alors l'appel, et les Routeurs connectent et permutent les informations de routage. Tout le trafic pour le réseau distant utilisera maintenant la liaison de sauvegarde.

    • S'il y a une artère valide pour au moins un des réseaux IP observés définis et l'artère indique une interface autre que l'Interface de sauvegarde configurée pour la Fonction Dialer Watch, la liaison principale est considérée et la Fonction Dialer Watch n'initie pas la liaison de sauvegarde.

  • Après que la liaison de sauvegarde soit en hausse, la liaison principale est vérifiée de nouveau à l'expiration de chaque délai d'attente de veille. Si la liaison principale demeure vers le bas, le temporisateur de veille est remis à l'état initial. Puisque le routeur devrait périodiquement vérifier si la liaison principale a été rétablie, configurez une petite valeur pour le dialer idle-timeout. Quand la liaison principale est rétablie, le protocole de routage mettra à jour la table de routage et tout le trafic devrait de nouveau transmettre la liaison principale. Puisque le trafic ne passera plus à travers la liaison de sauvegarde, le délai d'attente de veille expirera et le routeur désactivera la liaison de sauvegarde.

    Remarque: En définissant le trafic intéressant, refusez le trafic de protocole de routage pour empêcher des hellos périodiques de remettre à l'état initial le délai d'attente de veille.

  • Si la liaison principale est réactivée, la liaison de secours secondaire sera déconnectée. Cependant un temporisateur de débronchement peut être mis en application de sorte qu'il y ait un retard avant que la liaison de sauvegarde soit abandonnée une fois la liaison principale récupère. Ce temporisateur de délai est démarré quand le temporisateur de veille expire, et la route primaire s'avère. Ce temporisateur de délai peut assurer la stabilité, particulièrement pour les interfaces instables ou les interfaces éprouvant des changements de route fréquente.

Pour plus d'informations sur les caractéristiques de la Fonction Dialer Watch, référez-vous évaluation derrière des Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch pour la sauvegarde DDR.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/5600/bri-backup-map-watch.gif

Configurations

Cette configuration utilise une sauvegarde de circuit BRI une liaison série. Cette configuration utilise également le protocole de routage de Protocole OSPF (Open Shortest Path First) entre les deux Routeurs. Une fois que la connexion de sauvegarde est lancée, vous devez s'assurer que la table de routage est mise à jour pour utiliser la nouvelle route de secours.

Pour plus d'informations sur des conventions de commande, voyez le Conventions relatives aux conseils techniques Cisco.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Remarque: La configuration de maui-nas-05 n'inclut aucune sauvegarde associée commandes. Du point de vue de maui-nas-05, la liaison de sauvegarde est juste un autre client entrant. Ceci peut simplifier la configuration du lieu d'exploitation principal dans les situations où beaucoup de périphériques établissent une liaison de sauvegarde au même central site. Dans les scénarios de sauvegarde, il est idéal d'avoir seulement un initié de côté le cadran, tandis que l'autre côté reçoit seulement des appels.

Commandes de Fonction Dialer Watch

Ce qui suit est une liste des commandes disponibles pour la Fonction Dialer Watch. Certaines de ces commandes ont été incluses dans la configuration ci-dessus, alors que d'autres sont donnés pour la référence.

  • IP de groupe-nombre de dialer watch-list adresse-masque d'IP address : : Définit l'IP adresses ou réseaux à observer. L'adresse ou le réseau (avec le correct masque) qui est configuré doit exister dans la table de routage. Vous pouvez également observer artères de multiple avec la commande de dialer watch-list. Un exemple est montré :

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • montre-groupe de numéroteur groupe-nombre : : Fonction Dialer Watch d'enable sur Interface de sauvegarde. groupe nombre utilisé ici apparie nombre de groupe du numéroteur commande de montre-liste définissant les artères à observer. Le numéroteur l'ordre de montre-groupe avec un nombre de groupe particulier peut seulement être configuré sur une interface. Ceci signifie que le routeur ne peut pas utiliser le multiple interfaces pour fournir la sauvegarde pour une artère particulière. Cependant, une interface peut ayez les plusieurs commandes de montre-groupe de numéroteur, avec différents groupe-nombres. Par conséquent, une interface peut être utilisée pour fournir la sauvegarde pour de plusieurs artères.

  • dialer watch-disable secondes : : Appliquez-vous un temps de retard de débronchement à l'interface. Après que l'interface principale récupère, ce retard empêche déconnecter l'Interface de sauvegarde pour la période indiquée. Ce retard le temporisateur est démarré quand le temporisateur de veille expire, et l'état du primaire l'artère est vérifiée et avérée. Ce retard peut assurer la stabilité, particulièrement pour les interfaces instables ou les interfaces éprouvant l'artère fréquente modifications.

  • groupe-nombre de dialer watch-list secondes d'initiale d'artère-contrôle de retard : Ceci commandes enables le routeur à vérifier si la route primaire est en hausse après le démarrage initial du routeur est complet et le temporisateur (en quelques secondes) expire. Sans cette commande, la Fonction Dialer Watch est seulement déclenchée quand la route primaire est retiré de la table de routage. Si la liaison principale ne soulève pas pendant le démarrage initial du routeur, l'artère n'est jamais ajouté à la table de routage et par conséquent ne peut pas être observé. Par conséquent, avec cette commande, la Fonction Dialer Watch va le faire composez la liaison de sauvegarde en cas d'une défaillance de liaison primaire pendant l'initiale démarrez du routeur.

Vérifiez

Pour plus d'informations, reportez-vous à: Utilisation la commande d'état de show isdn pour BRI Dépannage.

Cette section fournit des informations que vous pouvez employer pour confirmer le votre la configuration fonctionne correctement.

Certaines commandes show sont prises en charge par L'Output Interpreter a pris, dont te permet pour visualiser une analyse sortie de commande show.

  • show dialer [type d'interface nombre] - les informations générales de diagnostic d'affichages pour les interfaces configurées pour le DDR et affiche la configuration du temporisateur et temps avant les temps de connexion. Vous devriez vérifier les messages suivants :

    • Le « état du numéroteur est couche liaison de données en hausse » - le numéroteur a monté correctement.

      • « Couche physique haute » - La ligne protocole a été soulevée, mais le réseau Le Control Protocol (NCP) n'a pas fait.

    • « Composez la raison » que ceci affiche la source et les adresses de destination de le paquet qui a initié la composition.

  • état de show isdn - Assurez à cela le routeur communique correctement avec le commutateur RNIS. Cette commande affiche également nombre d'appels actifs vous devriez vérifier les messages suivants :

    • Le « état de la couche 1 est EN ACTIVITÉ »,

    • « État et fonctionnement de la couche 2 = MULTIPLE_FRAME_ESTABLISHED »

Exemple de sortie avec show

La table de routage du client, maui-soho-01 (1600), avec le primaire le fonctionnement de lien est affiché ci-dessous :

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

La sortie du show ip route affichée ci-dessus, affiche les artères OSPF apprises des pairs utilisant la liaison principale (interface série 0). Notez que l'artère étant observée (172.22.53.0 avec masque 255.255.255.0) existe dans la table de routage. Ceci doit être vérifié pour que la Fonction Dialer Watch fonctionne correctement.

Maintenant nous apportons vers le bas la liaison principale et lançons la liaison de sauvegarde. Ensuite la liaison de sauvegarde est lancée, la table OSPF est permutée et les nouvelles routes utilisant la liaison de sauvegarde est installé. Le trafic passe maintenant à travers la liaison de sauvegarde.

Un exemple de ceci est affiché ci-dessous :

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

La sortie ci-dessus prouve que la table de routage a été mise à jour et tous le trafic utilisera la liaison de sauvegarde (BRI0)

La commande de show dialer peut être utilisée à vérifiez que l'interface DDR a été soulevée correctement. Notez que l'interface BRI a été composé parce que le routeur l'a détecté que la route surveillé a été perdue.

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Dépannez

Dépannage de la Fonction Dialer Watch

Configurez et vérifiez que la connexion DDR fonctionne correctement avant vous configurez la Fonction Dialer Watch. Ceci vous aidera à isoler et dépanner le DDR questions avant que vous abordiez des problèmes relatifs de sauvegarde. En configurant la Fonction Dialer Watch on le recommence que vous utilisez la version de logiciel 12.1(7) ou ultérieures de Cisco IOSÝ. Nous discuterons maintenant plusieurs problèmes et solutions possibles :

Problème : Le routeur ne compose pas la liaison de sauvegarde quand la liaison principale descend.

Solution possible #1 : Utilisez le show ip conduisez la commande de vérifier que l'artère que vous observez existe dedans la table de routage. La route configurée pour la Fonction Dialer Watch doit exactement apparier un dans la table de routage. Ceci inclut vérifier cela le réseau aussi bien que les masques sont identiques. Par exemple, si la table de routage affiche 10.0.0.0/8 et vous utilisez l'IP 10.0.0.0 du dialer watch-list 1 255.255.255.0 (qui est 10.0.0.0/24), la fonctionnalité Dialer Watch ne pourrez pas détecter que 10.0.0.0/8 n'est plus dans la table de routage.

Solution possible #2 : Vérifiez là sont carte de deux numéroteurs déclarations sur l'Interface de sauvegarde.

  • Il devrait y avoir une instruction de mappage pour l'artère/réseau spécifiés par la commande de dialer watch-list

  • Il devrait y avoir une instruction de mappage pour l'adresse IP du distant l'interface du routeur.

Solution possible #3 : Configurez la commande retard de groupe-nombre de dialer watch-list secondes initiales d'artère-contrôle . Reportez-vous à la section : commandes de Fonction Dialer Watch de section pour plus d'informations.

Problème : La liaison de sauvegarde est établie mais aucun routage les informations sont transmises à travers la liaison de sauvegarde.

Solution possible : Vérifiez que l'IP d'Interface de sauvegarde le réseau est inclus dans la configuration de protocole de routage

Problème : La liaison de sauvegarde n'est pas désactivée quand la liaison principale récupère.

Remarque: Avec la Fonction Dialer Watch, le trafic intéressant est seulement utilisé pour contrôler inactif-délai d'attente qui contrôle consécutivement l'intervalle utilisé pour voter l'état du route primaire.

Solution possible #1 : Diminuez le numéroteur inactif-délai d'attente. Le par défaut est de 120 secondes, mais vous pouvez souhaiter à diminuez cette valeur selon vos besoins.

Solution possible #2 : Utilisez l'exposition la commande de numéroteur de vérifier le délai d'attente de veille n'est pas remise à l'état initial.

Changez votre définition du trafic intéressant (configurée avec commande de dialer-list) d'être plus restrictif. Acheminement Le trafic de protocole devrait être inintéressant marqué.

En dernier recours, vous pouvez configurer tout le trafic IP comme inintéressant utilisant l'IP de protocole du dialer-list 1 de commande refusez. Avec cette définition du trafic intéressant, le délai d'attente de veille ne sera jamais remis à l'état initial, et le routeur vérifiera le statut de la liaison principale au spécifié intervalle.

Solution possible #3 : Vérifiez pour s'assurer que la liaison de sauvegarde est moins desirable que la liaison principale de la perspective du protocole de routage en service. C'est de sorte que quand la liaison principale récupère, le protocole de routage dynamique préférera le primaire au-dessus de la liaison de sauvegarde et pas équilibrez la charge à travers les deux liens. Le manque de faire ceci peut entraîner la liaison de sauvegarde pour rester constamment. Show ip route d'utilisation à déterminez si le routeur emploie le primaire et des liaisons de sauvegarde pour conduire le trafic entre les Routeurs. En pareil cas le routeur maintiendra identique routes doublées ; un pour le primaire et un pour la liaison de sauvegarde que vous pouvez utiliser les méthodes suivantes l'unes des pour s'assurer que la liaison de sauvegarde est moins desirable de la perspective du protocole de routage : bande passante, retard, ou distance. Référez-vous à la commande de logiciel de Cisco IOS Référence pour plus de détails.

Pour les couches RNIS générales 1,2 et 3 dépannant se rapportent au document Utilisant l'état de show isdn Commande pour le dépannage BRI.

Dépannage des commandes

Certaines commandes show sont prises en charge par Outil d'Output Interpreter, dont te permet pour visualiser une analyse sortie de commande show.

Remarque: Avant d'émettre des commandes de débogage, voyez s'il vous plaît Les informations importantes en fonction Commandes de debug.

  • mettez au point le numéroteur - Ceci est utilisé pour afficher le DDR informations sur les paquets reçus sur une interface de numérotation.

  • debug isdn q931 - Ceci affiche l'établissement d'appel et démolissez de la connexion réseau RNIS (couche 3) entre le routeur et Commutateur RNIS.

  • debug ppp negotiation - Ceci affichages les informations sur le trafic PPP et des échanges tout en négociant les composants de PPP y compris le Link Control Protocol (LCP), l'authentification, et le NCP. Un réussi La négociation PPP d'abord ouvrira l'état LCP, puis l'authentifie, et finalement négociez le NCP.

  • debug ppp authentication - Ceci affichages les messages du protocole d'authentification de PPP, y compris à échanges confirmés Échanges de paquet de Protocol d'authentification (CHAP) et authentification de mot de passe Échanges de Protocol (PAP). Si vous observez une panne pour vérifier que le CHAP le nom d'utilisateur et mot de passe sont configurés correctement.

  • debug ppp error - Ceci affiche le protocole les erreurs et les statistiques sur les erreurs ont associé avec la négociation de connexion PPP et exécution.

Exemple de sortie de débogage

La sortie de numéroteur de débogage ci-dessous affiche manquer et Fonction Dialer Watch de liaison principale identifiant l'artère perdue. Le routeur initie alors la liaison de sauvegarde. Ensuite chaque fois que l'inactif-délai d'attente expire, contrôles de routeur si la liaison principale est en baisse. Si la liaison principale est trouvée à soyez, Fonction Dialer Watch déconnecte la liaison de sauvegarde après le temporisateur de débronchement expire. Dans met au point, prête l'attention à l'horodateur dans chaque message en tant qu'eux peut fournir des informations sur les divers temporisateurs et les délais d'attente de veille qui sont actif.

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 5600