Composition et accès : Connexions asynchrones

Configuration d'un serveur de terminaux/communications

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Un serveur de terminaux ou de communication fournit généralement un accès hors bande à de nombreux périphériques. Un serveur de terminaux est un routeur avec plusieurs ports asynchrones de faible vitesse qui sont connectés à d'autres périphériques en série, par exemple à des modems ou des ports de console sur des routeurs ou des commutateurs.

Un serveur de terminaux vous permet de n'utiliser qu'un seul point pour accéder aux ports de console de nombreux périphériques. Un serveur de terminaux évite d'avoir à configurer des scénarios de sauvegarde tels que des modems sur des ports auxiliaires pour chaque périphérique. Vous pouvez également configurer un modem simple sur le port auxiliaire du serveur de terminaux afin de fournir un service à accès commuté aux autres périphériques quand la connectivité réseau échoue.

Ce document montre comment configurer un serveur de terminaux pour accéder uniquement aux ports de console sur d'autres routeurs via Reverse Telnet. Reverse Telnet vous permet d'établir une connexion Telnet sur le même périphérique que celui sur lequel vous lancez la commande Telnet, mais sur une interface différente. Pour plus d'informations sur le Reverse Telnet référez-vous à gérer des sessions de telnet.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Câblage

Les routeurs des gammes Cisco 2509 à 2512 utilisent un connecteur à 68 broches et un câble de séparation. Ce câble (CAB-OCTAL-ASYNC) fournit huit ports RJ-45 asynchrones à câble enroulé sur chaque connecteur à 68 broches. Vous pouvez connecter chaque port RJ-45 asynchrone à câble enroulé au port de console d'un périphérique. Le routeur 2511 permet d'accéder à distance à 16 périphériques maximum. En outre, les modules de réseau asynchrones à haute densité NM-16A ou NM-32A sont disponibles pour les routeurs des gammes Cisco 2600 et 3600 et fournissent la même fonction. Pour plus d'informations sur le câblage, reportez-vous aux documents Connectons-nous : Votre guide-câble série et Guide de raccordement de la console et des ports AUX.

Remarque: Les ports asynchrones du connecteur à 68 broches sont des périphériques de type ETD (Équipement pour Terminal de Données). Les périphériques DTE-DTE nécessitent un câble enroulé (null modem) et les périphériques DTE-DCE (équipement de terminaison de circuit de données) un câble droit. Le câble CAB-OCTAL-ASYNC est enroulé. Par conséquent, vous pouvez connecter chaque câble directement aux ports de console des périphériques disposant d'interfaces RJ-45. Cependant, si le port de console du périphérique auquel vous vous connectez est une interface à 25 broches (ETD), vous devez employer l'adaptateur RJ-45-25 broches marqué « modem » (pour inverser l'« enroulement ») afin de compléter la connexion.

Le tableau suivant montre les types de ports pour console et les ports auxiliaires des routeurs et commutateurs Cisco :

Type d'interface Interface DB25 Interface RJ-45
Console DCI DTE
AUX. DTE DTE

Stratégie de conception

Configurez le serveur de terminaux de sorte que vous puissiez y accéder de n'importe où. Afin de rendre le serveur de terminaux accessible, attribuez-lui une adresse Internet publique enregistrée et localisez le serveur en dehors du pare-feu. Ainsi, les problèmes de pare-feu n'interrompent pas votre connexion. Vous pouvez toujours gérer la connectivité au serveur de terminaux et accéder aux périphériques connectés. Si vous êtes préoccupé par la sécurité, configurez des listes d'accès afin de permettre l'accès uniquement au serveur de terminaux de certaines adresses. Pour une solution de sécurité plus robuste, vous pouvez également configurer d'après le serveur l'authentification, l'autorisation et la comptabilité (AAA) par exemple, RADIUS ou TACACS+. Pour plus d'informations sur l'AAA, référez-vous à l'Authentification, autorisation et comptabilité (AAA).

Vous pouvez configurer un modem sur le port auxiliaire du serveur de terminaux pour l'enregistrement d'appel, dans l'éventualité d'une interruption de votre connexion primaire (via Internet). Ce type de modem évite d'avoir à configurer l'enregistrement d'appel pour chaque périphérique. Les ports asynchrones du serveur de terminaux permettent de connecter ce dernier aux ports de console des autres périphériques. Pour plus d'informations sur la connexion d'un modem au port AUX, reportez-vous au Guide de connexion modem-routeur.

Utilisez l'instruction ip default gateway et pointez sur le routeur de saut suivant sur Internet. Cette commande vous permet de disposer d'une connectivité au serveur de terminaux via Internet même si le routage n'est pas activé, par exemple lorsque le serveur de terminaux est en mode moniteur ROM (ROMMON) en raison d'un redémarrage incorrect après une panne de courant.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

Configurations

Ce document utilise la configuration suivante :

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.


!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.


!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.


!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch.
 

!--- An EXEC session ensures that the line never becomes unavailable 


!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.


!--- Allow all protocols to use the line.


!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.


!--- Note: This configuration does not implement modem on AUX port modem InOut. 


!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

Remarque: Si vous utilisez le serveur 3600 comme serveur d'accès, reportez-vous à la rubrique sur la numérotation des lignes asynchrones dans les routeurs de la gamme Cisco 3600 pour connaître le nombre de lignes.

Résumé des commandes

hôte d'IP — Utilisez cette commande de définir le mappage nom/adresse de l'hôte statique dans le cache d'hôte. Pour supprimer le mappage nom/adresse, utilisez la forme no de cette commande.

  • ip host name [tcp-port-number] address1 [address2...address8]

    • nom — Ce champ indique le nom de l'hôte. Le champ Name ne doit pas nécessairement correspondre au nom réel du routeur auquel vous souhaitez vous connecter. Par contre, assurez-vous d'entrer un nom que vous souhaiteriez utiliser dans Reverse Telnet. Si vous utilisez cette commande avec le champ Name, vous n'avez pas besoin de connaître le numéro de port réel du périphérique distant.

    • TCP-port-nombre — Ce champ représente le nombre de port TCP auquel vous voulez se connecter quand vous utilisez le nom d'hôte défini avec un EXÉCUTIF vous connectez ou commande telnet. Dans notre exemple de configuration, nous utilisons une valeur Reverse Telnet, donc le numéro de port doit correspondre à 2000 + le numéro de ligne.

    • address1 — ce champ représente une adresse IP associée. Dans notre exemple de configuration, nous utilisons l'adresse IP de bouclage.

transport input — Utilisez cette commande de définir les protocoles pour utiliser quand vous vous connectez à une ligne spécifique du routeur.

  • transport input {all | lat | balai | nasi | aucun | protection | rlogin | telnet | v120}

    • entièrement tout sélectionne tous les protocoles.

    • aucun — Aucun n'empêche n'importe quelle sélection de protocole sur la ligne. Dans ce cas, le port devient inutilisable pour les connexions entrantes.

    Remarque:  Dans notre exemple de configuration, les lignes asynchrones utilisent la configuration minimale de la commande transport input telnet. Vous pouvez donc lancer la commande Telnet pour les périphériques qui se trouvent sur la ligne asynchrone.

telnet — Utilisez cette commande EXEC de se connecter dans un hôte qui prend en charge le telnet.

  • telnet host [port] [keyword]

    • host Ce champ indique un nom d'hôte ou une adresse IP. La valeur host peut correspondre à l'un des champs Name définis dans la commande ip host.

    • port — Ce champ indique un nombre décimal de port TCP. Le port du routeur Telnet (décimale 23) de l'hôte correspond au numéro de port TCP décimal par défaut. Pour Reverse Telnet, le numéro de port doit correspondre à 2000 + le numéro de ligne. Dans notre configuration, les lignes sont numérotées de 1 à 16. Utilisez la commande show line EXEC pour afficher les lignes disponibles.

Passage d'une session active à une autre

Pour passer d'une session active à une autre, procédez comme suit  :

  1. Tapez la séquence d'échappement Ctrl-Maj-6, puis x pour quitter la session en cours.

  2. Utilisez la commande show sessions pour afficher toutes les connexions ouvertes.

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Remarque: L'astérisque (*) indique la session de terminal en cours.

  3. Entrez le numéro de session (conn) pour vous connecter au périphérique correspondant. Par exemple, vous pouvez vous connecter à l'hôte 2511-1 de type 1, qui correspond au numéro de connexion. Par contre, si vous appuyez sur la touche Retour, vous serez connecté à la session de terminal en cours, en l'occurrence le routeur 2511-3.

Fermeture d'une session active

Pour quitter une session Telnet, procédez comme suit :

  1. Tapez la séquence d'échappement Ctrl-Maj-6, puis x pour quitter la session Telnet en cours.

    Remarque: Assurez-vous de pouvoir lancer la séquence d'échappement de façon fiable pour suspendre une session Telnet. Certains logiciels d'émulation de terminaux ne peuvent pas envoyer la séquence correcte, Ctrl-Maj-6, puis x.

  2. Lancez la commande show sessions pour afficher toutes les connexions ouvertes.

  3. Lancez la commande disconnect [connection] pour déconnecter la session voulue.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • le show ip interface donnent des instructions — indique si l'interface que vous utilisez pour la session de telnet est en hausse.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Procédure de dépannage

Suivez ces instructions pour dépanner votre configuration.

Si vous ne pouvez pas vous connecter au routeur de votre choix avec un nom configuré dans la commande ip host, vérifiez les points suivants :

  1. Vérifiez que l'adresse de port est configurée correctement.

  2. Vérifiez que l'adresse (interface) utilisée pour Reverse Telnet est active/active. Ces informations sont fournies par la commande show ip interface brief. Cisco recommande d'utiliser des bouclages, car ils sont toujours actifs.

  3. Assurez-vous que vous disposez du type de câblage correct. Par exemple, vous ne devez pas utiliser un câble croisé pour augmenter la longueur. Pour plus d'informations, reportez-vous à la section Câblage.

  4. Établissez une connexion Telnet sur le port de l'adresse IP pour tester la connectivité en direct. Vous devez lancer une commande Telnet à la fois depuis un périphérique externe et depuis le serveur de terminaux. Par exemple, telnet 172.21.1.1 2003.

  5. Vérifiez que la commande transport input telnet se trouve bien sous la ligne correspondant au périphérique cible. Le périphérique cible est celui qui est connecté au serveur de terminaux.

  6. Utilisez un terminal PC/dumb pour vous connecter directement à la console du routeur cible. Le routeur cible est celui qui est connecté au serveur de terminaux. Cette étape vous aide à identifier la présence d'un problème de port.

  7. Si vous êtes déconnecté, vérifiez les délais d'attente. Vous pouvez les supprimer ou les modifier.

    Remarque: Si vous rencontrez des échecs d'authentification, n'oubliez pas que la première authentification est exécutée par le serveur de terminaux (si configuré), alors que la seconde est exécutée par le périphérique auquel vous essayez de vous connecter (si configuré). Vérifiez que le paramètre AAA est correctement configuré à la fois sur le serveur de terminaux et sur le périphérique de connexion.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 5466