Composition et accès : Connexions asynchrones

Configuration de l'accès sortant en utilisant un modem sur le port AUX

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique comment utiliser un modem sur le port auxiliaire afin de configurer l'accès extérieur par réseau commuté. Dans ce scénario, un routeur sur lequel est connecté un modem à l'aide du port auxiliaire compose l'accès primaire (PRI) du routeur principal du site.

Remarque: Nous ne dépeignons pas un scénario de sauvegarde, mais affichons simplement la numérotation de Routage à établissement de connexion à la demande (DDR) entre les Routeurs avec un modem sur le port auxiliaire.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous comprenez les diverses questions associées avec des Modems sur des ports auxiliaires. Pour plus d'informations sur ces questions, voir le Guide de connexion modem-routeur.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Un routeur de gamme Cisco 2600 qui exécute le Cisco IOS ? ? Version de logiciel 12.1(2).

  • Un routeur de Cisco AS5300 qui exécute le Logiciel Cisco IOS version 12.0(7)T.

Remarque: Cette configuration peut être appliquée à n'importe quel routeur avec un port auxiliaire ou même un port de console. Cependant, en raison des questions du contrôle de modem RS232 et de quelques questions liées à la sécurité, il n'est pas recommandé pour relier un modem au port de console. Voyez le pour en savoir plus de Guide de connexion modem-routeur.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/5465/mod-aux-dialout.gif

Configurations

Ce document utilise les configurations suivantes :

  • maui-slt-01 (2600)

  • maui-nas-03 (5300)

Dans cette configuration, Maui-slt-01(2600), utilise le modem sur le port auxiliaire pour composer le PRI de maui-nas-03 (un AS5300). Le NAS (maui-nas-03) est configuré pour envoyer l'appel à un modem numérique interne.

maui-slt-01 (2600)
maui-slt-01#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-slt-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-nas-03 password 0 cisco

!--- Defines username for remote router (maui-nas-03), and shared secret 
!--- password. Shared secret (used for CHAP authentication)
!--- must be the same on both sides.

!
memory-size iomem 30
ip subnet-zero
!
chat-script Dialout ABORT ERROR ABORT BUSY "" 
"AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

!--- Sets up chat script "Dialout" used for the dialout connection on aux 0.

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!--- Modemcap (MY_USR_MODEM) is applied to the AUX port line interface.
!--- This modemcap was created through the command:
!--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
!--- See the Modem-Router Connection Guide for more information.

!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!

!--- Irrelevant output has been removed.

!
interface Async65

!--- Async interface that corresponds to the AUX Port. 
!--- This was determined through the show line command.
!--- See External Modem Setup and Troubleshooting Tasks for more information.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation over this link.

 dialer in-band
 dialer pool-member 20

!--- Designate Async65 as member of dialer pool 20.
!--- The dialer pool 20 command is specified in interface Dialer 10.

 async default routing

!--- This permits routing over the async interface.
!--- This is required for a routing protocol to run accross the async link.

 ppp authentication chap callin
!
interface Dialer10

!---Dialer 10 is the logical interface for Dialer Pool 20.

 ip unnumbered Loopback0

!--- This uses the Loopback 0 IP address.

 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name maui-nas-03

!--- This specifies the remote router name. 
!--- This name must match the name that the remote router uses for 
!--- authentication.

 dialer pool 20

!--- Async 65 is a member of this pool.

 dialer idle-timeout 900
 dialer string 81690

!--- This defines the phone number of the destination router.

 dialer max-call 4096
 dialer-group 1

!--- Apply the definition of interesting traffic from dialer-list 1.


 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls.

!
router ospf 5
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0

!---OSPF is used between the routers.
!---A routing protocol is unnecessary if you configure appropriate static routes.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10

!--- Default route points to int dialer 10. 
!--- This is necessary because OSPF is not configured to send default routes.

no ip http server
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Use access list 101 for interesting traffic definition.
!--- This is applied to interface Dialer 10 through dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
!
line aux 0

!--- Line interface for the AUX port.

 exec-timeout 0 0

!--- This disables exec timeout on the interface.

 script dialer Dialout

!--- Use chat script "Dialout".

 modem InOut

!--- This enables incoming and outgoing calls.

 modem autoconfigure type MY_USR_MODEM

!--- Now apply the modemcap MY_USR_MODEM that you configured previously.

 transport input all
 stopbits 1

!--- Reduce async framing overhead to improve throughput. 

 speed 115200

!--- The AUX port on the 2600 supports a speed of 115200.
!--- Note: If you route through the AUX port, each character generates a 
!--- processor interrupt. This is an abnormally high load on the CPU, 
!--- which can be resolved if you use a lower AUX port speed.

 flowcontrol hardware

!--- This configures RTS/CTS flow control.

line vty 0 4
!
no scheduler allocate
end

maui-nas-03 (5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-slt-01 password 0 cisco

!--- Defines username for remote router (maui-slt-01) and shared secret password.
!--- Shared secret(used for CHAP authentication) must be the same on both sides.

spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
ip subnet-zero
!
isdn switch-type primary-ni
mta receive maximum-recipients 0
!
controller T1 0

!--- Primary T1.

 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

!--- Irrelevant output has been removed.

!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.22.53.105 255.255.255.0
 no ip directed-broadcast
 no keepalive
!

!--- Irrelevant output has been removed.

!
interface Serial0:23

!--- D-channel for T1 0.

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- This sends incoming async calls to the modems.

 fair-queue 64 256 0
 ppp authentication chap
!         

!--- Irrelevant output has been removed.

!
interface Group-Async0

!--- Group-Async interface is used to aggregate the modems.

 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf network point-to-point

!--- This identifies the type of OSPF network. 

 async default routing

!--- This permits routing over the async interface.
!--- It is required for a routing protocol to run on the async link.

 async mode interactive
 peer default ip address pool clientpool

!--- This assigns an IP address from the pool named "clientpool" for the
!--- incoming call.

 ppp authentication chap
 group-range 1 96
!
router ospf 5
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
!
ip local pool clientpool 172.22.1.2 172.22.1.30

!--- IP addresses for dialin calls are given from this pool.

ip classless
no ip http server
!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 1 96
 autoselect ppp
 modem InOut
 transport preferred lat pad telnet rlogin udptn v120 lapb-ta
 transport output lat pad telnet rlogin udptn v120 lapb-ta
line aux 0
line vty 0 4
!
end

Remarque: maui-nas-03 n'est pas particulièrement configuré pour recevoir des appels seulement de client maui-slt-01(the). Du point de vue du NAS (maui-nas-03), l'appel entrant est juste un autre client entrant. Cette configuration peut être utilisée pour que beaucoup de clients distants composent le PRI du NAS de lieu d'exploitation principal, et se connecte au réseau d'entreprise.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Exemple de sortie avec show

Utilisez la commande de show ip route de vérifier s'il y a une artère au numéroteur ou à l'interface asynchrone. S'il n'y a aucune artère à l'async ou la composition d'interface de numérotation ne peut pas se produire. , Configurez par conséquent les artères statiques selon les besoins.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Dialer10

Remarque: Il y a un default route à l'interface de numérotation.

Le routeur alors initie le cadran, se connecte, négocie le PPP, et permute la base de données OSPF. Pour plus de détails sur ce processus voyez les informations de débogage qui suivent :

Utilisez la commande de show ip route après que la connexion soit réussie. Dans ce scénario, l'OSPF de protocole de routage est utilisé. Observez les artères OSPF ajoutées à la table de routage.

maui-slt-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1795] via 172.22.1.1, 00:00:03, Dialer10
C       172.22.1.1/32 is directly connected, Dialer10
S*   0.0.0.0/0 is directly connected, Dialer10

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Tâches d'installation et de dépannage de Modem externe

Terminez-vous ces étapes pour installer le Modem externe et pour le vérifier que le modem fonctionne correctement. Quand vous vérifiez que le routeur peut composer et se connecter à l'aide de ce modem, la configuration nécessaire DDR aussi bien que la configuration PPP et d'autres configurations de protocole de plus haut niveau peuvent être faites sur le routeur composant pour sortir. Cette section suppose que le routeur qui reçoit l'appel est configuré correctement, comme affiché ci-dessus.

  1. Reliez le câble approprié le du port auxiliaire au modem. Pour plus d'informations sur des options de câblage, voyez le Guide de connexion modem-routeur.

  2. Utilisez la commande de show line de déterminer l'interface asynchrone du port auxiliaire. Bien que la plupart des Routeurs aient le port auxiliaire comme interface 1 async, les serveurs d'accès ont l'interface de port AUX après les lignes TTY. Par exemple, si votre routeur a 16 async ou lignes du modem, le port auxiliaire est la ligne 17. En pareil cas, le port auxiliaire doit être configuré sur l'interface 17 async. Configurez le port auxiliaire basé sur les sorties de show line. Cet exemple vérifie cela sur maui-slt-01 que la configuration du port AUX est sur l'interface Async65.

    maui-slt-01#show line
       Tty Typ   Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise  Overruns  Int
    *    0 CTY            -    -      -    -    -     0      0     0/0      -
        65 AUX 9600/9600  -    -      -    -    -     0      1     0/0      -
        66 VTY            -    -      -    -    -     0      0     0/0      -
        67 VTY            -    -      -    -    -     0      0     0/0      -
        68 VTY            -    -      -    -    -     0      0     0/0      -
        69 VTY            -    -      -    -    -     0      0     0/0      -
        70 VTY            -    -      -    -    -     0      0     0/0      -
    
    Line(s) not in async mode -or- with no hardware support: 
    1-64
  3. Configurez un modemcap pour le modem connecté au port auxiliaire. Référez-vous au Guide de connexion modem-routeur pour que la chaîne d'initialisation appropriée soit utilisée pour la plate-forme de modem. Créez un nouveau modemcap qui inclut que chaîne d'initialisation (init). Voici un exemple pour un nouveau modemcap (MY_USR_MODEM Désigné) :

    maui-slt-01(config)#modemcap edit MY_USR_MODEM miscellaneous &F1S0=1

    Dans la configuration ci-dessus de modemcap &F1S0=1 est la chaîne d'initialisation. Référez-vous à créer un Modemcap pour des informations spécifiques sur la chaîne d'initialisation appropriée pour votre modem.

  4. Appliquez le modemcap au port auxiliaire. Nous avons précédemment vérifié que le port auxiliaire est sur la ligne 65.

    maui-slt-01(config)#line 65
    maui-slt-01(config-line)#modem autoconfigure type MY_USR_MODEM

    Vous devriez également configurer la ligne du port AUX pour la Connectivité de modem. Référez-vous au Guide de connexion modem-routeur pour les informations sur la ligne configuration. La configuration d'échantillon pour maui-slt-01 affiché inclut précédemment également les commandes nécessaires.

    Employez le debug confmodem pour vérifier si le modemcap est correctement appliqué. Après que vous arrêt et redémarrage le modem, le routeur configure automatiquement le modem.

    maui-slt-01#debug confmodem
    Modem Configuration Database debugging is on
    maui-slt-01#
    
    !--- Power cycle the modem.
    
    *Mar  1 06:58:10.118: TTY65: detection speed (115200) response ---OK---
    *Mar  1 06:58:10.122: TTY65: Modem command:  --AT&F1S0=1--
    
    !--- Apply the init string specified in the modemcap.
    
    *Mar  1 06:58:10.758: TTY65: Modem configuration succeeded
    
    !--- Modem configuration is successful.
    
    *Mar  1 06:58:10.758: TTY65: Detected modem speed 115200
    *Mar  1 06:58:10.758: TTY65: Done with modem configuration
    maui-slt-01#
  5. Émettez le show line commande aux. d'aux.-line de 0 ou de show line. Vérifiez que tous les signaux sont en hausse. Par exemple, CTS, RTS, DTR, CD. Si rien n'apparaît à côté de eux, ils sont. Si « non » apparaît à côté de eux (par exemple, aucun CTS), il signifie qu'ils sont vers le bas. S'ils sont vers le bas, vérifiez la le câble et la configuration sur le routeur. Vérifiez également si vous avez l'interface asynchrone et la ligne du port auxiliaire configuré correctement. Pour plus d'informations sur le câblage, référez-vous au guide de connexion de modem routeur. Utilisez le document sur des connexions entrantes de dépannage pour les informations sur la façon dont dépanner des questions. Voici un exemple :

    maui-slt-01#show line 65
       Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
    A   65 AUX 115200/115200- inout     -    -    -      8       1     1/0       -
      Ready
    
    Line 65, Location: "PPP: 172.22.1.1", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
    Status: Ready, Active, No Exit Banner, Async Interface Active
      Modem Detected, CTS Raised, Modem Signals Polled
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Modem Autoconfigure
    Modem state: Ready
    Group codes:    0
    Line is running PPP routing for address 172.22.1.1.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS
    
    !--- All signals are up.
    
     TTY NUMBER 65
    Parity Error = 0 Framing Error = 536 Receive Error = 536 Overrun = 1
    Outcount = 0 totalout = 40615 incount = 0 totalin = 49805
    , Modem Configured
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none                   
    Timeouts:    Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                 00:10:00        never                        none    not set
                              Idle Session Disconnect Warning
                                never 
                              Login-sequence User Response
                               00:00:30
                              Autoselect Initial Wait
                                not set 
    Modem type is MY_USR_MODEM.
    
    !--- Modemcap is MY_USR_MODEM.
    
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 10.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed transports are lat pad v120 mop telnet rlogin nasi. 
    Preferred is lat.
    No output characters are padded
    No special data dispatching characters
    maui-slt-01# 
  6. Exécutez r

    le telnet d'everse le port auxiliaire au modem, et emploient le positionnement de commande AT manuellement pour composer et se connecter au périphérique distant. Ceci peut être utilisé pour vérifier que le circuit de matériel et de téléphone de modem fonctionnent correctement. Dans cet exemple, parce que le port auxiliaire est sur la ligne 65, vous devez renverser le telnet au port 2065 sur le routeur. Pour plus d'informations sur des telnets inverses référez-vous à établir une session Reverse Telnet à un modem.

    maui-slt-01#telnet 172.17.1.1 2065 
    Trying 172.17.1.1, 2065 ...Open
    
    User Access Verification
    
    Username: admin Password:
    
    !--- Authentication performed by local router for the reverse Telnet.
    
    at
    OK
    atdt 81690 
    
    !--- The modem dials (81690), and connects. 
    !--- This process takes approximately 30 to 45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connection speed and protocols that were negotiated.
    
    User Access Verification
     
    Username: maui-slt-01
    Password:
    
    !--- Authentication performed by the remote router for the incoming call.
    
    
    
    maui-nas-03>
    
    !--- Prompt on the remote router.
    
    

    Comme affiché ci-dessus, nous exécutons le telnet inverse au modem, et utilisons à la commande de vérifier si le modem répond. Quand vous recevez l'OK, composez le numéro distant avec l'aide de la commande de nombre d'atdt. L'appel poursuit, et se connecte au périphérique distant. Le routeur distant authentifie alors l'appel entrant. Si vous observez que le Modem externe ne compose pas, vérifiez que le câblage est correct, que le Modem externe n'est pas défectueux, et que la ligne téléphonique est en activité. Référez-vous à configurer la prise en charge de modem et d'autres caractéristiques asynchrones et à dépanner le pour en savoir plus de connexions entrantes.

    Quand vous vous êtes terminé les tâches et les procédures ci-dessus, vous pouvez poursuivre pour tester si le routeur peut évoquer la connexion d'accès par réseau commuté automatiquement. Référez-vous aux sections d'exemple de sortie avec show et d'exemple de sortie de débogage de theConfiguring Dialout utilisant un modem sur le pour en savoir plus de document de port auxiliaire.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • mettez au point le numéroteur ? ? ? les affichages mettent au point des informations sur les paquets reçus sur une interface de numérotation. Quand le DDR est activé sur l'interface, les informations qui concernent la cause de n'importe quel appel (appelé la cause d'appel) sont également affichées. Le pour en savoir plus, voient la commande de numéroteur de débogage dedans mettre au point le CLNS - mettez au point les fras.

  • debug modem ? ? ? affiche l'activité de ligne du modem, le contrôle de modem et les messages d'activation de processus sur le routeur.

  • mettez au point la conversation ? ? ? surveille l'exécution du script de conversation quand la composition async/POTS est initiée. Référez-vous à appeler sortant async - Vérifiez la section d'exécution de script de conversation de technologie d'accès commuté : Pour en savoir plus de techniques de dépannage.

  • debug ppp negotiation ? ? ? affiche des informations sur le trafic PPP et des échanges comme il négocie les composants de PPP comme, Link Control Protocol (LCP), authentification, et protocole de contrôle de réseau (NCP). Une négociation PPP réussie d'abord ouvre l'état LCP, puis authentifie, et négocie finalement le NCP.

  • debug ppp authentication ? ? ? affiche les messages du protocole d'authentification de PPP, cela incluent des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP).

Exemple de sortie de débogage

Utilisez ces commandes de débogage de dépanner la connexion :

maui-slt-01#debug dialer
Dial on demand events debugging is on
maui-slt-01#debug chat
Chat scripts activity debugging is on
maui-slt-01#debug modem
Modem control/process activation debugging is on
maui-slt-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-slt-01#debug ppp authentication
PPP authentication debugging is on       
maui-slt-01#
maui-slt-01#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
maui-slt-01#
maui-slt-01#ping 172.22.53.105

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.22.53.105, timeout is 2 seconds:

*Mar  1 05:37:44.858: As65 DDR: rotor dialout [priority]
*Mar  1 05:37:44.858: As65 DDR: Dialing cause ip (s=172.17.1.1, d=172.22.53.105)

!--- Dialing reason.

*Mar  1 05:37:44.858: As65 DDR: Attempting to dial 81690

!--- Phone number that is dialed.

*Mar  1 05:37:44.858: CHAT65: Attempting async line dialer script
*Mar  1 05:37:44.858: CHAT65: Dialing using Modem script: Dialout
 & System script: none

!--- Use the chat-script "Dialout".

*Mar  1 05:37:44.862: CHAT65: process started
*Mar  1 05:37:44.862: CHAT65: Asserting DTR
*Mar  1 05:37:44.862: TTY65: Set DTR to 1
*Mar  1 05:37:44.862: CHAT65: Chat script Dialout started

!--- Chat-script "Dialout" has started.

*Mar  1 05:37:44.862: CHAT65: Sending string: AT
*Mar  1 05:37:44.862: CHAT65: Expecting string: OK
*Mar  1 05:37:44.990: CHAT65: Completed match for expect: OK
*Mar  1 05:37:44.990: CHAT65: Sending string: ATDT \T<81690>
*Mar  1 05:37:44.990: CHAT65: Expecting string: CONNECT
*Mar  1 05:38:02.774: CHAT65: Completed match for expect: CONNECT
*Mar  1 05:38:02.774: CHAT65: Sending string: \c
*Mar  1 05:38:02.774: CHAT65: Chat script Dialout finished, status = Success

!--- Chat script is successful. 
!--- Notice the Expect/Send Attributes and the time elapsed.

*Mar  1 05:38:02.774: TTY65: destroy timer type 1
*Mar  1 05:38:02.778: TTY65: destroy timer type 0
*Mar  1 05:38:04.778: %LINK-3-UPDOWN: Interface Async65, changed state to up
*Mar  1 05:38:04.778: Async65 DDR: Dialer statechange to up
*Mar  1 05:38:04.778: %DIALER-6-BIND: Interface As65 bound to profile Di10
*Mar  1 05:38:04.782: Async65 DDR: Dialer call has been placed
*Mar  1 05:38:04.782: As65 PPP: Treating connection as a callout

!--- PPP LCP negotiation begins.

*Mar  1 05:38:04.782: As65 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 05:38:04.782: As65 PPP: No remote authentication for call-out
*Mar  1 05:38:04.782: As65 LCP: O CONFREQ [Closed] id 43 len 20
*Mar  1 05:38:04.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:04.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:04.786: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:04.786: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:06.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:06.782: As65 LCP: O CONFREQ [REQsent] id 44 len 20
*Mar  1 05:38:06.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:06.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:06.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:06.782: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.782: As65 LCP: TIMEout: State REQsent
*Mar  1 05:38:08.782: As65 LCP: O CONFREQ [REQsent] id 45 len 20
*Mar  1 05:38:08.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.782: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.782: As65 LCP:    ACFC (0x0802)

!--- Observe that two outgoing CONFREQs timed out.
!--- If you observe such a situation with no incoming CONFREQs, verify that the 
!--- autoselect ppp or async mode dedicated commands are configured
!--- on the router that receives the call.

*Mar  1 05:38:08.934: As65 LCP: I CONFREQ [REQsent] id 2 len 25
*Mar  1 05:38:08.934: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.934: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.934: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.938: As65 LCP: O CONFACK [REQsent] id 2 len 25
*Mar  1 05:38:08.938: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.938: As65 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 05:38:08.938: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
*Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.942: As65 LCP: I CONFACK [ACKsent] id 45 len 20
*Mar  1 05:38:08.946: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 05:38:08.946: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
*Mar  1 05:38:08.946: As65 LCP:    PFC (0x0702)
*Mar  1 05:38:08.946: As65 LCP:    ACFC (0x0802)
*Mar  1 05:38:08.946: As65 LCP: State is Open
*Mar  1 05:38:08.946: As65 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 05:38:09.066: As65 CHAP: I CHALLENGE id 1 len 32 from "maui-nas-03"
*Mar  1 05:38:09.066: As65 CHAP: O RESPONSE id 1 len 32 from "maui-slt-01"
*Mar  1 05:38:09.206: As65 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful.

*Mar  1 05:38:09.206: As65 PPP: Phase is UP
*Mar  1 05:38:09.210: As65 IPCP: O CONFREQ [Not negotiated] id 13 len 10
*Mar  1 05:38:09.210: As65 IPCP:    Address 172.17.1.1 (0x0306AC110101)
*Mar  1 05:38:09.218: As65 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.218: As65 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
*Mar  1 05:38:09.350: As65 IPCP: I CONFNAK [ACKsent] id 13 len 10
*Mar  1 05:38:09.350: As65 IPCP:    Address 172.22.1.9 (0x0306AC160109)
*Mar  1 05:38:09.350: As65 IPCP: O CONFREQ [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: I CONFACK [ACKsent] id 14 len 4
*Mar  1 05:38:09.478: As65 IPCP: State is Open

!--- IPCP negotiation is complete.

*Mar  1 05:38:09.482: As65 DDR: dialer protocol up
*Mar  1 05:38:09.482: Di10 IPCP: Install route to 172.22.1.1
*Mar  1 05:38:10.206: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,
 changed state to up

!--- Interface is up.


Informations connexes


Document ID: 5465