Interfaces et modules Cisco : Module de commutation de contenu Cisco

Configuration du mode (routeur) sécurisé sur le module de commutation de contenu

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le module de commutation de contenu (CSM) fournit les connexions performantes entre les utilisateurs du réseau et les batteries de serveur basés sur la couche 4 les informations à 7. Vous pouvez représenter un groupe de vrais serveurs (la batterie de serveur) comme exemple de serveur unique (serveur virtuel), équilibrer le trafic à la batterie de serveur en sélectionnant une des méthodes d'équilibrage de charge du serveur, et le trafic de limite à différents serveurs (connexions adhérentes) et à batteries de serveur (stratégies). Cette configuration d'échantillon décrit comment configurer l'Équilibrage de charge de serveur (SLB) sur la famille CSM du Catalyst 6000.

Vous ne pouvez pas exécuter le logiciel du Ý SLB de Cisco IOS sur le même commutateur que le CSM. Vous devez configurer le mode CSM en émettant le mode de slb d'IP [csm | commande RP] avant toute configuration. Dans la commande de mode de slb d'IP, l'argument RP est par défaut.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Release 12.1(8)EX IOS de Supervisor de la famille du Catalyst 6000 pour l'engine 1 de superviseur avec MSFC1 (c6sup11-jsv-mz.121-8.EX)

  • Version de logiciel 2.1(0) CSM de famille du Catalyst 6000 (c6slb-apc.2-1-1.bin)

Les passages CSM sur la Cisco IOS version 12.1(6)E ou ultérieures. Si vous utilisez un Supervisor Engine 2, vous devez utiliser la Cisco IOS version 12.1(8a)E ou ultérieures.

Mode de fonctionnement

Les connexions de client et serveur par le CSM peuvent utiliser la couche 2 ou le commutation de couche 3. Les clients se connectent au côté client VLAN, et les serveurs se connectent au côté serveur VLAN. Les serveurs et les clients peuvent exister sur des différents sous-réseaux. Les serveurs mettent en boîte se trouvent également plus d'un saut loin et se connectent au côté serveur VLAN par des Routeurs. Dans ce cas, la passerelle par défaut des serveurs et le routage par le réseau des serveurs au côté serveur VLAN CSM doivent diriger tout le trafic équilibré par chargement des serveurs par le CSM, ou le client de serverfarm NAT doit être configuré dans le CSM pour tout le trafic destiné aux serveurs dans la batterie de serveur. Un client envoie une demande à une adresse de VIP, au Ý et au CSM en avant la demande à un serveur qui peut satisfaire la demande. Le serveur en avant la réponse au CSM, et le CSM en avant la réponse au client.

Quand le côté client et le côté serveur VLAN sont dans les différents sous-réseaux, vous pouvez configurer le CSM en mode sécurisé (de routeur). Foyers de cette configuration d'échantillon sur la configuration de mode sécurisée (de routeur). Quand le côté client et le côté serveur VLAN sont dans le même sous-réseau, vous pouvez configurer le CSM pour opérer en mode de sous-réseau unique (passerelle). Référez-vous aux configurations d'échantillon au-dessous du pour en savoir plus.

Diagramme du réseau

Le côté client et le côté serveur VLAN sont sur des différents sous-réseaux en mode sécurisé (de routeur). Le diagramme affiche comment la configuration de mode sécurisée (de routeur) est installée.

csm_router.gif

Configurations

Terminez-vous ces étapes pour configurer le CSM pour le mode sécurisé (de plusieurs sous-réseau) :

  1. Sélectionnez le mode CSM.

    cat(config)# ip slb mode csm
    
  2. Créez le client et serveur VLAN dans la base de données. En annulant le mode de base de données VLAN, les modifications de configuration sont appliquées.

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. Configurez les interfaces physiques qui connectent le client (liaison ascendante) au VLAN correspondant.

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. Configurez les interfaces physiques qui connectent les serveurs au VLAN correspondant.

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. Créez le côté client VLAN et la passerelle.

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. Créez le côté serveur VLAN.

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. Créez le serverfarm.

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. Créez le vserver et associez le serverfarm.

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

Ce qui suit est une configuration d'échantillon d'équilibrage de charge du serveur qui utilise le Cisco Catalyst 6500 et le CSM.

Configuration en cours CSM (WS-X6066-SLB-APC)
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
Ýmain-cpu 
Ý auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.Ý 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
Ýip address 172.17.63.217 255.255.255.192 
Ýgateway 172.17.63.210 
! 


!--- Server side VLAN configuration.Ý
 
ip slb vlan 200 server 
Ýip address 10.1.1.251 255.255.255.0 
Ýalias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
Ýnat serverÝ 
Ýno nat client 
real 10.1.1.3 
Ý inservice 
Ýreal 10.1.1.5 
Ý inservice 
! 


!--- Vserver configuration.Ý
 
ip slb vserver SERVER 
Ývirtual 172.17.63.241 tcp www 
Ýserverfarm WWWFARM 
Ýinservice 
! 
interface GigabitEthernet1/1 
Ýno ip address 
Ýshutdown 
! 
interface GigabitEthernet1/2 
Ýno ip address 
Ýshutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
Ýno ip address 
Ýswitchport 
Ýswitchport access vlan 100 
Ýswitchport mode access 
! 
interface FastEthernet2/2 
Ýno ip address 
Ýshutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
Ý 
interface FastEthernet2/3 
Ýno ip address 
Ýswitchport 
Ýswitchport access vlan 200 
Ýswitchport mode access 
! 
interface FastEthernet2/4 
Ýno ip address 
Ýswitchport 
Ýswitchport access vlan 200 
Ýswitchport mode access ... 
interface FastEthernet2/48 
Ýno ip address 
Ýshutdown 
! 
interface Vlan1 
Ýno ip address 
Ýshutdown 
! 
interface Vlan100 
Ýip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
Ýlogin 
! 
end

Commandes show

Remarque: Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

commande d'état de slb de show ip

La commande d'état de slb de show ip affiche le statut du module SLB. Le module doit être en ligne.

cat6#show ip slb statusÝ
SLB Module is online in slot 3.Ý
Configuration Download state: COMPLETE, SUCCESS

commande de vserver de slb de show ip

La commande de vserver de slb de show ip affiche les informations de serveur virtuel. Vous voyez également l'état du serveur virtuel et combien de connexions là sont :

cat6#show ip slb vserver
slb vserverÝÝ protÝÝÝ virtualÝÝÝÝÝÝÝÝÝÝÝÝÝ vlanÝÝ stateÝÝÝÝÝÝÝÝ connsÝÝÝÝÝÝÝÝÝÝ
---------------------------------------------------------------------------
SERVERÝÝÝÝÝÝÝ TCPÝÝÝÝ 172.17.63.241/32:80Ý ALLÝÝÝ OPERATIONALÝÝ 0

commande de show ip slb reals

L'affiche des informations de commande de show ip slb reals pour chaque vrai serveur, tel que la batterie de serveur où chaque serveur réside, les états de serveur, les seuils, et les connexions.

cat6#show ip slb reals
realÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ server farmÝÝÝÝÝ weightÝ stateÝÝÝÝÝÝÝÝÝ conns
-------------------------------------------------------------------
10.1.1.5ÝÝÝÝÝÝÝÝÝÝÝÝÝ WWWFARMÝÝÝÝÝÝÝÝÝ 8ÝÝÝÝÝÝ OPERATIONALÝÝÝ 0ÝÝÝÝÝÝÝÝ
10.1.1.3ÝÝÝÝÝÝÝÝÝÝÝÝÝ WWWFARMÝÝÝÝÝÝÝÝÝ 8ÝÝÝÝÝÝ OPERATIONALÝÝÝ 0

commande de show ip slb serverfarms

La commande de show ip slb serverfarms affiche les informations de ferme de serveur. Cette commande montre le predictor utilisé pour l'Équilibrage de charge. Cet exemple utilise le par défaut, recherche séquentielle.

cat6#show ip slb serverfarm
server farmÝÝÝ predictorÝÝÝ natÝÝ realsÝÝ redirectÝ bind id
-------------------------------------------------------------
WWWFARMÝÝÝÝÝÝÝ RoundRobinÝÝ SÝÝÝÝ 2ÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 0

commande de VLAN de slb de show ip

La commande de VLAN de slb de show ip affiche les informations VLAN pour le client et le serveur.

cat6# show ip slb vlan
vlanÝÝ IP addressÝÝÝÝÝÝ IP maskÝÝÝÝÝÝÝÝÝÝÝ typeÝÝ
---------------------------------------------------
100ÝÝÝ 172.17.63.217ÝÝÝ 255.255.255.192ÝÝÝ CLIENT
200ÝÝÝ 10.1.1.251ÝÝÝÝÝÝ 255.255.255.0ÝÝÝÝÝ SERVER

Dépannez

Vous pouvez seulement cingler le vrai serveur du Catalyst 6500 à l'aide de la commande de slb de ping, comme affiché ci-dessous.

cat6#ping slb 10.1.1.3Ý
IP addressÝÝÝÝÝÝ ReachableÝ
--------------------------Ý
10.1.1.3ÝÝÝÝÝÝÝÝ Yes

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 5448