IP : Protocole BGP (Border Gateway Protocol)

Présentation de la redistribution de routes OSPF en BGP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cette Note technique explique le comportement de la redistribution d'Open Shortest Path First (OSPF) dans Border Gateway Protocol (BGP) sur des routeurs Cisco. Le comportement de la redistribution OSPF dans BGP est souligné dans RFC 1403 .leavingcisco.com

Il y a plusieurs types de routes OSPF :

  • Intra-zone - Dans un réseau OSPF multizones, des routes, lancées dans une zone, sont connues par les routeurs dans la même zone que des routes intra-zone. Ces routes sont signalées comme O dans le résultat de commande show ip route.

  • Inter-zone - Quand une route croise un routeur Area Border Router (ABR) OSPF, la route est connue comme route inter-zone OSPF. Ces routes sont signalées comme O IA dans le résultat de commande show ip route.

    Les routes intra-zone et inter-zone sont toutes deux également appelées routes internes OSPF, car elles sont générées par le routage OSPF lui-même, quand une interface est couverte avec la commande de réseau OSPF.

  • Type-2 externe ou Type-1 externe - Des routes qui ont été redistribuées dans le routage OSPF, tel que routage connecté, routage statique, ou tout autre protocole de routage, sont connues en tant que Type-2 externe ou Type-1 externe. Ces routes sont signalées comme E2 ou O E1 dans le résultat de commande show ip route.

  • NSSA type 2 externe ou NSSA type 1 externe - Quand une zone est configurée comme Not-So-Stub Area (NSSA) et que des routes sont redistribuées dans le routage OSPF, les routes sont connues comme NSSA type 2 externe ou NSSA type 1 externe. Ces routes sont signalées comme O N2 ou O N1 dans le résultat de commande show ip route.

    La description des différences entre NSSA externe et NSSA type 2 ou 1 dépasse la portée de ce document - référez-vous au Guide de conception OSPF pour plus d'informations.

Le comportement par défaut n'est pas de redistribuer des routes depuis OSPF dans BGP. La redistribution doit être configurée. Vous pouvez utiliser la commande route-map pour filtrer des routes pendant la redistribution du routage OSPF dans BGP. Lors de la redistribution, des mots clés spécifiques comme internal, external et nssa-external sont requis pour redistribuer les routes respectives.

Conditions préalables

Conditions requises

Une compréhension des types de route OSPF est requise avant d'utiliser ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configuration du réseau

Quatre cas de redistribution des routes OSPF dans BGP sont abordés ci-dessous. Le diagramme de réseau s'applique aux trois premiers cas. Le diagramme et la configuration du quatrième cas peuvent être consultés dans la section Redistribution des routes NSSA-externes de routage OSPF dans BGP.

/image/gif/paws/5242/bgp-ospf-redis1.jpg

Redistribution des routes OSPF internes uniquement (intra-zone et inter-zone) dans BGP

Si vous configurez la redistribution de l'OSPF dans le BGP sans mots clé, seulement l'intra-zone et les routes inter-zone OSPF sont redistribuées dans le BGP, par défaut. Vous pouvez utiliser le mot clé internal avec la commande redistribute sous router bgp pour redistribuer les routes OSPF intra-zone et inter-zone.

Cette configuration est une nouvelle configuration du routeur B qui redistribue seulement la route intra-zone (131.108.2.0/24) et la route inter-zone (131.108.1.0/24) dans BGP et seules les routes OSPF internes (intra-zone et inter-zone) sont redistribuées dans BGP :

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!-- This redistributes only OSPF intra- and inter-area routes into BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

Le routeur B redistribue seulement les routes internes de routage OSPF :

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

Routeur C se renseignant sur ces routes depuis BGP :

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

Redistribution des routes OSPF externes uniquement (type 1 et 2) dans BGP

Utilisez le mot clé external avec la commande redistribute sous router bgp pour redistribuer des routes externes de routage OSPF dans BGP. Avec le mot clé external, vous avez trois choix :

  • redistribuez à la fois le routage externe type-1 et type-2 (par défaut)

  • redistribuez le routage type-1

  • redistribuez le routage type-2

Sélectionnez les commandes dans le mode de configuration comme décrit ici :

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

Dans cette configuration du routeur B, nous redistribuons seulement des routes externes de routage OSPF, mais à la fois de type-1 et type-2 :

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- This redistributes ONLY OSPF External routes, 
!--- but both type-1 and type-2.


 neighbor 3.3.3.3 remote-as 200
!
end

Remarque: La configuration affiche match external 1 external 2 et la commande entrée était redistribute ospf 1 match external. C'est normal parce que le routage OSPF ajoute automatiquement « external 1 external 2 » dans la configuration. Il correspond à la fois aux routes OSPF externe 1 et externe 2 et il redistribue les deux routes dans BGP.

Le routeur B redistribue seulement les routes externes de routage OSPF :

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

Le routeur C se renseigne sur ces deux routes externes de routage OSPF depuis BGP :

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

Redistribution des routes OSPF externes Type 1 ou Type 2 uniquement dans BGP

Sélectionnez cette commande sous router bgp 100 sur le routeur B pour redistribuer seulement les routes externes 1 de routage OSPF :

router bgp 100
 redistribute ospf 1 match external 1

La table de routage BGP du routeur B montre qu'il redistribue seulement les routes 1 externes dans le BGP et toutes les autres routes OSPF ne sont pas redistribuées dans BGP :

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

De même, sélectionnez cette commande sous router bgp 100 sur le routeur B pour redistribuer seulement les routes externes 2 de routage OSPF :

router bgp 100
 redistribute ospf 1 match external 2

Redistribution des routes OSPF internes et externes dans BGP

Dans ce cas, toutes les routes OSPF sont redistribuées dans BGP à l'aide des mots clés internal et external, suivant les indications de cette configuration du routeur B :

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- This redistributes all OSPF routes into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

De nouveau, external est remplacé par external 1 external 2 dans la configuration. C'est normal à moins que vous spécifiiez les routes externes spécifiques que vous voulez redistribuer dans BGP. Après avoir modifié la configuration, le routeur B redistribue toutes les routes OSPF et le routeur C commence à apprendre toutes les routes de BGP :

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

Redistribution des routes OSPF NSSA-externes dans BGP

C'est un cas particulier dans lequel seules des routes Not-So-Stubby Area (NSSA) sont redistribuées dans BGP. Ce cas est très semblable au cas décrit dans la section Redistribution des routes OSPF externes uniquement (Type 1 et 2) dans BGP. La seule différence est que le BGP correspond maintenant aux routes NSSA-externes et non juste aux routes externes. La table de routage du routeur B montre ces routes OSPF NSSA-externes :

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

Ce diagramme de réseau est utilisé pour ce cas :

/image/gif/paws/5242/bgp-ospf-redis2.jpg

Le diagramme de réseau montre que le routage du routeur B reçoit le routage OSPF N1 et les routes de N2. Le comportement par défaut est de redistribuer à la fois les routes N1 et N2 si seul le mot clé nssa-external est utilisé. Cette configuration du routeur B nous permet de redistribuer les routes OSPF N1 (200.1.1.0/24) et OSPF N2 (200.2.2.0/24) dans BGP :

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1 
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- This redistributes only OSPF NSSA-external routes 
!--- Type-1 and Type-2 into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

Remarque: Comme la configuration externe de routage OSPF, la configuration ci-dessus affiche match nssa-external 1 nssa-external 2 et la commande entrée était redistribute ospf 1 match nssa-external. C'est normal parce que le routage OSPF ajoute automatiquement « nssa-external 1 nssa-external 2 » dans la configuration. Il correspond à la fois à la route OSPF N1 et à la route OSPF N2 et redistribue les deux routes dans BGP.

Après la modification de configuration sur le routeur B, le routeur B redistribue les routes NSSA-externes de routage OSPF et le routeur C commence à apprendre les routes NSSA-externes de routage OSPF à partir du BGP :

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp 
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

De la même manière qu'avec des routes externes de routage OSPF, pour redistribuer seulement des routes OSPF N1, saisissez la commande suivante sous le router BGP 100 sur le routeur B :

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- This redistributes only OSPF NSSA-external 
!--- Type-1 routes into BGP.

Pour redistribuer seulement des routes N2 de routage OSPF, saisissez la commande suivante sous le router BGP 100 sur le routeur B :

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- This redistributes only OSPF NSSA-external 
!--- Type-2 routes into BGP.

Remarque: Des route-map peuvent également être utilisés pour redistribuer le type 1/2 OSPF dans le BGP. Référez-vous redistribuent des artères OSPF E2 dans le pour en savoir plus BGP.

Modifiez l'option de redistribution dans le routage OSPF

Il est important de comprendre comment la modification de configuration successive peut modifier votre configuration. Une nouvelle commande avec l'option de correspondance n'écrase pas la précédente mais est ajoutée à celle-ci. Débutant sans redistribution, cet exemple de séquence de commandes de configuration montre son incidence sur la redistribution :

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Initially, we redistribute internal OSPF routes into BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- With this second command, we tell BGP 
!--- to also redistribute external OSPF routes.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- With this no command, we only disable the 
!--- redistribution of external type 2 into BGP. 
!--- All other types of routes previously configured remain.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- As you can see, internal and external type 1 remain.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z 

!--- Now, with this no command, which includes all configured 
!--- keywords, it is important to note that we 
!--- still do not disable the redistribution fully.
!--- We only removed the keyword. After this, 
!--- the IOS still acts as default—redistributing
!--- internal routes only.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 

!--- Always use this command in order to completely
!--- disable redistribution.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

Impossible de redistribuer des routes acquises iBGP dans un IGP tels que EIGRP, OSPF

La redistribution de routes est utilisée pour propager des routes acquises avec l'utilisation d'un protocole de routage, dans un autre protocole de routage. Quand le BGP est redistribué dans un IGP, seules les routes eBGP acquises sont redistribuées. Les routes iBGP acquises connues sur le routeur ne sont pas introduites dans l'IGP afin d'empêcher la formation de boucles de routage.

Par défaut, la redistribution iBGP dans IGP est désactivée. Émettez la commande bgp redistribute-internal afin d'activer la redistribution des routes iBGP dans IGP. Des précautions doivent être prises pour redistribuer des routes spécifiques à l'aide de feuilles de route dans IGP.

Un exemple de configuration pour redistribuer des routes iBGP dans le routage OSPF est montré ici :

router bgp 65345 
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

Remarque: La redistribution des routes Border Gateway Protocol (iBGP) internes dans un Protocole IGP peut entraîner des boucles de routage dans l'Autonomous System (AS). Ceci n'est pas recommandé. Des filtres de route doivent être définis afin de contrôler les informations de routage, qui sont importées dans l'IGP.

Redistribuez les default route OSPF dedans au BGP

Afin de redistribuer des default route dedans au BGP, utilisez la déclaration de réseau et le default-information commencent. Dans notre exemple, les default route OSPF sont redistribués dedans au BGP. Ceci est fait avec la création d'un route-map et la distribution du réseau par défaut, qui est permis par l'ACL standard.

!
route-map map_default_only permit 10

 match ip address acl_default_only

!

ip access-list standard acl_default_only

 permit 0.0.0.0

!

router bgp 64601

network 0.0.0.0

 redistribute ospf 1 route-map map_default_only

 default-information originate

!--- distributes the default route in bgp

!

Après la configuration, effacez les sessions BGP avec le clear ip bgp * commande.


Informations connexes


Document ID: 5242