Interfaces et modules Cisco : Module de commutation de contenu Cisco

Configuration du mode sous-réseau unique (pont) dans CSM

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le module de commutation de contenu (CSM) fournit l'Équilibrage de charge de serveur (SLB) performant entre les périphériques de réseau et les batteries de serveur basés sur des brochures d'information de la couche 4 à 7. Batteries de serveur qui sont représentées pendant que les serveurs virtuels peuvent améliorer l'évolutivité et la Disponibilité des services pour votre réseau. Vous pouvez ajouter de nouveaux serveurs et retirer les serveurs défectueux ou existants à tout moment sans affecter la Disponibilité du serveur virtuel.

Les clients se connectent au CSM en fournissant l'adresse virtuelle IP (VIP) du serveur virtuel. Quand un client initie une connexion au serveur virtuel, le CSM choisit un vrai serveur (un périphérique physique qui est assigné à une batterie de serveur) pour la connexion basée sur les algorithmes d'équilibrage de charge et les stratégies configurés (règles d'accès). Les stratégies gèrent le trafic en définissant où envoyer des demandes de l'information de client.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Cette configuration peut être utilisée avec tous les logiciel et versions de matériel qui prennent en charge le CSM.

Théorie générale

Les clients et serveurs communiquent par le CSM technologie de ½ utilisant de la couche 2 ou de la couche 3ï ¿  dans une configuration de la particularité VLAN. Les clients se connectent au côté client VLAN et aux serveurs se connectent au côté serveur VLAN. Les serveurs et les clients peuvent exister sur des différents sous-réseaux. Les serveurs mettent en boîte se trouvent également plus d'un saut loin et se connectent au côté serveur VLAN par des Routeurs. Un client envoie une demande à une des adresses du VIP du module. Le CSM en avant cette demande à un serveur qui peut répondre à la demande. Le serveur puis en avant la réponse au CSM, et le CSM en avant la réponse au client.

Quand le côté client et le côté serveur VLAN sont sur les mêmes sous-réseaux, vous pouvez configurer le CSM en mode de sous-réseau unique (passerelle). Ce document décrit le mode de sous-réseau unique (passerelle).

Quand le côté client et le côté serveur VLAN sont sur des différents sous-réseaux, vous pouvez configurer le CSM pour opérer en mode sécurisé (de routeur). Le pour en savoir plus, se rapportent à configurer le mode sécurisé (de routeur) sur le CSM.

Configurez

Diagramme du réseau

Le diagramme suivant montre différents VLAN et différents sous-réseaux.

csm-bridge.gif

Configurations

Procédez comme suit :

  1. Créez le client et serveur VLAN sur le MSFC.

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. Configurez les interfaces physiques qui connecte le client (la liaison ascendante) au VLAN correspondant.

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. Configurez les interfaces physiques qui connecte les serveurs au VLAN correspondant.

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. Configurez le CSM.

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. Créez le côté client VLAN et la passerelle.

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. Créez le côté serveur VLAN.

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. Créez la batterie de serveur.

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. Créez Vserver et associez la batterie de serveur.

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

C'est une configuration d'échantillon de SLB utilisant le Cisco Catalyst 6500 et le CSM.

Configuration en cours CSM (WS-X6066-SLB-APC)
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
�main-cpu 
� auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.�
 
! 
module ContentSwitchingModule 3� 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
�vlan 100 client 
� ip address 172.17.63.217 255.255.255.192 
� gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
�vlan 200 server 
� ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
�serverfarm WWWFARM 
� nat server� 
� no nat client 
� real 172.17.63.215 
�� inservice 
� real 172.17.63.216 
�� inservice 
! 

!--- VServer configuration. 

! 
�vserver SERVER 
� virtual 172.17.63.241 tcp www 
� serverfarm WWWFARM 
� persistent rebalance 
� inservice 
! 
interface GigabitEthernet1/1 
�no ip address 
�shutdown 
! 
interface GigabitEthernet1/2 
�no ip address 
�shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
�switchport 
�switchport access vlan 100 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/2 
�no ip address 
�shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/4 
�switchport 
�switchport access vlan 200 
�switchport mode access 
�no ip address 
! 
interface FastEthernet2/5 
�no ip address 
�shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
�ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
�login 
! 
end

Vérifiez (commandes show)

show module csm # commande d'état

Le show module csm # commande d'état affiche le statut du module SLB. Le module doit être en ligne.

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

show module csm # commande de détail de mot de nom de vserver

Le show module commande de détail de mot de nom csm # de vservers affiche les informations détaillées de serveur virtuel. Vous voyez également l'état du serveur virtuel et combien de connexions là sont. C'est la meilleure commande de l'utiliser pour obtenir les informations de serveur virtuel.

cat#show module csm 3 vservers name server detail�
SERVER, state = OPERATIONAL, v_index = 10
� virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
� idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
� max parse len = 600, persist rebalance = TRUE
� conns = 0, total conns = 4
� Default policy:
��� server farm = WWWFARM
��� sticky: timer = 0, subnet = 0.0.0.0, group id = 0
� Policy���������� Tot Conn���� Client pkts� Server pkts
� ------------------------------------------------------
� (default)������� 4����������� 56���������� 56

show module csm # vraie commande de détail

Le show module csm # vraie affiche des informations de commande de détail pour chaque vrai serveur, tel que la batterie de serveur où chaque serveur réside, les états des serveurs, les seuils, et les connexions.

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
� conns = 0, maxconns = 4294967295, minconns = 0
� weight = 8, weight(admin) = 8, metric = 0, remainder = 0
� total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

show module commande de détail de mot de nom csm # de serverfarm

Le show module commande de détail de mot de nom csm # de serverfarms affiche les informations de ferme de serveur. Cette commande montre le predictor utilisé pour l'Équilibrage de charge. Dans cet exemple, la recherche séquentielle, qui est par défaut, est utilisée.

cat#show module csm 3 serverfarms name wwwfarm detail�
WWWFARM, predictor = RoundRobin, nat = SERVER
� virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
� inband health config: <none>
� retcode map = <none>
� Real servers:
��� 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
��� 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
� Total connections = 0

show module commande de détail csm # de VLAN

Le show module commande de détail csm # de VLAN affiche les informations VLAN pour le client et le serveur.

cat#show module csm 3 vlan detail�
vlan�� IP address������ IP mask��������� type������
---------------------------------------------------
100��� 172.17.63.217��� 255.255.255.192� CLIENT
� GATEWAYS
� 172.17.63.214����
200��� 172.17.63.217��� 255.255.255.192� SERVER
cat#

Dépannez

Vous devriez pouvoir cingler le vrai serveur et la passerelle CSM du Catalyst 6500 en émettant le ping ou le module de ping csm # commandes de reals.

cat#ping module csm 3 reals
IP address������ Reachable
--------------------------
172.17.63.215��� Yes
172.17.63.216��� Yes
cat#ping module csm 3 gateway�������������������������
IP address������ Reachable
--------------------------
172.17.63.214��� Yes

Une autre bonne commande de dépannage est show module csm # ARP. Le CSM apprendra les adresses. Assurez-vous que la passerelle et les reals apparaissent.

cat#show module csm 3 arp�
Internet Address� Physical Interface� VLAN����� Type������ Status
--------------------------------------------------------------------
�172.17.63.210��� 00-E0-B6-01-FA-49�� 100������ LEARNED��� up(0 misses)
�172.17.63.214��� 00-04-C0-C0-68-00�� 100������ GATEWAY��� up(0 misses)
�172.17.63.215��� 00-60-B0-87-DC-1A�� 200������ REAL������ up(0 misses)
�172.17.63.216��� 00-50-DA-BF-A1-7F�� 200������ REAL������ up(0 misses)
�172.17.63.217��� 00-30-F2-71-5D-2E�� 100/200�� --SLB--��� local
�172.17.63.222��� 00-02-B9-45-A2-91�� 100������ LEARNED��� up(0 misses)
�172.17.63.241��� 00-30-F2-71-5D-2D�� 0�������� VSERVER��� local

Informations connexes


Document ID: 5217