Commutation LAN : Routage inter-VLAN

Configuration du routage InterVLAN et de la jonction ISL/802.1Q sur un commutateur Catalyst 2900XL/3500XL/2950 à l'aide d'un routeur externe

18 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 septembre 2014) | Commentaires


Contenu


Introduction

Ce document fournit des exemples de configuration sur InterSwitch Link (ISL) et jonction 802.1Q entre un commutateur Catalyst 3512-XL et un routeur Cisco 2600 ; les résultats de chaque commande sont affichés au moment de leur exécution. Les routeurs de la gamme Cisco 3600 et 4500/4700, certains routeurs de la gamme Cisco 2600 avec interfaces FastEthernet et les commutateurs Catalyst 2900XL, 3500XL, 2940, 2950 ou 2970 peuvent être utilisés dans les scénarios présentés dans ce document pour obtenir les mêmes résultats.

L'agrégation est une manière de porter un trafic de plusieurs VLAN à travers un lien point à point entre deux périphériques. Voici deux manières d'implémenter une jonction de liens Ethernet :

  • L'ISL (protocole propriétaire de Cisco, non pris en charge par les commutateurs de la gamme 2940 ou 2950)

  • 802.1Q (norme IEEE)

Nous allons créer une agrégation qui portera le trafic de deux vlans (VLAN1 et VLAN2) à travers un lien unique entre un commutateur Catalyst 3500 et un routeur Cisco 2600.

Nous utiliserons le routeur Cisco 2600 pour effectuer un routage inter-VLAN entre VLAN1 et VLAN2. Les commutateurs de la gamme Catalyst 2900XL/3500XL/2940/2950/2970 sont des commutateurs de couche 2 (L2), et ne peuvent pas effectuer de routage ou assurer la communication entre les VLAN. Pour plus de détails sur le routage inter-VLAN, référez-vous au chapitre Vue d'ensemble du routage entre réseaux LAN virtuels du guide de configuration de services de commutation Cisco IOS®, version 12.1.

Pour illustrer les exemples de ce document, les commutateurs suivants ont été utilisés dans un environnement de laboratoire avec des configurations par défaut :

  • Commutateur Catalyst 3512XL sur Cisco IOS 12.0(5.x)XU

  • Routeur Cisco 2621 sur Cisco IOS 12.1(3)T

  • Routeur Cisco 2621 sur Cisco IOS 12.1(1)T

Les configurations dans ce document ont été mises en application dans un environnement de laboratoire isolé. Assurez-vous d'avoir pris connaissance de l'impact potentiel des configurations ou des commandes sur votre réseau avant de les utiliser. Les configurations sur tous les périphériques ont été effacées avec la commande write erase pour s'assurer que ces derniers sont définis sur leur configuration par défaut.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Remarques importantes

Pour les commutateurs Catalyst 2900XL/3500XL/2940/2950/2970 :

Les commutateurs de la gamme Catalyst 2940 et 2950 prennent uniquement en charge la jonction 802.1Q, et ne prennent pas en charge la jonction ISL.

Sur un commutateur Catalyst 2900XL 4 Mo DRAM, l'agrégation est seulement prise en charge avec les modules d'agrégation suivants :

  • WS-X2914-XL-V : Module de commutation 4 ports 10/100 ISL/802.1Q

  • WS-X2922-XL-V : Module de commutation 2 ports 100BaseFX ISL/802.1Q

  • WS-X2924-XL-V : Module de commutation 4 ports 100BaseFX ISL/802.1Q

  • WS-X2931-XL : Liaison ascendante 1000BaseX pour Catalyst 2900 XL

  • WS-X2932-XL : Liaison ascendante 1000BaseT pour Catalyst 2900 XL

Référez-vous au tableau 1 ci-dessous pour une liste de modèles de commutateurs actuelle qui prennent en charge l'agrégation :

Tableau 1 :

Modèles de commutateurs Version minimale nécessaire pour la jonction ISL Version minimale nécessaire pour la jonction IEEE 802.1Q Version actuelle nécessaire pour l'agrégation (ISL/802.1Q)
WS-C2916M-XL (commutateur 4 Mégas) 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 11.2(8.6)SA6 (édition originale)
C2912-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
C2924-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C2924C-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C2924M-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C2912MF-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C2924M-XL-DC 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) ou supérieure
WS-C3508G-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C3512-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition originale) 12.0(5)WC(1) ou supérieure
WS-C3524-XL 11.2(8)SA4 (édition entreprise) 11.2(8)SA5 (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C3548-XL 12.0(5)XP (édition entreprise) 12.0(5)XP (édition entreprise) 12.0(5)WC(1) ou supérieure
WS-C3524-PWR-XL 12.0(5)XU 12.0(5)XU 12.0(5)WC(1) ou supérieure
WS-C2940-8TF ISL non pris en charge 12.1(13)AY 12.1(13)AY ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2940-8TT ISL non pris en charge 12.1(13)AY 12.1(13)AY ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950-12 ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950-24 ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950C-24 ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950T-24 ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950G-12-EI ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950G-24-EI ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950G-48-EI ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950SX-24 ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2950-24-EI-DC ISL non pris en charge 12.0(5)WC(1) 12.0(5)WC(1) ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2955T-12 ISL non pris en charge 12.1(13)EA1 12.1(13)EA1 ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2955S-12 ISL non pris en charge 12.1(13)EA1 12.1(13)EA1 ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2955C-12 ISL non pris en charge 12.1(13)EA1 12.1(13)EA1 ou supérieure pour le 802.1Q. ISL n'est pas pris en charge.
WS-C2970G-24T 12.1(11)AX 12.1(11)AX 12.1(11)AX ou supérieure
WS-C2970G-24TS 12.1(14)EA1 12.1(14)EA1 12.1(14)EA1 ou supérieure

Remarque: Dans le tableau ci-dessus, seul WS-C2916M-XL est un commutateur de 4 Mo de DRAM. Tous les autres commutateurs énumérés sont des commutateurs de 8 Mo de DRAM. Pour déterminer si votre commutateur dispose de 4 Mo ou de 8 Mo de DRAM, entrez la commande Version show au niveau utilisateur. Pour plus d'informations, consultez la section Comment déterminer la quantité de mémoire de commutateur à l'aide de l'interface de ligne de commande de Logiciel de mise à niveau des commutateurs Catalyst 2900-XL/3500-XL à l'aide de l'interface de ligne de commande.

Remarque: Dans les commutateurs Catalyst 2900XL/3500XL/2940/2950/2970, une interface VLAN du type int vlan 1, vlan int 2 ou vlan int x peut être créée pour chaque VLAN configuré sur le commutateur. Toutefois, un seul VLAN peut être utilisé à la fois comme VLAN de gestion. L'adresse IP est affectée à l'interface VLAN du VLAN de gestion uniquement. Si l'adresse IP est attribuée à une autre interface VLAN dont le VLAN n'est pas utilisé comme VLAN de gestion, cette interface ne sera pas disponible. Il est préférable de créer l'interface VLAN seulement pour le VLAN de gestion.

Pour les routeurs Cisco 2600 :

Pour une jonction 802.1Q, un VLAN n'est pas balisé. Ce VLAN s'appelle le VLAN natif. Le VLAN natif est utilisé pour le trafic non balisé quand le port est en mode d'agrégation 802.1Q. Pendant la configuration de l'agrégation 802.1Q, il est très important de garder à l'esprit que le VLAN natif doit être configuré de la même manière de chaque côté du lien « trunk ». C'est une erreur courante de ne pas faire correspondre les VLAN natifs lors de la configuration de l'agrégation 802.1Q entre le routeur et le commutateur. Pour plus de détails sur le VLAN natif, reportez-vous à la section norme IEEE 802.1Q de Pontage entre les VLANs IEEE 802.1Q, dans Nouvelles fonctionnalités dans la version 12.1(3)T.

Dans cet exemple de configuration, le VLAN natif est VLAN1 par défaut, à la fois sur le routeur Cisco 2621 et le commutateur Catalyst 3512XL. En fonction de vos besoins en réseau, vous pouvez être amené à utiliser un VLAN natif autre que le VLAN par défaut, VLAN1. Des commandes ont été mentionnées dans la section Configurations de ce document, notamment sur la manière de changer le VLAN natif sur le routeur Cisco 2600 et le commutateur Catalyst 3500XL.

Des exemples de configurations présentées dans ce document peuvent être utilisés sur des routeurs de la gamme Cisco 2600/3600/4500/4700 avec des interfaces Fast Ethernet ou des modules réseau Fast Ethernet. Aussi, assurez-vous d'utiliser la version Cisco IOS prenant en charge l'agrégation de VLAN ISL/802.1Q. Pour une liste complète des routeurs Cisco 2600/3600/4500/4700 prenant en charge l'agrégation de VLAN ISL/802.1Q ainsi que des versions de Cisco IOS prises en charge, veuillez vous référer au tableau 2 ci-dessous.

Tableau 2

Modèles de routeurs Version minimale nécessaire pour la jonction ISL Version minimale nécessaire pour la jonction IEEE 802.1Q Ensemble de fonctionnalités minimal nécessaire (ISL/802.1Q)
Cisco 2620 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2621 11.3(3a)T 12.0(1)T IP PLUS / IP PLUS
Cisco 2620 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 2650 12.1(3a)T 12.1(3a)T IP PLUS / IP PLUS
Cisco 3620 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3640 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 3661 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 3662 12.0(5)T 12.0(5)T IP PLUS / IP PLUS
Cisco 4500-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS
Cisco 4700-M 11.3(1)T 12.0(1)T IP PLUS / IP PLUS

Remarque: Le tableau 2 énumère seulement les versions principales/de maintenance minimales ou actuelles prenant en charge cet exemple de configuration. Les modèles de routeurs avec certains modules réseau peuvent avoir différentes versions minimales de Cisco IOS. Pour une liste complète des logiciels pris en charge pour toute famille de routeur, utilisez Software Advisor (clients enregistrés uniquement).

Remarque: La version minimale supportée n'est pas nécessairement la version la plus recommandée. Pour déterminer la meilleure version de maintenance pour votre produit Cisco, recherchez des bogues listés par composant de produit dans la boîte à outils de bogue (clients enregistrés uniquement).

Remarque: Le tableau 2 énumère les caractéristiques minimales requises pour effectuer un routage et une agrégation IP Inter-VLAN pour prendre en charge cet exemple de configuration. Pour une liste complète d'autres ensembles de fonctionnalités pris en charge dans les différentes versions de Cisco IOS et sur différentes plates-formes, utilisez la zone de téléchargement de logiciel.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/14976/50a.jpg

Configurations

Ce document utilise les configurations présentées ci-dessous.

Remarque: Les modèles de routeurs avec certains modules réseau peuvent avoir différentes versions minimales de Cisco IOS prenant en charge l'agrégation ISL.

  • Catalyst 3512-XL

  • Routeur Cisco 2600

  • Configuration 802.1Q sur le routeur pour des versions de Cisco IOS antérieures à la version 12.1(3)T

Catalyst 3512-XL

Remarque: Les captures d'écran suivantes montrent les commandes qui ont été entrées sur le commutateur 3512XL. Des commentaires sont ajoutés en italique bleu entre les commandes pour expliquer certaines commandes ainsi que les étapes.


!-- Set the privileged mode


!-- and Telnet password on the switch.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Set the IP address and default gateway for VLAN1 for management purposes.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Set the VTP Mode.
!-- In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
!-- For details on VTP,
!-- refer to
!-- Creating and Maintaining VLANs on Catalyst 2900XL and 3500XL Switches.

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Adding VLAN2. VLAN1 already exists by default.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Enable trunking on the interface fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Enter the trunking encapsulation as either isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- or as dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- In case of 2940/2950 series switches, none of the above two commands are used,
!-- 2940/2950 series switches only support 802.1q encapsulation which is configured automatically,
!-- when trunking is enabled on the interface by using switchport mode trunk command.

!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- Depending on your network needs, you may change
!-- the native VLAN to be other than VLAN1,
!-- but it is very important that you change the native VLAN
!-- on the router accordingly.
!-- You may change the native VLAN, if needed, by using the following command:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Allow all VLANs on the trunk.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- The following set of commands will place FastEthernet 0/2
!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 is already in VLAN1 by default.
!-- Enable portfast on the interface.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- For details on why to enable portfast,
!-- refer to:
!-- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.
!-- Remember to save the configuration.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Routeur 2600

Remarque: Les captures d'écran suivantes montrent les commandes qui ont été entrées sur le routeur Cisco 2600. Des commentaires sont ajoutés en italique bleu entre les commandes pour expliquer certaines commandes ainsi que les étapes.


!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.
!-- No L2 or Layer 3 (L3) configuration is done here.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.1.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.1


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1


!-- or as dot1q:
!-- In case of dot1q, you need to make sure that
!-- the native VLAN matches across the link.
!-- On 3512XL, by default, the native VLAN is 1.
!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,
!-- on the router, configure the same VLAN to be the native VLAN,
!-- by using the above command.

Remarque: La commande encapsulation dot1Q 1 native a été ajoutée dans la version 12.1(3)T de Cisco IOS. Si vous utilisez une version antérieure de Cisco IOS, reportez-vous à la section Configuration 802.1Q pour les versions de Cisco IOS antérieures à 12.1 (3) de ce document pour configurer l'agrégation 802.1Q sur le routeur.


!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Enable trunking on the sub-interface FastEthernet 0/0.2.
!-- Note that actual trunks are configured on the sub-interfaces.

c2600(config)#int fastEthernet 0/0.2


!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 2


!-- or as dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Configure L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Remarque: Afin de faire fonctionner cette installation et d'envoyer un ping avec succès entre workstation1 et workstation2, vous devez vous assurer que les passerelles par défaut sur les postes de travail sont correctement configurées. Pour workstation1, la passerelle par défaut devrait être 10.10.11.1. Pour workstation2, la passerelle par défaut doit être 10.10.10.1. Pour plus de détails sur la façon de définir les passerelles par défaut sur les postes de travail, reportez-vous à leurs sections respectives dans ce document.

Remarque: Le paragraphe suivant s'applique uniquement si vous avez configuré l'agrégation 802.1Q entre le routeur et le commutateur.

Remarque: Si vous avez suivi les étapes de configuration figurant dans les sections ci-dessus, et que vous ne parvenez pas encore à envoyer un ping sur les VLAN (entre workstation1 et workstation2), il est possible que vous ayez utilisé Caveat CSCds42715, dans lequel le mot clé du VLAN natif 802.1Q ne fonctionne pas correctement lorsque la commutation rapide est activée. La correction du bogue a été intégrée dans les versions de code suivantes : 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Vous pouvez vérifier l'état ainsi qu'une brève description du bogue à l'aide de la boîte à outils de bogue (clients enregistrés uniquement), en entrant l'ID de bogue CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- If 802.1Q is configured,
!-- you will instead see the following output
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Configuration 802.1Q sur le routeur pour des versions de Cisco IOS antérieures à la version 12.1(3)T
Comme décrit plus haut dans ce document, il est très important, lors de la configuration de l'agrégation 802.1Q, de faire correspondre le VLAN natif sur la liaison. Dans les versions du logiciel Cisco IOS antérieures à 12.1(3)T, vous ne pouvez pas définir le VLAN natif explicitement, car la commande d'encapsulation dot1Q 1 native dans la sous-interface n'est pas disponible. Dans les versions antérieures du logiciel Cisco IOS, il est important de ne pas configurer l'interface VLAN native comme une sous-interface, comme le montre notre exemple VLAN1. S'il est mal configuré, le routeur pourrait s'attendre à une trame de tag dot1q sur VLAN1 alors que le commutateur ne s'attend pas à un tag sur VLAN1. Dans ce cas, aucun trafic ne passera entre VLAN1 (sur le commutateur) et le routeur. Dans ces situations, passez systématiquement la configuration du VLAN natif sous l'interface principale. Sur l'agrégation, créez une sous-interface pour tous les autres VLAN. Dans la configuration de laboratoire en cours, utilisez les étapes suivantes pour configurer le routeur Cisco 2600 :
 

!-- Set the privileged mode
!-- and Telnet password on the router.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Select FastEthernet 0/0 for the trunk configuration.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Note that the IP address for VLAN1 is configured on the main interface,
!-- and no encapsulation for VLAN1 will be done under the sub-interface.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Configure dot1q encapsulation for VLAN 2
!-- on sub-interface fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Configuring L3 information on the sub-interface 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Remember to save the configuration.

c2600#write memory
Building configuration...
[OK]
c2600#

Remarque: Afin de faire fonctionner cette installation et d'envoyer un ping avec succès entre workstation1 et workstation2, vous devez vous assurer que les passerelles par défaut sur les postes de travail sont correctement configurées. Pour workstation1, la passerelle par défaut devrait être 10.10.11.1. Pour workstation2, la passerelle par défaut devrait être 10.10.10.1. Pour plus de détails sur la façon de définir les passerelles par défaut sur les postes de travail, reportez-vous à leurs sections respectives dans ce document.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

Commandes debug et show

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Sur le commutateur Catalyst 2900XL/3500XL/2940/2950/2970, utilisez les commandes suivantes :

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport

  • show vlan

  • show vtp status

Sur le routeur Cisco 2600, utilisez les commandes suivantes :

  • show vlan

  • show interface

Exemple de sortie de la commande show

Commutateur Catalyst 3500XL

show int {FastEthernet | GigabitEthernet} <module/port> switchport

Cette commande est utilisée pour vérifier l'état administratif et opérationnel du port. Elle est également utilisée pour s'assurer que le VLAN natif correspond sur les deux côtés de la liaison. Le VLAN natif est utilisé pour le trafic non balisé quand le port est en mode d'agrégation 802.1Q. Reportez-vous à la section Création et maintenance de réseaux VLAN sur les commutateurs Catalyst 2900XL et 3500XL pour plus de détails sur les VLAN natifs.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Remarque: Pour l'agrégation 802.1Q, la sortie de la commande ci-dessus est modifiée comme suit :

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Cette commande est utilisée pour vérifier que les interfaces (ports) appartiennent au VLAN adéquat. Dans notre exemple, seule l'interface Fa0/2 appartient à VLAN2. Les autres membres font partie de VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

Cette commande est utilisée pour vérifier la configuration du protocole d'agrégation de VLAN (VTP) sur le commutateur. Dans notre exemple, nous avons utilisé le mode transparent. Le mode VTP adéquat dépend de la topologie de votre réseau. Pour plus de détails sur le mode VTP, reportez-vous à Création et maintenance de réseaux VLAN sur les commutateurs Catalyst 2900XL et 3500XL.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Routeur Cisco 2600

show vlan

Cette commande vous indique que les informations sur L2 ou L3 sont configurées pour chaque VLAN.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Remarque: Pour l'agrégation 802.1Q, la sortie de la commande ci-dessus est modifiée comme suit :

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Remarque: Pour une agrégation 802.1Q, avec les versions de Cisco IOS antérieures à la version 12.1(3)T, la sortie de la commande ci-dessus est modifiée comme suit :

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Remarque: Aucune encapsulation IEEE 802.1Q n'est affichée pour VLAN1 sur les sous-interfaces.

show interface

Cette commande est utilisée pour vérifier l'état administratif et opérationnel de l'interface.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Remarque: Pour l'agrégation 802.1Q, la sortie de la commande ci-dessus est modifiée comme suit :

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14976