Services de mise en réseau d'applications : Moteurs de contenu Cisco de la gamme 500

Configuration de la redirection de support en mode proxy transparent à l'aide du logiciel ACNS 4.x

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer Cisco cachent/engine de contenu pour transparent et la mise en cache de medias de proxy utilisant la release 4.x de Cisco ACNS de la version 2. de Protocol de coordination de cache de Web (WCCP), inclut, comme option, RealProxy de RealNetworks, Inc.leavingcisco.com de prendre en charge le flot séparant (les flux en direct de distribution) et le streaming media cachant (contenu sur demande) dans couler basé sur de Protocole RTSP (Real-Time Streaming Protocol) et d'autres vrais formats PNM (métafichier de RealNetworks).

L'engine satisfaite peut être configurée pour recevoir d'une manière transparente des demandes de RTSP réorientées du routeur WCCP, aussi bien que des demandes de style du proxy traditionnelles de RTSP de logiciel client de RealPlayer. La mise en antémémoire de streaming media fournit le à la demande satisfait à l'étendre que, si un utilisateur a déjà visualisé un fichier de streaming media caché, il peut être servi aux utilisateurs ultérieurs sans condition requise de se connecter au serveur d'origine. Rendez-vous compte que des diffusions en direct ne peuvent pas être cachées.

Pour configurer l'engine satisfaite pour recevoir le trafic de RTSP, terminez-vous ces étapes :

  1. Émettez la commande de proxy de RTSP en mode de configuration globale pour entrer dans l'adresse IP, le port, et le permis utilisé dans le RealProxy de l'engine satisfaite.

  2. Émettez la commande de configuration globale de support-cache de wccp d'enregistrer l'engine satisfaite avec tous les Routeurs WCCP-activés.

Des objets de streaming media sont cachés dans les partitions de disque de système de fichier multimédia (mediafs) tandis que le logiciel de RealProxy est copié sur la partition de système de fichier du logiciel (swfs) en tant qu'élément de la procédure d'installation. Émettez la commande de disque de créer les partitions de mediafs ; émettez les mediafs commandent de mettre à jour ces partitions (référez-vous à mettre à jour la mémoire de disque dur pour plus d'informations sur des partitions de disque). Le logiciel de RealProxy peut être géré avec le RealAdministrator GUIÝ (pour accéder à cette page, le nom d'utilisateur/mot de passe par défaut est admin/diamant).

Pour configurer WCCP-a activé des Routeurs, vous doit émettre la commande du service-groupe 80 de wccp. La sortie de commande est affichée dans la section de configurations.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Engine satisfaite exécutant la version de logiciel 4.x ou ultérieures ACNS

  • Logiciel de RealProxy installé avec des partitions de mediafs montées

Remarque: Vous devez acheter une clé de licence afin de lancer les caractéristiques de RealProxy en logiciel de cache. Pour passer commande sur Cisco.com, référez-vous à la commande.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 4.x ou ultérieures s'exécutante de Cisco ACNS du Cisco Content Engine 590 dans un environnement de travaux pratiques avec des configurations effacées

  • Version du logiciel Cisco IOS courante de Routeur Cisco 7513 12.0.18(S)

Configurez

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

/image/gif/paws/4717/media_redir.jpg

Configurations

Moteur de cache 560 (version de logiciel 4.x de Cisco de CiscoÝ ACNS)
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enableÝ

rtsp proxy incoming 554Ý

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

Ýip address 172.17.241.45 255.255.255.0

Ýno ip directed-broadcast

Ýip wccp 80 redirect out

!

interface Ethernet5/1

Ýip address 10.10.10.1 255.255.255.0

Ýno ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

Ýexec-timeout 0 0

line aux 0

line vty 0 4

Ýpassword <removed>

Ýlogin

!

end

Commandes debug et show

Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Commandes show de moteur de cache

commande show Description
affichez les contenu-engines de wccp Les informations d'engine de contenu des affichages WCCP.
affichez le support-cache d'écoulements de wccp Écoulements de paquet de service de mise en cache de medias d'affichages.
affichez les Routeurs de wccp Liste de routeur des affichages WCCP.
affichez les services de wccp Services des affichages WCCP configurés.
affichez la slowstart de wccp Début lent des affichages WCCP.
affichez l'état de wccp État courant des affichages WCCP.
affichez à mediacache de statistiques la vraie épargne Affiche des statistiques de l'épargne.
affichez à mediacache de statistiques les vraies demandes Statistiques de demande d'affichages.
affichez le RTSP tout Affiche toute la configuration de RTSP.
affichez le proxy de RTSP Affiche la configuration de mode proxy.
affichez les volumes de mediafs Affiche des volumes de mediafs.

Commandes de débogage de moteur de cache

commande de débogage Description
mettez au point le wccp tout Permet au WCCP d'activer toute l'élimination des imperfections.
mettez au point les événements de wccp Événements des enables WCCP.
mettez au point les paquets de wccp Les informations paquet paquet des enables WCCP.

Ordres de routeur show

commande show Description
détail du show ip wccp 80 Statistiques de moteur de cache d'affichages et de routeur WCCP pour un groupe de service particulier.
vue du show ip wccp 80 Affiche les informations de vue de groupe de service

Commandes de débogage de routeur

commande de débogage Description
debug ip wccp events Événements des affichages WCCP.
mettez au point les paquets d'ip wccp Les informations paquet paquet des affichages WCCP.

Résumé des commandes

Ces commandes de moteur de cache ont été utilisées dans cette configuration :

  • version {1 de wccp | 2}

  • IP address de nombre de routeur-liste de wccp

  • nombre routeur-liste-numérique de support-cache de wccp

  • clé de clé de licence de proxy de RTSP support-vraie

  • IP address d'IP address de proxy de RTSP support-vrai

  • enable de proxy de RTSP support-vrai

  • port d'entrée de proxy de RTSP

Ce sont les commandes de routeur qui ont été utilisées dans cette configuration :

  • ip wccp {Web-cache | service-nombre}

  • ip wccp {Web-cache | le service-nombre} réorientent

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 4717