IP : Protocole OSPF (Open Shortest Path First)

Redistribution OSPF entre différents processus OSPF

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des instructions pour la redistribution de l'Open Shortest Path First (OSPF) entre différents processus. La redistribution entre différents processus est difficile, et des mesures spéciales sont nécessaires pour le bon fonctionnement du réseau. Ce document met en valeur également quelques changements introduits de logiciel de Cisco IOSÝ.

Pourquoi redistribuez entre deux processus OSPF ?

Il peut y avoir plusieurs raisons pour la redistribution entre les processus multiples. Ce sont quelques exemples :

  • Pour filtrer une artère OSPF d'une partie du domaine

  • Pour séparer différents domaines OSPF

  • Pour migrer entre les domaines distincts

Bien que la redistribution entre différents processus pourrait être nécessaire dans certains cas, une solution alternative de conception (si possible) est un choix plus approprié, comme sera discuté dans les paragraphes de cette section.

Filtrage de l'artère OSPF

Artères d'Intra-zone

Dans l'OSPF, des préfixes IP dans une zone ne sont pas permutés directement entre les Routeurs. Ils font partie de la publicité d'État de lien (LSA) qu'annonce également la topologie du réseau ; donc, il n'y a aucune manière de filtrer des artères dans une zone.

Remarque: Des gens du pays filtrant sur un routeur (qui peut être fait pour empêcher quelques artères d'être installé dans un routeur donné) ne sont pas considérés filtrage d'artère réelle. Ceci est normalement accompli avec la commande de distribute-list sous le router ospf.

Une solution serait d'utiliser un processus différent et de filtrer les artères désirées sur les Routeurs redistribuants ; cependant, faire ceci sépare réellement la zone dans deux domaines. Une meilleure conception serait de séparer la zone dans différentes zones et d'utiliser la caractéristique de filtrage du type 3 de Cisco IOS, qui est expliquée plus tard.

Routes inter-zone

Dans l'OSPF, tous les Routeurs dans une zone ont le précis la même topologie. Une zone n'a aucune connaissance de la topologie d'une autre zone ; donc, il se fonde sur les informations annoncées par les Routeurs reliés de cadre de zone (abr).

Les informations annoncées à l'intérieur d'une zone par un ABR (en tant que LSA de type 3) sont réellement les préfixes IP qui sont appris des régions isolées ou qui sont calculés pour d'autres zones reliées.

Un ABR lance ces artères :

  • artères d'intra-zone de Non-circuit principal dans le circuit principal

  • Intra-zone et routes inter-zone de circuit principal dans la zone non principale

Par conséquent, entre les zones il y a un comportement de vecteur de distance qui peut être accru pour filtrer des artères entre les zones.

Le logiciel de Cisco IOS a mis en application une caractéristique de filtrage d'inter-zone. Pour plus d'informations sur cette caractéristique, référez-vous au Fonction OSPF ABR type 3 LSA filtering.

Filtrage externe d'artère

Puisque des artères externes sont annoncées comme type 5 LSAs et sont de la taille du domaine inondé, à moins que dans des zones d'extrémité et des zones non-ainsi-tronquées (NSSAs), il n'y ait actuellement aucune manière de filtrer un LSA du type 5. Une solution est d'avoir un processus différent et de filtrer entre les processus tout en redistribuant.

Gardant les différents domaines OSPF séparent

On le voit comme une pratique commune d'employer différents processus OSPF afin de séparer différents domaines de Routage IP, à des fins administratives ou segmenter le routing domain et contrôler les informations de routage au point de redistribution.

Il devrait noter, cependant, que l'instabilité dans un domaine pourrait affecter l'autre domaine. Par exemple, s'il y a un changement du réseau OSPF (type 1 et 2) où un routeur ASBR (Autonomous System Boundary Router) réside entre les deux domaines, tout le type 5 LSAs re-sera commencé et inondé dans tout le domaine distant. Ainsi, s'il y a une instabilité constante dans un réseau, ceci peut mener à une injection et à un retrait constants du type 5 LSAs dans l'autre domaine.

Un meilleur choix de conception est d'utiliser le Protocole BGP (Border Gateway Protocol) entre différents domaines. Dans ce cas, l'échange OSPF entre différents domaines va cependant le BGP ; et, parce que le BGP a la capacité d'atténuation, l'instabilité dans un domaine sera moins visible dans l'autre domaine.

Redistribuer entre différents processus OSPF

Comme mentionné précédemment, il peut y a une solution alternative à redistribuer entre les processus multiples. La section affiche comment la redistribution entre différents processus devrait être prévue soigneusement, selon le nombre de redistribution se dirige.

Règle de préférence d'artère OSPF

La règle de sélection de routes OSPF est que des artères d'intra-zone sont préférées au-dessus des routes inter-zone, qui sont préférées au-dessus des artères externes. Cependant, cette règle devrait appliquer aux artères apprises par l'intermédiaire du même processus. En d'autres termes, il n'y a aucune préférence entre les artères externes d'un processus comparé aux routes internes de l'autre processus.

La règle de préférence entre un processus donné OSPF et n'importe quel autre processus (que ce soit un OSPF ou un protocole de routage différent) devrait suivre la règle de distance administrative. Cependant, parce que les différents processus OSPF auront la même distance administrative par défaut, la distance OSPF devrait être configurée explicitement pour différents processus OSPF, pour réaliser le comportement désiré.

Remarque: Avant que l'ID de bogue Cisco CSCdi7001 — réparé dans le Logiciel Cisco IOS version 11.1 et plus tard — distance administrative entre les processus n'ait pas fonctionné correctement, et les routes internes d'un processus ont été préférées au-dessus des artères externes d'un autre processus.

Un seul point de redistribution

Quand il y a un seul point de redistribution, tout l'échange entre les domaines se produit à un seul point, et il y a aucune manière qu'une boucle de redistribution ne peut former. C'est un exemple de configuration :

Figure 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-01.gif

Configuration du routeur A
router ospf 1
redistribute ospf 2 subnet

router ospf 2
redistribute ospf 1 subnet

Deux points de redistribution

Il est plus compliqué quand il y a deux points de redistribution. Si la redistribution est faite aux deux points d'un réseau sans n'importe quel soin particulier, il peut y avoir des résultats inattendus.

Considérez la prochaine topologie, où le routeur A et le routeur B redistribuent mutuellement entre les deux domaines. Cette configuration ne fonctionne pas, comme sera expliqué plus tard dans cette section.

Figure 2

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-02.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet

router ospf 2
redistribute ospf 1 subnet

Donné un réseau N dans le domaine 1, le routeur A et le B apprennent le réseau N comme route interne dans le domaine 1. Puisqu'ils redistribuent le processus 1 dans le processus 2, le même réseau N est appris dans le domaine 2 comme artère externe.

Maintenant, dans chaque routeur, le réseau interne appris par l'intermédiaire d'un processus concurrence le réseau externe d'un autre processus. Comme précédemment mentionné, il n'y a aucune règle de préférence entre différents processus ; donc, le résultat serait indeterministic, car les deux le processus ont la même distance administrative.

Remarque: Ceci a pu mener à une injection et à un retrait constants d'un type 5 à partir d'un processus à l'autre.

Avant que l'ID de bogue Cisco CSCdw10987 (clients enregistrés seulement) (intégré dans des versions du logiciel Cisco IOS 12.2(07.04)S, 12.2(07.04)T, et plus tard), le dernier processus pour faire un shortest path first algorithm (SPF) aurait gagné, et les deux processus remplacent d'autres artères dans la table de routage. Maintenant, si une artère est installée par l'intermédiaire d'un processus, il n'est pas remplacé par un autre processus OSPF avec le même domaine administratif (AD), à moins que l'artère soit d'abord supprimée de la table de routage par le processus qui a au commencement installé l'artère dans la table de routage.

Distance administrative

Quand vous utilisez la redistribution entre les processus multiples, vous pouvez employer la distance administrative pour préférer un processus au-dessus d'un autre processus, parce que les préférences d'artère OSPF s'appliquent seulement dans le même processus. Cependant, ce n'est pas assez pour le bon fonctionnement dans le réseau, comme expliqué plus tard dans cette section.

Figure 3

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet
distance ospf external 200

router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

Exploitation réseau sans panne de réseau

Considérez un réseau N dans le domaine 1, où N sera connu comme route interne dans le domaine 1 et redistribué par le routeur A et par le routeur B. Puisque la distance administrative des artères externes a été augmentée, le routeur A et le routeur que B ont choisi le processus 1 OSPF pour atteindre le réseau N.

D'une manière plus générale, tous les réseaux internes au domaine 1 seront accédés par le domaine 1 et tous les réseaux internes au domaine 2 seront accédés par le domaine 2, par le routeur A et le routeur B. D'autres Routeurs dans chaque domaine prennent l'ASBR le plus étroit (si le type-2 métrique est utilisé) ou le plus court chemin par un des ASBR (si le type 1 métrique est utilisé).

S'il y a des préfixes externes aux deux domaines (qui proviennent quelques autres points de redistribution), le même problème se posera toujours parce que la distance administrative pour ces artères externes est identique dans les deux processus. Si vous rendez la distance administrative pour des processus externes différente, elle ne résoudra pas le problème. Voici un exemple :

Figure 4

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-04.gif

Le routeur C (ASBR) annonce N externe dans le domaine 1. Ce préfixe obtient redistribué par le routeur A et le routeur B dans le domaine 2 et atteindra chacun des Routeurs ; donc, N sera externe dans les deux domaines. Pour avoir des bons fonctionnements, la distance administrative des artères externes doit être différente pour les deux processus, de sorte qu'un domaine soit préféré au-dessus de l'autre. Supposez que la distance administrative pour le domaine 1 est réglée diminuent que le domaine 2.

Maintenant, si le routeur D (ASBR) annonce M externe dans le domaine 2, puis ce préfixe est redistribué par le routeur A et le routeur B dans le domaine 1 et il atteindra chacun des Routeurs. Ainsi, M sera externe dans les deux domaines et, parce que la distance administrative est inférieure pour le domaine 1, M sera accessible par l'intermédiaire du domaine 1. Cette séquence d'opérations a pu se produire :

  1. Routeur A (le routeur B) redistribue M dans le domaine 1, et M externe atteindra le routeur B (routeur A).

  2. Puisque la distance administrative du domaine 1 est inférieure au domaine 2, le routeur A (le routeur B) installera M par le domaine 1 et placera au maxage son LSA lancé précédent (événement 1) dans domaine 1.

  3. Puisque M a été placé au maxage dans le domaine 2, le routeur A (le routeur B) installera M bien que le domaine 2 et, en conséquence, redistribuera M dans le domaine 2.

  4. Mêmes que l'événement 1.

Ce cycle continue, et la manière de le réparer est d'avoir le préfixe du domaine 2 accessible par l'intermédiaire du domaine 2. Cependant, si la distance administrative est inférieure réglé pour le domaine 2, puis le même problème se posera pour le domaine 1 et pour le préfixe N.

La solution est de placer la distance administrative basée sur le préfixe. Voyez le filtrage basé sur thePrefix et filtrage basé sur préfixe et le pour en savoir plus basé sur préfixe de sections de distance administrative.

Exploitation réseau avec la panne de réseau

Vous voulez une sauvegarde de domaine l'autre domaine, au cas où un domaine serait inaccessible.

Par exemple, considérez le cas où le routeur A a perdu la Connectivité au réseau N par le domaine 1. Une fois que le routeur A perd sa Connectivité par le domaine 1, il videra son LSA précédemment généré annonçant le réseau N dans le domaine 2 et installera le chemin sur le réseau N par le domaine 2 par l'intermédiaire du réseau externe reçu du B. Puisque le processus 2 est redistribué dans le processus 1, le routeur A injectera également un réseau externe N dans le domaine 1.

Remarque: Quand le routeur A a eu la Connectivité au réseau N, il a utilisé le processus 1 en raison de la distance administrative meilleure, et le processus 2 a été gardé pour les informations de sauvegarde. Une fois que le chemin à travers le processus 1 devient inaccessible, le processus 2 est utilisé pour la Connectivité.

Figure 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-05.gif

Maintenant, tous les Routeurs dans le domaine 2 utiliseront le routeur B pour atteindre le réseau N ; et routeur A (ou la partie du domaine 1 qui a perdu la Connectivité au réseau N par le domaine 1) utilisera le domaine 2 pour la Connectivité au réseau N. Ce scénario demeure valide si le routeur B avait perdu la Connectivité au réseau N, au lieu du routeur A.

Si le routeur A et le routeur B les deux Connectivité lâche au réseau N (par exemple, si le routeur C descend), alors à cette séquence d'opérations pourraient se produire :

  1. Avant que le réseau N devienne inaccessible, le routeur A et le routeur B ont appris le réseau N bien que le processus 1 et redistribué lui dans le processus 2 comme externes.

  2. Le routeur A et le routeur que B détectent (presque en même temps) ce réseau N est inaccessible par le domaine 1 ; donc, ils videront leur N précédemment externe dans le domaine 2.

  3. Avant le routeur A (le routeur B) reçoit le LSA vidé du routeur B (le routeur A), il installera le N externe par le domaine 2 (une distance administrative plus élevée) comme route de secours.

  4. Depuis le routeur A (le routeur B) N installé par le processus 2, il génèrera un N externe dans le domaine 1.

  5. Routeur A (le routeur B) reçoit le LSA vidé (événement 1) de routeur B (routeur A). Il retirera le réseau N par le processus 2 et, en conséquence, vider le N externe dans le réseau N du domaine 1. a été appris par le domaine 2 et redistribué dans le domaine 1.

  6. Avant le routeur A (le routeur B) reçoit le LSA vidé du routeur B (le routeur A), il installera le réseau externe N par le domaine 1, parce que N a été cependant vidé le domaine 2.

  7. Depuis le routeur A (le routeur B) le réseau installé N par le processus 1, il génèrera un N externe dans le domaine 2.

Vous pouvez voir qu'il y a une condition de compétitivité qui pourrait apparaître d'un domaine à l'autre domaine. Dans les événements 1, 4, et 7, le routeur A génère un réseau externe N dans le domaine 2 ; et dans les événements 2 et 5, le routeur A retire le préfixe. Le problème se pose parce que les artères apprises par un domaine sont redistribuées de nouveau au même domaine.

Solution proposée

Cette section affiche comment empêcher une artère qui appartient à un domaine d'être redistribué de nouveau au même domaine, pour éviter des boucles de routage.

Utilisant la commande de la distance 255

La section précédente affiche comment une boucle de routage est créée si les préfixes appris d'un domaine sont redistribués de nouveau au même domaine. Puisque la redistribution se produit d'une table de routage, vous pouvez empêcher une artère qui appartient au domaine 1 et qui est apprise du routeur distant au-dessus du domaine 2 d'être installé dans la table de routage. Par conséquent, le routeur ne redistribuera pas ces artères de nouveau au domaine 1.

Pour faire ceci, émettez la commande access-list d'inverse_mask de router_ID de la distance 255. Cette commande indique le routeur refuser tous les préfixes qui sont reçus par un routeur distant avec l'ID de routeur spécifié et qui apparient la liste de contrôle d'accès (ACL) de la table de routage.

Remarque: La commande de la distance 255 donne une distance de 255 à ces artères et empêche, en conséquence, leur installation dans la table de routage.

Dans la figure 6, le routeur A utilise la commande de la liste d'accès 1 d'apparier toutes les artères dans le domaine 1 et utilise la commande de la distance 255 sous le processus 1 de refuser les artères reçues du routeur B qui apparient les préfixes qui appartiennent au domaine 1.

Quand vous utilisez la commande de la distance 255, elle refuse n'importe quelle artère reçue du routeur B qui appartient au domaine 1. Puisque le routeur B redistribue toutes les artères dans le domaine 1 dans le domaine 2, le routeur A n'installera pas ces artères et, en conséquence, ne les redistribuera pas de nouveau dans le domaine 1 de nouveau.

Remarque: L'interface connectée du routeur B dans le domaine 1 devrait être exclue de l'ACL.

Figure 6

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Configuration du routeur A Configuration du routeur B
router ospf 1
redistribute ospf 2 subnet
distance 255 <Router B> 0.0.0.0 2
!
access-list 1

!--- Matches the router in Domain 2.


router ospf 2
redistribute ospf 1 subnet
distance 255 <Router B> 0.0.0.0 1
!
access-list 2

!--- Matches the route in Domain 1.

router ospf 1
redistribute ospf 2 subnet
distance 255 <Router A> 0.0.0.0 2
!
access-list 1

!--- Matches the router in Domain 2.


router ospf 2
redistribute ospf 1 subnet
distance 255 <Router A> 0.0.0.0 1
!
access-list 2

!--- Matches the route in Domain 1.

La commande 200 externe de distance ospf précédent n'est nécessaire plus parce que des artères apprises du routeur distant par l'intermédiaire d'un des processus ne sont pas installées.

Cette configuration fonctionne correctement dans les cas où les deux Routeurs desserrent la Connectivité au réseau (comme décrit en fonctionnement l'exploitation réseau sans panne de réseau et l'exploitation réseau avec la panne de réseau). Cependant, parce que les préfixes sont refusés de la table de routage, les domaines ne peuvent pas se sauvegarder.

Remarque: Vous devez explicitement répertorier tous les préfixes de chaque domaine dans un ACL. La maintenance d'un tel ACL peut être très difficile.

Artères de filtrage basées sur des balises

Il y a une nouvelle caractéristique en logiciel de Cisco IOS (d'ID de bogue Cisco CSCdt43016 (clients enregistrés seulement)) qui te permet pour filtrer des artères a basé sur la balise. Pour empêcher la redistribution des artères d'un domaine de nouveau dans le même domaine, un routeur peut étiqueter une artère qui appartient à un domaine tandis qu'il redistribue, et vous pouvez filtrer ces artères sur le routeur distant basé sur la même balise. Puisque les artères ne seront pas installées dans la table de routage, elles ne seront pas redistribuées de nouveau dans le même domaine.

Figure 7

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet tag 1
distribute-list 1 route-map filter_domain2 in
!
route-map filter_domain2 deny 10
match tag 2
route-map filter_domain2 permit 20

router ospf 2
redistribute ospf 1 subnet tag 2
distribute-list 1 route-map filter_domain1 in
!
route-map filter_domain1 deny 10
match tag 1
route-map filter_domain1 permit 20

Quand vous redistribuez du domaine 1, les artères sont étiquetées avec la balise 1 et sont filtrées sur le routeur distant basé sur la même balise. Quand vous redistribuez du domaine 2, les artères sont étiquetées avec la balise 2 et sont filtrées sur le routeur distant basé sur la même balise.

Remarque: La commande 200 externe de distance ospf précédent n'est nécessaire plus parce que l'artère apprise du routeur distant par l'intermédiaire d'un des processus n'est pas installée.

Cette configuration fonctionne correctement dans les cas où les deux Routeurs desserrent la Connectivité au réseau (comme décrit en fonctionnement l'exploitation réseau sans panne de réseau et l'exploitation réseau avec la panne de réseau). Cependant, parce que les préfixes sont refusés de la table de routage, les domaines ne peuvent pas se sauvegarder.

Utilisant le mot clé interne de correspondance tout en redistribuant

Quand vous redistribuez d'un domaine, vous pouvez employer le mot clé interne de correspondance pour redistribuer seulement les routes internes qui appartiennent à un domaine dans un autre domaine. Ceci empêche la redistribution des préfixes qui sont déjà externes de nouveau dans le même domaine.

Figure 8

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet match internal
distance ospf external 200
!

router ospf 2
redistribute ospf 1 subnet match internal
distance ospf external 200
!

Cette configuration fonctionne correctement dans les cas où les deux Routeurs desserrent la Connectivité au réseau (comme décrit en fonctionnement l'exploitation réseau sans panne de réseau et l'exploitation réseau avec la panne de réseau). Un domaine a pu sauvegarder l'autre domaine.

S'il y a déjà des préfixes externes dans l'un ou l'autre des domaines (tels que les préfixes externes qui ont été redistribués par l'intermédiaire d'un autre protocole), alors ces préfixes ne seront pas redistribués à d'autres domaines, parce que seulement des préfixes internes sont redistribués. En outre, il n'y a aucun contrôle des préfixes externes, et tous les préfixes externes seront bloqués.

Filtrage basé sur préfixe

Quand vous redistribuez d'un domaine, des préfixes peuvent être appariés contre un ACL pour éviter la redistribution des préfixes qui appartiennent à un domaine de nouveau dans le même domaine.

Figure 9

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Routeur A et configuration B
router ospf 1
redistribute ospf 2 subnet route-map filter_domain2
distance ospf external 200
!
route-map filter_domain2 permit 10
match ip address 1
!
access-list 1

!--- Matches the prefix in Domain 1.


router ospf 2
redistribute ospf 1 subnet route-map filter_domain1
distance ospf external 200
!
route-map filter_domain1 permit 20
match ip address 2
!
access-list 2

!--- Matches the prefix in Domain 2.

Cette configuration fonctionne correctement dans les cas où les deux Routeurs desserrent la Connectivité au réseau (comme décrit en fonctionnement l'exploitation réseau sans panne de réseau et l'exploitation réseau avec la panne de réseau). Un domaine a pu sauvegarder l'autre domaine.

Remarque: Vous devez explicitement répertorier tous les préfixes de chaque domaine dans un ACL. La maintenance d'un tel ACL peut être très difficile. Une autre solution est d'étiqueter des préfixes pendant la distribution et puis de filtrer les étiquettes correspondantes.

Figure 10

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-03.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet tag 1 route-map filter_domain2
distance ospf 2 external 200
!
route-map filter_domain2 deny 10
match tag 2
route-map filter_domain2 permit 20

router ospf 2
redistribute ospf 1 subnet tag 2 route-map filter_domain1
distance ospf 1 external 200
!
route-map filter_domain1 deny 10
match tag 1
route-map filter_domain1 permit 20

Filtrage basé sur préfixe et distance administrative basée sur préfixe

Comme mentionné dans la section de distance administrative, il y a un besoin de distance administrative basée sur préfixe où il y a des préfixes externes lancés par d'autres ASBR de chaque domaine. Dans la topologie d'exemple suivant, ASBR1 et ASBR2 redistribuent des réseaux X et Y dans le domaine 1 et le domaine 2, respectivement.

Cet exemple emploie un ACL pour apparier tous les préfixes qui (internes et externes) appartiennent à un domaine, et il utilise la commande de distance d'augmenter la distance administrative des préfixes qui n'appartiennent pas au commencement au domaine correspondant.

Figure 11

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/4170-ospfprocesses-06.gif

Routeurs A et configuration B
router ospf 1
redistribute ospf 2 subnet route-map filter_domain2
distance 200 0.0.0.0 255.255.255.255 2
!
route-map filter_domain2 permit 10
match ip address 1
!
access-list 1

!--- Matches the prefixes in Domain 1.

access-list 2

!--- Matches the prefixes in Domain 2.


router ospf 2
redistribute ospf 1 subnet route-map filter_domain1
distance 200 0.0.0.0 255.255.255.255 1
!
route-map filter_domain1 permit 10
match ip address 2
!
access-list 1

!--- Matches the prefixes in Domain 1.

access-list 2

!--- Matches the prefixes in Domain 2.

La commande de 0.0.0.0 255.255.255.255 2 de la distance 200 sous le processus 1 place la distance administrative de tous les préfixes qui appartiennent au domaine 2 200 ; donc, les Routeurs A et B emploient le domaine 1 pour atteindre les préfixes qui appartiennent au domaine 1.

Remarque: Vous devez explicitement répertorier tous les préfixes externes de chaque domaine dans un ACL. La maintenance d'un tel ACL peut être très difficile.

Résumé

Quand il y a plus d'un point de redistribution entre les domaines OSPF, les boucles de routage peuvent facilement se produire. Pour empêcher des boucles de routage, des préfixes qui appartiennent à un domaine ne devraient pas être redistribués de nouveau au même domaine. En outre, les distances administratives des processus OSPF devraient être placées correctement. On a proposé ces cinq méthodes dans ce document :

  • Utilisez la commande de la distance 255.

  • Filtre basé sur des balises.

  • Utilisez le mot clé interne de correspondance pendant la redistribution.

  • Filtrage basé sur préfixe d'utilisation pendant la redistribution.

  • Filtrage basé sur préfixe d'utilisation et distance administrative basée sur préfixe.

Les deux premières solutions empêchent les artères qui appartiennent à un domaine d'être installé dans la table de routage, qui empêche leur redistribution de nouveau au même domaine.

Remarque: Puisque les préfixes sont refusés de la table de routage, les domaines ne peuvent pas se sauvegarder.

Vous pouvez employer les trois dernières solutions pour sauvegarder un domaine avec un autre domaine, si nécessaire. Cependant, vous devriez noter ces mises en garde :

  • La solution interne de correspondance ne te permet pas pour avoir le contrôle des préfixes, et tous les préfixes externes seront bloqués de la redistribution. En d'autres termes, s'il y a des préfixes externes d'autres ASBR, puis ces LSAs ne sera pas redistribué d'un domaine à l'autre.

  • « Le filtrage basé sur préfixe d'utilisation la solution pendant redistribution » permet à un domaine pour sauvegarder un autre domaine. Cependant, la sauvegarde fonctionne seulement correctement quand il n'y a aucune artère externe de l'autre ASBR.

  • La solution de filtrage basé sur préfixe d'utilisation et « de distance administrative basée sur préfixe » est la seule solution qui permet à un domaine pour sauvegarder un autre domaine en présence des artères externes d'autres ASBR.

Ce document se rapporte à plusieurs reprises à l'utilisation d'un domaine de sauvegarder un autre domaine. Il convient noter que la « sauvegarde » signifie que, si le routeur A lâchement sa connexion à une partie du domaine par un domaine donné (tel que le domaine 1), puis lui pourrait utiliser l'autre domaine (domaine 2) à conduire correctement à ces destinations qui ne peuvent pas être accédées par le domaine 1.

Cependant, si un domaine est divisé parce que des préfixes ne sont pas redistribués de nouveau au domaine d'origine, puis l'autre domaine ne pourrait pas sauvegarder le domaine divisé à moins que des préfixes soient redistribués de nouveau au domaine d'origine. Cependant, comme observé dans la distance administrative et l'exploitation réseau avec des sections de panne de réseau, ceci introduira d'autres problèmes.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 4170