Services de mise en réseau d'applications : Cisco LocalDirector de la gamme 400

Équilibrage de la charge de serveurs FTP via LocalDirector sans utiliser le service proxy FTP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Cisco a annoncé l' interruption de vente pour Cisco LocalDirector. Le pour en savoir plus, se rapportent aux notices de fin de vie et de fin de commercialisation de gamme 400 de LocalDirector et à des bulletins de produit.


Contenu


Introduction

Ce document explique comment équilibrer la charge des serveurs de Protocole FTP (File Transfer Protocol) par un LocalDirector sans utilisation du service de FTP de proxy.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Problèmes et solutions

Les difficultés principales de gérer le FTP par des périphériques comme le LocalDirector sont en grande partie dues à la voie de transmission de données. Ce qui suit sont deux scénarios possibles :

  1. FTP DE PORT : également connu en tant que FTP actif. La connexion de données est ouverte par le port de serveur 20 au port du client qui est passé par l'intermédiaire de la commande de PORT au-dessus du canal de contrôle.

  2. FTP DE PASSAGE : la connexion de données est initiée par le client. Le serveur envoie l'adresse IP et le port le client doit ouvrir la connexion avec au-dessus du canal de contrôle.

Scénario 1

Le problème dans le scénario le numéro 1, FTP de PORT, est que le LocalDirector doit être chargé pour créer une entrée d'écoulement pour le trafic initié du serveur interne.

Typiquement, la solution dans ce scénario est d'émettre la commande statique. Pour le trafic FTP, cependant, le LocalDirector l'applique automatiquement.

Scénario 2

Il y a deux problèmes avec le scénario le numéro 2, PASSENT LE FTP. Le premier problème est que l'équilibreur de charge doit être chargé de s'attendre à une connexion du client au port TCP de destination qui est différent de celui configuré sur les virtuals.

La solution dans ce problème est de créer non une configuration de port-limite telle que 172.17.241.254:0:0:tcp. À l'aide de l'aucune solution de port-limite, le LocalDirector reçoit et crée des écoulements pour chaque protocole de la couche 4 (L4) qui frappent l'adresse IP virtuelle. Avec le FTP sur le LocalDirector, cependant, ce n'est pas nécessaire, même avec une configuration de port-limite telle que 172.17.241.254:21:0:tcp.

Le LocalDirector continue d'examiner les sessions de contrôle de FTP afin d'intercepter les commandes qui déclencheront le transfert des données passif.

Le deuxième problème est que le LocalDirector doit prendre soin de la traduction de l'adresse IP envoyée par le serveur au client en mode de FTP de PASSAGE.

Ceci est fait automatiquement, même sans service proxy de FTP. L'adresse IP et le port auxquels le client devra se connecter sont affichés pendant la session de FTP toutes les fois qu'une commande qui déclenche une connexion de données est émise, comme affiché ci-dessous.

> 227 Entering Passive Mode (172,17,241,254,95,57) 

Vous pouvez voir que l'adresse retournée est le VIP externe et pas la vraie adresse interne. Ceci signifie que le LocalDirector continue d'observer la charge utile des paquets de la connexion de contrôle. Voyez le diagramme au-dessous du pour en savoir plus.

lb_ftp_servers.gif

L'exemple de sortie de commande est fourni ci-dessous.

[OK] 
localdirector# sho conf 
: Saved 
: LocalDirector 420 Version 4.2.2 
: Uptime is 0 weeks, 0 days, 3 hours, 0 minutes, 35 seconds 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 10baset 
interface ethernet 1 10baset 
interface ethernet 2 100basetx 
interface ethernet 3 100basetx 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure? 0 
no secure? 1 
no secure? 2 
no secure? 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 172.17.241.11 255.255.255.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 172.17.241.27 
no failover 
failover hellotime 30 
password dfeaf10390e560aea745ccba53e044ed encrypted 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
virtual 172.17.241.254:21:0:tcp is 
real 172.17.241.126:21:0:tcp is 
bind 172.17.241.254:21:0:tcp 172.17.241.126:21:0:tcp 

Est ci-dessous le log de la session de FTP.

smarsill@bru-cse-126% ftp 172.17.241.254 
Connected to 172.17.241.254. 
220 CISCO FTP server (Version wu-2.6.1(1) Wed Aug 9 05:54:50 EDT 2000) ready. 
Name (172.17.241.254:smarsill): cisco 
331 Password required for cisco. 
Password: 
230 User cisco logged in. 
Remote system type is UNIX. 
Using binary mode to transfer files. 
ftp> ls 
227 Entering Passive Mode (172,17,241,254,95,57) 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> pass 
Passive mode off. 
ftp> ls 
200 PORT command successful. 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> 

Est ci-dessous la sortie du netstat - commande n après que la dernière commande ait été émise.

cisco@localhost cisco]$ netstat -n 
Active Internet connections (w/o servers) 
Proto Recv-Q Send-Q Local Address?????????? Foreign Address???????? State 
tcp??????? 0????? 0 172.17.241.126:20?????? 144.254.3.201:40411???? TIME_WAIT?? 

!--- Data Active expired.
 
tcp??????? 0????? 0 172.17.241.126:24377??? 144.254.3.201:40410???? TIME_WAIT?? 

!--- Data Passive expired.

tcp??????? 0????? 0 172.17.241.126:21?????? 144.254.3.201:40408???? ESTABLISHED 

!--- Control.

tcp??????? 0??? 126 172.17.241.126:23?????? 144.254.3.201:40220???? ESTABLISHED 

!--- Telnet session. 

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 4068