Redes do MS Windows

Windows Networking Design Implementation Guide (Guia de implementação de projeto de rede Windows)

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice

Discussões relacionadas da comunidade de suporte da Cisco

Introdução

O termo “rede” abrange uma ampla gama de tecnologias, que, quando combinadas, permite que computadores compartilhes informações. Os componentes de rede podem ser segmentados em aplicativos do sistema final, sistemas operacionais de rede e equipamento de rede.

Um sistema operacional de rede é software executado em todos os sistemas intercomutado. Os exemplos incluem aplicação NFS do Novell netware, do Sun (Network File System), de AppleShare, e de Microsoft de um Windows Networking geralmente chamado do sistema operacional de rede. O Windows Networking é distribuído agora extensivamente com milhões de Nós.

Este Guia de Design explica os conceitos básicos do Windows Networking e fornece a introspecção em como projetar redes (LAN e WAN) ao melhor utiliza este sistema operacional. O guia igualmente explica protocolos, nomeação, e questões de escalada associadas com o Windows Networking.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Que é Windows Networking?

O Windows Networking refere o sistema de rede de comunicação compartilhado pelo software que vem com todos os seguintes sistemas operacionais Microsoft ou server:

  • Gerenciador de LAN do Microsoft

  • MS-DOS com cliente do gerenciador de LAN

  • Janelas para grupos de trabalho

  • Windows 95, 98, e MIM

  • Windows NT e 2000

O gerenciador de LAN do Microsoft, o cliente do gerenciador de LAN para MS-DOS, e o Windows NT 3.1 não são discutidos neste documento exceto em um contexto histórico.

Domínios contra grupos de trabalho

O Windows Networking tem três conceitos de um grupo de grupos de trabalho relacionados dos computadores, de domínios e de uma hierarquia de domínio. Os grupos de trabalho podem ser toda a coleção lógica dos computadores; todo o computador na rede pode juntar-se a um grupo de trabalho existente ou criar um novo. Mais entidades formais, domínios são criadas e controladas por um processo do controlador de domínio principal (PDC) que seja executado em um Windows NT ou em um servidor do Windows 2000. Um domínio tem a Segurança e as propriedades administrativas que um grupo de trabalho não faz. Cada domínio deve ter pelo menos um NT ou 2000 server, que é responsável para o processo PDC, a informação de conta de usuário no domínio, e a Segurança dentro do domínio. Os domínios de Rede Windows não são os mesmos que Domain Name do Internet como usados pelo Domain Name System (DNS). Uma hierarquia da hierarquia de domínio ou de diretório ativo é uma coleção de domínios organizada em relacionamentos pai-filho. Esta convenção, introduzida com Windows 2000, permite uma pesquisa mais fácil através dos domínios múltiplos em uma única pergunta (entre outras coisas). Estes mapas de hierarquia a um espaço de nome de DNS.

Que protocolo usa?

Antes do Windows 2000, o Windows Networking usou o protocolo de netbios para o compartilhamento de arquivo, o compartilhamento de impressora, a Mensagem, a autenticação, e a resolução de nome. Uma instalação pura do Windows 2000 exigiria NetBIOS somente para a Interoperabilidade com versões anterior do Windows Networking usando o espaço de nome plano de NetBIOS. NetBIOS é um protocolo de camada de sessão que possa ser executado em alguns dos seguintes protocolos de transporte:

  • NetBEUI (NetBIOS sobre LLC2)

  • NWLink (NetBIOS sobre o [IPX] das trocas de pacote Internetwork IPX)

  • NetBIOS sobre TCP (NBT)

Embora Microsoft recomende que os clientes usam somente um protocolo de transporte de cada vez para o desempenho máximo, esta instalação é somente o padrão para o Windows 2000. Você deve escolher um protocolo para usar-se para sua toda a rede, preferivelmente TCP/IP, e desliga então os outros protocolos porque o serviço de nome de netbios mantém a informação sobre nomes de computador (um espaço de nome) separadamente para cada transporte. Os espaços de nome não interagem um com o otro; cada transporte opera-se como uma rede separada.

O NetBEUI (NetBIOS sobre LLC2) é menos escalável dos três protocolos porque deve ser construído uma ponte sobre. O NetBEUI é incluído para apoiar somente serviços muito velhos (por exemplo, versões velhas do gerenciador de LAN). O NetBEUI não exige nenhuma configuração de endereço cliente. Não há nenhum limite fixo ao número de clientes do Windows pode ter com NetBEUI, mas é comum para que esta solução seja executado em problemas de desempenho porque o número de clientes em um grupo de Bridge único vai acima dos 50 pés a 100 usuários. A topologia plana e a confiança em transmissões não escalam, especialmente quando o tráfego deve atravessar um link MACILENTO.

O NWLink é recomendado somente para as redes já que executam o IPX que não pode ser promovido para usar o TCP/IP. Similar ao NetBEUI, o NWLink não exige nenhuma configuração de endereço cliente. O NWLink usa pacotes do tipo 20 IPX para trocar o registo e a informação de navegação. Para enviar pacotes IPX do tipo 20 através dos roteadores Cisco, você deve configurar a propagação IPX tipo 20 em cada relação em cada roteador em sua rede.

Recomenda-se utilizar NetBIOS sobre TCP (NBT) para a maioria de redes, ou quando a rede inclui WAN. Desde que o NBT usa o TCP/IP, cada computador deve ser configurado para usar um endereço IP estático, ou para buscar dinamicamente um endereço IP de Um ou Mais Servidores Cisco ICM NT com o protocolo de configuração dinâmica host (DHCP). Para a facilidade da administração de rede, é altamente recomendado usar o DHCP; para o desempenho de rede ótimo, é altamente recomendado usar também o server das VITÓRIAS a (Windows Internet Name Service). Um server das VITÓRIAS permite que os clientes obtenham a informação de navegação sem tem que requisições de transmissão todas as vezes. Há uma correlação direta entre o número de transmissões em uma rede e o desempenho da rede; as transmissões são necessárias para que uma rede funcione, mas minimizá-las pode ser crítica.

Cisco recomenda que a maioria de clientes usam o TCP/IP para o Windows Networking. O volume deste Guia de Design centra-se sobre projetos usando o NBT.

Endereçamento do IP dinâmico

Que é DHCP?

Manualmente endereçar clientes TCP/IP é demorado e sujeito a erros. Para resolver este problema, o Internet Engineering Task Force (IETF) desenvolveu o DHCP, o protocolo de configuração dinâmica host. O DHCP é projetado fornecer automaticamente clientes um endereço IP válido e uma informação de configuração relacionada (veja as opções de DHCP da seção abaixo). Cada intervalo de endereço que um servidor DHCP controla é chamado um espaço.

Escopos de DHCP

Você deve configurar um intervalo de endereço para cada sub-rede IP onde os clientes pedirão um endereço de DHCP; cada intervalo de endereço é chamado um escopo de DHCP. Você pode configurar um servidor DHCP para servir diversos espaços desde que o servidor DHCP ou os server não precisam de ser conectados fisicamente à mesma rede que o cliente. Se o servidor DHCP está em uma sub-rede diferente IP do cliente, a seguir você precisa de usar a transmissão de DHCP para enviar requisições DHCP a seu servidor DHCP.

Transmissão de DHCP

A transmissão de DHCP é executado tipicamente em um roteador e o suporte de relay está disponível na versão de servidor 4.0 do Windows NT e no servidor do Windows 2000. Em Cisco 700 Series Router, você pode girar sobre a transmissão de DHCP com o comando set dhcp relay. Você pode girar sobre a transmissão de DHCP em um roteador do Cisco IOS configurando o endereço auxiliar IP com o endereço do servidor DHCP em cada relação que terá clientes DHCP. O comando ip helper-address para a frente muitas outras transmissões IP, incluindo pacotes DNS, de Trivial File Transfer Protocol (TFTP), e de serviço de nome de netbios. Para enviar somente requisições DHCP, veja a configuração do exemplo seguinte. Para mais informação, veja a seção " configurando manejo de transmissão " nos protocolos de rede manual de configuração, a parte I.

no ip forward-protocol udp tftp

no ip forward-protocol udp dns

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip forward-protocol udp bootpc

!

interface ethernet 0

ip helper-address 172.16.12.15

interface ethernet 1

ip helper-address 172.16.12.15

Opções de DHCP

Além do que seu endereço IP de Um ou Mais Servidores Cisco ICM NT, um DHCP Client pode obter a outra informação de configuração TCP/IP de um servidor DHCP, incluindo a máscara de sub-rede, o gateway padrão, e a informação de DNS. Estas partes de informação, chamadas opções de DHCP, podem ser configuradas no gerenciador de DHCP em seu servidor DHCP do Windows NT ou do Windows 2000.

Figura 1: O gerenciador de DHCP de Microsoft

/image/gif/paws/10624/winnt_d0.gif

Se seus clientes estão usando o Windows Internet Name Service (VITÓRIAS) para a resolução de nome (discutida mais tarde), você deve configurar o endereço do server das VITÓRIAS e do tipo do nó do WINS. Uma lista resumida dos tipos de nó é incluída na seção " resolução de nome ". O p-nó do tipo de nó (0x2) é recomendado fortemente.

Server do DHCP Cisco

Cisco tem atualmente um DHCP e um servidor DNS integrados para o Windows NT, o Windows 2000 e o UNIX; o server tem uma interface gráfica, o apoio para o endereçamento secundário, e os muitos outros recursos de empreendimento. O Roteadores dos Cisco 700 Series Router (na liberação 4.1 e mais atrasado) e do Cisco IOS (na release 11.2(7)F e mais recente) igualmente inclui um servidor DHCP que possa atribuir endereços em segmentos de rede locais. Ambos os estilos do roteador incluem a tradução de endereços da rede e do porta-nível.

Resolução de nome

A resolução de nome é o processo de associar um nome conveniente, tal como o FRED ou o fred.domain.com, com um endereço de rede (frequentemente um endereço IP de Um ou Mais Servidores Cisco ICM NT). Para as finalidades atuais, esta discussão aplica-se à maneira que o Windows Networking resolve um nome original da estação de trabalho de NetBIOS (descrito como o WORKSTATION<00> em uma seção mais recente) a um endereço IP de Um ou Mais Servidores Cisco ICM NT. Este processo não deve ser confundido com o processo relacionado mas diferente de consultação (que usa outros tipos de nomes de netbios). Até à data da liberação do Microsoft Windows 2000, os clientes do Windows Networking usam até cinco métodos da resolução de nome:

  • Cache de nome de netbios

  • Broadcasts de sub-rede IP

  • LMHOSTS

  • GANHA

  • DN do Internet

Cache de nome de netbios

O Windows Networking mantém um esconderijo pequeno de nomes de netbios recentemente usados aos mapeamentos de endereço IP. Estas entradas são adicionadas após a resolução de nome bem sucedida e então removidas após algum período de tempo. As entradas adicionais podem ser preloaded na inicialização do sistema e no permanent feito criando uma entrada no LMHOSTS para arquivar com a etiqueta #PRE (veja a seção LMHOSTS abaixo).

Broadcasts de sub-rede IP

Os broadcasts de sub-rede IP podem ser usados para a resolução de nome. As transmissões são recebidas por todos os computadores em uma sub-rede, exigindo o tempo de processamento em cada computador. O Windows Networking igualmente mantém um Browse Master designado que mantém uma lista de todos os recursos disponíveis em uma sub-rede. Um processo de eleição que use transmissões determina este Browse Master porque os registos, as eleições de navegador, e as consultas de nome poderiam todos gerar transmissões, uso do método da resolução de nome de transmissão não é recomendado.

LMHOSTS

O Windows Networking pode consultar uma tabela estática em um arquivo chamado LMHOSTS. Para usar este método, o PDC deve manter pelo menos uma lista estática de todos os computadores e de seus endereços IP de Um ou Mais Servidores Cisco ICM NT nesse domínio e os nomes e endereço dos PDC para todos domínios restantes na rede. Todos os clientes devem então ter um arquivo LMHOSTS com o endereço IP de Um ou Mais Servidores Cisco ICM NT de seu PDC e o trajeto ao arquivo do mestre LMHOSTS no PDC.

Windows Internet Name Service

As VITÓRIAS foram criadas para permitir que os clientes no sub-redes IP diferente resolvam dinamicamente endereços, para registrar-se, e consultar a rede sem enviar transmite. Os clientes enviam pacotes do unicast ao server das VITÓRIAS em um endereço bem conhecido. Para a compatibilidade com os clientes mais idosos da rede microsoft, contudo, a resolução de nome de transmissão está girada ainda sobre à revelia, mesmo quando as VITÓRIAS são configuradas igualmente.

Para repetir o que foi indicado acima, é altamente recomendado para que o desempenho de rede ótimo use VITÓRIAS. Além disso, há uma correlação direta entre o número de transmissões em uma rede e o desempenho da rede; as transmissões são necessárias para que uma rede funcione, mas minimizá-las pode ser crítica.

DN do Internet

Todo o servidor DNS pode ser configurado estaticamente para responder a perguntas para computadores com endereços IP fixos. Esta encenação é útil se os computadores em sua rede têm endereços IP fixos. Quando os sistemas Windows usam o DHCP para conseguir um endereço IP de Um ou Mais Servidores Cisco ICM NT e VITÓRIAS registrar um nome de netbios, você pode estabelecer um servidor DNS de Windows para perguntar um server das VITÓRIAS para os nomes ou os endereços que não foram incorporados estaticamente. Em ambos os casos, Windows e os sistemas diferentes do Windows podem resolver endereços IP de Um ou Mais Servidores Cisco ICM NT corretamente.

Se um administrador configura cada servidor de rede Windows com um endereço IP estático, pode ser conveniente inscrever cada server no sistema DNS e no uso DNS para a resolução de nome. Ocasionalmente (por exemplo, ao usar um link de discagem sob demanda) é conveniente registrar clientes com VITÓRIAS e fazer perguntas com DNS. Microsoft NT 3.51 kit de recurso, server do Windows NT 4.0 e Windows 2000 todos inclui um servidor DNS que possa responder a perguntas DNS perguntando um server das VITÓRIAS no fundo. Para obter mais informações sobre de como configurar esta arquitetura, veja o apêndice A.

Com Windows 2000, os servidores DNS podem igualmente dinamicamente ser configurados com endereço aos mapeamentos de nome. Os server dos clientes DHCP, dos servidores DHCP e dos DN Dinâmicos funcionam junto para atualizar o nome aos mapeamentos de endereço no servidor DNS. O servidor DHCP executará esta atualização para 2000 clientes DHCP não-Windows.

Figura 2: Windows e os sistemas diferentes do Windows ambos enviam pesquisas de DNS para um server do Windows NT nomeado Javali africano. O servidor DNS não tem uma entrada para o javali africano, assim que pergunta o server das VITÓRIAS e retorna o endereço IP de Um ou Mais Servidores Cisco ICM NT.

/image/gif/paws/10624/winnt_d1.gif

Ordem de consulta de nome

Os componentes do Windows Networking enviam perguntas da resolução de nome em uma ordem diferente, segundo o tipo de nó de NetBIOS. Se o sistema é Windows NT 4.0 e o nome é mais longo de 15 caráteres, a seguir o Windows NT envia somente uma pergunta DNS. Outros componentes de rede de comunicação e serviços podem igualmente usar uma ordem diferente segundo o API chamado para executar a resolução de nome. Por exemplo, um aplicativo dos soquetes que chama o gethostbyname() usará o DNS para a resolução de nome primeiramente. Se não a consulta de nome é executada no seguinte ordem:

  • Verifique o cache de nome de netbios.

  • Envie uma pergunta da transmissão ou um nome da pergunta das VITÓRIAS, segundo o tipo de nó atual de NetBIOS.

  • Verifique o arquivo LMHOSTS.

  • Verifique o arquivo dos ANFITRIÕES (se a “resolução que usa o DNS” é verificada).

  • Envie uma pergunta dos DN do Internet (se a resolução que usa o DNS é verificada).

Tabela 1: Os nomes de netbios são procurados diferentemente basearam no tipo de nó de NetBIOS

Tipo de nó de NetBIOS Ordem de busca de nome
b-nó (0x1) Transmissão somente
p-nó (0x2) VITÓRIAS somente
m-nó (0x4) Transmissão, então VITÓRIAS
h-nó (0x8) As VITÓRIAS, transmitiram então

O navegador dos serviços de LAN de Microsoft

O Windows Networking foi projetado originalmente ser executado em um único segmento de LAN ou em uma rede construída uma ponte sobre (do plano). Naquele tempo, somente o protocolo de NetBEUI foi apoiado.

Microsoft desenvolveu o navegador dos serviços de LAN para permitir o usuário de consultar uma lista de todos os computadores disponíveis na rede. Cada cliente do Windows Networking registrou seu nome de netbios periodicamente enviando transmissões.

Cada computador igualmente teve que enviar transmissões para eleger um Browse Master para a rede. O Browse Master (e diverso o backup consulta mestres) manteve a lista de computadores e de seus endereços. Quando um usuário consultou a rede, o cliente enviou uma requisição de transmissão e um dos mestres da consultação respondeu.

Eventualmente Microsoft adicionou o apoio para NetBIOS sobre o IPX e NetBIOS sobre o TCP/IP, mas o Windows Networking ainda supôs que todos os clientes e servidor estavam na mesma Rede IPX lógica ou na sub-rede IP---ainda enviaram transmissões para registrar e encontrar computadores na rede.

Esta arquitetura, embora simples executar, gerado uma carga enorme na rede e no CPU de cada cliente na rede. Devido a estes problemas de escalabilidade, Microsoft começou a oferecer outros métodos da consultação e da resolução de nome---maneiras para que os clientes tracem um nome ao endereço IP de Um ou Mais Servidores Cisco ICM NT de outros computadores na rede. Eventualmente Microsoft igualmente forneceu uma maneira de consultar e resolver nomes sem transmissões.

O resto desta seção explica como consultar trabalha em vários ambientes. A seção anterior explicada como os nomes de netbios individuais são resolved. Estas duas atividades são similares mas distintas. Os usuários consultam a rede ao abrir a vizinhança de rede, ao usar o comando net view, ou ao registrá-lo em um domínio de Windows NT na partida. A resolução de nome é o processo de resolver os nomes conhecidos previamente, ou encontrou ao consultar. Note por favor que esta discussão é não relacionada aos navegadores da Web.

Nomes de netbios

Os nomes de netbios são 15-character, os nomes de caixa que têm um identificador especial adicionado ao 16o byte. Também, os nomes de netbios podem aplicar-se a um único endereço IP de Um ou Mais Servidores Cisco ICM NT (original), ou a mais de um (grupo). Alguns tipos do nome podem ser originais ou nomes do grupo. Alguma do mais comum destes últimos caráteres é alistada como segue (todos os valores estão no hexadecimal):

Tabela 2: Uma tabela parcial de nomes de netbios especiais e de suas descrições

Nomes especiais registrados Descrição
Nomes de usuário
<USERNAME><00> Usado para registrar o nome do usuário atualmente entrado no banco de dados das VITÓRIAS, de modo que os usuários possam receber os comandos net send enviados a seus nomes de usuário.
Nomes de computador
<COMPUTER><00> Usado por estações de trabalho da rede microsoft para receber requisições de slot de correio da classe secundária. Todas as estações de trabalho devem adicionar este nome a fim receber requisições de slot de correio. Este é o nome de computador registrado para serviços da estação de trabalho por um cliente das VITÓRIAS.
<COMPUTER><03> Usado como o nome de computador que é registrado para o serviço de transferência de mensagem em um computador que seja um cliente das VITÓRIAS.
<COMPUTER><20> Usado como o nome que é registrado para o serviço do servidor de peer em um computador de Windows 95 (ou no serviço do servidor em um computador do Windows NT) que seja um cliente das VITÓRIAS.
<COMPUTER><Be> Usado como o nome exclusivo que é registrado quando o agente de monitor de rede for começado no computador.
<COMPUTER><Bf> Usado como o nome do grupo que é registrado quando o agente de monitor de rede for começado no computador. Se este nome não é 15 caráteres de comprimento, está acolchoado com (+) símbolos positivos.
<COMPUTER><1f> Usado como o nome exclusivo que é registrado para o intercâmbio de dados dinâmico da rede (DDE) quando o serviço de NetDDE for começado no computador.
Nomes do grupo
<01><02>MSBROWSE<02><01> Usado por servidores de navegador mestre para anunciar periodicamente seu domínio em uma sub-rede local. Este anúncio contém o Domain Name e o nome do servidor de navegador mestre para o domínio. Além, os servidores de navegador mestre recebem estes anúncios de domínio a este nome e mantêm-nos no seu interno consultam a lista junto com o nome de computador do anunciador.
<DOMAIN><00> Usado por estações de trabalho e por server aos anúncios do servidor de processo para apoiar o gerenciador de LAN do Microsoft. Os server que executam Windows 95, o Windows NT, o server de Windows NT, e as janelas para grupos de trabalho não transmitem este nome a menos que a opção LMAnnounce for permitida nas propriedades de server.
<DOMAIN><1b> Usado para identificar o nome do navegador mestre de domínio, que é um nome exclusivo que somente o controlador de domínio principal (PDC) possa adicionar. O PDC processa pedidos de GetBrowserServerList neste nome. As VITÓRIAS supõem que o computador que registra um Domain Name com o caráter <1b> é o PDC.
<DOMAIN><1c> Usado para o nome de grupo de Internet, que os controladores de domínio registram. O nome de grupo de Internet é uma lista dinâmica de até 25 computadores que registraram o nome. Este é o nome usado para encontrar um computador do Windows NT para passagem-através da autenticação.
<DOMAIN><1d> Usado para identificar um navegador mestre (não um navegador mestre de domínio). O navegador mestre adiciona este nome como um nome de netbios exclusivo quando começa. As estações de trabalho anunciam que sua presença a este nome de modo que os navegadores mestres possam construir o seu consulte a lista. Para grupos de trabalho, este nome tem o formulário <WORKGROUP><1d>.
<DOMAIN><1e> Usado para todos os anúncios do grupo de trabalho ou do amplo domínio por servidores de navegador em um grupo de trabalho de rede do Windows ou em um domínio de servidor do Windows NT. Este nome é adicionado por todos os servidores de navegador e servidores potenciais no grupo de trabalho ou no domínio. Todos os pacotes da eleição de navegador são enviados a este nome. Para grupos de trabalho, este nome tem o formulário <WORKGROUP><1e>.

O processo de inicialização

Na partida, todo o sistema conectado por rede envia uma série de pacotes para descobrir endereços de rede, registrar-se, autenticar-se, e para descobrir serviços. Os sistemas do Windows Networking que registram em um domínio de Windows NT devem contactar um controlador de domínio para autenticar. Este processo usa a resolução de nome e a consultação.

Primeiramente o sistema de inicialização deve registrar um nome de computador (WORKSTATION<00>). Se o parâmetro de Anúncio LM está ligada (para a compatibilidade com server do gerenciador de LAN), a seguir o sistema igualmente registra o DOMAIN<00>. Em seguida o sistema encontra um controlador de domínio para o domínio do início de uma sessão tentando resolver o DOMAIN<1C>. Antes do Windows 2000, deste trabalhados somente com métodos da transmissão, da resolução de nome LMHOSTS, ou de VITÓRIAS. Com Windows 2000, o DNS é tentado primeiramente. Em seguida, o sistema entra ao controlador de domínio que usa os mensagens de slot de correio NetBIOS-baseados, que são enviados na porta 138 do User Datagram Protocol (UDP). Finalmente, depois que o início de uma sessão é bem sucedido, o sistema registra o usuário que que entrou (USERNAME<03>) assim que o serviço de transferência de mensagem pode encontrar esse usuário.

Encontrando um computador

Quando requisições de usuário um recurso em um computador por nome (por exemplo: \ líquido do uso \ fred \ someshare, ou os achados FRED), o sistema local tentam resolver o nome de computador. Esta pergunta é para um nome de netbios exclusivo do tipo <00>, ou um DNS ou HOSPEDA a entrada de arquivo.

Vendo a vizinhança de rede

Quando um usuário abre a vizinhança de rede para pedir uma lista de domínios, o sistema tentará obter uma lista de backup de navegador, com a transmissão ao nome de navegador mestre, ou diretamente da conexão ao navegador mestre de domínio (ou ambos). Uma vez que uma lista de backup de navegador é recuperada, o sistema escolherá um backup de navegador, conecta-o a esse sistema e recupera-o a lista de domínios. As requisições subsequente para server dentro de um domínio são enviadas ao mesmo backup de navegador.

Sub-rede que consulta

Nos anos 80, a maioria de redes eram “lisas,” ou tinham somente algumas sub-redes. O NetBEUI e o NWLink usam este modelo, e as transmissões IP podem ser construídas uma ponte sobre ou ajudado através de um pequeno número de sub-redes. A seguinte discussão supõe o exemplo de uma rede plana.

Cada sub-rede tem um navegador mestre de sub-rede pelo domínio ou o grupo de trabalho e pode ter alguns backup de navegador da sub-rede (igualmente pelo domínio ou o grupo de trabalho). Após a inicialização, os backup de navegador e os nonbrowsers enviam anúncios de transmissão em intervalos crescentes de 1, 2, 4, e 8 minutos; eles eventualmente anúncios de transmissão somente cada 12 minutos. Os navegadores mestres de sub-rede escutam estes anúncios para construir uma lista da consultação.

Os navegadores mestres de sub-rede e os backup de navegador são responsáveis para responder consultam perguntas de outros computadores. Os navegadores mestres podem responder a estes pedidos diretamente da lista da consultação. Os backup de navegador igualmente mantêm uma lista da consultação, que peçam do navegador mestre de sub-rede cada 15 minutos.

Transmissão que consulta através das sub-redes

Na realidade, a maioria de redes têm hoje diversas sub-redes. Dos domínios as sub-redes do período frequentemente e as sub-redes contêm às vezes sistemas em mais de um domínio. O software de navegador em alguns sistemas pode comunicar-se com um navegador mestre de domínio (geralmente o PDC) para trocar consulta lista de muitas sub-redes, mas precisa de conhecer o endereço de unicast do navegador mestre de domínio. Um navegador mestre de sub-rede pode obter o endereço de unicast do PDC de um arquivo LMHOSTS (para uma descrição detalhada, veja a seção da resolução de nome) ou das VITÓRIAS (veja a próxima seção).

LMHOSTS é um arquivo de texto que o software de navegador possa ler para encontrar o endereço de unicast de um PDC. Uma amostra segue. É primeiramente o endereço IP unicast do PDC, em seguida o nome de netbios do PDC (ENG_PDC), uma etiqueta que armazene esta linha no cache de nome de netbios, (#PRE) e finalmente, uma etiqueta que marque este sistema como um controlador de domínio para o domínio Eng (#DOM).

10.1.3.4 ENG_PDC #PRE #DOM:eng

Quando um navegador mestre de sub-rede conhece o endereço de unicast do navegador mestre de domínio, a troca dos navegadores consulta lista cada 15 minutos (que usam pacotes do unicast IP). Porque um navegador mestre é consultado, os clientes podem consultar somente os domínios que têm um sistema na sub-rede local (um navegador mestre de sub-rede). Na prática, esta encenação trabalha suficientemente bem para encontrar um server do início de uma sessão na partida, mas não permite que os usuários consultem usando a vizinhança de rede.

Observação importante: Devido a um erro em algumas versões de janela para os grupos de trabalho 3.11 e o Windows 95, estes sistemas não podem funcionar como um navegador mestre de sub-rede ou um backup de navegador. O erro impede que o navegador de sub-rede contacte o navegador mestre de domínio. Este erro foi fixado em Windows 95 OSR (liberação) do serviço OEM 2. em consequência, consultar na sub-rede falha se há Win31 ou mestre ou backup de navegador de Win95 na sub-rede.

Consultando algum domínio com VITÓRIAS

Em uma organização com diversos domínios, não é razoável ao arquiteto que um baseado na rede nas limitações esboçou na seção anterior. Quando as VITÓRIAS estão sendo executado, o navegador de sub-rede pode ser um cliente das VITÓRIAS e pode obter o endereço IP unicast do navegador mestre de domínio (o PDC) para todo o domínio. Contudo, as transmissões são enviadas ainda frequentemente e repetidamente à revelia (veja a tabela descrever tipos do nó do WINS na seguinte seção) na possibilidade que pode haver clientes de algumas NON-VITÓRIAS na sub-rede. A melhor solução na maioria de redes é desligar a transmissão que consulta.

Desligar transmite

O desafio o mais grande quando desligar transmissões evitar os Navegadores-Mestre de Rogue, que causam dano em uma sub-rede porque interrompem o processo da consultação.

Figura 3: Navegador-Mestre de Rogue

/image/gif/paws/10624/winnt_d2.gif

Você pode desabilitar a resolução de nome de transmissão ajustando a configuração do navegador principal desabilitou. Nas janelas para grupos de trabalho 3.11, as transmissões são desligadas adicionando um comando ao arquivo SYSTEM.INI. (Veja o apêndice B para detalhes.) No Windows 95/98, a configuração do navegador principal em arquivo avançado e a cópia que compartilha de propriedades devem ser ajustadas deficiente. No Windows NT, não é necessário girar fora a consultação na maioria dos casos, embora possa ser desejável. No Windows NT, ajuste o Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ chave de registro do navegador \ parâmetros \ MaintainServerList não aos administradores pode controlar as transmissões enviadas por clientes DHCP selecionando o tipo do nó do WINS apropriado (p-nó: 0x2). Uma lista completa dos tipos do nó do WINS segue.

Tabela 3: Lista de tipos do nó do WINS

Tipo do nó do WINS Ordem de busca de nome
b-nó (0x1) Transmissão somente
p-nó (0x2) VITÓRIAS somente
m-nó (0x4) Transmissão, então VITÓRIAS
h-nó (0x8) As VITÓRIAS, transmitiram então

Escamação às redes maiores

Domínios confiável

Ao planear uma rede Windows, consideração de que modelo de domínio se usar é importante. Os seguintes parágrafos discutem os benefícios e os inconvenientes de diversos modelos de domínio. Se você tem diversos domínios, você quer provavelmente aos dados de intercâmbio com outros domínios em sua rede. As relações de confiança são uma maneira de ganhar ou acesso da concessão a um domínio sem ter que controlar individualmente cada usuário. Cada relacionamento permite a confiança em um sentido somente. Para mais informação, veja o kit de recurso de servidor do Windows NT 4.0, o volume 2, o capítulo 4.

Escolha o domínio

Este modelo de domínio é o mais simples---a rede tem somente um domínio. Esta instalação trabalha para as instalações pequenas ou de tamanho médio sem WAN.

Global trust

É projetada para empresas sem um administrativo central ou a organização, o modelo do global trust é o mais fácil de compreender e o mais difícil de controlar. Cada domínio confia cada outro domínio.

Domínio mestre

Neste modelo, um domínio mestre é confiado por todos domínios restantes, mas o domínio mestre confia ninguém. Esta opção é benéfica quando os departamentos ou as divisões querem o controle administrativo sobre seus próprios serviços, mas ainda quer autenticar centralmente.

Domínios mestres múltiplos

Este modelo é projetado ser uma versão maior do modelo do domínio mestre. Diversos domínios mestres toda a confiança, e cada um dos domínios mestres, são confiados por sua vez por cada domínio departamental.

Replicating VITÓRIAS

Para a Redundância ou aperfeiçoar o tráfego MACILENTO, às vezes tendo diversos server das VITÓRIAS é desejável. O Windows NT e os servidores do Windows 2000 podem replicate ou o ressincronizar GANHA bancos de dados em qualquer um ou em ambos sentidos. Em figura 4, uma grande empresa multinacional tem diversos server distribuídos das VITÓRIAS, assim VITÓRIAS que as perguntas não têm que viajar através dos continentes.

Figura 4: Exemplo de uma configuração de replicação WINS enterprise-wide

/image/gif/paws/10624/winnt_d3.gif

Acesso de modem

O Windows NT e o Windows 2000 vêm com servidor de acesso remoto (RAS) de Microsoft, que usa o Point-to-Point Protocol (PPP). Os clientes podem querer usar o Cisco access servers em vez de NT RAS para suas associações do discado devido à densidade e ao desempenho melhores do discado disponíveis no Cisco access servers.

Windows apoia o TCP/IP, o IPX, e o NetBEUI ([IPCP] do protocolo de controle de IP, [IPXCP] do protocolo de controle de IPX, e de [NBFCP] do protocolo netbios frames control protocolos de controle para o PPP). O apoio do discado NetBEUI foi adicionado ao Cisco IOS Software na liberação 11.1. Para o seletor NetBEUI dentro, use o comando netbios nbf (segundo as indicações do exemplo seguinte) em cada interface assíncrona ou em uma interface de grupo assíncrono no servidor de acesso.

interface ethernet 0

nbf NetBIOS

Interface Group-Async 0

intervalo de grupos 1 16

nbf NetBIOS

Para configurar dentro o seletor IPX, use o comando ipx ppp-client (segundo as indicações do exemplo seguinte) em cada interface assíncrona ou em uma interface de grupo assíncrono no servidor de acesso. Este comando exige-o configurar um endereço de rede do IPX em uma interface de loopback. Os clientes de discagem de entrada não precisam de ouvir mensagens do protocolo service advertisement (SAP), assim que estas mensagens devem ser desligadas com o comando ipx sap-interval 0.

Interface loopback 0

ipx network <network number>

interface group-async 0
group-range 1 16
ipx ppp-client loopback 0
ipx sap-interval 0

A fim atribuir endereços IP de Um ou Mais Servidores Cisco ICM NT aos clientes de discagem de entrada, o Cisco access servers pode usar um pool dos endereços locais ou atuar como um proxy para um servidor DHCP. O servidor de acesso pedem um endereço do servidor DHCP e os usos que endereçam durante a negociação de PPP. O cliente pode igualmente negociar o endereço de seu server das VITÓRIAS.

ip dhcp-server n.n.n.n


async-bootp nbns-server m.m.m.m


async-bootp dns-serverp.p.p.p


ip address-pool dhcp-proxy-client

!

interface group-async 0

group-range 1 16

peer default ip address dhcp

Dial-on-Demand Routing (DDR)

O Dial-on-Demand Routing (DDR) fornece conexões de rede através da rede telefônica pública comutada (PSTN). Tradicionalmente, as conexões de WAN foram linhas alugadas dedicadas. O DDR fornece o volume baixo, conexões de rede periódicas, permitindo custos de rede por encomenda dos serviços e da diminuição. O Integrated Services Digital Network (ISDN) é uma tecnologia comutada em circuito. Como a rede de telefone analógico, as conexões ISDN são feitas somente quando há uma necessidade de se comunicar.

Uso DDR dos roteadores Cisco determinar quando uma conexão precisar de ser feita a um outro local. Os pacotes são classificados como interessante ou sem interesse, com base em Listas de acesso do específico de protocolo e em listas de discadores. Os pacotes desinteressante podem viajar através de um link DDR ativo, mas não trazem o link acima, nem mantêm o link acima.

Os clientes das janelas para grupos de trabalho e do Windows 95/98 que a parte arquiva ou as impressoras registram-se com GANHAM cada doze ou quinze minutos enviando um pacote do unicast ao server das VITÓRIAS (na porta do serviço de nome de netbios da porta 137---the UDP).

Os sistemas do Windows NT podem igualmente enviar uma variedade de outros pacotes periódicos, que podem causar custos MACILENTOS altos. Estes pacotes periódicos incluem a sincronização de navegador, a replicação das VITÓRIAS, a replicação, a navegação de impressora, e o DHCP SAM (banco de dados da conta de usuário). Muitos destes serviços têm as chaves de registro que podem ser ajustadas para trazer acima frequentemente à conexão de discagem sob demanda menos. Para mais informação, veja a base de conhecimento microsoft, artigo: Q134985. As entradas de registro importantes incluem:

Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ navegador \ parâmetros \ MasterPeriodicity

Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ navegador \ parâmetros \ BackupPeriodicity

Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ Replicator \ intervalo

Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ Netlogon \ PulseMaximum

Hkey_local_machine \ sistema \ CurrentControlSet \ serviços \ controle \ cópia \ DisableServerThread

Figura 5: Link de discagem sob demanda acima todo o tempo

/image/gif/paws/10624/winnt_d4.gif

Enviar um pacote ao server das VITÓRIAS traz normalmente acima o link de discagem sob demanda. Se, contudo, esta porta é classificada como sem interesse ao Cisco IOS Software, a seguir o roteador nem traz acima nem prossegue o link.

Interface bri 0

dialer-group 1
!

dialer-list 1 protocol ip list 101

access-list 101 deny udp any any eq netbios-ns

access-list 101 permit ip any any

Figura 6: A porta 137 UDP é sem interesse, link está para baixo

/image/gif/paws/10624/winnt_d5.gif

Os filtros para o Cisco 700 Series estão disponíveis na liberação 4.1(2). Um filtro do exemplo para fazer o tráfego do Windows NT SAM sem interesse segue:

SET netbsp OFFSET 2 FROM TCPHDR PATTERN 00 8b 

SET netbnsp OFFSET 2 FROM UDPHDR PATTERN 00 89 

SET netbdgp OFFSET 2 FROM UDPHDR PATTERN 00 8a 

SET refresh OFFSET 10 FROM UDPHDR PATTERN 40 00 

SET netbsm OFFSET 20 FROM TCPHDR PATTERN 00 

SET smb OFFSET 24 FROM TCPHDR PATTERN ff 53 4d 42 

SET tcppat2 OFFSET 13 FROM TCPHDR PATTERN 02 

SET netbsr OFFSET 20 FROM TCPHDR PATTERN 81 

SET keepali OFFSET 20 FROM TCPHDR PATTERN 85 

SET tcpres OFFSET 13 FROM TCPHDR PATTERN 04 

SET IP FILTER OUT netbnsp refresh IGNORE

SET IP FILTER OUT netbdgp IGNORE

SET IP FILTER OUT netbsp netbsm smb IGNORE

SET IP FILTER OUT netbsp tcppat2 IGNORE

SET IP FILTER OUT netbsp tcpres IGNORE

SET IP FILTER OUT netbsp netbsr IGNORE

SET IP FILTER OUT netbsp keepali IGNORE

Acesso de ISDN

Esta seção cobre os cartões ISDN e os adaptadores terminal (TA). Para obter informações sobre de usar o Windows Networking com ISDN Router, veja a seção anterior no Dial-on-Demand Routing (DDR).

Adtran

Porque Adtran e Cisco trabalharam proximamente durante testes da Interoperabilidade, Adtran é um bom candidato a considerar para TA externos. Adtran TA apoia o multilink ppp (MP), o protocolo de autenticação de cumprimento do desafio (RACHADURA), o protocolo password authentication (PAP), o síncrono ou interfaces serial assíncronas, e a configuração do Automatic Service Profile Identifier (AutoSPID).

Motorola BitSURFR

A maneira a mais simples de fazer um BitSURFR conectado a um interoperam PC com um roteador Cisco é girar sobre o async/conversão de sincronismo com o comando AT%A2=95 (para mais informação, veja a página 7-1 do BitSURFR manual). Se você está usando um BitSURFR PRO e o quer usar ambos os canais B, você deve usar a autenticação pap. O BitSURFR PRO não pode corretamente responder ao desafio da RACHADURA enviado ao trazer acima o segundo canal B. Para colocar um atendimento usando dois canais B, você deve entrar no número de telefone duas vezes. Por exemplo, se o número de telefone é 555-1212, você incorporaria o ATD555-1212&555-1212. A tabela a seguir alista os comandos entrar para diversos tipos de conexão:

Tabela 4: Comandos Configuration úteis para Motorola BitSURFR

Tipo de conexão Comando
Conecte usando o PPP %A2=95
Use ambos os canais B (o MP) @B0=2
Usam a autenticação pap @M2=P
Velocidade do Data Termination Equipment (DTE) (porta COM PC) &M
Coloque os atendimentos 64-kbps %A4=0
Coloque os atendimentos 56-kbps %A4=1
Coloque chamadas de voz %A98

Software do cliente

CiscoRemote Lite

O CiscoRemote Lite é um pedido livre da pilha TCP/IP e do discador para Windows 3.1 e janelas para grupos de trabalho. CiscoRemote apoia o PPP e os protocolos do protocolo serial line internet (SLIP).

Exemplos

Exemplo 1

O exemplo 1 mostra um pequeno, rede de domínio único usando o NWLink (NetBIOS sobre o IPX). A figura 7 mostra um gráfico da instalação.

Figura 7: Pequeno, rede de domínio único usando o NWLink

/image/gif/paws/10624/winnt_d6.gif

Configuração do Cisco 4700 Router

hostname 4700

ipx routing

!

interface ethernet 0

ipx network 50

ipx type-20-propagation

interface ethernet 1

ipx network 60

ipx type-20-propagation

interface ethernet 2

ipx network 7B

ipx type-20-propagation

interface ethernet 3

ipx network 95

ipx type-20-propagation

Configuração do Servidor de acesso Cisco 2511

hostname 2511

ipx routing

!

interface ethernet 0

ipx network 98

interface loopback 0

ipx network 163

interface group-async 0

group-member 1 16

ipx ppp-client loopback 0

ipx sap-interval 0

encapsulation ppp

async mode dedicated

!

line 1 16

modem inout

speed 115200

flowcontrol hardware

Exemplo 2

O exemplo 2 mostra uma rede de tamanho médio usando NBT (NetBIOS sobre o TCP) e a resolução de nome estática (LMHOSTS). Figura 8 mostra um gráfico da instalação.

Figura 8: Rede de tamanho médio usando o NBT e o LMHOSTS

/image/gif/paws/10624/winnt_d7.gif

Configuração lmhosts em Claude (um cliente no domínio de marketing)

1.2.1.8 mkt_PDC #PRE
1.2.7.3 mkt_BDC #PRE
SUBSTITUIÇÃO #BEGIN
\ #INCLUDE \ \ do mkt_pdc \ público \ LMHOST #INCLUDE \ mkt_bdc \ público \ LMHOST
SUBSTITUIÇÃO #END

Configuração lmhosts no mkt_PDC (Primary Domain Controller para o domínio de marketing)

1.1.1.3 eng_PDC #PRE #DOM: inglês
1.1.4.5 sales_PDC #PRE #DOM: vendas
1.2.1.4 sonolento -
1.2.1.5 sneezy -
1.2.6.2 Martin -
1.2.6.78 Theresa -
1.2.6.89 claude -

Configuração do Cisco 7500 Router

hostname 7500

ip forward-protocol udp bootpc

!

interface ethernet 0

ip address 1.5.6.1 255.255.255.0

ip helper-addressn.n.n.n


...

interface ethernet 23

ip address 1.5.56.1 255.255.255.0

ip helper-addressn.n.n.n

Configuração de um AS5200 em um grupo de pilhas

hostname as5200-1

!

controller t1 0

framing esf

linecode b8zs

pri-group

controller t1 1

framing esf

linecode b8zs

pri-group

!

sgbp group as5200s

sgbp member as5200-2

sgbp member as5200-3

username as5200s password stackpassword

!

ip dhcp-servern.n.n.n


ip wins-serverm.m.m.m


ip address-pool dhcp-proxy-client

!

interface ethernet 0

ip address 192.168.2.1 255.255.255.0

!

interface group-async 0

group-member 1 48

peer default ip address dhcp

!

interface serial 0:23

dialer rotary-group 1

isdn incoming-voice modem

interface serial 1:23

dialer rotary-group 1

isdn incoming-voice modem

interface dialer 1

ip unnumbered ethernet 0

encapsulation ppp

ppp multilink

ppp authentication chap

ppp use-tacacs

dialer-group 1

!

dialer-list 1 protocol ip permit

!

line 1 48

modem inout

modem autoconfigure type microcom-hdms

speed 115200

flowcontrol hardware

Configuração do Cisco 700 Router

set system 700

cd LAN

set ip address 1.4.3.1

set ip netmask 255.255.255.248

set ip routing on

set ip rip update periodic

CD

set user as5200s

set encapsulation ppp

set ip framing none

set ip routing on

set number 5551212

set ip route destination 0.0.0.0/0 gateway 0.0.0.0

CD

set active as5200s

set bridging off

Exemplo 3

O exemplo 3 mostra uma rede de tamanho médio usando NBT (NetBIOS sobre o TCP) e um único server das VITÓRIAS. A figura 9 mostra um gráfico da instalação.

Figura 9: Rede de tamanho médio usando NBT (NetBIOS sobre o TCP) e um único server das VITÓRIAS

/image/gif/paws/10624/winnt_d8.gif

Configuração de um Cisco 1600

hostname 1600

username as5200s password secret

!

interface ethernet 0

ip address 1.4.3.1 255.255.255.248

interface bri 0

ip unnumbered ethernet 0

encapsulation ppp

ppp multilink

dialer string 5551212

dialer-group 1

!

dialer-list 1 protocol ip list 101

access-list 101 deny udp any any eq netbios-ns

access-list 101 permit ip any any

Exemplo 4

A figura 10 mostra uma rede grande usando NBT (NetBIOS sobre o TCP) com domínios mestres múltiplos e os server replicated das VITÓRIAS.

Figura 10: Rede grande usando o NBT com domínios mestres múltiplos e os server Replicated das VITÓRIAS

winnt_d9.gif

Apêndice A: Desligando a resolução de nome de transmissão

Ao usar as janelas para grupos de trabalho 3.11

Ao usar as janelas para grupos de trabalho 3.11, um arquivo novo do navegador, o VREDIR.386, que é incluído com Windows NT 3.5, deve ser usado para reservar consultar para trabalhar corretamente. O Windows 95/98 já inclui este navegador alterado. O arquivo VREDIR.386 é ficado tipicamente no diretório de C:\WINDOWS\SYSTEM.

Os clientes das janelas para grupos de trabalho devem fazer a seguinte mudança ao SYSTEM.INI arquivar:

; SYSTEM.INI

;

[Network]

MaintainServerList=No

Windows 95/98

Figura 11: Desligando o Browse Master no Windows 95/98

/image/gif/paws/10624/winnt_10.gif

Windows NT 3.51

As estações de trabalho e os server do Windows NT 3.51 que são configurados para a resolução de nome das VITÓRIAS não enviam transmissões a menos que outros computadores na requisição de rede uma eleição de navegador. Nenhuma ação é exigida.

Entradas de registro do Windows NT

Estas entradas no hkey_local_machine \ sistema \ currentcontrolset \ serviços \ navegador \ área de parâmetros do registro devem ser ajustadas como segue: MaintainServerList deve ser ajustado ao Yes, e IsDomainMaster deve ser ajustado a falso. Estas são as configurações padrão.

A configuração de periodicidade mestre (nos segundos) especifica como frequentemente a sub-rede consulta server pergunta o domínio mestre para obter uma lista da consultação. Quando a sub-rede consulta server e o domínio mestre está separado por um link de baixa velocidade ou do carga-por-pacote, você pode ajustar este a uma hora ou a mais.

Encontrando Navegadores-Mestre de Rogue

As estações de trabalho de Windows 3.1 e do Windows 95/98 não podem funcionar como consultam mestres em uma rede do Windows NT porque não seguram o servidor NT e a informação de domínio. Infelizmente, à revelia, o Windows 95/98 tenta transformar-se um Browse Master. Uma estação de trabalho única que reivindica incorretamente ser o Browse Master impede a consultação para cada computador nessa sub-rede inteira. A prioridade para transformar-se um Browse Master é PDC, BDC, servidor NT, estação de trabalho de NT, a seguir Windows 95/98, que devem impedir que este ocorra.

O kit de recurso de servidor do Windows NT 4.0 contém uma utilidade chamada BROWSTAT. A maneira a mais fácil de encontrar um radiodifusor desonesto em uma sub-rede é executar o BROWSTAT em um computador do Windows NT na sub-rede afetada.

Apêndice B: Configurando a resolução de DNS de nomes das VITÓRIAS

O server do Windows NT 4.0 e o Windows 2000 ambos incluem um servidor DNS que possa responder a perguntas DNS perguntando um server das VITÓRIAS no fundo. O servidor DNS do Windows 2000 igualmente apoia atualizações dinâmica pelo RFC 2136. O server das VITÓRIAS e o servidor DNS não precisam de estar na mesma máquina de Windows Nt/2000. Todas as perguntas DNS a um subdomínio (neste exemplo, wins.cisco.com) devem ser delegadas ao server DNS/WINS. Configurar um servidor DNS de Windows Nt/2000 que usa um arquivo da bota não é necessário ou recomendado por Microsoft. O gerenciador DNS fornece uma relação rica para o serviço.

O arquivo da bota DNS

; INICIALIZAÇÃO - -
esconderijo . ESCONDERIJO
primário domain.com domain.dom
primário 8.17.1.in-addr.arpa 1-17-8.rev

O arquivo DNS para domain.com

; domain.dom
@ IN SOA ns.domain.com. rohan.domain.com. (
1 ; Número de série
10800 ; Refresque [3h]
3600 ; Experimente de novo [1h]
604800 ; Expiram [7d]
86400) ; Mínimo [1d]
@ IN GANHA 1.1.4.6 1.2.7.4
vitória-server IN 1.1.4.6
wins-server2 IN 1.2.7.4

1Albitz, Paul e críquete Liu. Sebastopol, CA: O'Reilly e associados, 1992.


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 10624