Switches : Switches Cisco Catalyst 3750 Series

Roteamento de PIM Stub nos Catalyst 3750 e 3560 Series Switches

17 Julho 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (4 Agosto 2011) | Feedback

Índice

Introdução
Pré-requisitos
      Requisitos
      Componentes Utilizados
      Produtos Relacionados
      Convenções
Configuração
      Diagrama de Rede
      Configurações
      Configuração (mix_stack) do Switch
Verificação
Discussões relacionadas da comunidade de suporte da Cisco

Introdução

O tráfego de planos de controle multicast é sempre visto por cada roteador em um ambiente de LAN. O multicast IP de stub é usado para reduzir e minimizar o tráfego de multicast desnecessário visto na camada de acesso da LAN e economiza largura de banda da mídia para encaminhar o tráfego de multicast para a camada principal/distribuição superior.

Nos Catalyst 3750 e 3560 Series Switches, o recurso PIM Stub Multicast oferece suporte ao roteamento de multicast entre a camada de distribuição e a camada de acesso. Ele oferece suporte a dois tipos de interfaces PIM: interfaces PIM uplink e interfaces PIM passivas. Especificamente, uma interface roteada configurada com o modo passivo de PIM não transmite/encaminha tráfego do plano de controle PIM; ela somente transmite/encaminha tráfego IGMP.

Pré-requisitos

Requisitos

Verifique se você atende a estes requisitos antes de tentar esta configuração:

  • O roteador de PIM stub não roteia o tráfego de trânsito entre os roteadores de distribuição. Esse comportamento é imposto pelo roteamento de stub unicast (EIGRP). A configuração correta do roteamento de stub unicast é necessária para suporte a esse comportamento do roteador de PIM stub. O recurso PIM stub não impede que o RIP de configuração do administrador do roteador, rotas estáticas ou RP PIM ignorem esta restrição.

  • Somente receptores e origens de multicast conectados diretamente (IGMP) são permitidos nos domínios de acesso da camada 2. Não há suporte ao protocolo PIM nos domínios de acesso.

  • Não há suporte à topologia de roteador de PIM stub.

Componentes Utilizados

As informações contidas neste documento são baseadas no Catalyst 3750 Switch.

As informações deste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração padrão. Se a sua rede estiver em um ambiente de produção, esteja ciente do impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com os seguintes tipos de switch:

  • Catalyst 3750 e 3560 Series Switches

Os switches Cisco Catalyst 3750 e 3560 oferecem suporte ao código de Roteamento Multicast de PIM Stub versão 12.2(37)SE ou posterior.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configuração

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

O SSM PIM é usado nos uplinks para comunicação com o roteador superior. Os usuários podem usar qualquer outro modo de PIM (por exemplo, dense ou sparse).

Para obter informações adicionais sobre a configuração do roteamento multicast nos 3750 Series Switches, consulte Configurando o Roteamento Multicast de IP.

Nota: Use a Command Lookup Tool (somente clientes registrados) para obter mais informações sobre os comandos usados nesta seção.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

pim_stub-1.gif

Configurações

Este documento utiliza as seguintes configurações:

Siga estes passos para configurar o roteador de PIM stub:

  1. Execute este comando para ativar o roteamento multicast globalmente no switch ou na pilha de switches:

    mix_stack(config)#ip multicast-routing distributed
    
  2. Execute este comando para definir o intervalo de SSM de endereços IP de multicast com o intervalo do grupo padrão:

    mix_stack(config)#ip pim ssm default
    
  3. Execute este comando para ativar o SSM PIM no uplink:

    mix_stack(config)#interface GigabitEthernet3/0/25
    mix_stack(config-if)ip pim sparse-dense-mode
    
  4. Execute este comando para ativar o roteamento de PIM stub na interface VLAN:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)ip pim passive
    

Configuração (mix_stack) do Switch

mix_stack#sho run
Building configuration...

Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Saída suprimida.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Saída suprimida.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Saída suprimida.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Saída suprimida.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Saída suprimida.
!
!
ip pim ssm default
!
!
!--- Saída suprimida.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Verificação

Utilize esta seção para confirmar se a sua configuração está funcionando corretamente.

A Output Interpreter Tool (somente clientes registrados) (OIT) oferece suporte a determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Execute o comando show ip pim interface para exibir o PIM stub ativado para cada interface.

mix_stack#show ip pim interface

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Execute o comando show ip igmp detail para exibir o cliente interessado que ingressou na origem/grupo de multicast específico.

mix_stack#sho ip igmp group 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Execute o comando show ip igmp mroute para verificar se o fluxo de multicast é encaminhado da origem para os clientes interessados.

mix_stack#sho ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Document ID: 98289