IP : IP Versão 6 (IPv6)

IPv6: Conectando ao 6bone Utilizando Túneis 6to4

29 Agosto 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Feedback

Índice

IPv6: Conectando ao 6bone Utilizando Túneis 6to4
Objetivos Comerciais
Soluções Possíveis
Solução Proposta: Número 2, Túneis 6to4
Implementação
Documentação Relacionada

IPv6: Conectando ao 6bone Utilizando Túneis 6to4


Histórico da Versão

Número da Versão Data Notas

1

28 de Fevereiro de 2002

Esse documento foi criado.

2

19 de Maio de 2003

A seção de documentos relacionados foi atualizada.

Este documento descreve como um cliente do campus empresarial (por exemplo, uma instituição educacional, uma pequena firma de software ou uma pequena fábrica) pode se conectar ao 6bone utilizando túneis 6to4. O 6bone é uma rede de teste de IP versão 6 (IPv6) desenvolvida para ajudar na evolução e na implantação do IPv6 na Internet.

Este documento faz parte de um conjunto de documentos que oferecem suporte e complementam a publicação Estratégias de Implantação do IPv6, que está disponível no seguinte URL:

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/ipv6_sol/ipv6dswp.pdf

Você deve ler este documento junto com as Estratégias de Implantação do IPv6 para entender melhor as atividades de pré-implantação do IPv6.

Este documento contém as seguintes seções:

Objetivos Comerciais

Uma pequena empresa de software (considerada um ambiente típico de campus corporativo) com uma rede IPv4 está discutindo uma fusão com outra empresa que executa IPv6 na rede. Para avaliar o impacto da conectividade que a fusão teria nas empresas, o cliente deseja ampliar seus conhecimentos do IPv6 conectando-se ao 6bone. Os objetivos comerciais do cliente do campus empresarial discutidos neste documento são estes:

  • Para que seja feito um investimento mínimo, ganhe experiência no IPv6 em um backbone IPv6 estabelecido utilizando sua topologia IPv4 existente.
  • Teste os procedimentos transacionais e operacionais em um ambiente IPv6 real antes de implantar o IPv6 no campus.

Procedimentos transitórios são aqueles que são necessários para migrar de IPv4 para IPv6. Estes procedimentos incluem configurar os routers de pilha dupla e sistemas finais, mecanismos de tunelamento, servidores de Domain Name System (DNS) e, no futuro, o teste de Network Address Translation-Protocol Translation (NAT-PT).

Procedimentos operacionais estão relacionados ao gerenciamento de redes, gerenciamento de elementos de hosts de pilha dupla e sistemas finais e outras funções semelhantes.

  • Teste as implementações e os aplicativos do IPv6 em estações de trabalho locais.
  • Minimize o overhead de gerenciamento associado a uma conexão 6bone.

  • Observação: Embora o 6bone englobe muitos tipos de organizações (por exemplo, organizações acadêmicas e governamentais, fornecedores de hardware e software e provedores de serviço), este documento utiliza o termo 6bone ISP ao se referir à organização que está no lado 6bone do túnel.

Topologia de Rede Inicial

A Figura 1 mostra a topologia da rede IPv4 inicial para o cliente do campus empresarial. Esta rede usa diversos routers para fornecer conectividade de IP entre usuários locais. Uma conexão IPv4 permanente com um ISP (Provedor de Serviços de Internet) fornece conectividade externa.


Figura 1   Topologia da Rede IPv4 Empresarial Inicial


Soluções Possíveis

Duas formas possíveis para esse cliente do campus empresarial se conectar ao 6bone utilizando sua topologia IPv4 e seus túneis existentes são os túneis configurados manualmente e os túneis 6to4. Tunelamento é uma técnica para encapsular pacotes IPv6 em pacotes IPv4 de modo que eles possam ser transportados em infra-estruturas de roteamento IPv4. Ambas as soluções exigem que o host ou o router em cada extremidade do túnel esteja executando pilha dupla, o que significa que eles oferecem suporte simultaneamente a pilhas de protocolo IPv4 e IPv6. Ambas as soluções possíveis são aceitas pelo Cisco IOS Software.

Número da Solução Possível. 1: Túneis Configurados Manualmente

O tunelamento IPv6 configurado manualmente é uma técnica em que um endereço IPv6 é configurado manualmente em uma interface de túnel e endereços IPv4 são configurados manualmente na origem do túnel e no destino do túnel. Túneis configurados manualmente podem ser configurados entre routers de borda ou entre um router de borda e um host. Pelo fato de túneis configurados manualmente exigirem configuração em ambas as extremidades do túnel, eles possuem uma carga adicional de gerenciamento maior quando vários túneis são implementados em comparação à utilização de túneis 6to4. Por serem configurados um por um entre pontos finais bem conhecidos, túneis configurados manualmente disponibilizam as informações sobre o tráfego de cada ponto final e fornecem segurança extra contra tráfego injetado.

Número da Solução Possível. 2 Túneis 6to4

O tunelamento 6to4 é uma técnica na qual o ponto final do túnel é determinado pelo endereço IPv4 exclusivo globalmente embutido em um endereço 6to4. Um endereço 6to4 IPv6 é uma combinação do prefixo de roteamento exclusivo 2002::/16 e um endereço IPv4 de 32 bits exclusivo globalmente. (Endereços IPv6 compatíveis com IPv4 são um formato diferente dos endereços 6to4 IPv6. Endereços IPv6 compatíveis com IPv4 não são usados no tunelamento 6to4). Os túneis 6to4 são configurados entre routers de borda ou entre um router de borda e um host. Os túneis 6to4 exigem que um local de transmissão 6bone 6to4 seja identificado para fornecer o serviço de transmissão 6to4 à empresa. O local de transmissão 6to4 irá fazer a configuração de um router de borda de pilha dupla que irá se tornar o ponto final do túnel 6to4 da empresa. Depois que o local de transmissão 6to4 é definido para o tunelamento 6to4, sua sobrecarga de gerenciamento é mínima. Na extremidade da empresa, uma configuração simples de router permite o acesso ao 6bone através do túnel 6to4.

Embora seja possível utilizar túneis 6to4 para interconectar locais IPv6 dentro de sua empresa, essa utilização está além do escopo deste documento.

Solução Proposta: Número 2, Túneis 6to4

A solução proposta é fazer a conexão ao 6bone usando túneis 6to4 porque essa é a solução mais simples que atende aos objetivos comerciais.

Visão geral

Os túneis 6to4 fornecem um mecanismo para os locais finais IPv6 acessarem o 6bone através do tunelamento da Internet IPv4. Para evitar interferências na rede de produção corporativa, a solução deverá ser inicialmente implantada em uma rede isolada, como um laboratório.

Estratégia

Comece com uma rede IPv4 que possua uma conexão IPv4 externa a um ISP. O IPv4 é necessário porque o túnel para o 6bone que será configurado irá utilizar o IPv4 para transportar o tráfego IPv6.

Selecione o Ambiente de Teste IPv6 Inicial

Determine qual dos dois ambientes a seguir você deseja utilizar para implementar a conexão 6bone inicial:

  • Uma rede de teste completamente independente, como um laboratório
  • Uma rede de teste que está conectada ao restante da rede, mas está isolada por um firewall que não transfere o tráfego IPv6

Este documento utiliza o segundo ambiente isolado por firewall, mas a configuração também se aplica ao primeiro ambiente.

Forneça a Rede de Teste IPv6

Instale os dispositivos que irá utilizar em sua rede de teste IPv6. A Figura 2 mostra uma rede de teste IPv6 totalmente engrenada que é isolada da rede IPv4 corporativa por um firewall que é configurado para bloquear o tráfego IPv6. Todos os routers da rede de teste são configurados para executar pilha dupla.


Figura 2   Topologia de Rede Inicial com Rede de Teste IPv6 Adicionada


Identifique o Router para Conectar-se ao 6bone

Na rede de teste IPv6, identifique um router de borda que você irá usar para fazer a conexão ao 6bone ISP. Este router de borda deve ser um router de pilha dupla, que será configurado com o túnel para transmitir o tráfego IPv6 para a Internet IPv4.

Obtenha Informações de Endereço do 6bone ISP

Solicite que o 6bone ISP faça a configuração de sua extremidade do túnel e, então, forneça a você o endereço IPv4 do router que será utilizado para acessar o 6bone.

Já que você irá configurar um túnel 6to4 para o 6bone, o endereço IPv6 de seu router de borda será o (globalmente roteável) endereço IPv4 concatenado ao prefixo 6to4 2002::/16.


Nota   O ISP que você utiliza para a conectividade 6bone pode não ser o mesmo ISP utilizado para a conectividade IPv4. Seu 6bone ISP normalmente será o parceiro mais próximo que irá fornecer o serviço de transmissão 6to4, de modo que você não fique restrito ao seu ISP local para a conectividade 6bone.

Faça a configuração do Router de Borda 6bone

Utilizando o endereço IPv4 do 6bone ISP, faça a configuração do router de borda designado para executar pilha dupla, com um túnel 6to4 para conectar ao 6bone. Recomendamos que cada local tenha apenas um endereço 6to4 atribuído à interface externa do router. Todos os locais precisam executar um protocolo de roteamento interior IPv6, como o Protocolo de Informações de Roteamento de próxima geração (RIPng), para o roteamento IPv6 dentro do local, mas o roteamento exterior é manipulado pelo protocolo de roteamento exterior IPv4 relevante.

Agora você possui conectividade 6bone para sua rede de teste, como mostra a Figura 3.


Figura 3   Conectividade Estabelecida a partir da Rede de Teste para o 6bone ISP


Conecte a Rede Corporativa ao 6bone

Quando estiver pronto para implantar o IPv6 em sua rede corporativa, a conexão ao 6bone ISP será feita através do IPv4 ISP. Você irá fazer a configuração do router de borda que está vinculado ao IPv4 ISP para executar pilha dupla e com um túnel 6to4 para o 6bone ISP. O endereço IPv4 do router de borda que está vinculado ao IPv4 ISP será alterado de acordo com o que o endereço do IPv4 ISP fornece. Identifique outros routers e hosts de sua rede que você deseje que tenham conectividade IPv6. Será necessário fazer a configuração de cada um desses dispositivos para executar pilha dupla.

Você pode remover o firewall entre a rede corporativa e o laboratório para permitir que o tráfego IPv6 flua através da rede e pode manter uma porção da rede como IPv4 somente até que você esteja pronto para implantar o IPv6 nessa rede. A Figura 4 mostra a rede corporativa com conectividade IPv6 ao 6bone através de um túnel 6to4 via IPv4 ISP.


Figura 4   Rede Corporativa com Conectividade IPv6 ao 6bone


Topologia de rede

A Figura 5 mostra a topologia de um túnel 6to4 comum para o 6bone.


Figura 5   Túnel 6to4 para o 6bone


Como Esta Solução Funciona

Um túnel 6to4 é configurado em um router de borda de pilha dupla corporativo. Todo o tráfego de IPv6 empresarial destinado para o 6bone é roteado sobre o IPv4 por meio do túnel para o router de relay 6bone ISP 6to4. O tráfego do 6bone para um host empresarial é roteado via IPv4 pelo túnel até o router de borda de empilhamento dual empresarial e, em seguida, até o host de destino IPv6.

Benefícios

Os benefícios para a empresa com o uso de túneis 6to4 são os seguintes:

  • Túneis 6to4 são aceitos pelo Cisco IOS Software.
  • A configuração de host do usuário final é simples, exigindo pouca carga adicional de gerenciamento.
  • O túnel é automático; nenhuma configuração específica ao empreendimento é necessária no local de transmissão 6to4.
  • Túneis 6to4 são bem escaláveis.
  • Esta solução abrange endereços IP dinâmicos na empresa.
  • O túnel existe somente durante a sessão.
  • Um túnel 6to4 exige somente uma única configuração no ISP, disponibilizando o serviço de transmissão 6to4 simultaneamente para várias empresas.
  • Failover para um router secundário poderia ser obtido sem envolver o ISP.

Ramificações

As ramificações para a empresa com a utilização de túneis 6to4 são as seguintes:

  • NAT gerenciada de forma independente não é permitida no caminho do túnel.
  • A implantação da hospedagem múltipla não é fácil.
  • O mecanismo de túnel 6to4 fornece um bloco de endereço /48; não há mais endereços disponíveis.
  • Como os túneis 6to4 são configurados como muitos-para-um e o tráfego de túnel poder originar-se de múltiplos pontos finais, podem oferecer somente informações gerais sobre tráfego no ISP.
  • Como o prefixo do endereço 6to4 IPv6 da empresa é determinado pelo e depende do endereço IPv4 subjacente, a migração para o IPv6 nativo exige uma renumeração da rede.
  • Essa solução é limitada para roteamento estático ou BGP4+.

Implementação

Esta seção descreve como um cliente empresarial pode implantar um túnel 6to4 para fazer conexão ao 6bone. Ele contém as seguintes seções:

Pré-requisitos e Considerações do Desenho

Antes de implementar um túnel 6to4 no 6bone, execute as seguintes tarefas:

  • Identifique o router de borda no seu site o qual você irá fazer a configuração para executar uma pilha dupla. Este router de borda deve ter um endereço IPv4 estático, roteável globalmente.
  • No ISP 6bone, obtenha o endereço IPv4 do router de transmissão 6a4 que você usará para o acesso 6bone.

Nota    Ao fazer a configuração dos túneis para os routers de borda de sua empresa, você deverá usar endereços IPv4 roteáveis globalmente. Os endereços IPv4 utilizados nas configurações de exemplo neste documento não são globalmente roteáveis e são fornecidos para fins de ilustração apenas.

  • Certifique-se de que o DNS está executando o (ou possui capacidades equivalentes ao) Berkeley Internet Name Domain (BIND) versão 9, que fornece uma implantação dos principais componentes do DNS para IPv6. A configuração de DNS está além do escopo deste documento.
  • Reconheça que a implantação de pilha dupla atual no Cisco IOS Software permite uma solução de gerenciamento de redes temporária, permitindo que aplicativos como TFTP, ping, Telnet e traceroute sejam executados em um transporte IPv4 ou IPv6.
  • Selecione um protocolo de roteamento interior IPv6, como RIPng, apropriado para sua configuração de rede. Para simplificar, a solução apresentada neste documento usa uma rota estática. O roteamento exterior é manipulado pelo protocolo de roteamento exterior IPv4 relevante.
  • Faça a configuração todos os routers de pilha dupla para usar RIP.

Para obter mais informações sobre como configurar a rede para IPv6, consulte o seguinte documento, listado na seção "Documentos Relacionados": IPv6 para o Cisco IOS Software, Arquivo 2 de 3: Configurando.

Etapas do Processo de Implementação

O endereço IPv4 do seu router de borda é 192.168.99.1. Derive seu prefixo 6to4 a partir do endereço IPv4, convertendo os componentes decimais desse endereço em hexadecimais e, em seguida, prefixando “2002” aos números hexadecimais resultantes. Então, o prefixo 6to4 para os nós IPv6 em sua rede é 2002:C0A8:6301::/48.

A parte C0A8:6301 do endereço IPv6 anterior é formada pelo endereço IPv4, convertendo-se cada octeto da notação decimal com pontos em seu equivalente hexadecimal, como mostra a tabela 1.

Tabela 1   Conversão de Decimal com Pontos em Hexadecimal

Decimal Hexadecimal

192

C0

168

A8

99

63

1

01

O 6bone ISP forneceu o endereço IPv4 do router de borda 6bone: 192.168.33.1.

Utilizando as informações de endereço anteriores, faça a configuração de um túnel 6to4 em seu router de borda de pilha dupla identificado, inserindo os seguintes comandos:

Enterprise Router
ipv6 unicast-routing
interface Ethernet0
 descrição de conexão para o 6bone ISP
 ip address 192.168.99.1 255.255.255.0
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
ipv6 route 2002::/16 Tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1

O 2002:C0A8:2101::1 no segundo comando ipv6 route é o endereço IPv6 do router de retransmissão ISP 6to4 que fornece acesso ao 6bone. A parte do endereço C0A8:2101 é derivada do endereço IPv4 (192.168.33.1) do router de transmissão 6a4, de maneira semelhante à tabela 1.

Na outra extremidade do túnel, o router de borda no 6bone ISP teria uma configuração como a seguir:

Router de Relay 6to4 ISP
ipv6 unicast-routing
interface ethernet0/0
 descrição de conexão para a empresa
 ip address 192.168.33.1 255.255.255.0
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
ipv6 route 2002::/16 tunnel2002

Características do Dispositivo

A tabela 2 descreve os dispositivos usados nessa solução.

Tabela 2   Hardware e Software Utilizados

Router de Borda da Empresa Router ISP 6bone
Nome de host

6bone-gw

ipv6-router

Tipo de chassi

Router Cisco 3660

Router Cisco 7206

Interfaces físicas

2 Ethernet
2 Fast Ethernet
4 serial

4 Ethernet
2 Fast Ethernet
4 serial

Software carregado

Cisco IOS Versão 12.2(4)T

Cisco IOS Versão 12.2(4)T

Memória

64 MB de RAM; 16 MB de Flash

128 MB de RAM; 20 MB de Flash

Endereços IP

Ethernet0:
IPv4  192.168.99.1

Tunnel2002:
IPv6  2002:C0A8:6301::1/128

Ethernet0/0:
IPv4  192.168.33.1

Tunnel2002:
IPv6  2002:C0A8:2101::1/128

Arquivos de Configuração Anotados

Esta seção contém os arquivos de saída anotados do comando show running-configuration para a empresa e routers de borda 6bone ISP mostrados na Figura 5.

Enterprise Router
! Identifique a versão do Cisco IOS Software em execução no router
!
versão 12.2
!
! Inclua selos de data/hora nas entradas do registro e de depuração úteis para
! análise de falhas e otimização da rede.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Especifique que as senhas serão criptografadas na saída da configuração.
!
criptografia de serviços por senha
!
! Faça a configuração do nome do router
!
hostname 6bone-gw
!
! Faça a configuração das opções de inicialização
!
boot system flash slot0:
boot system flash bootflash:
!
! Faça a configuração do registro
!logging buffered 10000 debugging
!
! Faça a configuração da senha secreta
!
enable secret 5 [removido]
!
! Faça a configuração do fuso horário e a regra do horário de verão
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Faça a configuração do nome de domínio do router
!
ip domain-name EnterpriseDomain.com
!
! Faça a configuração dos servidores de nome DNS
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Habilite o roteamento IPv6
!
ipv6 unicast-routing
!
! Faça a configuração da interface de túnel
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Faça a configuração da interface física
!
interface Ethernet0
 descrição de conexão para o 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 descrição de conexão para o router de interface de laboratório
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 descrição de conexão para o router central
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 descrição de conexão para o router central exclusivo para IPv4
 ip address 192.168.99.42 255.255.255.0
!
! Todas as outras interfaces não estão sendo utilizadas
!
interface Serial4/0
 no ip address
 fechamento
!
interface Serial4/1
 no ip address
 fechamento
!
interface Serial4/2
 no ip address
 fechamento
!
interface Serial4/3
 no ip address
 fechamento
!
! Faça a configuração do IP routing básico
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Faça a configuração do roteamento estático IPv6
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
fim
Router ISP 6bone
! Identifique a versão do Cisco IOS Software em execução no router
!
versão 12.2
!
! Inclua selos de data/hora nas entradas do registro e de depuração úteis para
! análise de falhas e otimização da rede.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Especifique que as senhas serão criptografadas na saída da configuração.
!
criptografia de serviços por senha
!
! Faça a configuração do nome do router
!
hostname ipv6-router
!
! Faça a configuração das opções de inicialização
!
boot system flash slot0:
boot system flash bootflash:
!
! Faça a configuração do registro
!
logging buffered 10000 debugging
!
! Faça a configuração da senha secreta
!
enable secret 5 [removido]
!
! Faça a configuração do fuso horário e a regra do horário de verão
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Faça a configuração do nome de domínio do router
!
ip domain-name 6boneISP.com
!
! Faça a configuração dos servidores de nome DNS
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Habilite o roteamento IPv6
!
ipv6 unicast-routing
!
! Faça a configuração da interface de túnel
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Faça a configuração da interface física
!
interface Ethernet0/0
 descrição de conexão para a empresa
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 fechamento
!
interface Ethernet0/2
 no ip address
 fechamento
!
interface Ethernet0/3
 no ip address
 fechamento
!
interface FastEthernet1/0
 descrição de conexão para ISP-central-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 auto duplex
 auto velocidade
!
interface FastEthernet2/0
 descrição de conexão para ISP-central-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 auto duplex
 auto velocidade
!
! Todas as outras interfaces não estão sendo utilizadas
!
interface Serial4/0
 no ip address
 fechamento
!
interface Serial4/1
 no ip address
 fechamento
!
interface Serial4/2
 no ip address
 fechamento
!
interface Serial4/3
 no ip address
 fechamento
!
! Faça a configuração do IP routing básico
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Faça a configuração do roteamento estático IPv6
!
ipv6 route 2002::/16 tunnel2002
!
fim

Documentação Relacionada

Consulte os seguintes documentos para obter informações adicionais sobre o IPv6 para o Cisco IOS Software, o 6bone e o IPv6 em geral:

  • Estratégias de Implantação do IPv6
  • IPv6: Conectando ao 6bone Utilizando Túneis Configurados Manualmente
  • IPv6: Fornecendo Serviços IPv6 por um Backbone IPv4 Utilizando Túneis
  • Interconectando Domínios IPv6 Utilizando Túneis
  • Comece Aqui: Versão do Cisco IOS Software Específica para Recursos IPv6
  • Implementing IPv6 for Cisco IOS Software
  • IPv6 para referências a comandos do Cisco IOS Software
  • RFC 2185, Aspectos de Roteamento de Transição de IPv6 (informativo)
  • RFC 2373, Arquitetura de endereçamento de IP versão 6
  • RFC 2374, Um formato de endereço de unicast global agregável
  • RFC 2460, Protocolo de Internet, Especificação Versão 6 (IPv6)
  • RFC 2464, transmissão de pacotes IPv6 por redes Ethernet
  • RFC 2471, teste de alocação de endereço IPv6
  • RFC 2893, Mecanismos de transição de hosts e routers IPv6
  • RFC 3056, Conexão de Domínios IPv6 via Nuvens IPv4