Software Cisco IOS e NX-OS : Implantações especiais e antecipadas do software Cisco IOS versões 12.0

Configurando Placas de Interface T1/E1 Multiflex Voice/WAN de 1 e 2 Portas em Cisco 2600 e 3600 Series Routers

1 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Inglês (17 Novembro 1999) | Feedback

Índice

Configurando Placas de Interface T1/E1 Multiflex Voice/WAN de 1 e 2 Portas em Cisco 2600 e 3600 Series Routers

Este documento explica como você pode configurar as Multiflex Voice/WAN interface cards (VWICs) T1 e E1 com 1 e 2 portas em routers Cisco 2600 e 3600 e inclui as seguintes seções:

Visão geral do recurso

Cisco Multiflex Voice/WAN interface cards (VWICs) T1/E1 suportam aplicativos de voz e dados em routers das séries Cisco 2600 e 3600. As VWICs oferecem funcionalidade WIC (WAN interface card) e VIC (voice interface card) em muitos aplicativos para empresas e para provedores de serviços que fornecem equipamento de escritório para o cliente.


Figura 1: Aplicativos Multiflex VWIC T1/E1, Portas VWIC Atribuídas para PBX e CO (Sem Conectividade WAN)


As Multiflex VWICs suportam os seguintes aplicativos:

  • Dados: Como WICs para aplicativos T1/E1, incluindo uso fracional, a versão T1 integra uma DSU/CSU (data service unit/channel service unit) totalmente gerenciada, e a versão E1 inclui uma DSU totalmente gerenciada.

  • Voz de Pacote: Como as VICs incluíam Módulo de Rede de Tronco de Voz de Pacote T1 Digital para fornecer conexões T1 para PBXs (private branch exchanges) e COs (central offices), as T1 VWICs produziram pacotes de aplicativos VoIP (voice over IP) ativos.

  • Voz e Dados Multiplexados: As T1/E1 VWICs de 2 portas podem oferecer serviços multiplexados de Soltar e Inserir com DSU/CSUs integradas. Por exemplo, quando utilizada com o Módulo de Rede de Tronco de Voz do Pacote T1 Digital, o recurso Soltar e Inserir permite que você pegue canais DS0 de 64 kb de um T1 e faça uma conexão cruzada digitalmente deles para canais DS0 de 64 kb em outro T1. Soltar e Inserir, às vezes chamado de Conexão Cruzada TDM (Time-Division Multiplexing), utiliza comutação de circuito e não utiliza os DSPs (digital signal processors) que a tecnologia VoIP emprega.

As seguintes Multiflex VWICs estão disponíveis:

  • Interface de Tronco Multiflex T1 de uma porta (VWIC-1MFT-T1)

  • Interface de Tronco Multiflex E1 de 1 porta (VWIC-1MFT-E1)

  • Interface de Tronco Multiflex T1 de 2 portas (VWIC-2MFT-T1)

  • Interface de Tronco Multiflex de 2 portas E1 (VWIC-2MFT-E1)

  • Interface de Tronco Multiflex T1 de 2 portas com Soltar e Inserir (VWIC-2MFT-T1-DI)

  • Interface de Tronco Multiflex E1 de 2 portas com Soltar e Inserir (VWIC-2MFT-E1-DI)

Os recursos da Multiflex VWIC incluem:

  • Recursos soltar e inserir que permitem que canais DSD individuais de 64 Kb sejam transmitidos de forma transparente, descompactados, entre duas portas na mesma Multiflex VWIC sem passar por um DSP (digital signal processor):

    • Utilizando esse método, o tráfego de canal é enviado entre um PBX e um CO (central office) ou outro dispositivo de telefonia.

    • Adicionalmente, Soltar e inserir pode permitir a conexão cruzada de um switch de telefonia (do CO ou PSTN) a um banco de memória de canal para proporcionar conectividade analógica externa.


Observação Canais T1/E1 podem ser utilizados tanto para Soltar e Inserir ou VoIP, mas não para ambos.
  • Recurso de encaminhamento de alarme da camada física entre as portas em placas de 2 portas

  • Interfaces de rede T1/E1 ou T1/E1 fracionária

  • Taxas de dados T1/E1 por canal de 64 ou 56 kbps para serviços WAN (Frame Relay ou linha alugada)

A Tabela 1 mostra as configurações de hardware possíveis para Multiflex VWICs.


Tabela 1: Suporte Multiflex VWIC
VWIC e Aplicativo Série Cisco 2600 Cisco 3620 e 3640 Cisco 3660

1 porta

Dados somente

T1 ou E1 VWIC em um slot de chassi

T1 ou E1 VWIC em um módulo de rede de 1 ou 2 portas (NM-1E2W, NM-2E2W, NM-1E1R2W)

Planejado para disponibilidade futura

2 portas

Dados somente

T1 ou E1 VWIC em um slot de chassi. Não fornece pacote de voz. Pode fornecer duas conexões físicas de WAN com ambas as portas suportando T1/E1 de velocidades completas.

Planejado para disponibilidade futura

Planejado para disponibilidade futura

2 portas

Soltar e Inserir

T1 ou E1 D&I VWIC em um slot de chassi. Não fornece pacote de voz. Fornece conexões WAN e conexão cruzada digital.

T1 D&I VWIC em um Módulo de Rede de Tronco de Voz de Pacote TI Digital. Fornece conexões de voz e conexão cruzada digital. Não fornece conexões WAN.

T1 ou E1 D&I VWIC em um módulo de rede de 1 ou 2 portas (NM-1E2W, NM-2E2W, NM-1E1R2W). Fornece conexões WAN e conexão cruzada digital.

T1 D&I VWIC em um Módulo de Rede de Tronco de Voz de Pacote TI Digital. Fornece conexões de voz e conexão cruzada digital. Não fornece conexões WAN.

1 ou 2 portas

Voz somente, sem conexões WAN

T1 VWIC em um Módulo de Rede de Tronco de Voz de Pacote T1 Digital

T1 VWIC em um Módulo de Rede de Tronco de Voz de Pacote T1 Digital

T1 VWIC em um Módulo de Rede de Tronco de Voz de Pacote T1 Digital



Benefícios

As T1/E1 Multiflex VWICs reduzem os custos no ciclo de vida da rede de duas maneiras:

  • Permitem uma transição eficiente de aplicativos de dados apenas para aplicativos multiplexados de voz, dados e pacotes de voz.

  • São mais fáceis de implementar e gerenciar do que as interfaces de finalidade única.

As T1/E1 Multiflex VWICs oferecem os seguintes benefícios de suporte de multifunção para roteamento LAN-para-LAN, voz e dados e voz multiplexados:

  • Eliminam o custo de CSUs ou DSUs externas.

  • Eliminam a necessidade de multiplexadores Soltar e Inserir.

  • Simplificam o gerenciamento de redes remotas permitindo que uma única ferramenta de gerenciamento, como CiscoView ou CiscoWorks, suporte router, as funções multiplexadoras de CSU/DSU e Drop-and-Insert.

  • Aumentam a densidade da porta T1/E1 suportada em routers Cisco série 2600 e permitem duas conexões T1/E1 em um único slot WIC.

Restrições

As seguintes restrições aplicam-se às configurações da T1/E1 Multiflex VWIC:

  • Em plataformas Cisco 3660, as Multiflex VWICs são suportados somente quando instaladas em um Módulo de Rede de Tronco de Voz de Pacote T1 Digital.

  • Em todas plataformas Cisco 2600 e 3600, os Módulos de Rede de Tronco de Voz de Pacote T1 Digital suportam apenas T1 Multiflex VWICs.

  • E1 VWICs não são suportadas em plataformas Cisco 3660.

  • Os módulos de rede de combinação Cisco 3620 e 3640 permitem a instalação de uma VWIC de 1 porta ou de uma VWIC de 2 portas com o recurso Soltar e Inserir.

  • O recurso soltar e inserir é suportado somente entre duas portas na mesma placa multiflex.

  • Quando instalado em um slot de chassi Cisco 2600, os recursos DSP para voz de pacote não estão disponíveis para Multiflex VWICs com o recurso Soltar e Inserir.

Consulte a Tabela 1 para obter informações resumidas.

Recursos e Tecnologias Relacionados

Os Módulos de Rede de Tronco de Voz de Pacote T1 Digital requerem T1 Multiflex VWIC de duas portas para operação. Para mais informações sobre esses módulos, consulte Configurando Rede de Tronco de Voz de Pacote T1 Digital Módulos em Cisco 2600 e 3600 Series Routers.

Documentação Relacionada

Os documentos a seguir fornecem informações adicionais sobre como instalar e configurar as T1/E1 Multiflex VWICs:

Os seguintes documentos do Cisco IOS Versão 12.0 fornecem informações que ajudam a utilizar as T1/E1 Multiflex VWICs:

  • Guia de Configuração de Aplicativos Locais, Voz e Vídeo

  • Referências a Comandos de Aplicativos Locais, Voz e Vídeo

  • Guia de Configuração de Protocolos de Rede, Parte 1

  • Guia de Configuração da Interface do Cisco IOS

  • Referências a Comandos da Interface do Cisco IOS

  • Guia de Configuração de Soluções de Discagem

Plataformas suportadas

Este recurso tem suporte nas seguintes plataformas:

  • Cisco 2610

  • Cisco 2611

  • Cisco 2612

  • Cisco 2613

  • Cisco 2620

  • Cisco 2621

  • Cisco 3620

  • Cisco 3640

  • Cisco 3661

  • Cisco 3662

Padrões Suportados, MIBs e RFCs

As T1/E1 Multiflex VWICs suportam os MIBs e RFCs padrões relacionados nesta seção.

Conformidade T1 (Lista Parcial)
  • ANSI T1.403

  • US (UL 1950, T1)

  • FCC Parte 68

  • CS-03

  • Canadá (CSA 950, T1)

  • US (FCC Parte 15 Classe B, T1)

  • Reino Unido (BS6301, EN60950, EN41003)

  • Canadá (CSA C108.8 Classe A, T1)

  • Bellcore --- AT&T Accunet (62411)

  • ATT 54016

  • Japão (VCCI Class 2, VCCI:V-3/97.04, T1, JATE Green Book, IEC950)

Conformidade E1 (Lista Parcial)
  • Austrália (TS 016, AS/NZS 3548:1995)

  • Alemanha (TUV GS, EN60950)

  • Alemanha (VDE 0878 parte 3 e 30)

  • França (NFC98020, EN60950, EN41003)

  • Suécia (SS447-2-22, SS636334, EN60950)

  • Reino Unido (NTR4)

  • Europa (EN55022 Classe B, EN55102-1, EN55102-2, CTR12, EN60950, EN50082-1:1992, EN55022:1994)

  • CCITT/ITU G.704, I.431

  • ETSI NET5, ETS300156

  • TBR4

  • CTR-13

  • ETS 300011

  • ITU I.431

RFC

RFC 1406

MIB
  • T1 CSU MIB

Outros Padrões
  • ANSI T1.40

  • Publicação 62411 da AT&T

Pré-requisitos

As T1/E1 Multiflex VWICs requerem serviços, software e hardware específicos:


Observação Você pode instalar um Módulo de Rede de Tronco de Voz de Pacote T1 Digital em um router Cisco série 2600 ou em um router Cisco 3620. Um router Cisco 3640 pode suportar três módulos, e é possível instalar até seis módulos em um router Cisco 3660.
  • Instale a T1 ou E1 Multiflex VWIC seguindo as instruções em Guia de Instalação de Hardware de Placas de Interface WAN Cisco 2600 e 3600 Series.

  • Se estiver utilizando o recurso Soltar e Inserir com um Módulo de Rede de Tronco de Voz de Pacote T1 Digital, instale pelo menos um outro módulo de rede ou placa de interface WAN para fornecer a conexão para IP LAN ou WAN.

  • Estabeleça o funcionamento de uma rede IP. Para obter mais informações sobre como configurar IP, consulte os capítulos "Visão Geral de IP," "Configurando Endereço IP" e "Configurando Serviços IP" no Guia de Configuração de Protocolos de Rede, Parte 1 do Cisco IOS Versão 12.0.

  • Conclua o plano de discagem de sua empresa.

  • Estabeleça o funcionamento de uma rede de telefonia baseada nos planos de discagem de sua empresa.

O Guia de Configuração de Aplicativos Locais, Voz e Vídeo e a Referências a Comandos de Aplicativos Locais, Voz e Vídeo do Cisco IOS Versão 12.0 fornecem informações sobre a configuração de redes de voz.

Tarefas de configuração

A configuração de T1/E1 Multiflex VWICs inclui as seguintes tarefas:

  • Instalar placas de voz (voz somente) e controladores T1/E1.

  • Configurar interfaces serial e de LAN.

  • Instalar portas de voz (serviços de voz aplicáveis somente às T1 Multiflex VWICs instaladas em Módulo de Rede de Tronco de Voz de Pacote T1 Digital).

  • Configurar pontos de discagem de voz (serviços de voz aplicáveis somente às T1 Multiflex VWICs instaladas em Módulos de Rede de Tronco de Voz de Pacote T1 Digital).

Para obter informações detalhadas sobre como configurar uma T1 Multiflex VWIC instalada em um Módulo de Rede de Tronco de Voz de Pacote T1 Digital, consulte Configurando Rede de Tronco de Voz de Pacote T1 Digital Módulos em Cisco 2600 e 3600 Series Routers.

Configurando as Definições das Placas de Voz e do Controlador

Esta seção inclui as seguintes seções:

  • Configurando placas de voz e grupos DS0, somente para T1 Multiflex VWICs instaladas em Módulos de Rede de Tronco de Voz de Pacote T1 Digital quando forem necessários serviços de voz

  • Configurando controladores T1 ou E1

  • Configurando Soltar e Inserir para T1 ou E1

Configurando Placas de Voz e Grupos DS0

Siga as etapas abaixo se estiver configurando T1 Multiflex VWICs instaladas em Módulos de Rede de Tronco de Voz de Pacote T1 Digital para voz. Repita as Etapas 2 e 3 para cada placa de voz.

Etapa Comando Propósito
1 .  


Router# configure terminal

Inserir o modo de configuração global.

2 .


Router(config)# voice-card slot

Inserir o modo de configuração de interface de placa de voz e especificar o local do slot utilizando um valor de 0 a 5, dependendo de seu router.

3 .


Router(config-voice-ca)# codec complexity {high |
medium}

Especificar a complexidade do codec de acordo com o padrão de codec que está sendo utilizado. Codecs de alta complexidade suportam densidades de chamada mais baixas do que codecs de complexidade média. O número de canais suportados depende do número de PVDMs (packet voice data modules) instalados e da complexidade do codec. Esta é uma orientação:

  • Em modo de codec de alta complexidade, até seis chamadas de voz ou fax podem ser feitas por PVDM-12, utilizando os seguintes codecs: G.711, G.726, G.729, G.729 Annex B, G.723,1, G.723,1 Annex A, G.728 e fax relay.

  • Em modo de codec de complexidade média, até doze chamadas de voz ou fax podem ser feitas por PVDM-12, utilizando os seguintes codecs: G.711, G.726, G.729 Annex A, G.729 Annex B com Annex A e fax relay

Todas as placas de voz precisam utilizar a mesma definição de complexidade de codec.

A palavra-chave especificada para complexidade de codec afeta a opção de codecs disponíveis utilizando o comando de configuração de ponto de discagem codec. Consulte a Etapa 7 em "Configurando Pontos de Discagem de Voz".

Não é possível alterar a complexidade do codec enquanto são definidos os grupos DSO. Se eles já estiverem configurados, utilize o comando no ds0-group antes de redefinir a complexidade de codec. Para obter mais informações sobre o comando ds0-group, consulte o Etapa 5.

4 .  


Router(config)# controller T1 slot/port

Inserir o modo de configuração do controlador do VWIC. Valores válidos do slot são 0 a 5 e para port são 0 e 1.

5 .


Router(config-controller)# ds0-group ds0-group-no
timeslots timeslot-list type {e&m-immediate |
e&m-delay |e&m-wink | fxs-ground-start |
fxs-loop-start | fxo-ground-start | fxo-loop-start}

(Voz somente) Este comando define os canais T1 para uso pelas chamadas de voz compactada assim como o método de sinalização que o router utiliza para conectar o PBX ou CO. Configure grupos DS0 depois de ter especificado a complexidade de codec em configuração de placa de voz, conforme mostrado na Etapa 3. Se você modificar os parâmetros do comando codec complexity, precisará primeiro remover quaisquer grupos DS0 existentes, então reinstalá-los depois de alterar a complexidade de codec.

ds0-group-no é um valor de 0 a 23 que identifica o grupo DS0.

Observação O comando ds0-group cria automaticamente uma porta de voz lógica que está numerada como segue: slot/port:ds0-group-no. Embora somente uma porta de voz seja criada, as chamadas aplicáveis são roteadas para qualquer canal do grupo.

timeslot-list consiste em um único número, números separados por vírgulas ou um par de números separados por um hífen para indicar uma faixa de intervalos de tempo. Para 1, os valores permitidos são de 1 a 24. Para mapear intervalos de tempo DS0 individuais, defina grupos adicionais. O sistema mapeia portas de voz adicionais para cada grupo definido. Consulte a Etapa 2 de "Configurando Portas de Voz".

A seleção do método de sinalização para type depende na conexão que está sendo feita:

  • A interface E&M permite conexão para linhas de tronco PBX (linhas de ligação) e equipamento de telefone. As configurações de início e atraso especificam sinais de confirmação entre as extremidades de transmissão e recepção, à etapa que a configuração imediata não estipula nenhum sinal especial para fora do gancho/no gancho.

  • A interface FXO é para conexão de um CO (central office) para uma interface PBX padrão quando permitida pelas regulamentações locais; a interface muitas vezes é utilizada para extensões extra-escritório.

  • A interface FXS permite conexão de equipamento de telefone básico e PBXs.



Configurando Controladores T1 e E1

Siga este procedimento para configurar controladores T1 e E1. Pule as Etapas 1 e 2 se já estiver no modo de configuração do controlador.

Repita as etapas seguintes à Etapa 2 de cada controlador.

1 .  


Router# configure terminal

Ignore esta etapa se já estiver no modo de configuração do controlador.

Inserir o modo de configuração global.

2 .


Router(config)# controller {T1 | E1}slot/port

Ignore esta etapa se já estiver no modo de configuração do controlador.

Inserir o modo de configuração do controlador para o controlador T1 ou E1 no local slot/port especificado.

3 .  


Router(config-controller)# loopback {diagnostic |
local {payload | line}|remote {iboc |esf {payload | line}}

(Opcional, T1 apenas, testando) Este comando gera um teste de loopback local na linha ou no nível de carga ou em um loopback remoto. Para obter mais informações, Configurando Pacote T1 Digital Módulos de Rede de Tronco de Voz em Cisco 2600 e 3600 Series Routers.

4 .


Router(config-controller)# clock source {line
[primary] | internal}

Especifique a origem do horário. A palavra-chave line especifica que a origem do horário é derivada da linha ativa --- em vez de ser do horário interno de execução livre. Essa é a configuração padrão e geralmente é mais confiável. Estas regras aplicam-se à origem do horário:

  • Quando ambas as portas são definidas para a sincronização de linha sem especificação primária, a porta 0 é a origem do horário primária padrão e a porta 1 é a origem secundária padrão.

  • Quando ambas as portas são definidas para a linha e uma porta é identificada como a origem de horário primária, a outra porta será por padrão a origem secundária ou de backup e será programada em circuito.

  • Se uma porta está definida como linha de origem do horário ou linha de origem do horário primária e a outra está definida como origem do horário interna, a porta interna recupera o horário a partir da porta da linha de origem de horário se essa porta estiver ativa. Se estiver desligada, a porta interna gerará seu próprio horário.

  • Se ambas as portas estiverem definidas como clock source internal, haverá apenas a origem de horário --- interna.

5 .  


Router(config-controller)# framing {sf | esf}

ou

Router(config-controller)# framing {crc4 | no-crc4}
[australia]

Definir o enquadramento para o formato SuperFrame (SF) ou Extended SuperFrame (ESF), de acordo com os requisitos do provedor de serviços.

Definir o enquadramento para CRC4 (cyclic redundancy check 4) ou sem CRC4, de acordo com os requisitos do provedor de serviços. A palavra-chave opcional australia especifica Homologação de Camada 1 da Austrália para o enquadramento E1.

6 .  


Router(config-controller)# linecode {b8zs | ami | hdb3}

Definir a codificação de linha de acordo com as instruções do seu provedor do serviço. B8ZS (bipolar-8 zero substitution), disponível somente para linhas T1, codifica uma seqüência de oito zeros em uma seqüência binária exclusiva para detectar violações de código de linha.

AMI (alternate mark inversion), disponível para linhas T1 ou E1, representa zeros utilizando um 01 durante cada célula de bits, e algumas são representadas por 11 ou 00, alternativamente, durante cada célula de bits. A AMI requer que o dispositivo de envio mantenha a densidade em um. A densidade de um não é mantida de forma independente do fluxo de dados.

Para E1, definir o código de linha para AMI ou HDB3 (high-density bipolar 3), o padrão.

7 .  


Router(config-controller)# line-termination {75-ohm |
120-ohm}

(E1 somente) Inserir um valor de terminação de linha. Esse comando especifica a impedância (quantidade de resistência do fio e reatividade à corrente) de cada terminação E1. Os níveis de impedância são mantidos para evitar danos nos dados sobre ligações de longa distância.

Especifique 120 ohm para corresponder à interface de 120 ohm equilibrada. Esse é o padrão.

75 ohm é para uma interface de BNC 75 ohm desequilibrada.

8 .  


Router(config-if)# fdl {att | ansi | both}

(Interfaces T1 somente) Este comando define o padrão de intercâmbio de FDL (Facility Data Link) para os controladores CSU. O FDL é um canal de 4 Kbps utilizado com o formato de enquadramento ESF (Extended SuperFrame) para fornecer mensagem fora da faixa em uma ligação T1.

Normalmente deixe essa configuração como padrão, ansi, que segue o padrão ANSI T1.403 para suporte de intercâmbio de ligação de dados em instalações de superquadro estendido. A alteração disso permite um melhor gerenciamento em alguns casos, mas pode causar problemas se sua definição não for compatível com a de seu provedor de serviços.

att seleciona o padrão AT&T TR54016 para suporte de intercâmbio de ligação de dados em instalações de superquadro estendido.

both ativa ambos os padrões acima.

9 .  


Router(config-controller)# cablelength long {gain26 |
gain36} {-15db | -22.5db | -7.5db | 0db}

ou

cablelength short {133 | 266 | 399 | 533 | 655}

(Interfaces T1 somente) A definição do comprimento do cabo deve estar em conformidade com o comprimento de cabo que está sendo utilizado. Por exemplo, se você tenta digitar o comando cablelength short em uma ligação T1 de percurso longo, o comando será rejeitado.

Para definir um comprimento de cabo maior que 655 pés para uma ligação T1, digite o comando cablelength long:

  • gain26 especifica o ganho de pulso de decibéis em 26. Esse é o ganho de pulso padrão.

  • gain36 especifica o ganho de pulso de decibéis em 36.

  • -15db especifica a taxa de pulso de decibéis em -15 decibéis.

  • -22.5db especifica a taxa de pulso de decibéis em -22,5 decibéis.

  • -7.5db especifica a taxa de pulso de decibéis em -7,5 decibéis.

  • 0db especifica a taxa de pulso de decibéis em 0 decibéis. Essa é a taxa de pulso padrão.

Para definir um comprimento de cabo menor que 655 pés para uma ligação T1, digite o comando cablelength short. Não há padrão para cablelength short:

  • 133 especifica um comprimento de cabo de 0 a 133 pés.

  • 266 especifica um comprimento de cabo de 134 a 266 pés.

  • 399 especifica um comprimento de cabo de 267 a 399 pés.

  • 533 especifica um comprimento de cabo de 400 a 533 pés.

  • 655 especifica um comprimento de cabo de 534 a 655 pés.

Se a definição do comprimento do cabo não for feita, o sistema padroniza para uma definição de cablelength long gain26 0db.



Configurando Soltar e Inserir

Execute as etapas desta seção se estiver configurando o recurso Soltar e Inserir. Se não estiver, continue em "Configurando Interfaces Seriais".

1 .


Router(config-controller)# tdm-group tdm-group-no
timeslots timeslot-list type [e&m | fxs [loop-start |
ground-start] fxo [loop-start | ground-start]

Digite este comando para configurar grupos de canal TDM para a função Soltar e Inserir com uma Multiflex VWIC de 2 portas.

tdm-group-no é um valor de 0 a 23 para T1 e de 0 a 30 para E1; ele identifica o grupo.

timeslot-list consiste em um único número, números separados por vírgulas ou um par de números separados por um hífen para indicar uma faixa de intervalos de tempo. A faixa válida é de 1 a 24 para T1. Para E1, o intervalo é de 1 a 31.

A seleção do método de sinalização para type depende na conexão que está sendo feita. As opções fxs and fxo permitem a especificação de linha de início-terra ou linha de início-circuito. Referências a Comandos de Aplicativos Locais, Voz e Vídeo do Cisco IOS Versão 12.0 inclui informações adicionais sobre essas opções.

Observação Os números de grupos para os grupos de controladores devem ser únicos. Por exemplo, um grupo TDM não deve ter o mesmo número ID de um grupo DS0 ou grupo do canal.
2 .  


Router(config-controller)# channel-group
channel-group-no timeslots timeslot-list [speed
[48|56|64]]

(Opcional) Digite esse comando para definir grupos de canal para serviços de dados WAN com uma VWIC Multiflex com Soltar e Inserir de 2 portas.

channel-group-no é um valor de 0 a 23 para T1 e de 0 a 30 para E1; porque pode haver somente um grupo de canal em uma Multiflex VWIC de 1 ou 2 portas, 0 é sempre o valor.

timeslot-list consiste em um único número, números separados por vírgulas ou um par de números separados por um hífen para indicar uma faixa de intervalos de tempo. A faixa válida é de 1 a 24 para T1. Para E1, o intervalo é de 1 a 31.

A definição opcional de velocidade padroniza como 56 Kbps em T1 e 64 Kbps em E1.

Observação Embora o CLI exiba 48 como uma opção de velocidade, essa opção não é suportada.
3 .


Router(config-controller)# no shutdown

Ativar o controlador.

4 .


Router(config-controller)# exit

Sair do modo de configuração do controlador. Pule para a próxima etapa se não estiver definindo o recurso Soltar e Inserir.

5 .


Router(config)# connect id {T1 | E1} slot/port-1
tdm-group-no-1
{T1 | E1} slot/port-2 tdm-group-no-2

Esse comando de configuração global configura a conexão entre dois grupos TDM T1 ou E1 de intervalos de tempo na WVIC --- para Soltar e Inserir.

id é um nome para a conexão.

Identifica cada controlador por sua localização de slot/port.

tdm-group-no-1 e tdm-group-no-2 identificam os números do grupo TDM (de 0 a 23 ou 30) no controlador especificado. Os grupos foram configurados na Etapa 1.

Consulte a seção "Exemplos de Configuração" para obter amostras de configurações de Soltar e Inserir.



Verificando as Definições das Placas de Voz e do Controlador

Etapa 1 Digite o comando show running-config para exibir a configuração de placa de voz atual. Se não for exibida nenhuma complexidade do codec, será definido o padrão de complexidade médio. O exemplo a seguir mostra um trecho da saída de comando:

Router# show running-config
.
.
hostname router-alpha

voice-card 1
 codec complexity high 
.
.
.

Etapa 2 O comando EXEC privilegiado show controllers t1/e1 exibe o status de controladores T1 ou E1 e informações sobre origens do horário e outras configurações para as portas:

Router# show controller T1 1/0

T1 1/0 is up.
  Applique type is Channelized T1
  Cablelength is short 133
  Description: T1 WIC card Alpha
  No alarms detected.
  Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
  Data in current interval (1 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs  

Etapa 3 O comando EXEC privilegiado show connection all exibe o status de grupos do controlador TDM T1 ou E1 e como eles são configurados:

Router# show connection all

ID   Name               Segment 1            Segment 2           State
========================================================================
1    Test              -T1 1/0 01           -T1 1/1 02           ADMIN UP

Configurando interfaces seriais

A forma como as interfaces serial e LAN são configuradas depende de seu aplicativo. Este documento não explica todas as opções possíveis de configuração da interface serial, nem mostra a configuração da interface de LAN. Para obter informações completas, consulte o Guia de Configuração da Interface Cisco IOS e Referências a Comandos da Interface Cisco IOS do Cisco IOS Versão 12.0.

Se estiver planejando utilizar o suporte de voz, continue em "Exemplos de Configurações".

Para configurar o VoIP, é necessário no mínimo definir endereços IP para interfaces seriais. Quando um usuário digita dígitos suficientes para corresponder ao padrão de destino configurado, o número de telefone é mapeado para um host IP por meio do mapeador de plano de discagem. O host IP possui uma conexão direta para o número de telefone de destino ou um PBX que completa a chamada para o padrão de destino configurado.


Observação Para obter informações sobre como monitorar interfaces seriais para acionar uma condição de ocupado em uma porta de voz quando uma interface está desativada, consulte "Configurando Portas de Voz".
Etapa Comando Propósito
1 .  


Router# configure terminal

Inserir o modo de configuração global.

2 .


Router(config)# interface serial
slot/port:channel-group

Inserir o modo de configuração de interface para uma interface serial que você especifica por slot e porta. A parte channel-group do comando é necessário somente para interfaces T1 ou E1 canalizadas; seu valor é sempre 0 para suporte de Multiflex VWIC. (Para configurar interfaces canalizadas, consulte o Guia de Configuração de Soluções de Discagem para Cisco IOS Versão 12.0.)

3 .  


Router(config-if)# ip address ip-address mask

Atribuir o endereço IP e máscara de sub-rede para a interface.


Verificando a Configuração da Interface Serial

Para verificar a configuração da interface serial, digite o comando EXEC privilegiado show interfaces serial, que mostra o status de todas as interfaces seriais ou de uma interface serial específica, como no exemplo a seguir. Você pode utilizar esse comando para verificar o encapsulamento, o endereço IP e outras definições:

Router #show interface serial0/0:0
Serial0/0:0 is up, line protocol is up
  Hardware is QUICC Serial
  Internet address is 1.156.1.1/24
  MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not set
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     637 packets input, 64736 bytes, 0 no buffer
     Received 181 broadcasts, 0 runts, 5 giants, 0 throttles
     3617 input errors, 1506 CRC, 1646 frame, 0 overrun, 0 ignored, 0 abort
     682 packets output, 67213 bytes, 0 underruns
     0 output errors, 0 collisions, 1070 interface resets
     0 output buffer failures, 0 output buffers swapped out
     13 carrier transitions
     Timeslot(s) Used:1-24, Transmitter delay is 0 flags

Configurando as portas de voz

Siga estas etapas para configurar portas de voz para suportar as estações local e remota. Este procedimento se aplica apenas a T1 Multiflex VWICs instaladas em módulos de rede de tronco de voz em pacote T1 digital quando são requeridos serviços de voz.

Esta seção não mostra todos os comandos que podem ser utilizados. Para aprender mais, consulte o Guia de Configuração de Aplicativos Locais, Voz e Vídeo e Referências a Comandos de Aplicativos Locais, Voz e Vídeo para Cisco IOS Versão 12.0.

Etapa Comando Propósito
1 .  


Router# configure terminal

Inserir o modo de configuração global.

2 .


Router(config)# voice-port slot/port:ds0-group-no

Inserir o modo de configuração de porta de voz.

slot é o local do router onde o módulo de voz está instalado. Os valores válidos são de 0 a 3.

port indica um local de Multiflex VWIC. Os valores válidos são 0 ou 1.

Cada número de grupo DSO definido é representado em uma porta de voz separada. Isso permite que você defina DS0s individuais na placa T1 digital. Para obter mais informações sobre grupos DS0, consulte a Etapa 5 de "Configurando Placas de Voz e Definições do Controlador".

Observação Essa sintaxe de comando voice-port não se aplica a módulos de rede de voz analógicos e placas de interface de voz. Especifique as placas de interface de voz utilizando slot/subunit/port, designando o slot do router para o módulo de rede de voz, o local da placa de interface de voz no módulo de rede e a porta na placa de interface de voz.
3 .  


Router(config-voice-port)# busyout monitor interface
interface number

(Opcional) Esse comando permite especificar uma interface LAN ou WAN que será monitorada e, quando estiver desativada, aciona um estado de ocupado (fora do gancho) na porta de voz. Isso permite rotear novamente as chamadas. Por exemplo, se você especificar Serial 1/0 como interface e número, a porta de voz envia um sinal de ocupado quando essa interface estiver desativada. Você pode emitir o comando repetidas vezes para especificar quantas interfaces, interfaces virtuais e subinterfaces forem necessárias para uma porta de voz.

Por exemplo, se você emitir o comando três vezes, de modo que três interfaces são monitoradas, a porta de voz somente ficará ocupada quando todas as três interfaces estiverem desativadas. Quando uma das três interfaces estiver operacional, o estado de ocupado é removido.

4 .  


Router(config-voice-port)# comfort-noise

(Opcional) Esse parâmetro é ativado por padrão. Ele cria um ruído de fundo sutil para preencher os intervalos de silêncio durante as chamadas quando o VAD está ativado em pontos de discagem de voz. Se o ruído de conforto não for gerado, o silêncio pode ser desconfigurado para chamadores.

5 .  


Router(config-voice-port)# echo-cancel enable

(Opcional) Essa definição é ativada por padrão. O cancelamento de eco aumenta a qualidade das transmissões de voz ajustando o eco que ocorre na interface devido às incompatibilidades de impedância. Algum eco é reafirmado; eco acima de 25 milissegundos pode causar problemas.

6 .  


Router(config-voice-port)# echo-cancel coverage {16 |
24 |32 | 8}

(Opcional) Este comando ajusta o cancelador de eco pelo número especificado de milissegundos; o padrão é 16.

7 .  


Router(config-voice-port)# connection {plar |trunk}
string

(Opcional) Esse comando configura um modo de conexão para a porta de voz.

plar especifica uma conexão PLAR (private line automatic ring down), que toca em um telefone remoto quando o ponto de discagem fica fora do gancho.

trunk especifica uma conexão de linhas de ligação direta a um PBX.

string especifica o número de telefone remoto ou dígitos iniciais significativos do número.

Consulte "Exemplos de Configurações" para obter uma amostra de configurações PLAR e de tronco.

8 .  


Router(config-voice-port)# timeouts interdigit seconds

(Opcional) Este comando define o número de segundos que o sistema aguarda --- depois que o chamador tiver inserido o dígito inicial --- de um dígito subseqüente da cadeia digitada. Se o intervalo terminar antes que o destino seja identificado, soa um tom e a chamada é finalizada. O valor padrão é 10 segundos e o intervalo pode ser definido de 0 a 120 segundos.

Observação Alterações no padrão deste comando normalmente são obrigatórias. Outras configurações de cronometragem também são necessárias. Para obter mais informações, consulte o Guia de Configuração de Aplicativos Locais, Voz e Vídeo do Cisco IOS Versão 12.0.
9 .


Router(config-voice-port)# exit

Sair do modo de configuração de porta de voz.

Repita as Etapas 2 a 9 em cada grupo DS0 que criar.



Verificando as Portas de Voz

Siga este procedimento para verificar a configuração de porta de voz. Para saber mais, consulte Referências a Comandos de Aplicativos Locais, Voz e Vídeo do Cisco IOS Versão 12.0.

A saída importante do comando é apresentada em negrito.

Para verificar a configuração de porta de voz, digite o comando EXEC privilegiado show voice port slot/port:ds0-group. A amostra de saída a seguir desse comando mostra informações explicativas após os caracteres <<:

cisco-router# show voice port 1/0:1

receEive and transMit Slot is 1, Sub-unit is 0, Port is 1  << voice-port 1/0:1
 Type of VoicePort is E&M
 Operation State is DORMANT
 Administrative State is UP
 No Interface Down Failure
 Description is not set
 Noise Regeneration is enabled
 Non Linear Processing is enabled
 Music On Hold Threshold is Set to -38 dBm
 In Gain is Set to 0 dB
 Out Attenuation is Set to 0 dB
 Echo Cancellation is enabled
 Echo Cancel Coverage is set to 8 ms
 Connection Mode is normal
 Connection Number is not set
 Initial Time Out is set to 10 s
 Interdigit Time Out is set to 10 s
 Region Tone is set for US

Configurando Pontos de Discagem de Voz

Siga estas etapas para configurar pontos de discagem de voz para suportar as estações local e remota. Este procedimento se aplica apenas a T1 Multiflex VWICs instaladas em módulos de rede de tronco de voz em pacote T1 digital quando são requeridos serviços de voz.

Esta seção não mostra todos os comandos que podem ser inseridos. Para aprender mais, consulte o Guia de Configuração de Aplicativos Locais, Voz e Vídeo e Referências a Comandos de Aplicativos Locais, Voz e Vídeo para Cisco IOS Versão 12.0.

Etapa Comando Propósito
1 .  


Router# configure terminal

Inserir o modo de configuração global.

2 .  


Router(config)# dial-peer voice number pots

Insira o modo de configuração de ponto de discagem e defina um ponto de discagem local que conectará com a rede POTS (plain old telephone service).

number consiste em um ou mais dígitos que identificam o ponto de discagem. Os valores válidos são de 1 a 2147483647.

pots indica um ponto utilizando serviço de telefonia básico.

3 .


Router(config-dialpeer)# destination-patternstring
[T]

Configure o padrão de destino do ponto de discagem, de modo que o sistema possa conciliar os dígitos discados com um número de telefone.

string consiste de uma série de dígitos que especifica o E.164 ou número de telefone de plano de discagem privada. Valores válidos são dígitos de 0 a 9 e as letras de A a D. O sinal de mais (+) não é válido. É possível inserir os seguintes caracteres especiais:

  • O caractere estrela (*) que aparece nos teclados de discagem por multifreqüência padrão pode estar em qualquer cadeia de discagem, mas não como um caractere inicial (por exemplo, *650).

  • O ponto (.) funciona como um caractere curinga.

  • A vírgula (,) pode ser utilizada somente em prefixos e introduz uma pausa de um segundo.

Quando o caractere do temporizador (T) é incluído no final do padrão de destino, o sistema coleta dígitos discados na media em que são inseridos --- até que o temporizador interdígitos expire (10 segundos, por padrão) --- ou o usuário disque a terminação da chave final de discagem (o padrão é #).

Observação O caractere do temporizador deve ser um T maiúsculo.
4 .  


Router(config-dialpeer)# prefix string

(Opcional) Inclui um prefixo de discagem que o sistema insere automaticamente em vez de ser digitado pela pessoa.

string é um valor de 0 a 9, e você pode utilizar uma vírgula (,) para indicar uma pausa.

Observação Há outros comandos de manipulação de dígito padrão disponíveis para lidar com tais situações, como prefixos para serviços especiais, ignorando alguns dígitos, e discando para PBXs remotos como se fossem locais.
5 .  


Router(config-dialpeer)# port slot/port:ds0-group-no

Esse comando associa o ponto de discagem a uma interface lógica específica.

slot é o local do router onde o módulo de voz está instalado. Os valores válidos são de 0 a 3.

port indica o local da placa da interface de voz. Os valores válidos são 0 ou 1.

Cada número de grupo DSO definido é representado em uma porta de voz separada. Isso permite que você defina DS0s individuais na placa T1 digital.

6 .  


Router(config)# dial-peer voice number voip

Inserir o modo de configuração de ponto de discagem e definir um ponto de discagem VoIP remoto.

number consiste em um ou mais dígitos que identificam o ponto de discagem. Os valores válidos são de 1 a 2147483647.

voip indica um ponto VoIP utilizando encapsulamento de voz na rede IP.

7 .


Router(config-dialpeer)# codec {g711alaw | g711ulaw |
g723ar53 | g723ar63 | g723r53 | g723r63 | g726r16 |
g726r24 | g726r32 | g728 | g729r8 [pre-ietf] | g729br8}
[bytes]

O comando codec complexity de configuração de placa de voz define as opções de codec disponíveis quando esse comando é digitado (consulte a Etapa 3 de "Configurando Placa de Voz e Definições do Controlador").

Caso a complexidade do codec não seja definida, será usado g729r8 com ordenação de bit IETF.

Se configurar a complexidade do codec para alta, as opções a seguir estarão disponíveis:

  • g711alaw---G.711 A Law 64.000 bps

  • g711ulaw---G.711 u Law 64.000 bps

  • g723ar53---G.723.1 Annex A 5,300 bps

  • g723ar63---G.723,1 Annex A 6.300 bps

  • g723r53---G.723,1 5.300 bps

  • g723r63---G.723,1 6.300 bps

  • g726r16---G.726 16.000 bps

  • g726r24---G.726 24.000 bps

  • g726r32---G.726 32.000 bps

  • g728---G.728 16.000 bps

  • g729r8---G.729 8.000 bps (padrão)

  • g729br8---G.729 Annex B 8.000 bps

Se configurar a complexidade do codec para média, as seguintes opções serão válidas:

  • g711alaw---G.711 A Law 64.000 bps

  • g711ulaw---G.711 u Law 64.000 bps

  • g726r16---G.726 16.000 bps

  • g726r24---G.726 24.000 bps

  • g726r32---G.726 32.000 bps

  • g729r8---G.729 Annex A 8,000 bps

  • g729br8---G.729 Annex B com Annex A 8.000 bps

O parâmetro opcional bytes define o número de bytes de dados de voz por quadro. São aceitáveis valores de 10 a 240 em incrementos de 10 (por exemplo, 10, 20, 30 e assim por diante). Qualquer outro valor será arredondado para baixo (por exemplo, de 236 para 230).

Se for especificado g729r8, então o seqüenciamento de bits IETF (Internet Engineering Task Force) será utilizado. Para interoperabilidade com um router Cisco 2600, 3600 ou AS5300 executando em um Cisco IOS de versão anterior à Versão 12.0(5)T ou 12.0(4)XH, é necessário especificar a palavra-chave adicional pre-ietf após g729r8.

8 .  


Router(config-dialpeer)# vad

(Opcional) Essa configuração é ativada por padrão e ativa VAD (voice activity detection). VAD permite que o sistema reduza transmissões de voz desnecessárias causadas por ruído de fundo não filtrado.

9 .  


Router(config-dialpeer)# dtmf-relay [cisco-rtp]
[h245-signal] [h245-alphanumeric]

(Opcional) A DTMF (Dual-tone multifrequency) descreve o tom que surge em resposta a uma tecla pressionada em um telefone de toque como tom. Os tons DTMF são compactados em uma extremidade da chamada e descompactados na outra extremidade.

Em caso de codec de largura de banda baixa, como G.729 ou G.723, os tons podem soar distorcidos. O comando dtmf-relay transporta tons DTMF gerados depois de estabelecida a chamada fora de faixa utilizando um método que transmite com mais fidelidade do que possível dentro de faixa na maior parte de codecs de largura de banda baixa. Sem relé DTMF, as chamadas estabelecidas com codecs de baixa largura de banda podem ter problemas ao acessar sistemas de telefones automáticos, como sistemas de correio de voz e sistemas IVR (interactive voice response).

Um método de sinalização é fornecido somente se a extremidade remota suportá-lo, e as opções são: propriedade da Cisco (cisco-rtp), padrão H.323 (h245-alfanumérico) e H.323 padrão com duração de sinal (h245-sinal).

10 .  


Router(config-dialpeer)# fax-rate {2400 | 4800 | 7200
| 9600 | 12000 | 14400 | disable | voice}

(Opcional) Especifique a velocidade da transmissão de um fax a ser enviado para esse ponto de discagem. disable desativa o recurso de transmissão de fax e voice especifica a maior velocidade de fax possível suportada pela taxa de voz.

11 .  


Router(config-dialpeer)# destination-patternstring
[T]

Consulte a Etapa 3 nesse procedimento.

12 .  


Router(config-dialpeer)# session target
{ipv4:destination-address | dns:[$s$. | $d$. | $e$. |
$u$.] host-name}

Configurar o destino da sessão IP para o ponto de discagem.

ipv4:destination-address indica o endereço IP do ponto de discagem.

dns:host-name indica que o servidor de nome do domínio resolverá o nome do endereço IP. Os valores válidos para este parâmetro são caracteres representando o nome do dispositivo host.

Também há caracteres curingas disponíveis para definir nomes de domínio com palavras-chave utilizando informações de origem, destino e discadas no nome do host.

Para obter informações completas sobre sintaxe de comando, consulte Referências a Comandos de Aplicativos Locais, Voz e Vídeo para Cisco IOS Versão 12.0.



Verificando Pontos de Discagem de Voz

Siga o procedimento abaixo para verificar a configuração do ponto de discagem. Para saber mais sobre esses comandos, consulte a Referências a Comandos de Aplicativos Locais, Voz e Vídeo do Cisco IOS Versão 12.0.

A saída importante do comando é apresentada em negrito.

Digite o comando EXEC privilegiado show dial-peer voice. O texto a seguir é uma amostra de saída do comando de um ponto de discagem POTS:

router# show dial-peer voice 1
VoiceEncapPeer1
        tag = 1, dest-pat = \Q+14085551000',
        answer-address = \Q',
        group = 0, Admin state is up, Operation state is down
        Permission is Both,
        type = pots, prefix = \Q',
        session-target = \Q', voice-port =
        Connect Time = 0, Charged Units = 0
        Successful Calls = 0, Failed Calls = 0
        Accepted Calls = 0, Refused Calls = 0
        Last Disconnect Cause is "10"
        Last Disconnect Text is ""
        Last Setup Time = 0

O texto a seguir é uma amostra da saída do comando show dial-peer voice de um ponto de discagem VoIP:

Router# show dial-peer voice 10
VoiceOverIpPeer10
        tag = 10, dest-pat = \Q',
        incall-number = \Q+14087',
        group = 0, Admin state is up, Operation state is down
        Permission is Answer,
        type = voip, session-target = \Q',
        sess-proto = cisco, req-qos = bestEffort,
        acc-qos = bestEffort,
        fax-rate = voice, codec = g729r8,
        Expect factor = 10,Icpif = 30, VAD = disabled, Poor QOV Trap = disabled,
        Connect Time = 0, Charged Units = 0
        Successful Calls = 0, Failed Calls = 0
        Accepted Calls = 0, Refused Calls = 0
        Last Disconnect Cause is "10"
        Last Disconnect Text is ""
        Last Setup Time = 0

Exemplos de configurações

Esta seção inclui três configurações de amostra para ilustrar cenários diferentes:

  • Soltar e Inserir, onde os serviços PSTN e VoIP são fornecidos por meio da mesma linha do provedor de serviços.

  • Soltar e Inserir, onde os serviços PSTN e de dados são fornecidos por meio da mesma linha do provedor de serviços.

  • Soltar e Inserir, onde os serviços PSTN, de dados e VoIP são fornecidos por meio da mesma linha do provedor de serviços.


Observação Para obter exemplos adicionais, consulte Configurando Módulos de Rede de Tronco de Voz de Pacote T1 Digital em Cisco 2600 e 3600 Series Routers.

A tecnologia Soltar e Inserir é uma forma de integrar velhas tecnologias PBX com VoIP. Permite ter canais DS0 de 64 Kb de um T1 ou E1 e conectá-los cruzados digitalmente com canais DS0 de 64 Kb em outro T1 ou E1.

Soltar e Inserir permite que canais DS0 de 64 Kb sejam transmitidos de forma transparente, descompactados, entre portas T1/E1 sem processamento DSP. O tráfego do canal é enviado entre um switch PBX e CO ou outro dispositivo de telefonia, permitindo o uso, por exemplo, de alguns canais PBX para serviços de longa distância por meio de PSTN enquanto o router comprime outros de chamadas VoIP entre escritórios. Adicionalmente, Soltar e inserir pode permitir a conexão cruzada de um switch de telefonia (do CO ou PSTN) a um banco de memória de canal para proporcionar conectividade analógica externa.

Tenha em mente as seguintes considerações:

  • Soltar e Inserir funciona somente entre portas na mesma Multiflex VWIC.

  • A VWIC pode estar em um slot WIC independente em um router Cisco da série 2600, integrado em um slot VWIC de Módulo de Rede de Tronco de Voz de Pacote T1 Digital, ou instalado em um módulo de rede de 2 portas do Cisco série 3600 (NM-1E2W, NM-2E2W, NM-1E1R2W).

  • Quando o módulo VWIC está instalado no slot VWIC de um Módulo de Rede de Tronco de Voz de Pacote T1 Digital, as portas T1 não fornecem conectividade de WAN (por exemplo. Frame-Relay, PPP e assim por diante) além de voz e Soltar e Inserir.

  • Os recursos de WAN e Soltar e Inserir são suportados quando a VWIC está em um slot WIC de chassi em um router Cisco série 2600.

Soltar e Inserir com Serviços VoIP e PSTN


Figura 2: Configuração de Amostra: Soltar e Inserir com Serviços VoIP e PSTN

O exemplo desta seção mostra a configuração do recurso Soltar e Inserir quando uma Multiflex VWIC de 2 portas está instalada em um slot VWIC de Módulo de Rede de Tronco de Voz de Pacote T1 Digital e o VoIP está configurado. As conexões WAN devem ser fornecidas por ligações separadas.

hostname RTR-A

!
voice-card 1
  codec complexity high
!
controller T1 1/0
framing esf
linecoding b8zs
ds0-group 1 timeslots 1-12 type e&m-wink
tdm-group 2 timeslots 13-24 type e&m
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line primary
tdm-group 3 timeslots 13-24 type e&m
!
voice-port 1/0:1
!
dial-peer voice 1 voip
destination-pattern 4...
codec g723r63
dtmf-relay h245-alpha
session target ipv4:209.165.200.253
session target ipv4:209.165.200.252
!
dial-peer voice 2 pots
destination-pattern 5...
prefix 5
port 1/0:1
!
interface serial 0/0
encapsulation ppp
ip address 209.165.200.252 255.255.255.224
!
connect tdm1 T1 1/0 2 T1 1/1 3
hostname RTR-B
!
voice-card 1
  codec complexity high
!
controller T1 1/0
framing esf
linecoding b8zs
ds0-group 1 timeslots 1-12 type e&m-wink
tdm-group 2 timeslots 13-24 type e&m
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line primary
tdm-group 3 timeslots 13-24 type e&m
!
voice-port 1/0:1
!
dial-peer voice 1 voip
destination-pattern 5.
codec g723r63
dtmf-relay h245-alpha
!
!
!
dial-peer voice 2 pots
destination-pattern 4.
prefix 4
port 1/0:1
!
interface serial 0/0
encapsulation ppp
ip address 209.165.200.253 255.255.255.224
!
connect tdm1 T1 1/0 2 T1 1/1 3 

Origens de tempo

Neste exemplo, duas origens de horário estão disponíveis em cada porta da Multiflex VWIC do router: uma do PBX e uma do CO (central office) PSTN. No entanto, as origens de horário devem ser as mesmas, para que o sistema se ajuste a essa necessidade.

O comando primary keyword of the clock source, aplicado ao T1 1/1, significa que o PSTN está fornecendo origem de horário. A porta T1 1/0 conectada ao PBX é automaticamente inserida no modo looped-time, o que significa que a porta pega a temporização recebida em seu par Rx (recepção) e gerada novamente em seu par Tx (transmissão). Enquanto ela está recebendo a temporização, não conduz um horário integrado. É "falsificando" a porta que o PBX conectado não detecta a temporização que está fora da sincronização, o que é indicado pelos lapsos. O router detecta os lapsos como controlador e não força a porta a falhar.

Considerações Adicionais

Aqui estão alguns pontos principais para consideração:

  • O comando tdm-group 2 timeslots 13-24 type e&m define Soltar e Inserir configurando os intervalos de tempo de cada T1 que será utilizado na conexão cruzada digital. A palavra-chave type é opcional, mas seu uso é específico para o recurso Soltar e Inserir.

    • Se a palavra-chave type tiver sido incluída com um tipo de sinalização, a conexão cruzada Soltar e Inserir assegura que a sinalização especificada (no gancho e fora do gancho) seja transmitida entre os DS0s. Ela também utiliza os bits de sinalização para sinalizar ocupado se um dos T1s ficar desativado.

    • Se a palavra-chave type não for utilizada, a conexão cruzada Soltar e Inserir é um canal limpo e não interpreta nenhuma sinalização.

  • O comando connect tdm1 T1 1/0 2 T1 1/1 3 ativa a conexão digital cruzada Soltar e Inserir entre os T1s. A parte tdm1 do comando é apenas um nome da conexão cruzada, e o nome pode ser qualquer palavra, número ou série de letras.

  • Você pode verificar as conexões Soltar e Inserir utilizando o comando show connection.

Soltar e Inserir com Serviços de Dados e PSTN


Figura 3: Configuração de Amostra: Soltar e Inserir com Serviços de Dados e de Voz PSTN


Este exemplo nesta seção mostra a configuração do recurso Soltar e Inserir quando uma Multiflex VWIC de 2 portas está instalada em um slot de chassi do Cisco série 2600 ou em um slot WIC de um módulo de rede do Cisco série 3600. Dados de Frame Relay e chamadas de voz PSTN viajam entre os PBXs, mas nenhuma informação VoIP ou VoIP sobre Frame Relay é conduzida.

Origens de tempo

Como no exemplo anterior, duas origens de horário estão disponíveis em cada porta da Multiflex VWIC do router: uma do PBX e uma do CO (central office) PSTN. No entanto, as origens de horário devem ser as mesmas, para que o sistema se ajuste a essa necessidade.

A origem de horário principal é T1 ou E1 1/0, conectada ao PSTN, e seu horário é uma referência para T1 ou E1 1/1. Se o T1 1/0 falhar, a origem do horário para conduzir T1 ou E1 1/1 é gerada da linha para o PBX.

Considerações Adicionais

O comando channel-group 0 é configurado de tal forma que o provedor de serviços pode enviar LMI (link management information) de Frame-Relay em canais T1 de 13 a 24 (17 a 31 no E1) para serviços de dados do Frame-Relay. Este comando cria automaticamente a interface serial 1/0:0.

A interface serial 1/0:0 é onde todos os detalhes de protocolo de WAN e Camada 3 são configurados, por exemplo, encapsulamento de Frame Relay ou endereços IP.

Configuração T1

hostname RTR-A

!
controller T1 1/0
framing esf
linecoding b8zs
clock source line primary
tdm-group 1 timeslots 1-12
channel-group 0 timeslots 13-24
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
connect tdm1 T1 1/0 1 T1 1/1 2
hostname RTR-B
!
controller T1 1/0
framing esf
linecoding b8zs
clock source line primary
tdm-group 1 timeslots 1-12
channel-group 0 timeslots 13-24
!
controller T1 1/1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.253 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
connect tdm1 T1 1/0 1 T1 1/1 2

Configuração E1.

hostname RTR-A

!
controller E1 1/0
framing crc4
linecoding hdb3
clock source line primary
tdm-group 1 timeslots 1-15
channel-group 0 timeslots 17-31
!
controller E1 1/1
framing crc4
linecoding hdb3
clock source line
tdm-group 2 timeslots 1-15
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
connect tdm1 T1 1/0 1 T1 1/1 2

hostname RTR-B
!
controller E1 1/0
framing crc4
linecoding hdb3
clock source line primary
tdm-group 1 timeslots 1-15
channel-group 0 timeslots 17-31
!
controller E1 1/1
framing crc4
linecoding hdb3
clock source line
tdm-group 2 timeslots 1-15
!
interface serial 1/0:0
encapsulation frame-relay
!
interface serial 1/0:1.1
ip address 209.165.200.253 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
connect tdm1 T1 1/0 1 T1 1/1 2

Soltar e Inserir com Serviços PSTN, de Dados e VoIP


Figura 4: Configuração de Amostra:Soltar e Inserir com Serviços PSTN, Dados e VoIP


Essa configuração mostra como utilizar alguns canais T1 para transmitir voz do PSTN para o PBX e alguns canais de serviços de dados que também transmitem tráfego VoIP. Esta configuração requer ambos, um Módulo de rede de Tronco de Voz de Pacote T1 Digital com uma Multiflex VWIC instalada e uma Multiflex VWIC separada.

Origens de tempo

A origem de horário primária é T1 1/0, e seu horário é uma referência para T1 1/1. Se T1 1/0 falhar, a origem de horário para conduzir T1 1/1 será gerada internamente.

hostname RTR-A

!
controller T1 1/0
description - NM-HDV connected to PBX
framing esf
linecoding b8zs
clock source internal
tdm-group 1 timeslots 1-12 
ds0-group 2 timeslots 13-24 type e&m-wink
!
controller T1 1/1
description - xconnect to VWIC T1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
controller T1 2/0
description - connected to TELCO WAN
framing esf
linecoding b8zs
channel-group 0 timeslots 13-24 
tdm-group 3 timeslots 1-12
clock source line
!
controller T1 2/1
description - xconnect to NM-HDV
framing esf
linecoding b8zs
clock source internal
tdm-group 4 timeslots 1-12
!
voice-port 1/0:2
!
interface serial 2/0:0
encapsulation frame-relay
!
interface serial 1/0:0.1
ip address 209.165.200.252 255.255.255.224
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.200.250 255.255.255.224
!
router eigrp 1
network 209.165.200.224
!
dial-peer voice 1 voip
destination-pattern 5...
session target ipv4:209.165.200.253
!
dial-peer voice 2 pots
destination-pattern 4...
prefix 4
prefix 5
port 1/0:2
port 1/0:2
!
connect tdm1 T1 1/0 1 T1 1/1 2
connect tdm2 T1 2/0 3 T1 2/1 4
hostname RTR-B
!
controller T1 1/0
description -  NM-HDV connected to PBX
framing esf
linecoding b8zs
clock source internal
tdm-group 1 timeslots 1-12
!
controller T1 1/1
description - xconnect to VWIC T1
framing esf
linecoding b8zs
clock source line
tdm-group 2 timeslots 1-12
!
!
controller T1 2/0
description - connected to TELCO WAN
framing esf
linecoding b8zs
channel-group 0 timeslots 13-24
tdm-group 3 timeslots 1-12
clock source line
!
controller T1 2/1
description - xconnect NM-HDV
framing esf
linecoding b8zs
clock source internal
tdm-group 4 timeslots 1-12
!
voice-port 1/0:2
!
interface serial 2/0:0
encapsulation frame-relay
!
interface serial 1/0:0.1
ip address 209.165.200.253 255.255.255.0
frame-relay interface-dlci 100 br
!
interface ethernet 0
ip address 209.165.201.1 255.255.255.224
!
router eigrp 1
network 209.165.200.224
network 209.165.201.0
!
dial-peer voice 1 voip
destination-pattern 4...
session target ipv4:209.165.200.252
!
dial-peer voice 2 pots
destination-pattern 5...
!
connect tdm1 T1 1/0 1 T1 1/1 2
connect tdm2 T1 2/0 3 T1 2/1 4



Considerações Adicionais

As conexões a seguir são feitas utilizando canais de 1 a 12 a partir do provedor de serviços:

  • Os canais são trazidos na Multiflex VWIC que não está instalada no Módulo de Rede de Tronco de Voz de Pacote T1 Digital.

  • Esses 12 canais fazem conexão cruzada para outra porta da Multiflex VWIC.

  • De lá, um cabo crossover T1 externo faz a conexão cruzada aos canais da primeira porta T1 no Módulo de Rede de Tronco de Voz de Pacote T1 Digital.

  • Os 12 canais fazem a conexão cruzada para outra porta T1 no Módulo de Rede de Tronco de Voz de Pacote T1 Digital e fora do PBX conectado.

Os canais de 13 a 24 passam Frame-Relay LMI a partir do provedor de serviços para serviços de dados, e os canais terminam no grupo de canais da Multiflex VWIC. Essa interface serial é utilizada para tráfego de dados na Ethernet, assim como tráfego VoIP que origina nos canais de 13 a 24 do PBX conectado ao Módulo de Rede de Tronco de Voz de Pacote T1 Digital.

Referências a Comandos

Comandos novos e modificados estão incluídos na seção de Referências a Comandos do Configurando Módulo de Rede de Tronco de Voz de Pacote T1 Digital em Cisco 2600 e 3600 Series Routers. Todos os outros comandos usados com este recurso estão documentados nas referências de comando da versão 12.0 do Cisco IOS.

Glossário

AMI --- alternate mark inversion. Tipo de código de linha utilizado em circuitos T1 e E1. Em AMI, zeros são representados por 01 durante cada célula de bits, e um é representado por 11 ou 00, alternativamente, durante cada célula de bits. A AMI requer que o dispositivo de envio mantenha a densidade um, a qual não é mantida independentemente do fluxo de dados. Às vezes chamada inversão de marca alternada de código binário.

ATM --- Asynchronous Transfer Mode. Padrão internacional de transmissão de célula relay no qual vários tipos de serviço (como voz, vídeo ou dados) são transportados em células de comprimento fixo (53-bytes) que permitem processamento de célula para ocorrer em hardware; os atrasos, assim, são reduzidos. ATM é projetada para tirar vantagem da mídia de transmissão em alta velocidade, como E3, SONET e T3.

B8ZS --- binary 8-zero substitution. Tipo de código de linha, utilizado em circuitos T1 e E1, no qual um código especial é substituído sempre que 8 zeros consecutivos são enviados sobre a ligação. Este código é então interpretado na extremidade remota da conexão. Esta técnica garante que a densidade um fique independente do fluxo de dados.

CAS --- channel-associated signaling. Sinalização de tronco (por exemplo, em uma linha T1) na qual os sinais de controle, como aqueles para sincronizar e ligar estruturas, são conduzidos no mesmo canal juntamente com sinais de voz e dados.

CCS --- common channel signaling. Sinalização de tronco (por exemplo, utilizando a Interface de Taxa Primária), na qual um canal de controle conduz sinalização para canais de voz e dados separados.

CO --- central office. Escritório de companhia de telefone local onde todos os loops locais em uma determinada área são conectados e ocorre a comutação de circuito das linhas do assinante.

codec --- Coder-decoder. Dispositivo que normalmente utiliza modulação de código de pulso para transformar sinais analógicos em um fluxo de bits digital e sinais digitais de volta para analógicos.

DTMF --- Dual-tone multifrequency. Uso de dois tons de banda de voz simultâneos para discagem (como teclas).

Soltar e Inserir --- (também chamado Conexão Cruzada TDM) Permite que canais DSO de um recurso T1 ou E1 sejam conectados digitalmente para canais DS0 em outro T1 ou E1. Utilizando este método, o tráfego do canal é enviado entre um switch PBX e CO PSTN ou outro dispositivo de telefonia, de modo que alguns canais PBX são direcionados para serviço de longa distância por meio de PSTN enquanto o router comprime outros para chamadas VoIP entre escritórios. Adicionalmente, Soltar e inserir pode permitir a conexão cruzada de um switch de telefonia (do CO ou PSTN) a um banco de memória de canal para conectividade analógica externa.

DSP --- digital signal processor.

E1 --- Recurso transportador digital europeu utilizado para transmitir dados através da hierarquia de telefone. A taxa de transmissão para E1 é 2.048 megabits por segundo (Mbps).

E&M --- rEceive and transMit, ou Ear and Mouth. Tipo de sinalização originalmente desenvolvida para telefonia de voltagem de dois estados analógica utilizando terminais de orelha e boca; na telefonia digital, utiliza dois bits.

ESF --- Extended Superframe. Tipo de quadro utilizado em circuitos T1 que consiste em 24 quadros de 192 bits cada com o 193º bit fornecendo temporização e outras funções. ESF é uma versão avançada do formato SF.

FDL --- Facility Data Link. Um canal de 4 Kbps, fornecido pelo formato de quadro T1 do ESF (Extended SuperFrame). O FDL executa fora a capacidade de carga e permite que um provedor de serviços verifique as estatísticas de erro no equipamento terminal, sem intrusão.

FXO --- Foreign Exchange Office. Uma interface de voz emulando uma linha de tronco PBX para um switch ou equipamento telefônico para uma interface de ramal PBX.

FXS --- Foreign Exchange Station. Uma interface de voz para conectar equipamento de telefone; emula a interface de extensão de um PBX ou interface de assinante para um switch.

HBD3 --- High-Density Bipolar 3. Tipo de código de linha utilizado em circuitos E1.

IETF --- Internet Engineering Task Force.

ISDN --- Integrated Services Digital Network. Protocolo de comunicação oferecido pelas empresas de telefonia. ISDN permite que rede de telefone transportem dados, voz e outros tráfegos de origem.

packet --- Agrupamento lógico de informações que inclui um cabeçalho contendo informações de controle e (geralmente) dados de usuários. Os pacotes são muitas vezes utilizados para referência de uma unidade de dados de camadas de rede.

POTS --- plain old telephone service.

PDVM --- packet data voice module.

PSTN --- Public Switched Telephone Network. Termo geral que se refere à variedade de redes de telefonia e serviços atualmente no mundo.

QoS --- quality of service. Medida de desempenho para um sistema de transmissão que reflete sua qualidade de transmissão e disponibilidade de serviço.

SF --- Super Frame. Tipo de enquadramento comum utilizado em circuitos T1. O SF consiste em 12 quadros de 192 bits cada com o 193° bit proporcionando a verificação de erro e outras funções. O SF é substituído por ESF, mas ainda é amplamente usado. Também chamado enquadramento D4.

SNMP --- Simple Network Management Protocol. Protocolo de gerenciamento de redes utilizado quase que exclusivamente em redes TCP/IP. O SNMP oferece um meio para monitorar e controlar dispositivos de rede e para gerenciar configurações, coleta de estatísticas, desempenho e segurança.

T1 --- Recurso transportador de WAN digital. T1 transmite dados formatados de DS 1 em 1.544 Mbps por meio de rede de comutação de telefone utilizando a inversão de marca alternada ou codificação B8ZS.

Tronco T1 --- Recurso transportador de WAN digital. Veja T1.

TDM --- time-division multiplexing.

Troco --- Conexão física e lógica entre dois switches entre os quais viaja o tráfego da rede. Um backbone é composto de diversos troncos.

UNI --- User-Network Interface. Especificação do Fórum ATM que define um padrão de interoperabilidade para a interface entre produtos baseados em ATM (um router ou um switch ATM) localizado em uma rede privada e os switches ATM localizados dentro de rede de transportador público. Utilizado também para descrever conexões similares em redes Frame Relay.

VAD --- voice activity detection.