Software Cisco IOS e NX-OS : Software Cisco IOS versões 12.2 T

NAT - Capacidade de Utilização de Mapas de Rota com Conversões Estáticas

1 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Inglês (14 Outubro 2001) | Feedback

Índice

NAT - Capacidade de Utilização de Mapas de Rota com Conversões Estáticas
Visão geral do recurso
Plataformas suportadas
Padrões Suportados, MIBs e RFCs
Tarefas de configuração
Exemplos de configurações
Referências a Comandos
ip nat inside source

NAT - Capacidade de Utilização de Mapas de Rota com Conversões Estáticas


Histórico do Recurso
Versão Modificação

12.2(4)T

Este recurso foi introduzido.

12.2(4)T2

O suporte foi adicionado ao Cisco 7500 Series Routers.

Este documento descreve a NAT—Capacidade de Utilização de Mapas de Rota com o recurso de Conversões Estáticas. Ele inclui as seguintes seções:

Visão geral do recurso

Plataformas suportadas

Padrões Suportados, MIBs e RFCs

Tarefas de configuração

Exemplos de configurações

Referências a Comandos

Visão geral do recurso

Antes desse recurso, o mapeamento de rota era suportado somente com a conversão dinâmica NAT (Network Address Translation).

A NAT—Capacidade de Utilização de Mapas de Rota com o recurso de Conversões Estáticas ativa a capacidade multihoming da NAT com conversões de endereço estáticas. Redes internas multihomed agora podem hospedar serviços comuns tais como a Internet e DNS (Domain Name System), que são acessados a partir de redes externas diferentes.


Observação   O suporte estático de rede não está incluído nesse recurso.


Benefícios

  • A capacidade de fazer a configuração das instruções de mapa de rota fornece a opção de utilizar IP Security (IPSec) com NAT.
  • As decisões de conversão podem ser feitas com base no endereço IP de destino ao utilizar entradas de conversão estática.

Documentação Relacionada

  • Referências a Comandos Cisco IOS IP, Volume 1 de 3: Endereços e Serviços, Versão 12.2
  • Guia de Configuração de IP Cisco IOS, Versão 12.2

Plataformas suportadas

  • Série Cisco 2500
  • Série Cisco 2600
  • Router Cisco 3620
  • Router Cisco 3640
  • Router Cisco 3660
  • Série Cisco 7100
  • Série Cisco 7200
  • Série Cisco 7500
Definindo Suporte à Plataforma através do Feature Navigator

O software Cisco IOS é distribuído em conjuntos distintos de recursos que oferecem suporte a plataformas específicas. Para obter informações atualizadas sobre o suporte à plataforma para esse recurso, acesse o Feature Navigator. O Feature Navigator atualiza a lista de plataformas suportadas dinamicamente quando um novo suporte de plataforma é incluído ao recurso.

O Feature Navigator é uma ferramenta com base na Web que possibilita determinar rapidamente imagens do software do Cisco IOS que suportam conjunto de recursos específicos e quais recursos são suportados em uma imagem do Cisco IOS específica.

Para acessar o Feature Navigator, é necessário possuir uma conta no site Cisco.com. Caso tenha se esquecido ou perdido informações sobre sua conta, envie um e-mail em branco para cco-locksmith@cisco.com. Uma verificação automática confirmará se o seu endereço de e-mail está registrado no site Cisco.com. Se a verificação for bem-sucedida, você receberá detalhes da conta com uma nova senha aleatória. Usuários qualificados podem estabelecer uma conta no site Cisco.com seguindo as orientações em https://tools.cisco.com/RPF/register/register.do.

O Feature Navigator é atualizado sempre que houver modificações significativas em versões de tecnologia e do software do Cisco IOS. Desde maio de 2001, o Feature Navigator oferece suporte a versões M, T, E, S e ST. É possível acessar o Feature Navigator no seguinte endereço:

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

Padrões Suportados, MIBs e RFCs

Padrões

Nenhum padrão novo ou modificado são suportados por esse recurso.

MIBs

Nenhum MIB novo ou modificado são suportados por esse recurso.

Para obter listas de MIBs suportados pela plataforma e pela versão do Cisco IOS e para fazer o download de módulos MIB, acesse o site da Cisco MIB em Cisco.com no seguinte URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

Nenhum RFC novo ou modificado são suportados por esse recurso.

Tarefas de configuração

Consulte as seções seguintes para tarefas de configuração para a NAT—Capacidade de Utilizar Mapas de Rota com o recurso de Conversões Estáticas. Cada tarefa na lista é identificada como obrigatória ou opcional:

  • Ativando Mapeamento de Rota da NAT Estática (obrigatório)
  • Verificando Mapeamento de Rota da NAT Estática (opcional)

Ativando Mapeamento de Rota da NAT Estática

Para ativar o mapeamento de rota com configurações da NAT estáticas, utilize o seguinte comando no modo de configuração global:

Comando Propósito
Router(config)# ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}

Ativa o mapeamento de rota com conversão de NAT estática configurado na interface interna da NAT.

Verificando Mapeamento de Rota da NAT Estática

Para verificar a configuração do mapeamento de rota da NAT, utilize os seguintes comandos no modo EXEC privilegiado:

Comando Propósito
Router# show ip nat translations [verbose]

Exibe as conversões NAT ativas.

Exemplos de configurações

Esta seção fornece os seguintes exemplos de configurações:

  • Ativando Mapeamento de Rota da NAT Estática

Ativando o Exemplo de Mapeamento de Rota da NAT Estática

O seguinte exemplo exibe a utilização de mapeamento de rota com conversões NAT estáticas:

interface Ethernet3
 endereço IP 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 endereço IP 192.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 endereço IP 11.1.1.100 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
rip do router
 rede 172.68.0.0
 rede 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101

 set ip next-hop 172.68.1.1

Referências a Comandos

Esta seção confirma o comando modificado ip nat inside source. Todos os outros comandos utilizados com este recurso estão documentados nas publicações de referências a comandos do Cisco IOS Versão 12.2.

ip nat inside source

Para ativar a Network Address Translation (NAT) do endereço de origem interna, utilize o comando ip nat inside source em global configuration mode. Para remover a conversão estática ou a associação dinâmica de um pool, utilize a forma no desse comando.

ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}
no ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}

Descrição da sintaxe

list access-list-number

Número da lista de acesso IP padrão. Pacotes com endereços de origem aprovados na lista de acesso são convertidos dinamicamente utilizando endereços globais a partir do pool nomeado.

list access-list-name

Nome de uma lista de acesso IP padrão. Pacotes com endereços de origem aprovados na lista de acesso são convertidos dinamicamente utilizando endereços globais a partir do pool nomeado.

pool pool-name

Nome do pool a partir do qual endereços IP globais são dinamicamente alocados.

sobrecarga

(Opcional) Permite que o router utilize um endereço global para vários endereços locais. Quando a sobrecarga estiver configurada, o número da porta TCP ou UDP de cada host interno é diferenciado entre as conversações múltiplas que utilizam o mesmo endereço IP local.

estático local-ip

Configura uma conversão estática única. O argumento local-ip estabelece o endereço IP local designado a um host na rede interna. O endereço pode ser escolhido aleatoriamente, alocado a partir do RFC 1918, ou obsoleto.

global-ip

Configura uma conversão estática única. O argumento global-ip estabelece o endereço IP exclusivo globalmente de um host interno conforme ele aparece externamente.

route-map map-name

Nome da configuração do mapa de rota na interface interna da NAT em conversões estáticas.

Defaults

Sem comportamento ou valores-padrão.

Modos de comando

Configuração global

Histórico de comando

Versão Modificação

11.2

Esse comando foi introduzido.

12.2(4)T

Este comando foi modificado para incluir a capacidade de utilização de mapas de rota com conversões estáticas, e a palavra-chave/argumentoroute-map map-name foram incluídos.

Diretrizes de uso

Este comando possui duas formas: conversão de endereço estática e dinâmica. A forma com uma lista de acesso estabelece a conversão dinâmica. Pacotes de endereços que correspondem à lista de acesso padrão são convertidos utilizando os endereços globais alocados a partir do pool nomeado com o comando ip nat pool.

Como alternativa, a forma sintática com a palavra-chave static estabelece uma conversão estática única.

Exemplos

Os seguintes exemplos fazem conversão entre hosts internos remetidos a partir da rede 192.168.1.0 ou 192.168.2.0 para a rede 171.69.233.208/28 globalmente única:

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28
ip nat inside source list 1 pool net-208
!
interface ethernet 0
 endereço IP 171.69.232.182 255.255.255.240
 ip nat outside
!
interface ethernet 1
 endereço IP 192.168.1.94 255.255.255.0
 ip nat inside
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255

O seguinte exemplo exibe a utilização de mapeamento de rota com conversões NAT estáticas:

!
interface Ethernet3
 endereço IP 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 endereço IP 192.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 endereço IP 11.1.1.100 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
rip do router
 rede 172.68.0.0
 rede 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101
 set ip next-hop 172.68.1.1

Comandos relacionados

Comando Descrição

clear ip nat translation

Limpa conversões NAT dinâmicas a partir da tabela de conversões.

ip nat

Determina que o tráfico originado ou destinado à interface está sujeito à NAT.

destino do ip nat inside

Ativa a NAT do endereço de destino interno.

ip nat outside source

Ativa a NAT do endereço de destino externo.

ip nat pool

Define o pool dos endereços IP para a NAT.

show ip nat statistics

Exibe as estatísticas da NAT.

show ip nat translations

Exibe as conversões NAT ativas.