Voz e comunicações unificadas : Cisco Unified Communications Manager (CallManager)

Configurando o Gateway Cisco IOS MGCP

3 Abril 2008 - Tradução Manual
Outras Versões: Versão em PDFpdf | Tradução por Computador (29 Julho 2013) | Inglês (1 Novembro 2006) | Feedback


Índice

Introdução
Pré-requisitos
     Requisitos
     Componentes Usados
     Convenções
Tarefas a executar
     Passo-a-Passo
Resumo
Configurações
Solucionando Problemas no Gateway IOS MGCP
Discussões relacionadas da comunidade de suporte da Cisco
Informações Relacionadas

Introdução

Este documento:

  • Lhe orienta por meio de uma configuração simples de MGCP (Media Gateway Control Protocol)

  • Apresenta somente os comandos exigidos para criar uma configuração que funcione para um roteador com duas portas FXO (Foreign Exchange Office) e duas portas FXS (Foreign Exchange Station)

Observação: As instruções deste documento funcionam para o Cisco Voice Gateway 200 (VG200) e Cisco 2600 e 3600 Series Routers que executam o Cisco IOS® Software Release 12.1(5)T e superior. Consulte a documentação do Cisco IOS Software para obter as versões de software aceitas de outros gateways MGCP Cisco.

Sintomas:

A lista de sintomas a seguir pode ser encontrada na configuração do Cisco CallManager sem gateways IOS MGCP com portas FXO e FXS analógicas:

  • O gateway MGCP não é registrado com o Cisco CallManager. Consulte Falha de Registro do Gateway MGCP com o Cisco CallManager.

  • O identificador de chamada não funciona em portas FXS. Isso ocorre porque o identificador de chamadas não é suportada via portas FXO quando configurado para MGCP. Em vez disso, configure o gateway no modo H.323.

  • A paginação da carga adicional bloqueia a porta FXO quando realiza hookflash, a menos que os usuários desliguem totalmente. Encerramento seguido por não-encerramento redefine a porta. Esse problema é relacionado à ID de bug da Cisco CSCef62275 (clientes registrados somente) quando corrigido no Cisco IOS Software Release 12.3(14)T e posterior.

Este documento é a parte 2 de um conjunto de seis documentos:

Pré-requisitos

Requisitos

A Cisco recomenda que você tome conhecimento destes tópicos:

  • Um gateway Cisco IOS que execute um Cisco IOS Software com uma versão que ofereça suporte a MGCP com o Cisco CallManager

  • VG200 Cisco

Observação: Há outros treinamentos de versão do Cisco IOS Software que oferecem suporte a MGCP em roteadores Cisco. O Cisco IOS Software Release 12.1XM é um exemplo.

cuidado Cuidado: A sintaxe de alguns comandos MCGP é diferente em outras versões do Cisco IOS Software. Consulte a documentação da sua configuração para determinar a sintaxe requerida.

Componentes Usados

As informações neste documento são baseadas nestas versões de hardware e software:

  • 1 * Cisco VG200 / 2 X FXS / 2 X FXO / 1 porta Fast Ethernet 10/100; Cisco IOS Software Release 12.1(5)T

  • 1 * Cisco CallManager 3.0(5a) executado em um MCS7835

  • 2 * Aparelhos de telefone analógico

  • 2 * Telefones IP Cisco 7960

Consulte a Matriz de Compatibilidade Cisco CallManager para obter as versões de software compatíveis recomendadas entre o Cisco CallManager e o gateway Cisco IOS.

Observação: A Cisco recomenda o Cisco IOS Software Release 12.2(11)T ou posterior com base nas melhorias do comando ccm-manager. O comando ccm-manager requer o Cisco IOS Software Release 12.1(5)XM ou posterior em todos os roteadores (2600 e 3600) e no VG200.

Os roteadores Cisco 2600 e 3600 suportam MGCP se eles executarem o Cisco IOS Software Release 12.1(3)T e posterior. As versões de software de que você precisa se baseiam nos recursos que você precisa habilitar. O servidor Cisco CallManager deve executar a versão de software 3.0(5)a ou posterior. A configuração do roteador é a mesma para todos os tipos de roteadores. A configuração do Cisco CallManager também é a mesma para todos os tipos de roteadores.

O Cisco IOS Software Release 12.1(5)XM1 e posterior suporta o VG200. As versões de software exigidas se baseiam nos recursos que você tem que habilitar. Utilize as versões de software 3.0(5)a e posterior mesmo que haja suporte a VG200 em versões anteriores de software do Cisco CallManager.

Observação: Há outros treinamentos de versão do Cisco IOS Software que oferecem suporte a MGCP em roteadores Cisco. O Cisco IOS Software Release 12.1XM é um exemplo.

cuidado Cuidado: A sintaxe de alguns comandos MCGP é diferente em outras versões do Cisco IOS Software. Consulte a documentação da sua configuração para determinar a sintaxe requerida.

As informações apresentadas neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos usados neste documento foram iniciados com uma configuração vazia (padrão). Se a sua rede estiver ativa, certifique-se de entender o impacto potencial de todos os comandos.

Convenções

Consulte Convenções de Dicas Técnicas da Cisco para obter mais informações sobre as convenções de documentos.

Tarefas a executar

Conclua estas etapas:

  1. Configure o endereço IP na interface interface Ethernet do gateway Cisco IOS.

  2. Atribua um nome exclusivo ao gateway Cisco IOS.

  3. Configure o gateway Cisco IOS para executar MGCP como protocolo de sinalização.

  4. Configure o endereço IP ou o nome DNS (Domain Name System) do servidor Cisco CallManager.

  5. Selecione o tipo do codec e a função de relay de multifreqüência de tom dual (DTMF).

  6. Diga ao gateway Cisco IOS que ele se comunica com um servidor Cisco CallManager.

  7. Vincule o aplicativo MGCP às portas de voz.

  8. Habilite as portas de voz.

  9. Habilite a conectividade IP.

Passo-a-Passo

Observação: O restante deste documento se refere ao VG200. O VG200 começa com uma configuração padrão, pois vem de fábrica.

Conclua estas etapas:

  1. Configure o endereço IP na interface Ethernet do VG200 e habilite a interface.

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
                   
  2. Atribua um nome exclusivo ao VG200. Isso permite que o servidor Cisco CallManager o identifique.

    router(config)#hostname VG200A
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. Configure o VG200 para executar MGCP como protocolo de sinalização.

    VG200A(config)#mgcp
                   
  4. Configure o endereço IP ou o nome DNS do servidor Cisco CallManager.

    VG200A(config)#mgcp call-agent 172.16.1.252
                   
    VG200A(config)#ccm-manager config server 172.16.1.252
                   
    VG200A(config)#ccm-manager config
                   

    O comando mgcp call-agent é usado para configurar o endereço e o protocolo do agente de chamada dos pontos finais MGCP em um gateway de mídia. Esse comando pode ser usado para especificar a versão do protocolo utilizado. Para obter mais informações, consulte mgcp call-agent .

    O comando ccm-manager config server é usado para especificar o servidor de TFTP a partir do qual o gateway MGCP (Media Gateway Control Protocol) baixa os arquivos de configuração XML do Cisco CallManager.

    O comando ccm-manager config é necessário para habilitar o download dos arquivos de configuração XML do Cisco CallManager.

    Observação: Emita estes comandos para configurar Cisco CallManagers redundantes no cluster do Cisco CallManager.

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name]
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes}
                   
  5. Selecione o tipo do codec e a função de relay DTMF.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
                   
  6. Emita este comando para ativar o suporte a Cisco CallManager dentro do MGCP:

    VG200A(config)#ccm-manager mgcp
                   
  7. Vincule o aplicativo MGCP às portas de voz.

    Observação: Emita o comando show voice port para determinar o tipo de portas que o VG200 possui e em que ordem elas estão instaladas.

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    Observação: O comando de aplicativo MGCPAPP diferencia maiúsculas de minúsculas em algumas versões do Cisco IOS Software. Sempre emita esse comando em maiúsculas a menos que você saiba que o seu software não diferencia maiúsculas de minúsculas. Verifique a saída do comando show running-config para saber se sua versão de software diferencia maiúsculas de minúsculas. O Cisco IOS Software Release 12.1(5)T não diferencia maiúsculas de minúsculas.

  8. Certifique-se de que as portas de voz estejam habilitadas.

    Observação: Os comandos shutdown e no shutdown afetam ambas as portas de voz em uma placa de interface de voz (VIC). Emita o comando somente em uma dessas portas.

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. Habilite a conectividade IP.

    Habilite o IP Routing se algum dos dispositivos de VoIP com os quais o VG200 se comunica estiver localizado em diferentes sub-redes ou VLANS. Também é preciso criar uma rede padrão ou um gateway de último recurso. Esta etapa mostra como executar ambas as tarefas:

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
                      
                   

    Observação: O VG200 não é um roteador IP. Não é possível executar protocolos de IP Routing, como RIP (Routing Information Protocol), IGRP (Interior Gateway Routing Protocol) ou OSPF (Open Shortest Path First) nele. Ele se comporta mais como uma estação final (cliente) no que diz respeito à conectividade IP.

    Observação: É possível configurar um protocolo de roteamento em vez de rotas estáticas em outros gateways Cisco IOS, que são essencialmente roteadores com interfaces de voz. A questão importante é garantir a conectividade IP entre os dispositivos de VoIP.

    Observação: O comando ip routing não é exibido na configuração porque ele normalmente está ativado por padrão quando o roteamento IP é ativado. Os comandos padrão normalmente não são exibidos em uma configuração de roteador Cisco. As imagens do VG200 Cisco IOS cancelam este comportamento padrão codificando o comando no ip routing para a configuração inicial. Esta configuração é criada quando a imagem é inicializada:

    • Em uma plataforma em que o comando write erase tenha limpado a configuração

    • Em um VG200 que nunca tenha sido configurado

    O comando ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway faz com que o VG200 instale um gateway de último recurso na tabela de roteamento. O comando show ip route confirma isto. O endereço IP do gateway é 172.16.1.1 neste exemplo:

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway de último recurso é 172.16.1.1 para rede 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    Observação: O comando ip classless também é requerido para que o gateway de último recurso seja efetivo. O comando ip classless está ativado por padrão. Este comando é um dos poucos comandos padrão do Cisco IOS Software exibidos em uma configuração quando ativado e também é exibido no formulário no quando desativado. Emita o comando ip classless para habilitar ip classless se a sua configuração incluir a linha no ip classless.

cuidado Cuidado: O Cisco CallManager controla todos os elementos de configuração relacionados ao plano de discagem. Não configure estes elementos no gateway MGCP para pontos finais gerenciados por MGCP (aqueles com o comando de aplicativo mgcpapp na instrução do peer de discagem). Não configure nenhuma destas funções:

  • Em Peers de Discagem

    • destination-pattern

    • session target

  • Em Portas de Voz

    • connection { plar | tie-line | trunk }

Resumo

O VG200 agora está pronto para se comunicar com o servidor Cisco CallManager. O VG200 periodicamente envia mensagens em uma tentativa de estabelecer uma conexão. A conexão automaticamente se estabelece quando a configuração do servidor Cisco CallManager está concluída. Não é necessário fazer mais alterações no VG200.

Observação: Redefina as portas do gateway após concluir a configuração, conforme mostrado no exemplo:

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown
         

Configurações

Esta tabela contém a configuração completa do VG200A para este documento:

Configuração do VG200A

VG200A#show running-config 
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

Informações de Versão VG200A

VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

Solucionando Problemas no Gateway IOS MGCP

Podem ocorrer falhas de chamada unidirecional em chamadas de entrada ou saída individualmente em um gateway IOS MGCP. Para resolver este problema, reconfigure o gateway MGCP. Normalmente isto envolve reconfigurar as interfaces PRI e/ou FXO e então reiniciar o protocolo mgcp no gateway emitindo o comando IOSno mgcp e então mgcp no modo de configuração global.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 42105